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After Sound Forge software is installed and you start it for the first time, the registration wizard is displayed. This wizard offers easy steps 
that allow you to register the software online with Sony Media Software. Alternatively, you may register online at http://www.sony.com/
mediasoftware at any time.

Registration assistance

If you do not have access to the Internet, registration assistance is available during normal weekday business hours. Please contact our 
Customer Service Department by dialing one of the following numbers:

Customer service/sales

For a detailed list of Customer Service options, we encourage you to visit  
http://mediasoftware.sonypictures.com/support/custserv.asp. Use the following numbers for telephone support during normal 
weekday business hours:

Technical support

For a detailed list of Technical Support options, we encourage you to visit  
http://mediasoftware.sonypictures.com/support/default.asp. To listen to your support options, please call 608-256-5555.

About your rights in Sound Forge software

Sound Forge software is licensed to you under the terms of the End User License Agreement. The End User License Agreement is first 
presented to you when you install the software. Please review the End User License Agreement carefully as its terms affect your rights 
with respect to the software. For your reference, a copy of the End User License Agreement for Sound Forge software is located at http:/
/www.sony.com/mediasoftware.

Telephone/Fax Country
1-800-577-6642 (toll-free) US, Canada, and Virgin Islands

+608-204-7703 for all other countries

1-608-250-1745 (Fax) All countries

Telephone/Fax Country
1-800-577-6642 (toll-free) US, Canada, and Virgin Islands

+608-204-7703 for all other countries

1-608-250-1745 (Fax) All countries
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About your privacy

Sony Media Software respects your privacy and is committed to protecting personal information. Your use of the software is governed 
by the Software Privacy Policy. A copy of this policy is incorporated into the registration process and you are asked to agree to its terms 
prior to accepting the terms of the End User License Agreement. Please review its contents carefully as its terms and conditions affect 
your rights with respect to the information that is collected by the software. For your reference, a copy of the Software Privacy Policy is 
located at http://mediasoftware.sonypictures.com/corporate/privacy.asp. 

Proper use of software

Sound Forge software is not intended and should not be used for illegal or infringing purposes, such as the illegal copying or sharing of 
copyrighted materials. Using Sound Forge software for such purposes is, among other things, against United States and international 
copyright laws and contrary to the terms and conditions of the End User License Agreement. Such activity may be punishable by law 
and may also subject you to the breach remedies set forth in the End User License Agreement.

Legal notices

Vegas, Vegas+DVD, DVD Architect, Vegas Movie Studio, Vegas Movie Studio+DVD, DVD Architect Studio, ACID, Music Studio, ACIDized, Super Duper 
Music Looper, Jam Trax, Sony Sound Series, Chopper, Groove Mapping, Groove Cloning, Media Manager, CD Architect, Sound Forge, Audio Studio, 
Cinescore, Acoustic Mirror, Noise Reduction, Wave 64, Wave Hammer, and XFX are trademarks or registered trademarks of Madison Media Software, Inc. 
or its affiliates in the United States and other countries.

Thomson Fraunhofer MP3

MPEG Layer-3 audio coding technology licensed from Fraunhofer IIS and Thomson.

Supply of this product does not convey a license nor imply any right to distribute content created with this product in revenue generating broadcast 
systems (terrestrial, satellite, cable and/or other distribution channels), streaming applications (via internet, intranets and/or other networks), other 
content distribution systems (pay-audio or audio on demand applications and the like) or on physical media (compact discs, digital versatile discs, 
semiconductor chips, hard drives, memory cards and the like).

An independent license for such use is required. For details, please visit: http://mp3licensing.com.

Microsoft DirectX programming interface

Portions utilize Microsoft® DirectX® technologies. Copyright © 1999 – 2007 Microsoft Corporation. All rights reserved. 

Microsoft Windows Media 9

Portions utilize Microsoft Windows Media® technologies. Copyright © 1999 – 2007 Microsoft Corporation. All rights reserved. 

Real, RealMedia, RealAudio, and RealVideo applications

2007 RealNetworks, Inc. Patents Pending. All rights reserved. Real®, Real Media®, RealAudio®, RealVideo®, and the Real logo are trademarks or registered 
trademarks of RealNetworks, Inc. in the United States and other countries. 

Dolby, Dolby Digital AC-3, and AAC encoding

This product contains one or more programs protected under international and U.S. copyright laws as unpublished works. They are confidential and 
proprietary to Dolby Laboratories. Their reproduction or disclosure, in whole or in part, or the production of derivative works therefrom without the 
express permission of Dolby Laboratories is prohibited. Copyright 1992 - 2007 Dolby Laboratories. All rights reserved. 

Dolby Digital 5.1 Creator technology is not intended for use in content creation for commercial or broadcast distribution, or content that displays Dolby 
trademarks and logos. Only Approved Dolby Digital Professional Encoders may be used for content that is commercially distributed or carries the Dolby 
Digital trademark and logo.

Dolby®, the double-D symbol, AC-3®, and Dolby Digital® are registered trademarks of Dolby Laboratories. AAC™ is a trademark of Dolby Laboratories.

PNG file format

Copyright © 2007. World Wide Web Consortium (Massachusetts Institute of Technology, European Research Consortium for Informatics and 
Mathematics, Keio University). All rights reserved. This work is distributed under the W3C Software License in the hope that it will be useful, but 
WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTIBILITY or FITNESS FOR A PARTICULAR PURPOSE. http://www.w3.org/
Consortium/Legal/2002/copyright-software-20021231.

Apple QuickTime

Apple® QuickTime® application is a trademark of Apple, Inc. in the United States and other countries. 

Apple Macintosh Audio Interchange File Format (AIFF) file format. 

Apple® Macintosh® Audio Interchange™ File Format (AIFF) is a trademark of Apple, Inc. in the United States and other countries. 

Targa file format

The Targa™ file format is a trademark of Pinnacle Systems, Inc.

Tagged Image File Format (TIFF)

Adobe Tagged Image™ File Format is a registered trademark of Adobe Systems Incorporated in the United States and other countries. All rights reserved. 
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Steinberg Media Technologies AG. 

VST is a registered trademark of Steinberg Media Technologies AG.

ASIO is a trademark of Steinberg Media Technologies AG.

Gracenote

CD and music-related data from Gracenote, Inc., copyright © 2000-2007 Gracenote. Gracenote Software, copyright 2000-2007 Gracenote. This product 
and service may practice one or more of the following U.S. Patents: #5,987,525; #6,061,680; #6,154,773, #6,161,132, #6,230,192, #6,230,207, #6,240,459, 
#6,330,593, and other patents issued or pending. Services supplied and/or device manufactured under license for following Open Globe, Inc. United 
States Patent 6,304,523. 

Gracenote and CDDB are registered trademarks of Gracenote. The Gracenote logo and logotype, MusicID, and the “Powered by Gracenote” logo are 
trademarks of Gracenote.

Ogg File Formats

©2007, Xiph.org Foundation

Neither the name of the Xiph.org Foundation nor the names of its contributors may be used to endorse or promote products derived from this software 
without specific prior written permission. 

This software is provided by the copyright holders and contributors “as is” and any express or implied warranties, including, but not limited to, the 
implied warranties of merchantability and fitness for a particular purpose are disclaimed. In no event shall the foundation or contributors be liable for any 
direct, indirect, incidental, special, exemplary, or consequential damages (including, but not limited to, procurement of substitute goods or services; loss 
of use, data, or profits; or business interruption) however caused and on any theory of liability, whether in contract, strict liability, or tort (including 
negligence or otherwise) arising in any way out of the use of this software, even if advised of the possibility of such damage.

http://xiph.org/


The information contained in this manual is subject to change without notice and does not represent a guarantee or commitment on 
behalf of Madison Media Software, Inc. in any way. All updates or additional information relating to the contents of this manual will be 
posted on the Sony Media Software web site, located at http://www.sony.com/mediasoftware. The software is provided to you under 
the terms of the End User License Agreement and Software Privacy Policy, and must be used and/or copied in accordance therewith. 
Copying or distributing the software except as expressly described in the End User License Agreement is strictly prohibited. No part of 
this manual may be reproduced or transmitted in any form or for any purpose without the express written consent of Madison Media 
Software, Inc.

Copyright © 2007. Madison Media Software, Inc., a subsidiary of Sony Corporation of America.

Program Copyright © 2007. Madison Media Software, Inc., a subsidiary of Sony Corporation of America. All rights reserved.

Madison Media Software, Inc.
A subsidiary of Sony Corporation of America

1617 Sherman Avenue 
Madison, WI  53704  
USA

http://www.sony.com/mediasoftware
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Chapter 1
 Introduction

Introducing Sound Forge software

Thank you for purchasing Sound Forge® software and for your continued support of the Sony Media Software family of 
products. The software provides you with the powerful features you have come to expect, as well as a number of new 
features designed to make digital audio editing quick and easy.

Sample files

Throughout the manual, you will find references to six sample audio files. The manual directs you to use these files as you 
experiment with different Sound Forge features. These files are installed in the same folder as the application:

• Drumhit.pca
• Fill.pca
• Loop.pca
• Musicbed.pca
• Saxriff.pca
• Voiceover.pca

The files are in Perfect Clarity Audio® (PCA) format, a Sony Media Software proprietary lossless audio compression format.

System requirements

The following lists the minimum system requirements for using Sound Forge:

• 500 MHz processor
• 128 MB RAM, 256 MB recommended
• 150 MB hard-disk space for program installation
• Microsoft® Windows® 2000 SP4, Windows XP, or Windows Vista™
• Microsoft Windows®-compatible sound card
• CD-ROM drive (for installation from a CD only)
• Supported CD-Recordable drive (for CD burning only)
• DirectX® Media 9.0c or later (version 9.0c included on application disc)
• Microsoft .NET Framework 1.1 (included on application disc)
• Microsoft® Internet Explorer 5.1 or later to view online help (included on application disc)
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Installing Sound Forge software

The install utility, setup.exe, located on the Sound Forge application disc, creates the necessary folders and copies all files required to 
operate Sound Forge software.

1. Place the Sound Forge application disc in the drive. The setup screen is displayed (if AutoPlay is enabled for your CD-ROM or DVD-
ROM drive).

2. Click Install, and follow the on-screen prompts to install the appropriate version of Sound Forge for your computer.

Getting help

To access online help, choose Contents and Index from the Help menu or press F1.

The following table describes the four tabs of the Online Help window.

Note: The Sound Forge application requires Microsoft DirectX 9.0c or later and Internet Explorer 5.1 or later. The setup program alerts 
you if either is not detected on your system and prompts their installation from the Sound Forge application disc.

Note: If you have disabled the drive’s AutoPlay feature, click the Start button and choose Run. Type D:\setup.exe, where D is the drive 
letter of your CD or DVD drive, and follow the on-screen prompts to complete the installation.

Note: To view online help, Internet Explorer 5.1 or later must be installed on your system. If you purchased the Sound Forge boxed 
version, Internet Explorer version 5.1 is included on your application disc.

Tab Description
Contents Provides a list of available help topics. Click a closed book ( ) to open the pages, and then click on a topic page ( ).
Index Provides a complete listing of the help topics available. Scroll through the list of available topics or type a word in the Type in 

the keyword to find box to quickly locate topics related to that word. Select the topic and click the Display button.
Search Allows you to enter a keyword and display all of the topics in the online help that contain the keyword you have entered. Type 

a keyword in the Type in the word(s) to search for box and click the List Topics button. Select the topic from the list and click 
the Display button.

Favorites Allows you to keep topics that you revisit often in a separate folder. To add a topic to your favorites, click the Add button on 
the Favorites tab.

Information 
pane

Toolbar

Tabs
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Help on the Web

Additional Sound Forge information is available on the Sony Media Software Web site. From the Help menu, choose Sony on the Web, 
and choose the desired location from the submenu. The software starts your system’s Web browser and attempts to connect to the 
appropriate page on the Sony Web site.
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Chapter 2
 Learning the Sound Forge Workspace

This chapter provides a detailed overview of Sound Forge® toolbars and controls.

Using the mouse

The following table defines the mouse-related terms used throughout this manual.

Using the mouse wheel 

The following table describes the available mouse wheel functionality you can use to navigate audio files.

Mouse Term Description
Pointing Moving the mouse pointer over an item.
Clicking Pointing to an item and quickly pressing and releasing the left mouse button. If there is no left or right 

specification, left-clicking is implied. 
Right-clicking Pointing to an item and quickly pressing and releasing the right mouse button. Right-clicking is frequently used 

to display shortcut menus.
Double-clicking Identical to clicking, but instead of pressing and releasing the mouse button once, it is done twice in quick 

succession. Double-clicking always indicates the left mouse button.
Triple-clicking Identical to clicking, but instead of pressing and releasing the mouse button once, it is done three times in 

quick succession. Triple-clicking always indicates the left mouse button.
Toggle-clicking Clicking the right mouse button while holding down the left mouse button. This is used to toggle options and 

is a shortcut for drag-and-drop editing and using the Magnify tool.
Shift-clicking Holding down the Shift key while clicking the mouse. Shift-clicking is typically used to skip dialogs and quickly 

repeat operations.
Ctrl-clicking Holding down the Ctrl key while clicking the mouse. Ctrl-clicking is used to modify the operation of a normal 

click.
Dragging Holding down the left mouse button while moving the mouse pointer and releasing the mouse at the desired 

location. Dragging is used to quickly move sections of data between windows, as well as to adjust sliders, 
scrollbars, and faders.

Slow-dragging Holding down the right and left mouse buttons while adjusting sliders and faders increases the resolution of 
the movement. This is useful when making fractional adjustments to parameters.

Tip: Once you are familiar with Sound Forge basics, you may want to use mouse and keyboard shortcuts. For more 
information, see Shortcuts on page 253.

Mouse Functionality Description
Wheel Up Zoom in horizontally
Wheel Down Zoom out horizontally
Ctrl+Wheel Up Zoom in vertically
Ctrl+Wheel Down Zoom out vertically
Shift+Wheel Up Scroll left (in 10ths of screen width)
Shift+Wheel Down Scroll right (in 10ths of screen width)
Ctrl+Shift+ Wheel Up Cursor left or current selection point left (if there is a selection)
Ctrl+Shift+ Wheel Down Cursor right or current selection point right (if there is a 

selection)
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The main window

When you start the application, the main window is displayed. The main window’s workspace is where you perform all audio editing.

Main window components

The following table describes the major components of the main window.

Component Description
Menu bar Displays the menu headings for the available functions. 
Standard toolbar Provides quick access to some of the most common tasks in the application (pg. 27). 
Transport bar Provides quick access to basic audio transport functions (pg. 27).
Status bar Help and processing information appears on the left side. The boxes on the right side display 

the playback sample rate, bit depth, channel configuration, length of the active data window, 
and total free storage space (pg. 83). With the exception of the free storage space box, you 
can edit these boxes by double-clicking or right-clicking them. When no data windows are 
open, only the free storage space box contains a value.

Workspace This is the area located behind the data windows. Audio selections dragged to the workspace 
automatically become new data windows. Windows such as the Regions List and Playlist can 
be docked along the edges of the workspace.

Channel Meters Displays the level of the output audio signal. These meters can be toggled on/off by choosing 
Channel Meters from the View menu. Right-clicking the channel meters displays a shortcut 
menu that allows you to precisely configure the appearance of the meters.

Channel Meters 
(docked)

Standard toolbar
Transport bar

Menu bar

Workspace

Status bar
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Floating and docking windows

With the many features in Sound Forge software, it is easy for the workspace to become cluttered. Docking windows allows you to keep 
more windows open while maintaining a greater degree of organization. You can choose to float or dock the windows listed in the View 
menu, including the Regions List, Playlist, and Time Display windows.

Docking a window

1. Drag a window to the edge of the workspace. The outline of the window changes shape as you approach the edge.

2. Release the mouse. The window docks against the edge of the workspace.

Preventing a window from docking

Press Ctrl while dragging a window to prevent it from docking in the workspace. 

Floating a window

Drag the handle of a docked window away from the edge of the workspace so that it is a floating window.

Tip: You can choose to reverse this behavior so that windows will not dock unless you press Ctrl. From the Options menu, choose 
Preferences, and clear the Allow floating windows to dock check box on the General tab.

 

 

Docked channel 
meters

Docked keyboard

Stacked 
windows with 
tabs

Close window

Expand window

 

Handle
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Hiding the window docking area

You can double-click the separator between the workspace and window docking area to hide the docking area. You can also use the 
following shortcut keys to manage the workspace:

Window Docking Area (F11)

Explorer window (Alt+1)

The Explorer window is used to find, preview, and open media files. From the View menu, choose Explorer to show or hide the Explorer 
window.

Regions List window (Alt+2)

The Regions List window contains all regions and markers that exist in the active data window. From the View menu, choose Regions 
List to show or hide the Regions List window.

Playlist window (Alt+3)

The Playlist window is used to arrange regions for playback. From the View menu, choose Playlist to show or hide the Playlist window.

Video Preview window (Alt+4)

The Video Preview window shows the video frame at the current cursor or play position. From the View menu, choose Video Preview to 
show or hide the Video Preview window.

Time Display window (Alt+5)

The Time Display window displays the current cursor or play position. From the View menu, choose Time Display to show or hide the 
Time Display window.

Channel Meters window (Alt+6)

Sound Forge software provides peak and VU/PPM (peak program) meters that you can use to monitor your audio levels.

From the View menu, choose Channel Meters to show or hide the channel meters.

Undo/Redo History window (Alt+7)

The Undo/Redo History window allows you to see all of your edit operations. From the View menu, choose Undo/Redo History to show 
or hide the Undo/Redo History window.

Spectrum Analysis window (Alt+8)

The Spectrum Analysis window allows you to examine the fundamental frequency and overtones present in a recording. From the View 
menu, choose Spectrum Analysis to show or hide the Spectrum Analysis window.

Shortcut key Description
F11 Show/hide window docking area at bottom of workspace.
Shift+F11 Show/hide windows docked on left/right sides of workspace.
Ctrl+F11 Show/hide all docked windows.
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Plug-In Chainer window (Alt+9)

The Plug-In Chainer window allows you to link up to 32 DirectX and VST plug-ins into a single processing chain. From the View menu, 
choose Plug-In Chainer to show or hide the Plug-In Chainer window.

Plug-In Manager window (Ctrl+Alt+0)

The Plug-In Manager window displays your plug-ins in a tree view like Windows Explorer. From the View menu, choose Plug-In 
Manager to show or hide the Plug-In Manager.

Keyboard window (Ctrl+Alt+1)

The Keyboard window allows you to control internal or external synthesizers and samplers from Sound Forge software. From the View 
menu, choose Keyboard to show or hide the Keyboard window.

Script Editor window (Ctrl+Alt+2)

The Script Editor window can be used to open, create, edit or run scripts. From the View menu, choose Script Editor to show or hide the 
Script Editor window.

Hardware Meters window (Ctrl+Alt+3)

The Hardware Meters window allows you to monitor hardware outputs and adjust preview levels. From the View menu, choose 
Hardware Meters to show or hide the Hardware Meters window. For more information, see Using the hardware meters on page 92.

The data window

Data windows contain audio data (as a waveform) as well as a number of controls and commands used to edit and process audio.

 

Edit Tool 
Selector

Level ruler

Waveform  
display

Level zoom 
in/out

Playbar Scrub control

Position 
scroll bar

Selection status 
boxes

Overview bar

Title bar Time ruler

Time zoom 
resolution

Time zoom in/out

Maximize width

Marker bar
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Data window components

Displaying data window components

You can customize the appearance of individual data windows.

1. From the File menu, choose Properties or press Alt+Enter. The current file’s Properties dialog is displayed.

2. Click the Display tab.

3. Display/hide specific components by selecting/clearing the corresponding check boxes.

4. Select the Save as the default for all new windows check box if you want to set the new configuration as the default data window 
display.

5. Click OK.

Arranging data windows

You can use the commands on the Window menu to arrange data windows in the Sound Forge workspace..

Component Description
Title bar Displays the file name. If title information is included in the summary of a file, it appears here instead of the 

file name. Double-click to maximize and restore the window.
Level ruler Displays the amplitude of the waveform. Right-click to display the level ruler shortcut menu. Drag to shift 

the view up/down when zoomed in vertically.
Time ruler Displays the current location in the data window. Right-click to display the time ruler shortcut menu. Drag 

to scroll the data window.
Marker bar Displays the position of region end points, loop end points, and markers. You can place, name, and 

position markers and regions anywhere in the data window. These informational tags can serve as cues or 
reminders highlighting important events in your project.

Right-click a marker or region tag to display a shortcut menu. Drag to edit a tag’s position. Double-click 
anywhere within a region to select it.

Edit Tool Selector Toggles through the Edit, Magnify, and Pencil tools. Right-click to display a shortcut menu that allows you 
to display or hide data window elements.

Playbar Contains audio transport buttons, including Go to Start, Go to End, Stop, Play Normal, Open/Play Plug-In 
Chainer, Play as Cutlist, and Play as Sample. For more information on the playbar, please see page 25. 

Selection status boxes Displays the beginning, end, and length of a selection. If no selection exists, only the cursor position 
displays. Double-click the leftmost box to edit the current cursor position or selection start position. 
Double-click either of the other two boxes to edit the selection end position or the selection length. Right-
click to display the status format shortcut menu.

Waveform display Displays a graphical representation of an audio file. The horizontal axis represents time, and the vertical 
axis represents amplitude. Right-click within this display to open the waveform display shortcut menu.

Scrub control Scrolls playback of your project at varying speeds.
Position scroll bar Scrolls forward/backward through an audio file to display sections of the file not visible in the current area 

of the waveform display.
Overview bar Allows for quick navigation and playback of any part of an audio file. The overview bar also indicates the 

portion of the waveform currently depicted in the waveform display, as well as the selected region. Click to 
move the cursor. Double-click to center the cursor in the waveform display. Right-click to start or pause 
playback. Drag to activate the audio event locator.

Time zoom resolution Specifies the number of samples of data represented by each horizontal point on the screen. This 
determines the length of time displayed in the data window. Smaller resolution values display less time.

Time zoom in/out Changes the zoom resolution for the time (horizontal) axis.
Level zoom in/out Changes the zoom resolution for the level (vertical) axis.
Maximize width Resizes the data window to maximize its size within the workspace.

Tip: Right-click the Edit Tool Selector (upper-left corner of data window) to display or hide components for the selected data 
window.

Tip: Press Ctrl+Tab to switch forward through the open windows, or press Ctrl+Shift+Tab to switch backward through the open 
windows.
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Playbar

The playbar is located in the bottom-left corner of a data window. You can use the playbar to navigate and play audio files in a variety of 
ways.

Current playback mode

When you play a file from the playbar, a small horizontal line appears beneath the selected Play button’s icon . This indicates the 

current playback mode, which is the mode used when you click the transport bar Play  button. For more information, see Transport 

toolbar on page 27.

Changing the current playback mode

To change the current playback mode, click a playbar button or press X.

Optional Backward and Forward buttons

You can choose to display Rewind  and Forward  shuttle controls on the playbar. From the Options menu, choose Preferences, 
and select the Show shuttle controls on Data Window transport check box on the General tab.

Command Description
New Window Creates a new data window
Cascade Arranges all open data windows so they overlap with the title bar of each window 

remaining visible.
Tile Horizontally Arranges all open data windows top to bottom with no overlapping.

Note: This command affects only non-minimized windows.
Tile Vertically Arranges all open data windows left to right with no overlapping.

Note: This command affects only non-minimized windows.
Arrange Icons Arranges minimized data windows at the bottom of the workspace. 
Minimize All Minimizes all open data windows.
Restore All Restores all minimized windows to their previous window size and position. 
Close All Closes all open data windows.
Window List Switches focus to another data window.

Go to Start: moves the cursor to the start of the 
file.

Play Plug-In Chainer: previews the audio processed through 
plug-ins when the Plug-In Chainer window is open. 

If there is a selection, plays from the beginning of the 
selection to the end of the selection.

If the Plug-In Chainer window is not open, the Open Plug-In 

Chainer button ( ) appears instead.

Go to End: moves the cursor to the end of the 
file.

Play as Cutlist: plays the file with the regions in the cutlist 
omitted. This button appears only if you treat the playlist as 
a cutlist.

Stop: stops playback and returns the cursor to 
its position prior to playback.

Play as Sample: plays the file with the sustaining and 
release loops repeating the specified number of times. This 
button appears only if you have defined a sample loop. 

Play Normal: plays from the cursor to the end 
of the file. 

If there is a selection, plays from the beginning 
of the selection to the end of the selection.
LEARNING THE SOUND FORGE WORKSPACE | 25



Toolbars

Sound Forge toolbars contain buttons used to quickly execute many of the program’s commands and functions. Toolbars can be 
dragged throughout the workspace, docked, resized, hidden, and customized.

You can use the Toolbars tab in the Preferences dialog to specify which toolbars you want to display. Perform either of the following 
actions to display this tab:

• Choose Preferences from the Options menu and click the Toolbars tab.
• From the View menu, choose Toolbars.

Displaying a toolbar

1. From the View menu, choose Toolbars. The Preferences dialog appears with a list of available toolbars.

2. To display a toolbar, select the corresponding check box and click OK. 

Customizing a toolbar

1. From the View menu, choose Toolbars. The Preferences dialog appears with a list of available toolbars.

2. Select the check box and the toolbar name for the toolbar that you want to customize.

3. Click Customize. The Customize Toolbar dialog is displayed.

4. Use the controls in the Customize Toolbar dialog to add, remove, or rearrange the buttons on the selected toolbar. Click Reset to 
restore the toolbar to its default setting.

5. Click the OK button.

Docking a toolbar

When you drag a floating toolbar to any edge of the main screen, the toolbar docks on that edge.

Floating a toolbar

When you drag a docked toolbar away from an edge, the toolbar becomes a floating toolbar.

Select a check box to 
display a toolbar.

Click Customize to add, remove 
or rearrange buttons on a 
toolbar.
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Standard toolbar

The Standard toolbar displays by default when you start the application. The buttons on this toolbar provide quick access to many 
common commands.

Transport toolbar

The transport toolbar also displays by default and contains basic audio transport buttons.

New: creates a new data window. Play Clipboard: plays the audio on the clipboard.

Open: displays the Open dialog. Trim/Crop: removes all data from the file that is not 
currently selected. This command has no effect if there 
is no selected data. This command does not copy data 
to the clipboard.

Save: saves the current audio data. Undo: reverses the last edit operation.

Save As: saves the current file with a new name or 
format. 

Redo: reverts the previously undone edit operation.

Render As: renders the current project file to a media 
file.

Repeat: repeats the last operation. This command can 
be used with most processing functions. The previous 
operation’s parameters are repeated. To specify new 
parameters, hold Shift and click this button.

Publish: opens the Publish Setup wizard so you can 
upload your media file to the Web.

Edit Tool: selects the Editing tool.

Cut: removes selected audio data and places it on the 
clipboard. This command has no effect if there is no 
selection.

Magnify Tool: selects the Magnify tool.

Copy: copies selected audio data to the clipboard. This 
command has no effect if there is no selection.

Pencil Tool: selects the Pencil tool.

Paste: inserts a copy of the clipboard data at the current 
insertion point. If there is a selection, this command 
replaces the selected data with the clipboard data.

Envelope Tool: selects the Envelope tool.

Mix: mixes a copy of the clipboard data with the current 
audio file. The mix start point is either the cursor point 
or the start or end of the selection in the destination 
data window.

Record: records data to a new or existing data window. Stop: stops playback and returns the cursor to its prior 
position.

Loop Playback: toggles Loop Playback mode on and off. Go to Start: moves the cursor to the start of the file.

Play All: plays the entire file from beginning to end, 
regardless of cursor position, selection, or playlist.

Rewind: moves the cursor backward in the current file. 

Play: plays the file in current playback mode (Play 
Normal, Play Plug-In Chainer, Play as Cutlist, or Play as 
Sample).

Forward: moves the cursor forward in the current file. 

Pause: pauses playback and maintains the cursor at its 
current position.

Go to End: moves the cursor to the end of the file.
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Navigation toolbar

The Navigation toolbar contains buttons used to navigate within the current data window.

Views toolbar

The Views toolbar contains buttons used to store and retrieve data window views.

Zoom In Full: magnifies the selected area to a 24:1 ratio. Go To: displays the Go To dialog and allows you to 
quickly move the cursor to a specific point in a file.

Zoom Normal: resets the audio data to its original 
magnification.

Cursor Center: centers the display with the cursor 
displayed in the center of the data window.

Zoom Selection: maximizes the selection vertically and 
horizontally.

Cursor to Selection Start: moves the cursor to the 
beginning of the selection.

Custom Zoom 1: sets the audio data to a custom time 
magnification level.

Cursor to Selection End: moves the cursor to the end of 
the selection.

Custom Zoom 2: sets the audio data to a custom time 
magnification level.

Center Sustaining Start: moves the cursor to the 
beginning of the sustaining loop.

Insert Marker: drops a marker at the current cursor 
position. 

Center Sustaining End: moves the cursor to the end of 
the sustaining loop.

Mark In: marks the “in” point of a new selection. Center Release Start: moves the cursor to the beginning 
of the release loop.

Mark Out: marks the “out” point of a new selection. Center Release End: moves the cursor to the end of the 
release loop.

Toggles views 1-8 between setting and restoring. Stores and recalls specific selection views.
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Status/Selection toolbar

The Status/Selection toolbar contains buttons used to specify a file’s status format and control snapping functions.

Regions/Playlist toolbar

The Regions/Playlist toolbar contains the Regions List and Playlist buttons as well as buttons corresponding to synchronization 
commands and status displays.

Playlist Position display

Displays the current playback position of an audio file being played from the playlist. Right-clicking this box displays a shortcut menu 
that allows you to specify a new format.

Sync Status display

Allows you to monitor the status of incoming/outgoing MIDI commands.

Samples: changes the status format to Samples. SMPTE EBU: changes the status format to SMPTE EBU 
(25 fps). 

Time: changes the status format to Time. SMPTE Non-Drop: changes the status format to SMPTE 
Non-Drop (29.97 fps, Video). 

Seconds: changes the status format to Seconds. SMPTE Drop: changes the status format to SMPTE Drop 
(29.97 fps, Video). 

Time and Frames: changes the status format to Time 
and Frames.

SMPTE 30: changes the status format to SMPTE 30 
(30 fps, Audio).

Absolute Frames: changes the status format to 
Absolute Frames.

Auto Snap to Zero: forces the ends of selections to the 
nearest zero-crossing.

Measures and Beats: changes the status format to 
Measures and Beats.

Auto Snap to Time: forces the ends of selections to the 
nearest whole time division on the time ruler. 

SMPTE Film Sync (24 fps): changes the status format to 
SMPTE Film Sync (24 fps). 

Regions List: displays the Regions List. Generate MIDI Timecode: configures the software to 
send MIDI timecode through the MIDI output port. The 
MIDI output port is specified on the MIDI/Sync tab of 
the Preferences dialog.

Playlist: displays the playlist. Pre-Queue for MIDI Timecode: opens the wave device 
and preloads data for the next region to be played from 
the playlist. 

Trigger from MIDI Timecode: configures the software to 
be triggered by MIDI commands received through the 
MIDI input port. The MIDI input port is specified on the 
MIDI/Sync tab in the Preferences dialog. For more 
information, see Turning on MIDI input synchronization 
on page 196.
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Process toolbar

The Process toolbar contains buttons corresponding to all commands located in the Process menu.

Effects toolbar

The Effects toolbar contains buttons corresponding to all Sound Forge built-in XFX™ plug-ins.

Auto Trim/Crop: removes silence and automatically 
fades in/out the end-points of each phrase.

Insert Silence: inserts user-configurable silence into 
audio files.

Bit-Depth Converter: converts a file to a different bit 
depth.

Invert/Flip: inverts (or flips) the polarity of the current 
selection.

Channel Converter: converts between mono and 
multichannel formats. Can also intermix the channels of 
a file to create panning effects.

Mute: mutes the current selection.

DC Offset: changes the baseline of an audio file. Normalize: normalizes the loudness of an audio file.

Graphic EQ: opens Sony Media Software’s XFX Graphic 
EQ.

Pan/Expand: creates custom pans, expands, and mixes.

Paragraphic EQ: opens Sony Media Software’s XFX 
Paragraphic EQ.

Resample: creates a copy of the audio file with a new 
sample rate.

Parametric EQ: opens Sony Media Software’s XFX 
Parametric EQ.

Reverse: reverses the current selection.

Graphic Fade: creates user-configurable fades. Smooth/Enhance: opens Sony Media Software’s XFX 
Smooth/Enhance tool.

Fade In: fades-in the selection. Time Stretch: opens Sony Media Software’s XFX Time 
Stretch tool.

Fade Out: fades-out the selection. Volume: adjusts the volume of an audio file.

Acoustic Mirror: adds environmental coloration to your 
existing recordings. 

Flange/Wah-Wah: mixes a modulated delay signal with 
the original signal.

Amplitude Modulation: applies a sinusoidal or square-
shaped periodic gain to the input signal. 

Gapper/Snipper: removes/inserts sections of silence at 
regular intervals to create unusual effects.

Chorus: simulates multiple audio sources from a single 
sound.

Noise Gate: removes signals below a set amplitude 
threshold.

Multi-Tap Delay: creates a delay with up to eight delay-
taps spaced anywhere within 2.5 seconds of the original 
sound. 

Pitch Bend: creates a modified sound envelope that 
corresponds to increasing or decreasing the pitch of a 
sound file over time.

Simple Delay: adds a delayed copy of the audio signal 
to the file.

Pitch Shift: changes the pitch of a selection with or 
without preserving the duration of the file.

Distortion: simulates the overloading of an amplifier. Reverb: simulates the acoustics of different 
environments. 

Graphic Dynamics: applies compression, expansion, 
and limiting to affect the dynamic range of an audio file.

Vibrato: creates periodic pitch modulation in an audio 
file.

Multi-Band Dynamics: allows compression and limiting 
to be placed on up to four different frequency bands.

Wave Hammer: acts as a classic compressor and volume 
maximizer.

Envelope: forces the amplitude envelope of a waveform 
to match a specified envelope shape.
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Tools toolbar

The Tools toolbar contains buttons corresponding to commands in the Tools menu.

Levels toolbar

The Levels toolbar displays the audio levels in the left and right channels in the user-specified format. You can right-click to choose the 
format from a shortcut menu.

ACID Loop Creation Tools toolbar

The ACID Loop Creation Tools toolbar contains buttons corresponding to commands used when creating audio loops for Sony’s ACID® 

family of products. For more information, see Creating loops for ACID software on page 217.

Tempo window

The ACID Loop Creation Tools toolbar also contains a Tempo window that appears to the right of the toolbar buttons. This window 
calculates and displays the ACID project’s tempo as if the current selection represents a complete measure.

Extract Audio from CD: extracts audio from CD and 
opens for editing.

Audio Restoration: removes clicks and background 
noise associated with vinyl records.

Burn CD: writes the selected audio track to CD. Crossfade Loop: mixes audio occurring before the loop 
start point into the end of the loop to smooth 
transitions.

Auto Region: creates regions in an audio file according 
to rapid sound attacks or a specified time interval.

Sampler: allows you to transfer samples to/from the 
Sound Forge application.

Extract Regions: extracts all file regions and saves them 
as individual files.

DTMF/MF Tones Synthesis: generates dial tones used by 
telephone companies.

Clip Detect: performs clip detection on the current file 
or selection.

FM Synthesis: uses frequency modulation and additive 
synthesis to create complex sounds from simple 
waveforms.

Find: searches for clicks and pops, volume levels, or 
silent breaks in an audio signal.

Simple Synthesis: generates a simple waveform of a given 
shape, pitch, and length.

Interpolate: replaces selected audio with interpolated 
audio data based on the selection’s beginning and end 
samples.

Statistics: displays statistics corresponding to the 
current file or selection.

Replace: replaces selected audio data with previous 
adjacent data.

Preset Manager: backs up and transfers user-configured 
presets from effects, processes, and plug-ins.

Copy Other Channel: replaces selected audio with a 
corresponding selection from the opposite channel.

Edit ACID Properties: displays the Edit ACID Properties 
dialog.

Shift Selection Left: shifts the current selection to the 
left so the current start point becomes the end point.

Edit Tempo: calculates the musical tempo (beats per 
minute) based upon the current selection.

Shift Selection Right: shifts the current selection to the 
right so the current end point becomes the start point.

Double Selection: doubles the size of the current 
selection.

Rotate Audio: moves the current selection to the 
opposite end of the file.

Halve Selection: divides the current selection in half. Selection Grid Lines: toggles the selection grid line 
display on/off.

Left Right 
channel level channel level
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Scripting toolbar

The Scripting toolbar allows you to show, hide, or activate the Script Editor and display the Batch Converter window.

ToolTips

Using ToolTips

Hovering the mouse pointer over a button or status bar box for longer than one second displays a small text box adjacent to the 
pointer. This text, called a ToolTip, is a brief description of the item’s function. Using ToolTips is an effective way to quickly familiarize 
yourself with features. 

Turning off ToolTips

1. From the View menu, choose Toolbars. The Preferences dialog is displayed.

2. Clear the Show ToolTips check box and click OK.

Command descriptions

When you click and hold a menu item or a button in a toolbar, a brief description of the command appears in the lower-left corner of the 
status bar. If you release the mouse button outside of the menu item or toolbar, the command is not executed.

Keyboard shortcuts

The Keyboard map allows you to customize the keyboard shortcuts available in the Sound Forge interface. You can access the Keyboard 
map by choosing Customize Keyboard from the Options menu.

Monitoring levels in digital audio

The Sound Forge channel meters display peak levels during playback. Use the meters to monitor levels and ensure no clipping occurs in 
your file.

Decibels

The standard method for digital metering is to use the maximum possible sample value as a reference point. This value is referred to as 
0 dB. Decibels are used to represent fractions logarithmically. In this case, the fraction is: sample amplitude divided by the maximum 
possible amplitude. The actual equation used to convert to decibels is: dB = 20 log (amplitude/32,768)

To illustrate this, consider a sine wave with a peak amplitude of 50% of full scale. Inserting the values in the appropriate places yields 20 
log (0.50) = -6.0 dB. Each time a signal’s amplitude is divided by two, its dB value is decreased by 6 dB. Likewise, doubling the amplitude 
of a signal increases its dB value by 6 dB. Dividing the sine wave until its peak amplitude is equal to 1 produces lowest peak dB possible, 
-90.3 dB.

Why are dBs used when talking about audio? Decibels are typically used when dealing with sound pressure levels because of the vast 
range of sound (about 120 dB) that the human ear can perceive. It’s also easier to say -90 dB than 0.000030 (1/32,768).

Script Editor: Allows you to create, edit, or run scripts. Batch Converter: Allows you to modify and manipulate 
multiple audio files without having to process each file 
individually.

ToolTip
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Digital versus analog levels

When recording to an analog medium such as magnetic tape, recording engineers typically try to keep VU (volume unit) meters as close 
to zero as possible. This ensures a high signal-to-noise ratio while preserving adequate headroom to keep the tape from saturating and 
distorting. In addition, occasional peaks above 0 do not cause problems because the tape saturation point is not an absolute.

However, this is not true in the digital realm, where amplitudes are stored as discrete numbers instead of continuous variables. The 
flexible recording ceiling of analog is replaced by the absolute maximum sample values of digital audio. Stored signals must never have 
a value above these maximums, as the wave peaks are literally clipped. This clipping adds audible distortion and though it can go 
unnoticed, it can also ruin an entire project. Therefore, sample with the understanding that digital audio has absolutely no headroom.

Setting digital audio levels

Because digital audio has no headroom, setting the sampling level becomes critical. If the loudest section of the audio is identified in 
advance, the recording level should be set so that the peak is as close to 0 dB as possible to maximize the dynamic range of the digital 
medium. If the loudest section of audio is unknown, allow 3 to 6 dB of headroom for unexpected peaks.

Using the channel meters

From the View menu, choose Channel Meters to open or close the channel meters. By default, Sound Forge software provides peak 
meters that you can use to monitor your audio levels. You can also choose to display VU/PPM (peak program) meters, a phase scope, 
and a mono-compatibility meter.

The peak meters display instantaneous levels during playback to help you determine the loudest level in your audio signal and whether 
the signal is clipping.

To prevent clipping, keep an eye on your peak meters. Peak levels should never exceed 0 dB. You can use the Status tab in the 
Preferences dialog to calibrate the VU/PPM meters to their associated levels on the peak meters and adjust the VU meters’ sensitivity.

Showing or hiding the Channel Meters window

From the View menu, choose Channel Meters to open or close the channel meters. You can dock the Channel Meters window on any 
edge of the Sound Forge workspace.

Tip: From the Tools menu, choose Find and use the Find dialog to identify the largest peak in your file.

Mono-compatibility meter

Phase scope

Peak meter

VU/PPM Meters
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Showing or hiding meters

You can display a peak meter, VU/PPM, a phase scope, and mono-compatibility meter for each channel. To toggle the display of each 
meter, right-click the Channel Meters or Hardware Meters window and choose a command from the shortcut menu. 

A check mark is displayed to indicate which meters are currently visible.

• For more information about VU/PPM meters, please see Using the VU meters on page 35.
• For more information about phase scopes, please see Using phase scopes on page 36.
• For more information about mono-compatibility meters, please see Using the mono-compatibility meters on page 37.

Resetting clipping indicators 

When audio levels are too high, clipping can occur. A red indicator appears at the top of the meter to show when audio is clipping. Do 
any of the following to reset the indicator:

• From the Options menu, choose Channel Meters, and then choose Reset Clip from the submenu.
• Click to reset the indicator, or right-click the meters and choose Reset Clip from the shortcut menu.

You can also detect and mark clipped audio using the detect clipping tool. For more information, see Detecting and marking clipping on 
page 98.

Changing the meters’ display resolution

The peak meters display levels in dB FS. To change the resolution of the meters, do either of the following:

• From the Options menu, choose Channel Meters, choose Peak Range from the submenu, and then choose a display range.
• Right-click the channel meter, choose Peak Range from the submenu, and then choose a display range.

Changing the meters’ display options

You can choose whether labels, peaks, and valleys are displayed in the meters and whether the meters are displayed on top of other 
windows when they are not docked.

Do either of the following to change the meters’ display options:

• From the Options menu, choose Channel Meters, and then choose a command from the submenu.
• Right-click the meters and choose a command from the shortcut menu.

Note: Choosing a wide range allows you to see low-level signals at the expense of precision display at high levels.

Command Description
Expand Meters Toggles expanded-width meters. Turning off expanded meters can conserve screen space.

Interleave Meters Toggles interleaved or stacked display of VU/PPM meters with the corresponding channel meters.

Show Labels Toggles the meter level labels on and off.

Hold Peaks When selected, the highest peak levels are represented by a thin line on the meter.

Hold Valleys When selected, the lowest peak levels are represented by a thin line on the meter.

Always on Top When this command is selected, the channel meters will always be displayed above any other windows.

Click the clipping 
indicator to reset it.

Clipping 
indicator
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To change the layout of the meters in the Channel Meters window, right click the meters, choose Layout from the shortcut menu, and 

then choose a command from the submenu.

Routing channels to hardware outputs

You can change channel assignments from the Audio tab in the Preferences dialog or the Channel Meters window (for more 
information, see Audio tab on page 248). Changing the setting in either location updates your preferences and affects all open data 
windows.

To change a channel’s output device using the Channel Meters window, click the channel number and choose a new output port from 
the menu:

Using the VU meters

You can display volume unit (VU) and peak program (PPM) meters in the Channel Meters and Hardware Meters windows to help you 
determine the perceived loudness of your audio signal (peak program meters provide faster response times to volume increases than 
VU meters). For more information on the channel meters, see Using the channel meters on page 33. For more information the hardware 
meters, please see Using the hardware meters on page 92.

VU/PPM meters are especially helpful when you're mastering: comparing two audio files’ VU/PPM readings will help take the guesswork 
out of matching levels

Right-click the Channel Meters or Hardware Meters window and choose Show VU/PPM from the shortcut menu to toggle the display of 
the VU/PPM meters.

VU/PPM readings should fall near the 0 (or reference) mark. 0 VU is merely a reference level, and your signal may exceed 0 VU. To 
prevent clipping, keep an eye on your peak meters. Peak levels should never exceed 0 dB. You can use the Status tab in the Preferences 
dialog to calibrate the VU/PPM meters to their associated levels on the peak meters and adjust the VU meters’ sensitivity. For more 
information, see Status tab on page 247.

Choosing a VU or PPM scale

To change the scale of the meter, choose Channel Meters from the Options menu, choose VU/PPM Scale, and then choose a setting 
from the submenu (you can also right-click the meter to set its options).

VU and PPM scales are most useful for displaying the average volume of the signal: the meter represents the RMS average level during 
playback, and their attack nd decay are not as sensitive as the peak meter. 

PPM scales are useful for monitoring peak levels. The meters use a fixed integration time (5 or 10 ms) that is sensitive to increases in 
volume, but the meters are less sensitive to decreases in volume than the VU scales, which produces less meter activity and decreased 

eyestrain.

Command Description
Horizontal/Vertical/
Auto

Choose a command to change the orientation of the meters in the Channel Meters window.

Narrow Width Toggles narrow- or normal-width meters. Using narrow meters can conserve screen space.
Interleave Peak/VU Toggles interleaved or stacked display of VU/PPM meters with the corresponding channel meters.

Item Description
Traditional VU The traditional VU meter is displayed with a scale of –10 dB to +2 dB. 0 dB on the VU meter equals 4 dBu.

Extended VU The extended VU meter is displayed with a scale of –30 dB to +8 dB. 0 dB on the VU meter equals 4 dBu.

Logarithmic VU Displays the meters in a logarithmic scale (like the Sound Forge peak meters) instead of the linear scales traditionally associated with 
VU meters.
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Adjusting the VU meters’ sensitivity

Unlike peak meters — which read instantaneous changes in your audio signal — the VU/PPM meters read a portion of the signal and 
calculate the average level. The size of the signal that the meters read is determined by the meters’ integration time.

To set the amount of data surrounding the cursor that will be used to calculate levels in the VU meters, specify a value in the VU meter 
integration time box on the Status tab of the Preferences dialog.

The PPM scales use a fixed integration time:

Changing the meters’ display resolution

The VU/PPM meters display levels in dB VU. To change the resolution of the meters, perform either of the following steps:

• From the Options menu, choose Channel Meters, choose VU/PPM Scale from the submenu, and then choose a display range.
• Right-click the channel meter, choose VU/PPM Scale from the submenu, and then choose a display range.

Choosing a wide range allows you to see low-level signals at the expense of precision display at high levels.

Showing labels

Right-click the meters and choose Show Labels from the shortcut menu to toggle the meter dB markings on and off.

Holding peaks and valleys

Right-click the meters to access the Hold Peaks and Hold Valleys commands in the shortcut menu. 

• Choose Hold Peaks to display a marker on the meters indicating the highest reading. 
• Choose Hold Valleys to display a marker on the meters indicating the lowest reading. 

Using phase scopes

You can display a phase scope in the Channel Meters and Hardware Meters windows to find phase cancellation among the channels in 
an audio file. For more information on the channel meters, see Using the channel meters on page 33. For more information the hardware 
meters, please see Using the hardware meters on page 92.

Right-click the Channel Meters or Hardware Meters window and choose Show Phase Scope from the shortcut menu to toggle the 
display of the phase scope.

UK PPM The UK peak program meter (also known as a BBC meter) is a Type II meter and is displayed with a scale of 1 to 7, which corresponds to 
a range of -12 to 12 dBu:

UK Marks dBu

7 12

6 8

5 4

4 0

3 4

2 8

1 -12

EBU PPM The EBU peak program meter is a Type II meter and is displayed with a scale of –12 to +12, which corresponds to -12 dBu to 12 dBu. 0 
on the EBU PPM equals 0 dBu.

The EBU PPM and UK PPM respond identically to increases in volume, but the EBU PPM decays more slowly.

DIN PPM The DIN peak program meter is a Type I meter and is displayed with a scale of –50 dB to +5 dB, which corresponds to -44 dBu to 11 dBu. 
0 dB on the DIN PPM equals 6 dBu.

Nordic PPM The Nordic peak program meter is a Type I meter and is displayed with a scale of –42 dB to +12 dB, which corresponds to -42 dBu to 12 
dBu. 0 dB on the Nordic PPM equals 0 dBu.

Scale Integration time
UK PPM 10 ms

EBU PPM 10 ms

DIN PPM 5 ms

Nordic PPM 5 ms

Item Description
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To change the display, right-click the Channel Meters or Hardware Meters window, choose Phase Scope Style from the shortcut menu, 

and then choose a setting from the submenu:

Using the mono-compatibility meters

You can display a mono-compatibility meter in the Channel Meters and Hardware Meters windows to detect correlations or differences 
between the channels of a file that can cause phase cancellation when downmixing to mono. For more information on the channel 
meters, see Using the channel meters on page 33. For more information the hardware meters, please see Using the hardware meters on page 
92.

Right-click the Channel Meters or Hardware Meters window and choose Show Mono-Compatibility Meter from the shortcut menu to 
toggle the display of the mono-compatibility meter.

When the channels are similar, the right (or top) half of the meter is illuminated: 

When the channels exhibit phase cancellations, the left (or bottom) half of the meter is illuminated: 

Controls

A major step in mastering Sound Forge software is becoming familiar with the controls used to set and adjust feature parameters, 
including faders, sliders, and envelope graphs.

Faders and sliders

Faders and sliders are frequently used to edit effect and process parameters. To use either control, drag the control to the desired 
position and release.

Resetting fader and slider values

Double-click to return the control to its default value.

Style Description
Lissajous - XY Plot Displays the right and left channels plotted along the X and Y axes of the graph. 
Lissajous - Rotated Displays the right and left channels plotted along the X and Y axes of the graph. This 

setting is identical to the Lissajous - XY Plot setting, but the graph is rotated 45 degrees.
Polar - Linear Plot Displays the right and left channels plotted vertically on the graph. 
Polar - Circular Plot Displays the right and left channels plotted on a circular graph.

Fader

Drag to set value

Slider
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Fader and slider shortcuts

There are numerous keyboard shortcuts available when using faders and sliders. 

Envelope graphs

Envelope graphs are used to configure the shape of frequency or amplitude envelopes applied to audio waveforms.

Understanding the envelope graph

To use the envelope graph, you must first understand what it represents. In the previous example, the horizontal axis represents time, 
with the leftmost point representing the start of the selection and the rightmost point representing the end of the selection. The vertical 
axis represents either amplitude or frequency, depending upon the operation.

Moving an envelope point

1. Drag an envelope point to a new position.

2. Release the mouse button. The point is repositioned and the envelope adjusts.

Moving multiple envelope points

1. Starting in an unused area of the envelope graph, drag the mouse to create a selection box containing all points to be moved.

If you want to Then use the following shortcuts
Change the value in small increments

   

-or-

Hover the mouse over the fader or slider control and press Ctrl while moving the 
mouse wheel.

Change the value in larger increments Page Up and Page Down 

-or-

Hover the mouse over the fader or slider control and move the mouse wheel.
Set the control to its maximum and minimum values 
respectively

Home and End

Envelope point

Envelope

Time axis

Amplitude or 
frequency axis
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2. Release the button. The selected envelope points are displayed with a white square center.

3. Drag any of the selected envelope points to the desired position. The pointer displays as a multi-directional arrow and the selected 
points move together.

4. Release the mouse button. The entire envelope graph adjusts.

Changing the fade curve between two points

To change the type of fade between two envelope points, right-click an envelope segment and choose a fade type (Linear Fade, Fast 
Fade, Slow Fade, Smooth Fade, Sharp Fade, and Hold) from the shortcut menu.

Selecting or clearing all envelope points

Press Ctrl+A to select or clear all envelope points.

Adding an envelope point

1. Hover over the envelope.

2. Double-click the mouse. A point is added to the envelope graph and can be positioned as needed. For more information, see Moving 
an envelope point on page 38.

Deleting an envelope point

Right-click the point to be deleted and choose Delete from the shortcut menu. The point is deleted and the envelope adjusts.

Delete all points

Delete all envelope points by clicking the Reset Envelope button.

Displaying the waveform on an envelope graph

Certain envelope graphs (such as in the Graphic Fade dialog) allow you to view the audio waveform on the graph. If the selection is 
small, the waveform automatically displays. Otherwise, selecting an option from the Show wave drop-down list displays the waveform. 

Displaying multichannel waveforms

The Show Wave drop-down list allows you to specify how multichannel files display in the envelope graph.

Reposition multiple envelope points

Place the pointer on the envelope 
and double-click to add a point.
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Multichannel files

When a data window displays a multichannel file, all channels are shown at the same time. 

Working with multichannel files

When playing, editing, or processing multichannel files, you can select a single channel or all channels. However, certain processing 
tasks cannot be performed on an individual channel of a multichannel file. For more information, see Single-channel editing on page 42, or 
Editing Multichannel Audio on page 91.

Selecting data in multichannel files

When editing a multichannel file, you can use the mouse to select data simply by clicking and dragging in a data window. There are 
several options for data selection in multichannel files.

1. Open a multichannel file.

2. Select the Edit tool by choosing Tool from the Edit menu and Edit from the submenu.

3. Select the data:

• Drag within a channel to select that channel only.

• Double-click a channel number to select the entire channel.

Tip: Press Ctrl+D or click the Edit Tool button  on the Standard toolbar.
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• Drag across channels to select multiple channels.

• Drag along the divider between channels (or the loop bar above the ruler) to select all channels.

• Hold Ctrl and click a channel to add or remove it from the current selection.

Toggling channel selections

Once you place the cursor or create a selection in a multichannel file, you can cycle through channel options by pressing Tab.

Previewing channels

The single channel selection option allows you to preview channels in a multichannel file individually.

1. Open a multichannel file and select all data.

2. Click the Play Normal button . All channels play. Click the Stop button .

3. Press Tab. The first channel is selected.

4. Click the Play Normal button . Only the first channel plays. Click the Stop button .

5. Press Tab. The second channel is selected.

6. Click the Play Normal button . Only the second channel plays. Click the Stop button .
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Single-channel editing

You have the ability to cut, copy, and paste data in single channels of a multichannel file. However, channel lengths must always remain 
equal in multichannel files. For more information on cutting, copying, and pasting data, see Editing audio on page 57.
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Chapter 3
 Getting Started

The Sound Forge® digital audio editing tool is for users from all musical backgrounds. It is an extremely deep program, 
containing features that may only be required by the most advanced or specialized users. Nonetheless, a firm grasp of 
Sound Forge basics is essential. This chapter is designed to provide you with information on Sound Forge fundamentals.

Creating a project

You can use Sound Forge project files to organize and work with your media files nondestructively. When you save a 
project file, two things are created: a .frg file and a subfolder that contains your media file and all of the temporary files 
created while working on your project. This file is not a multimedia file, but is used to render the final file after editing is 
finished. When you copy, cut, paste, and otherwise edit your project, the process is nondestructive—meaning you can 
edit without worrying about corrupting your source files. Within the project file, you can also undo any past operations, 
including those occurring before your last save. Once you are finished working with a project file, you can save your work 
to a media file using the Render As option on the File menu.

1. From the File menu, choose Save As to save the current data window to a project file. The Save As dialog is 
displayed.

2. Using the Save in drop-down list, locate the folder where you want to save the project.

3. From the Save as type drop-down list, choose Sound Forge Project File (*.frg).

4. In the File name box, enter a name for the file.

5. Click the Save button. A .frg file is created with the name you specified, and a folder with a similar name 
(projectname_frg, for example) is created in the same location for the temporary files.

Note: To use the advanced undo/redo capabilities mentioned above, you must have the Allow Undo past Save check 
box selected on the General tab of the Preferences dialog. To access the Preferences dialog, choose Preferences from the 
Options menu.

Important: The associated project folder created by this process should not be deleted, as this will cause your project file 
to be unusable.
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Getting media files

The software can open a variety of audio and video files. There are two main methods for locating, previewing, and opening media files:

• From the File menu, choose Open to display the Open dialog.
• From the View menu, choose Explorer to display the Explorer window.

These methods are explained in greater detail in the following sections.

Using the Open dialog

1. From the File menu, choose Open. The Open dialog is displayed.

.

The Open dialog contains several features that allow you to locate and open audio files. These features are detailed below.

2. Locate and select a media file using the Look in drop-down list at the top of the dialog.

3. To preview the file before adding it to your project, click the Play button.

Note: To have pulldown fields automatically removed when opening 24 fps progressive-scan DV video files, select the Allow pulldown 
removal when opening 24p DV check box on the Video tab of the Preferences dialog. To open your 24p DV video files as 29.97 fps 
interlaced video (60i), clear this check box.

Tip: Click the Open button .

Feature Description
Files of type Use this drop-down list to specify the file format displayed in the system. A variety of file formats are supported.

Tip: Choose the CD Audio (*.cda) option from this list to extract audio tracks from a CD.
Recent Use this drop-down list to locate recently accessed folders.
Merge L/R to stereo Select this check box and hold the Ctrl button while selecting two mono files in the browse window. The two 

mono files will be merged to the left and right channels of a new stereo file.

The first file you select will be placed in the left channel, and the second file will be placed in the right channel.

Compressed files are not supported for merging.
Auto play Select this check box to automatically preview files as you select them in the Open dialog.

Note: If you have the Auto play check box selected, your file will automatically begin previewing when you select it.

File Information Display
Select to automatically 
preview files
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4. Click Open. The file is opened and a data window containing the waveform is displayed.

Using the Explorer window

In addition to using the Explorer window for locating, previewing and opening media, you can drag files or regions from the Explorer 
window to an open data window to paste or mix the data. Click the right mouse button while dragging to toggle mix and paste drag-
and-drop modes. You can also extract audio from a CD.

Previewing media

The Explorer window allows you to easily preview files before you open them. The Explorer window has a mini-transport bar with Play, 

Stop, and Auto Preview buttons . When you preview a file, its stream is sent to the channel meters on the main workspace (for 
audio files) or to the Video Preview window (for video files).

1. Select a file in the Explorer window.

2. Click the Play button  to listen to the file.

3. Click the Stop button  or select a different file to stop previewing the file.

Opening media

To open a media file into a new data window from the Explorer window, double-click the file. To open a media file in a specific data 
window, drag the media file from the Explorer window to the data window.

Obtaining or editing CD information

If Sound Forge can access information about a track or CD (either from the file or CD itself or from a local cache), it automatically reads 
and displays this information when you insert a CD or browse your computer. However, if this information is not available, the software 
can retrieve information over the Internet from Gracenote® MusicID™. 

Once Sound Forge obtains information from Gracenote MusicID, it is saved to a local cache so the information displays more quickly the 
next time the tracks are displayed.

Note: To preview video files, you must have the Video Preview window open. To display the Video Preview window, choose Video 
Preview from the View menu.

Tip: To automatically preview selected files, click the Auto Preview button  on the Explorer window’s transport bar.
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If the software cannot connect to the Gracenote Media Database and the appropriate CD information is not available on your computer, 
the tracks are simply listed numerically. In this case, you can edit CD information and submit it to the Gracenote Media Database.

Locating matching CD information using Gracenote

1. Insert a CD in your drive.

2. Browse to the CD and click the MusicID  button in the Explorer window.

Gracenote MusicID attempts to obtain matching CD information and displays artist, album, and track data:

• If the service locates an exact match, this information is automatically displayed. No additional action is necessary.
• If the service locates multiple possible matches, the Match dialog is displayed. Proceed to step 2.

3. Choose a method for completing the CD information:

• If none of the possible matches is appropriate, click the Submit New button. The Gracenote MusicID Disc Information dialog is 
displayed, allowing you to complete information for the CD and submit it for inclusion in the Gracenote Media Database. For 
help on submitting CD information, click the Help/Guidelines button in this dialog. 
When you are finished typing information, click the OK button to submit your data.

• Select the appropriate match from the list and click the Accept Match button. The artist, album, and track information is 
displayed based on your selection in the right side of the PC pane.

Editing and submitting CD information to Gracenote

If a CD is not currently part of the Gracenote Media Database, you can submit it for inclusion.

1. Insert a CD in your drive.

2. Browse to the CD and click the MusicID  button in the Explorer window. The Gracenote MusicID Disc Information dialog is 
displayed.

3. Use the Gracenote MusicID Disc Information dialog to edit information about the CD. For help on submitting CD information, click 
the Help/Guidelines button in this dialog.

4. When you are finished entering the information, click the OK button to submit it for inclusion in the Gracenote database.

Extracting audio from CD

The Explorer window allows you to easily extract audio from a CD into a data window. Each audio track on the CD is extracted into a 
separate data window.

1. Use the Explorer window to browse to and select your CD drive. The CD’s audio tracks display in the right pane of the Explorer 
window.

2. Select the track(s) you want to extract.

3. Drag the track(s) to the main Sound Forge workspace. The software begins extracting the selected tracks into individual data 
windows. 

4. To stop the extraction process, you can click the Cancel button on the status bar to stop the whole process or on the individual 
data windows to stop extracting a specific track.

Notes:

• Using Gracenote MusicID requires an active Internet connection.
• For more information on using Gracenote MusicID, please refer to the Gracenote Web site at  

http://www.gracenote.com/cddb2info/using.html.

Tip: To extract a single audio track into a new data window, double-click the track in the right pane of the Explorer window.
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Using Explorer views

You can control the information that is displayed in the Explorer window by clicking the Views button  and selecting a view. These 
options are explained below:

Peak files

When you first open a file, the entire file is scanned and a peak file is created. The peak file is stored with the same name and in the same 
location as the audio file, but it is given an .sfk extension. This peak file is automatically updated whenever the original file is edited. 

If you modify a file in another application, you can regenerate the peak file by choosing Rebuild Peak Data from the Special menu.

Working with video files

The Sound Forge application has the ability to open and save many video file formats. The video files cannot be edited within the 
software, but this functionality allows you to attach, detach, and edit audio for the video. Once you’ve edited the audio, you can preview 
the audio and video together.

When you open a media file containing video, the data window displays the video portion in a video strip above the audio. 

For more information, see Working with Video on page 223.

Item Description
Tree View Displays all of the available drives and folders that you may choose from to find files.
Region View Displays any regions that have been defined in the selected media file.
Summary View Displays a short description of the selected media file at the bottom of the Explorer window.
Details Displays the file size, date and when the file was last created or last modified.
All Files Displays all file types in the active folder.
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Playing a file

After you open a file, you can play it by clicking the Play All button  on the transport bar. For more information, see Transport toolbar 
on page 27.

Viewing the current position

As a file plays, the current playback position is indicated in the data window in three ways:

• A cursor travels across the visible portion of the data window.
• The current playback position in relation to the entire file appears in the overview bar.
• The first selection status box in the playbar displays the current position in the user-specified format. For more information, see 

Selecting status formats on page 65.

Data window scrolling during playback

From the Options menu, choose Scroll Playback (or press F6) to enable automatic data window scrolling during playback. When the 
cursor moves off of the current window, it will quickly scroll to show another full window of data.

To enable smooth scrolling, select the Scroll Smoothly option from the Options menu (or press Shift+F6). When this option is selected, 
the cursor will slowly move back to the center of the display, and the wave data will scroll past it. This allows you to view upcoming data 
while the file is being played.

Playing a file from a specified point

You can begin playback from any point in a file.

1. Click to position the cursor in the data window. A flashing cursor (spanning the height of the waveform display) is displayed. 

2. Click the Play button  on the transport bar. The file plays from the cursor position. 

If you do not hear playback, you may have inadvertently created a small selection. To determine if you created a selection, examine 
the status boxes in the bottom-right corner of the data window. 

• If only the first box contains a value, there is no selection.
• If all three boxes contain values, a selection has been created. Clear the selection by clicking anywhere in the data window.

For more information, see Viewing selection status on page 49.

Overview bar current 
position

Status box value

Cursor 
position

Selection status bar
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Playing in Loop Playback mode

You can play an entire file or a selection in Loop Playback mode. In Loop Playback mode, the audio is played in a continuous loop. 

Click the Loop Playback button  on the transport bar (or press Q) to turn Loop Playback mode on and off.

Playing a selection

You can play specific portions of audio data by creating selections in the waveform display. 

1. Drag the mouse within the data window. Notice that the waveform is selected as the mouse is dragged. 

2. Click the Play button . Only the selection plays.

Viewing selection status 

When a selection exists, the boxes in the selection status bar in the bottom-right corner of the data window contain values. These values 
indicate the start, end, and length of the selection. Double-click a box to edit the value.

Selecting the status format

You can display status values in any supported format. You can change the format by right-clicking and choosing a new format from the 
shortcut menu. For more information, see Selecting status formats on page 65.

Selection status bar

No selection Selection

Cursor position Selection start Selection end Selection length
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Viewing selection statistics

Choosing Statistics from the Tools menu displays a Statistics dialog showing information about the current selection or, if there is no 
selection, on the entire file.

The following table describes all statistical categories displayed in the Statistics dialog.

Statistical Category Description
Ruler Format Choose a setting from the drop-down list to determine the format you would like to use for the Cursor position, Minimum sample 

position, and Maximum sample position. For more information, see Selecting status formats on page 65.
Level Format Choose a setting from the drop-down list to specify how the left- and right-channel levels at the cursor position will display.

• Values - Displays as an integer. The range is from -8388608 to 8388607 in 24-bit audio, -32768 to 32767 in 16-bit audio and -128 and 
127 in 8-bit audio.

• Decibels - Displays as decibels. A value of 0 dB corresponds to maximum absolute amplitude and negative infinity (-Inf.) corresponds 
to complete silence. In 16-bit audio, -90.3 dB is the lowest possible dB value (sample value of 1).

• Percentages - Displays as a percentage ranging from -100 to 100 percent.

Cursor position The cursor position (in samples) from the start of the audio file.

Sample value at cursor The actual number stored by a single sample. The maximum allowed sample value is often referred to as 100% or 0 dB.

Maximum/minimum sample 
position and sample value

The maximum and minimum sample values and the locations (in samples) where they occur.

These values may help determine if clipping will occur in the audio file. These values can also be used to determine the noise level of a 
signal for use with Noise Gate (a built-in XFX plug-in installed with Sound Forge). For example, to determine the noise amplitude of a 
file, run Statistics on a region of noisy silence.

RMS level The Root Mean Square of the sample values relative to the RMS value of a maximum-amplitude square wave (the loudest possible 
recording).

On short intervals, this value relates to the volume level of the audio file. If used on a large selection with large volume variation, this 
value becomes less meaningful.

Average value The sum of all sample values in the selected region divided by the number of samples. If this value is not zero, it usually indicates a DC 
offset in the recording process.

Zero crossings The number of times per second that the waveform fluctuates from a negative to a positive value.

This value can be used as a rough estimate of the frequency of the audio data for very simple waveforms.

Copy to Clipboard Copies all contents of the Statistics window to the clipboard. This can be useful if you want to compare statistics of multiple files in a 
spreadsheet.

Note: To copy specific data or cell, select the cells that you want to copy and press Ctrl+C.
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Creating a new data window

1. From the File menu, choose New. The New Window dialog is displayed.

2. Complete the New Window dialog:

a. From the Sample rate drop-down list, choose a sample rate.

b. From the Bit-depth drop-down list, choose a bit depth. 

c. Choose a setting from the Channels drop-down list to select the number of channels stored in the file. 

For more information, see Editing file attributes on page 83.

3. Click OK. A new data window with the specified attributes is displayed.

Active data windows vs. inactive data windows

When multiple data windows are displayed on the workspace, only the window currently being edited is active, and all operations affect 
this window exclusively.

Activating a window

To activate a data window, click anywhere within it. The title bar changes to the color defined as the active window color and the 
previously active window is deactivated.

Tip: New windows are automatically named for you. You can customize this automatic naming feature to suit your needs. For more 
information, see Customizing marker labeling on page 97.

Note: Choosing Focus to Data Window from the View menu also results in the focus being returned to the current data window.
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Copying data to a new file

You can create new audio files by copying data to a new data window. 

1. Open an audio file and create a selection.

2. From the Edit menu, choose Copy (or click the Copy button ). The selection is copied to the clipboard.

3. Create a new data window. For more information, see Creating a new data window on page 51.

4. From the Edit menu, choose Paste (or click the Paste button ). The selected data is pasted in the new data window. 

Working with files

You can save a file in a variety of formats, including popular audio formats such as WAV and AIFF, and streaming media formats such as 
Windows Media® Audio and RealMedia™. You can save a file using a standard template, or you can customize the settings to suit your 
needs. Once you create custom settings, you can save those settings as a template.

You have the option to save all open files at once or to save all open files as a workspace file.

Saving a file

1. Click anywhere in the data window to select it.

2. From the File menu, choose Save.

Using the Save As/Render As dialog

The Save As dialog allows you to save an audio file with a new name, in an alternate format, or with new attributes.

The Render As dialog allows you to render a file using a standard template, or you can customize the settings to suit your needs. Once 
you create custom settings, you can save those settings as a template.

Note: When saving a new file, the Save As dialog is displayed. If the file was previously saved, choosing Save automatically saves the file 
without your input.

Select file type

Select recent directories

Select template

Template description

Select saving metadata option

Select video options
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1. Click anywhere in the data window to select it.

2. From the File menu, choose Save As to display the Save As dialog.

If you’re working with a Sound Forge project file, you can use the Save As dialog to save your project to a different name or location. 
Choose Render As to save your project as a media file.

3. Select the folder where you want to save the file:

a. From the Save in drop-down list, choose a drive and folder.

--or--

b. From the Recent drop-down list, choose a folder where you have previously saved files.

4. In the File name box, enter a name for the file or select a file in the browse window to replace the existing file.

5. From the Save as type drop-down list, choose a file format.

If the selected file type supports it, you can choose an encoding template from the Template drop-down list, or click Custom to 
create a new template. For more information, see Creating custom rendering settings on page 54.

If you know that the file format is unsupported, select Raw Audio and click the Custom button to display the Custom Template 
dialog, where you can specify format parameter. For more information, see Creating custom templates on page 54.

6. In the Template drop-down list, choose a setting that will be used to save your file, or click the Custom button to create a new 
template. For more information, see Creating custom templates on page 54.

7. If you want to preserve metadata (such as embedded data from other applications, regions, markers, commands, playlist, and 
sampler information) in your file, select the Save metadata with file checkbox. For more information see Using Markers, Regions, 
and the Playlist/Cutlist on page 95, Adding summary information on page 88, and Saving loop points on page 221.

If the check box is not selected, the data will be ignored when you save the file.

8. If you are saving to a format with a different aspect ration than your source media settings, then select the Stretch video to fill 
output frame (do not letterbox) check box.

9. If you see unacceptable video artifacts in the rendered video (these artifacts are most obvious with MPEG and streaming formats), 
then clear the Fast video resizing check box.

10. Click the Save button.

Notes: 

• When you convert from mono to stereo, the data will be stored in both channels. When converting from stereo to mono, the data from 
both channels will be mixed to a single channel.

• When determining bit rates, 1K=1024.

Note: If the file type selected in the Save as type drop-down list doesn’t support metadata, you are prompted to save the metadata in an 
external file with an .sfl extension (using the same name as your media file). Metadata can be saved internally for the following file 
formats: MP3, Windows Media Format (WMA and WMV), WAV, WAV64, SFA, PCA, Scott Studios.

Note: When this check box is not selected, black bars may appear at the top and bottom (letterboxing) or sides (pillarboxing) of the 
frame to preserve the aspect ration. For more information, see Saving a video file on page 228.

Note: Turning this option off can correct the artifacts, but your rendering times will increase significantly. For more information, see 
Saving a video file on page 228.
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Creating custom templates

If the file type you select supports it, you can create custom settings for saving files by clicking the Custom button.

When you click the Custom button, a Custom Template dialog is displayed. Adjust the settings for the different template properties as 

needed. For help on the different settings, click the Help button  or press Shift+F1.

When you are finished editing the template properties, click the OK button.

Saving custom templates

You can save a custom template to use again by entering a template name in the Template box (in the Custom Template dialog) and 

clicking the Save Template button . 

Deleting custom templates

You can delete a custom template by selecting the template from the Template drop-down list (in the Custom Settings dialog) and 

clicking the Delete Template button .

Creating custom rendering settings

The Custom Template dialog appears when you click Custom in the Render As dialog. You can use the Custom Template dialog to 
create custom encoding templates for many of the file formats available in the software.

1. From the File menu, choose Render As. The Render As dialog is displayed.

2. Choose your preferred file format from the Save as type drop-down list. If the format allows you to create custom settings, the 
Custom button becomes active.

3. Click Custom. The Custom Template dialog is displayed.

4. Make the appropriate setting changes for the chosen file format. For help on individual settings, click the Help button.

5. Click OK. The Custom Template dialog closes.

Saving all open audio files

Choosing Save All from the File menu automatically prompts you to save all open audio files on the current workspace.

Saving files as a workspace

To accommodate complex editing scenarios, you can save the entire workspace as an alternative to saving individual files. Workspaces 
are saved as Sound Forge Workspace (SFW) files. When you open a workspace file, all files are restored to their previous sizes, positions, 
and magnification. In addition, each file’s current cursor position, custom views, and plug-ins in the Plug-In Chainer are restored. For 
more information, see Creating and using views on page 82 and Using the Plug-In Chainer on page 160.

Note: If a file type supports custom templates, a Custom button displays next to the Template drop-down list after you choose the file 
type.

Tip: To save the custom settings for future use, enter a name for the template in the Template box and click the Save Template button.

Note: Pressing Shift while choosing the Save All command automatically saves all open files without prompting you to approve each 
save.
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Saving the current workspace

1. From the File menu, choose Workspace, and choose Save As from the submenu. The Save Workspace dialog is displayed.

2. Browse to the folder where the file will be saved.

3. Enter a name for the file in the File name box and click Save. 

Opening a workspace

1. From the File menu, choose Workspace, and choose Open from the submenu. The Open Workspace dialog is displayed.

2. Browse to the folder containing the desired SFW file.

3. Select the desired file and click Open.

Working with projects

Projects are new to Sound Forge software; however, if you’ve used ACID or Vegas software, then you’ll be quite familiar with how to use 
Sound Forge projects. You should note that Sound Forge projects do function slightly different than ACID and Vegas projects.

A project file is not a multimedia file. It contains pointers to the original source files, so you can edit your project nondestructively 
without changing your source files. When you edit a Sound Forge project, you can undo edit operations even past your last save. For 
more information, see Using undo and redo on page 62.

Saving the project

1. Click anywhere in the data window to select it.

2. From the File menu, choose Save As to display the Save as dialog.

3. Select the folder where you want to save the file from one of the following locations:

• From the Save in drop-down list, choose a drive and folder.
• From the Recent drop-down list, choose a folder where you have previously saved files.

4. In the File name box, enter a name for the file or select a file in the browse window to replace the existing file.

5. From the Save as type drop-down list, choose Sound Forge Project File (*.frg). Sound Forge software creates a .frg file in the folder 
you specified and creates a subfolder to store your sound and temporary files.

Note: Since a Sound Forge project contains all your original sound data plus all PCM temporary files, they can take some time to create.

Warning: Deleting a project’s [filename]_frg folder will break the project.
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Saving the project path in the rendered file

1. Save your Sound Forge project. The project must be saved before you can embed the project reference in the rendered file.

2. Follow the steps in Using the Save As/Render As dialog on page 52 to choose the file type and location for rendering your files and 
then select the Save project as path reference in rendered media check box.

3. Click Yes if you would like to open the file in a new window or click No if you would like to close the dialog and return to the Sound 
Forge window.

Editing a media file’s source project

When your Sound Forge project uses source media files that are rendered with an embedded project path reference, you can easily 
open the source project in the associated application if you need to edit the media. By saving your project path reference when you 
render files in ACID, Sound Forge, or Vegas, you can quickly access the media from Sound Forge via the Edit Source Project shortcut 
menu.

1. Right-click one of the following items:

• the waveform in a data window
• a media file in the Explorer window

2. From the shortcut menu, choose Edit Source Project. An ACID, Vegas, or Sound Forge window will open with the source project.  
 
If you are editing a source project using a computer other than the computer where the project was created, then the editing 
computer must meet the following requirements:

• The software that was used to create the project must be installed and the project file extension (.acd, .acd-zip, .veg, or .frg) 
must be registered on the editing computer.

• The editing computer must have the same version (or later) of the software as the computer where the project was created.
• The project file must exist on the editing computer using the same file path as on the computer where the project was created.
• The project’s source media must exist on the editing computer. If the media files do not use the same file path as on the 

computer where the project was created, you will be prompted to choose a new folder or replacement files.

3. Edit the project as necessary.

4. Render the edited project using the same name as the original media file and close the editing application.

Note: This check box will be unavailable if you did not save your project or if you are rendering using a third-party file-format plug-in.

Note: If you modify the project file after rendering, the project data will no longer match the rendered file. To edit a project using a path 
reference, the project file and all media must be available on your computer.

Note: The project information in the rendered file is only a reference to a project file. If you modify the source project file after rendering, 
the project data will no longer match the rendered file. To edit a project using a path reference, the project file and all media must be 
available on your computer.

Note: If you are editing an existing track, your project will automatically be updated with the latest rendered media file.
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Editing audio 

New Sound Forge users should remember that even the most complex editing is derived from a few simple operations: copy, paste, cut, 
delete (clear), trim/crop, and mix. The following table provides a brief description of the basic editing operations.

Copying

You can copy audio data from a data window to the clipboard without changing the original file. Once audio data is on the clipboard, 
you can paste it into existing files or use it to create new files.

Copying data to the clipboard

1. Open the Voiceover.pca file. This file is located in the same folder as the application.

2. Create a selection containing “Wow.” 

3. From the Edit menu, choose Copy (or click the Copy button ). The selected data is copied to the clipboard, but the waveform is 
unchanged.

Previewing clipboard contents

To preview the contents of the clipboard, choose Clipboard from the View menu, and choose Play from the submenu.

Recycling clipboard contents

Once audio data is on the clipboard, you can paste or mix it into an infinite number of windows. Data remains on the clipboard until you 
replace it with new data. Pasting

Once audio data is on the clipboard, you can paste or mix it into an existing data window or use it to create a new data window.

Editing Operation Description
Copy Copies data from the window to the clipboard.
Paste Inserts the contents of the clipboard into the window at the current cursor position. If a selection exists in the data 

window, the pasted data replaces the current selection.
Cut Deletes data from the window and copies it to the clipboard.
Delete (Clear) Deletes data from the window, but does not copy it to the clipboard.
Trim/Crop Deletes all data in the window with the exception of the selection.
Mix Mixes data from the clipboard with the data in the current window, starting at the current cursor position or the start of 

the current selection.

Tip: You can display detailed information on the size and attributes of the clipboard contents by choosing Clipboard from the View 
menu and Contents from the submenu.
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Pasting data in an existing data window

1. After you have cut or copied your data, move the cursor to the beginning of the Voiceover.pca file by clicking the Go To Start 
button  in the playbar. For more information on cutting or copying data, see Copying on page 57 or Cutting on page 59. For more 
information on the playbar, see Playbar on page 25.

2. From the Edit menu, choose Paste (or click the Paste button ). The clipboard data is inserted into the file and the data for “Wow” 
appears on the left side of the waveform.

3. To confirm that the data has been pasted into the file, click the Play All button . “Wow. Wow. Sound editing just gets easier and 
easier” plays back.

Pasting by dragging and dropping a selection

1. Choose the Edit tool .

2. Drag the mouse in the data window to create a selection anywhere in Voiceover.pca. 

3. Hold Ctrl and drag the selection to the location where you want to paste the data. The cursor is displayed as a  , and a vertical 
line is displayed to show you where the paste will occur.

4. You can click the right mouse button while dragging to toggle mix and paste drag-and-drop modes.

Pasting in a new data window

To use data from the clipboard to create a new data window, go to the Edit menu, choose Paste Special, and choose Paste to New from 
the submenu. A new window containing the clipboard data in a single step is created.

Notes:

• Pasting into a multichannel file will insert data to all channels — the channels in a multichannel file must always be equal in length. 
Silence is pasted to the unselected channel. If multiple channels were selected, the same data would be pasted to all selected channels, 
and silence would be pasted to the unselected channel. If no channels were selected, the same data would be pasted to all channels.

• Pasting data of different sample rates will cause the data in the clipboard to play at the same rate as the rate of the window in which the 
data is pasted.

• If any regions, markers, or loops are present in with the original sound data, they will also be pasted into the destination sound file. To turn 
this feature off, turn off the Paste Events command on the Options menu.

Note: If there is a selection, the Paste command deletes the selected data before inserting.

Tip: If the Always open dropped files in new window check box on the General page of the Preferences dialog is cleared, you can also 
hold Ctrl while dragging a file (or region) from the Explorer window to a data window to paste sound data. When the check box is 
selected, dropping a file on the Sound Forge workspace always creates a new data window.

Tip: When dragging a selection to paste sound data, drag up or down before moving the mouse left or right. Dragging left or right before 
moving the mouse vertically adjusts the selection length.
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Cutting

Cutting allows you to remove a section of sound data from a data window and store it on the clipboard until you paste or mix it into 
another file. Cutting sound data replaces the previous contents of the clipboard. When deciding between cut and copy, consider the 
following information:

• Copying data has no effect on the original file.
• Cutting data modifies the original file.

Cutting data from a window

1. Create a selection containing the second “Wow” (there should be two if you are following the examples) in Voiceover.pca.

2. From the Edit menu, choose Cut (or click the Cut button ( ). The selected data is removed from the file and placed on the 
clipboard. 

3. Click the Play All button ( ). “Wow. Sound editing just gets easier and easier” plays back.

Previewing a cut

You can preview cuts prior to performing the edit. This option allows you to determine if you made the selection accurately and if the 
results are desirable by playing the data before and after the current selection.

1. Create a selection anywhere in Voiceover.pca.

2. From the Edit menu, choose Preview Cut/Cursor (or press Ctrl+K). The selection is ignored and the audio before and after the 
selection is played to allow you to preview the cut.

Note: If you cut data from individual channels of multichannel files, the waveform will contain silence at the end of the cut channel. The 
channels in a multichannel file must always be equal in length.

Notes: 

• To set the amount of pre- and post-roll that will be played when you preview a cut, choose Preferences from the Options menu and 
choose the Previews tab. Enter values in the Pre-roll and Post-roll boxes in the Cut preview configuration section of the dialog.

• If there is no selection, the playback will pre- and post-roll around the cursor position.
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Configuring cut pre-roll and post-roll lengths

Frequently, the default pre-roll and post-roll lengths are insufficient to evaluate the accuracy of an edit. For this reason, you can 
configure pre-roll and post-roll lengths.

1. From the Options menu, choose Preferences. The Preferences dialog is displayed.

2. Click the Previews tab.

3. Configure the Pre-roll and Post-roll values in the Cut preview configuration area of the dialog and click OK.

Deleting

Deleting a selection permanently removes it without placing it on the clipboard. To delete data, choose Delete (Clear) from the Edit 
menu (or press the Delete key).

Trimming/Cropping

Trimming allows you to retain a selection while deleting all surrounding data.

1. Create a selection containing “Wow, sound editing just gets easier” in Voiceover.pca, but do not select the second “and easier.”

2. From the Edit menu, choose Trim/Crop (or press Ctrl+T). Only “Wow, sound editing just gets easier” remains in the data window.

Mixing

Mixing is a powerful editing function that allows you to mix a copy of the clipboard contents at the current cursor position.

Mixing by dragging and dropping a selection

1. Open and play the Drumhit.pca file. The file contains a snare drum and crash cymbal sound.

2. Choose the Edit tool .

Notes:

• If you delete data from individual channels of multichannel files, the waveform will contain silence at the end of the deleted channel. 
The channels in a multichannel file must always be equal in length.

• If the Treat as Cutlist command (available in the Special menu, Playlist/Cutlist submenu) is selected, deleting a selection creates a 
region in the Cutlist window, but does not remove the selection. For more information, see Configuring the playlist as a cutlist on page 
111.
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3. Drag the mouse over the data window to select the entire waveform.

4. Drag the selection to the beginning of the Voiceover.pca file. The cursor is displayed as a , and a shaded selection box is 
displayed to show you where the mix will occur.

You can click the right mouse button while dragging to toggle mix and paste drag-and-drop modes.

5. When you release the mouse button to drop the selection, the Mix/Replace dialog is displayed. Choose a setting from the Preset 
drop-down list, or adjust the controls as needed:

6. Click the OK button to apply the mix.

Mixing audio from the clipboard

1. Open and play the Drumhit.pca file. The file contains a snare drum and crash cymbal sound.

2. Verify that the Drumhit.pca window is active and choose Select All from the Edit menu. The entire waveform is selected.

3. From the Edit menu, choose Copy (or click the Copy button ).

4. Activate the Voiceover.pca data window and click the Go To Start button  on the playbar. The cursor moves to the start of the 
file.

5. From the Edit menu, choose Paste Special, and choose Mix from the submenu (or click the Mix button ). The Mix/Replace dialog 
is displayed.

Tip: If the Always open dropped files in new window check box on the General page of the Preferences dialog is cleared, you can also 
drag a file (or region) from the Explorer window to a data window to paste sound data. When the check box is selected, dropping a file on the 
Sound Forge workspace always creates a new data window. For more information, see General tab on page 240.

Tip: When dragging a selection within the same data window, drag up or down before moving the mouse left or right. Dragging left or 
right before moving the mouse vertically adjusts the selection length.

Item Description
Source Drag the Source fader to adjust the volume of the selection you want to mix.

Changing this setting has the same effect as dragging the sustain portion of the wet gain envelope in the data window.

Select the Invert Data check box to invert the source audio at the baseline (reverse the phase). Inverting data can help 
match transitions and compare the phase relationship of the two sound files.

Destination Drag the Destination fader to adjust the volume of the selection you want to mix over.

Changing this setting has the same effect as dragging the sustain portion of the dry gain envelope in the data window.

Select the Invert Data check box to invert the destination audio at the baseline (reverse the phase). Inverting data can 
help match transitions and compare the phase relationship of the two sound files.

Fade In Type a value in the Fade In box (or use the spinner) to set the length of the fade in between the source and destination 
audio.

Changing this setting has the same effect as dragging the attack portion of the envelope in the data window.

Click the Fade Curves button  and choose a curve type from the menu to set the speed of the fade in.

Proportional Fade 
Lengths

Select the Proportional fade lengths check box if you want to specify fade lengths as a percentage of the selection.

Fade Out Type a value in the Fade Out box (or use the spinner) to set the length of the fade out between the source and 
destination audio.

Changing this setting has the same effect as dragging the attack portion of the envelope in the data window.

Click the Fade Curves button  and choose a curve type from the menu to set the speed of the fade out.

More Click to display additional controls at the bottom of the dialog that you can use to change the selection you want to 
process.
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6. Verify that the Source and Destination volume faders are set to 0 dB and click OK. The drum hit is mixed equally with the spoken 
passage.

Preview the file and notice that mixing does not change the length of the file.

Using undo and redo

You can easily undo/redo edit operations, even prior to your last save operation.

• You can undo any edit operation by choosing Undo from the Edit menu (or click the Undo  button on the Standard toolbar).
• You can redo any undone edit operation by choosing Redo from the Edit menu (or click the Redo  button on the Standard toolbar).

Using the Undo/Redo History window

The Undo/Redo History window may seem confusing at first, but you will find it invaluable once you have mastered it. This window 
allows the audio file to be auditioned in various versions by undoing/redoing multiple operations.

To display the Undo/Redo History window, choose Undo/Redo History from the View menu (or press Alt+7).

Important: The ability to undo past save is disabled by default. To enable this functionality, choose Preferences from the Options 
menu, click the File tab, and select the Allow Undo past Save check box. When this option is enabled, your undo/redo history is retained 
until you close the file or exit the software.

Note: The undo/redo history for an audio file is retained until you close the file or exit the software. If you want to retain undo/redo 
history indefinitely, you should work with a Sound Forge project (.frg) file.

Set both faders to 0dB

Both waveforms are combined
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Undoing and redoing

1. Verify that the Voiceover.pca data window is active and choose Undo/Redo History from the View menu. The Undo/Redo History 
window is displayed. If you have performed the previous procedures, the window should look like the figure below:

Notice that the Mix operation appears at the top of the Undo pane. The most recent operations always display at the top of the 
appropriate list.

In the Undo pane, click the  corresponding to the Mix operation. The audio file plays without the drum track.

2. Select the Mix operation and choose Undo from the Edit menu. The drum track is extracted from the Voiceover.pca data window 
and the Mix operation moves to the Redo pane.

Play 

Performed operations

Undone operations

button
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3. In the Redo pane, click the  corresponding to the Mix operation. The audio file plays with the mixed drum track.

4. Select the Mix operation again and choose Redo from the Edit menu. The drum track is remixed into the Voiceover.pca waveform 
and the Mix operation is returned to the Undo pane.

5. Select the Trim/Crop operation in the Undo pane and click . Only the Mix operation is undone and moved to the Redo pane. 
This is due to the fact that operations can only be undone or redone in the order originally performed.

6. Double-click the Cut operation in the Undo pane. The Cut and Trim/Crop operations are both undone in the waveform and moved 
to the Redo pane.

Clearing the Undo/Redo History for the current file

Clearing the current file’s Undo/Redo History frees up disk space by deleting the file’s temporary undo/redo files. However, deleting 
these temporary files prevents you from undoing changes made to the file since it was last saved (or beyond, if you have the Allow 
Undo past Save check box enabled on the General tab of the Preferences dialog). To clear the undo/redo history for the current file, go 
to the Special menu, choose Undo/Redo History, and choose Clear from the submenu.

Clearing the Undo/Redo History for all open files

You can simultaneously clear the undo/redo history for all open files. Once again, however, you cannot undo any previous changes once 
these histories are deleted. To clear the undo/redo history for all open files, go to the Special menu, choose Undo/Redo History, and 
choose Clear All from the submenu.

Tip: To quickly undo/redo operations in the Undo/Redo History window, double-click the operation.

Note: A file’s undo/redo history is also automatically cleared when you close the file or exit the software.
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Selecting status formats

The status format determines how a file’s position and length information is displayed. The following table briefly describes supported 
status formats (hh=hours, mm=minutes, ss=seconds, and ff=frames). For more information, see SMPTE Timecode on page 265. 

Experimenting with status formats

You can experiment with the Voiceover.pca file to see how status formats affect values in the selection status bar display boxes. 

1. Open the Voiceover.pca file.

2. From the Options menu, choose Status Format, and choose Samples from the submenu. 

3. Select all data in the Voiceover.pca window by choosing Select All from the Edit menu. Notice the selection status boxes.

• The first selected sample is sample 0.
• The last selected sample is 220,507.
• The total number of samples in the selection is 220,507.

4. From the Options menu, choose Status Format, and choose Time from the submenu. Notice that status values change from 
samples to hours, minutes, and seconds. 

5. From the Options menu, choose Status Format, and choose SMPTE Non-Drop (29.97 fps, Video) from the submenu. Notice that 
status values change to hours, minutes, seconds, and frames.

6. Experiment with each status format and make note of how each format displays.

Configuring the Measures & Beats format

Choosing the Measures & Beats format allows you to specify the beats per minute and beats per measure values used to calculate 
measures and beats. 

Format name Description Format
Samples Number of samples Numbered (starting with zero)
Time Hours, minutes, seconds, and milliseconds hh:mm:ss.sss
Seconds Seconds and fractions of seconds sssss.sss (to three decimal places)
Time & Frames Hours, minutes, seconds, and frames. hh:mm:ss.ff
Absolute Frames Frames and fractions of frames Numbered (starting with zero, to 

three decimal places)
Measures & Beats Measures, beats, and quarter beats measures:beats.quarters
SMPTE Film Sync (24 fps) SMPTE at 24 frames per second for 

synchronizing with film
hh:mm:ss:ff

SMPTE EBU (25 fps, Video) SMPTE at 25 frames per second for 
European Broadcasting Union

hh:mm:ss:ff

SMPTE Non-Drop (29.97 fps, Video) SMPTE at 29.97 frames per second hh:mm:ss:ff
SMPTE Drop (29.97 fps, Video) SMPTE at 29.97 frames per second using 

dropped frame numbers
hh:mm:ss:ff

SMPTE 30 (30 fps, Audio) SMPTE at 30 frames per second hh:mm:ss:ff

Notes:

• Selecting a new format changes the status format for the current data window only.
• To quickly change a file’s status format, right-click any of the data window’s status display boxes and choose a new format from the 

shortcut menu.
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Changing a file’s beat values

1. From the Special menu, choose Edit Tempo. The Edit Tempo dialog is displayed.

2. Enter an appropriate value in the Tempo in beats per minute box.

3. Enter an appropriate value in the Number of beats in a measure box and click OK.

Alternately, you can make a selection in the file equal to one measure, and then enter the number of beats in the sample measure in the 
Selection length in beats box. The Tempo in beats per minute value is automatically calculated based on the selection length and 
number of beats.

Changing the default beat values

The previous procedure changes the beat values for the current audio file only. Use the following steps to change the Sound Forge 
default beat values.

1. From the Options menu, choose Preferences. The Preferences dialog is displayed.

2. Click the Status tab.

3. Enter an appropriate value in the Default beats per measure box.

4. Enter an appropriate value in the Default beats per minute box and click OK.

Publishing to the Web

You can share your media file with others by publishing it to the Web from within the software. You can upload your file to 
ACIDplanet.com or another publishing provider. From the File menu, choose Publish and follow the instructions to set up your 
publishing provider(s) and upload your content.

Exporting to CD Architect software

You can export your Sound Forge audio files directly to CD Architect 5.2 software.

Exporting a single audio file

This feature allows you to add your Sound Forge audio files to the CD Architect timeline one file at a time.

1. Open the file that you want to add to your CD Architect project.

2. Click anywhere in the data window that you want to export to establish focus.

3. From the File menu, choose Export to CD Architect.

• If CD Architect software is not running, the application will be started and the audio file will be added to the timeline and 
Media Pool of a new project. 

• If CD Architect software is running, the audio file will be added to the timeline and Media Pool of the open project.

4. Use CD Architect software to edit your CD project as needed.

Note: A separate CD track will be created for each region in the media file.
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Exporting all audio files

This feature allows you to add all of your open Sound Forge audio files to the CD Architect timeline. 

1. Open the file that you want to add to your CD Architect project.

2. From the File menu, choose Export All to CD Architect.

• If CD Architect software is not running, the application will be started and all open audio files will be added to the timeline and 
Media Pool of a new project.

• If CD Architect software is running, all open audio files will be added to the timeline and Media Pool of the open project.

3. Use CD Architect software to edit your CD project as needed.

Exporting to Net MD devices

You can export your Sound Forge audio files to your Net MD device.

1. From the File menu, choose Export to Net MD.

2. Type information about your project:

a. In the Name of track box, type the name you want to use to identify your audio file on your Net MD device.

b. In the Name of artist box, type the artist name you want to associate with this track on your device.

c. In the Name of genre box, type the genre you want to associate with this track on your device.

d. In the Comment for track box, type any comments you want to associate with this track on your device.

3. Click the Export button. Your project is converted to the appropriate format for your device and begins transferring when 
conversion is complete.

Recovering files after a crash

If Sound Forge software terminates improperly, you can recover all open and unsaved audio files not opened in read-only mode. When 
a file is opened, it automatically creates temporary files that it uses to save any changes made to the file. The original file remains 
unchanged until it is saved. If the software terminates improperly, the temporary files remain on your hard drive and can be used to 
recover any unsaved changes made prior to the crash.

Recovering files

Click the Recover button to restore the changes and undo history for the files listed in 
the Files that can be recovered list. 

Deleting recovered files

Click the Cancel button to delete the temporary files. The original media files remain 
unchanged.

Tip: You can specify the folder used to store temporary files by choosing Preferences from the Options menu and designating a 
Temporary files and record folder location on the General tab.
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Chapter 4

e 256.
Navigating, Zooming, and Selecting

This chapter introduces some of the Sound Forge® navigation and selection features.

Setting the cursor position

While you can click anywhere in the waveform to position the cursor, there are times when you may need to position the 
cursor more precisely. You can use the Go To dialog to move the cursor to a specific point in an audio file and center it in 
the data window.

1. Choose Go To from the Edit menu.

2. Set the cursor position using one of the following methods:

• From the Go To drop-down list, choose a preset. 
• From the Input format drop-down list, choose a format and enter an appropriate value in the Position box.

3. Click OK. The cursor is placed at the specified position in the data window.

Previewing audio with pre-roll

Many audio editing operations depend upon accurate placement of the cursor in the data window. The Pre-roll to Cursor 
command allows you to preview audio data leading up to the current cursor position. This command is extremely useful 
when recording punch-ins. For more information, see Choosing a recording mode on page 119.

A 1.5 second pre-roll is automatically designated. However, you can change this value if necessary. For more information, 
see Configuring cut pre-roll and post-roll lengths on page 60.

1. Place the cursor anywhere in the data window.

2. From the Edit menu, choose Pre-roll to Cursor (or press Ctrl+Shift+K). The Sound Forge software plays the audio 
leading up to the cursor and stops at the cursor.

Tip: You can also use a variety of keyboard shortcuts to position the cursor. For more information, see Cursor movement on pag

Tip: You can also use the following methods:

• Right-click the waveform, choose Cursor, and choose Go To from the submenu.
• Press Ctrl+G.
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Using the overview bar

When navigating or editing a file, the overview bar changes to reflect the current position in the file. 

The overview bar represents the length of the entire file zoomed out to its maximum position. By observing the overview bar, you can 
determine the following items: 

• The section of the audio file currently displayed in the data window.
• The location and size of a selection in relation to the audio file and data window.
• The current cursor location.

Understanding the overview bar

1. Open the Voiceover.pca file and verify that the waveform display is zoomed completely out (1:512 in this case). 

Notice that the entire overview bar is bracketed, indicating that the entire file appears in the data window.

2. Place the mouse pointer over the word “Wow,” and click. A small vertical marker, representing the cursor, appears in the overview 
bar.

3. Create a selection containing the word “Wow.” A shaded block, sized in relation to the size of the selection within the entire audio 
file, appears in the overview bar.

Title bar

Overview bar

Time ruler

The entire overview bar is bracketed
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4. Click the Zoom In button  twice. The bracketed area in the overview bar becomes incrementally smaller as less of the waveform 
appears in the data window. 

However, the selection remains the same size and does not move. This allows you to quickly locate a selection, even when another 
section of an audio file is displayed.

Navigating in the overview bar

1. Open the Voiceover.pca file.

2. Click the Zoom In button  until you reach a 1:32 zoom ratio.

3. Click outside the bracketed region in the overview bar. The cursor position changes, but the cursor is located beyond the scope of 
the data window.

4. Double-click anywhere in the overview bar. The cursor position updates and centers in the data window.

Playing audio in the overview bar

To make navigating a file from the overview bar easier, you can start audio playback from the overview bar.

1. Open the Voiceover.pca file.

2. Right-click the overview bar. Playback of the file begins from the cursor location.

3. Right-click the overview bar again. Playback pauses. 

4. Right-click the overview bar once more and immediately left-click at several random positions in the overview bar. Each time you 
click the mouse in the overview bar during playback, the cursor jumps to the new location and playback continues. The feature is 
useful for quickly navigating a file and locating general events.

Zooming in on a selection decreases the size of the bracketed area
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Scrubbing

Scrubbing is a type of timeline playback that gives you precise control over the speed and direction of playback. Both linear and 
logarithmic scale scrubbing are allowed.

Scrubbing with the scrub control slider

The scrub control slider , located at the bottom of the data window, can be dragged back and forth. The farther from the center 

that the slider is dragged, the faster the playback, both forward and in reverse.

Scrubbing on the timeline

You can scrub the project by using the timeline.

1. Position the cursor on the timeline, hover the mouse pointer over the cursor and press Ctrl. The 
mouse pointer changes to a speaker icon.

2. Left click and drag the mouse left or right to scrub the timeline. The cursor changes again to a 
pan/scrub icon.

Scrubbing with the keyboard

Three letters (JKL) are used as a keyboard scrub control.

• Press J for reverse playback. Press again to accelerate the playback rate.
• Press L for forward playback. Press again to accelerate the playback rate.
• Press K to pause playback.

There are several ways to adjust the playback speed:

• Hold K while pressing J or L to emulate a shuttle knob mode.
• Press K+J to turn the knob to the left or K+L to turn the knob to the right.
• Press K again or Space to return to normal mode.

Scrubbing with the audio event locator

Dragging the mouse within the overview bar initiates playback of small audio loops adjacent to the cursor position. This is not 
technically a scrub function, but it serves a similar purpose. It allows you to audition brief audio segments and quickly locate specific 
events within a file. Playback stops when the mouse button is released.

Configuring the audio event locator

You can set the amount of pre-roll and loop duration for the audio event locator.

1. From the Options menu, choose Preferences. The Preferences dialog is displayed.

2. Click the Previews tab.

3. In the Audio event locator section, edit the Pre-roll and Loop time values as desired and click OK.

Tip: Choose a setting from the JKL/shuttle speed drop-down list on the Editing tab of the Preferences dialog to control the scrub speed 
and range when using the keyboard or multimedia controllers.

Note: You can also drag the Normal Rate indicator , which is located below the scrub control, to adjust playback speed or 
double-click Rate and type a playback rate.

Press Ctrl over 
timeline cursor

Left-click and 
drag to scrub

J K L
Reverse Pause Forward

Keyboard scrub letters
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Zooming and magnifying

Since there are considerably more samples in a sound file than horizontal points (pixels) on the screen, many data samples must be 
represented by each horizontal point when audio data displays in the data window. Depending upon the editing operation, you may 
want to view the entire file at once or a small portion of data in greater detail. For this reason, you can utilize two varieties of zooming: 
time ruler zooming and level ruler zooming.

Zooming the time ruler (horizontal)

The current time ruler magnification ratio appears in the lower-right corner of the data window above the status boxes. 

Understanding the zoom ratio

The zoom ratio determines the number of samples represented by each horizontal point on the screen. The zoom ratio is a value of X:Y, 
where X is the number of horizontal points and Y is the number of samples. If the ratio is 1:1, each point on the screen represents one 
sample. At this zoom ratio, a brief but detailed selection of time is displayed.

Conversely, if the zoom ratio is 1:1024, 1,024 samples are represented by each point on the screen and a greater length of time is 
displayed. 

For very precise editing, you may want to zoom in more tightly than a 1:1 ratio. Sound Forge allows up to a 24:1 ratio, where 24 points 
on the screen represent one sample. This high level of zoom may be useful when editing with the Pencil tool. For more information, see 
Repairing audio glitches manually with the Pencil tool on page 134.

Zoom out

Zoom out

Maximize width of 
window

Zoom ratio

Waveform at 1:1 zoom ratio

Waveform at 24:1 zoom ratio
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Changing the zoom ratio

To edit the zoom ratio, use the Zoom In/Out spin control located adjacent to the zoom ratio display. 

• Clicking the plus/minus buttons increases/decreases the zoom ratio by single-step increments. 
• Dragging the spin control increments the zoom ratio quickly in the corresponding direction.

Using zoom time commands

If you prefer using commands, you can control the time magnification from the View menu. The following table briefly describes the 
available time zoom commands. You can access these commands from the View menu by choosing Zoom Time and choosing the 
desired command from the submenu.

Zooming the level ruler (vertical)

Zooming along the level ruler displays a larger vertical waveform and allows for more precise editing at low audio amplitudes.

Changing the level zoom

To edit the level ruler zoom, use the Zoom In/Out spinner control located above the playbar. 

• Clicking the plus/minus buttons increases/decreases the level ruler zoom by single-step increments. 
• Dragging the spin control increments the level ruler zoom quickly in the corresponding direction.

At high zoom levels, only low-level samples are visible because the peaks of the waveform move beyond the vertical scope of the data 
window. Consider the following data windows.

Notes: 

• When a file is opened, the horizontal magnification is set to the value specified by the Normal zoom ratio setting in the Display tab in the 
Preferences dialog. To access the Preferences dialog, choose Preferences from the Options menu.

• Right-clicking the waveform display allows you to quickly access time ruler zoom commands from the shortcut menu.

Command Description
In Full Increases the zoom ratio to represent each audio sample with 24 screen pixels (24:1 zoom ratio).
Normal Returns the file to its default zoom ratio.
Out Full Changes the zoom ratio to display the entire file within the data window.
Selection Changes the zoom ratio to maximize the display and center the selection within the data window.
Custom Zoom X:Y Sets the zoom ratio to a custom setting. For more information, see Using custom zoom settings on page 75.

Level ruler zooming controls

Zoom in Zoom out
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Both data windows display the same audio file at a 1:1 zoom ratio. The window on the left shows the level ruler zoomed to its maximum 
out position. The window on the right shows the level ruler zoomed to its maximum in position. Notice that wave peaks clearly visible in 
the left window are out of display range in the right window.

Using zoom level commands

If you prefer using commands, you can control the level magnification from the View menu. The following table briefly describes the 
three available zoom level commands. You can access these commands from the View menu by choosing Zoom Level and choosing 
the desired command from the submenu.

Formatting the level ruler

You can configure the level ruler to display in decibels or percent by right-clicking the ruler and choosing Label in Percent or Label in 
dB from the shortcut menu. 

Using custom zoom settings

You can create two custom time zoom settings for quick access to time magnification levels that you use frequently. 

Creating custom zoom settings

1. From the Options menu, choose Preferences. The Preferences dialog is displayed.

2. Click the Display tab.

3. Select time magnification settings from the Custom zoom ratio 1 and Custom zoom ratio 2 drop-down lists.

4. Click OK.

Zooming to custom settings

From the View menu, choose Zoom Time, and choose a custom zoom setting from the submenu.

Command Description
Out Full Decreases the zoom level to minimize the display of the file’s amplitude.
Window Changes the level zoom to display the entire waveform amplitude in the data window.
Selection Maximizes the display of the selection (vertically and horizontally) in the data window.

Tip: You can also click a Custom Zoom button  or  on the Navigation toolbar or press 1 or 2 on the numeric keypad.

Level zoom out maximum Level zoom in maximum
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Using zooming shortcuts

Zooming to a selection

1. Create a selection. If no selection is created, this function is not available.

2. Right-click the waveform and choose Zoom Selection from the shortcut menu. The minimum zoom ratio that allows the full 
selection to display in the window is calculated, and the selection is then zoomed and centered in the data window.

Zooming the window

Right-click the level ruler and choose Zoom Window from the shortcut menu. The maximum zoom level that allows the loudest portion 
of the selection to display in the window is calculated and the entire sound file is adjusted.

Zooming out full

To quickly display all data in a data window, right-click the waveform, choose Zoom, and choose Out Full from the submenu. This 
command sets the zoom ratio and zoom level to the lowest values required to display all data in the window.

Zooming in full

To quickly set the zoom factor to its maximum magnification, right-click the waveform and choose Zoom In Full from the shortcut 
menu. The maximum magnification available is 24:1.

Optimizing time and level ruler scaling

To optimize both the time ruler and level ruler display of a selection, double-click the level ruler. Double-clicking the level ruler a second 
time restores both displays to their default levels.

Using the Magnify tool

The Magnify tool provides an additional way to magnify a section of an audio file. You can access the Magnify tool in three ways:

• From the Edit menu, choose Tool, and choose Magnify from the submenu. 
• Click the Magnify Tool button  on the Standard toolbar.
• Click the Edit Tool Selector in the upper-left corner of the data window until the Magnify tool is displayed.

When you select the Magnify tool, the cursor displays as . You can use this tool to create a selection box indicating how audio data is 
magnified. By using the Magnify tool and toggle-clicking the mouse, you can toggle between time zoom, level zoom, and simultaneous 
time/level zoom. For more information, see Using the mouse on page 19.

Zooming the time ruler with the Magnify tool

1. Drag the Magnify tool on the waveform to make a small selection box.

2. Toggle-click the mouse until the selection box is the same height as the data window. 

Note: To reverse this function, right-click the waveform, choose Zoom, and choose Out Full from the submenu.

Note: To reverse this function, right-click the level ruler and choose Zoom Out Full from the shortcut menu.

Note: To reverse this function, go to the View menu, choose Zoom Time, and choose Normal from the submenu.

Note: To reverse this function, right-click the waveform and choose Zoom Normal from the shortcut menu.
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3. Drag the Magnify tool to create a time zoom selection and release the mouse button. The zoom ratio of the selection increases.

Zooming the level ruler with the Magnify tool

1. Drag the Magnify tool on the waveform to make a small selection box.

2. Toggle-click the mouse until the selection box is the full width of the data window.

3. Drag the Magnify tool to create a level zoom selection and release the mouse button. The zoom ratio of the selection increases.

Selection box spans the height of the window The selection is time zoomed

Selection box spans the width of the window The selection is level zoomed
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Zooming both time and level with the Magnify tool

1. Drag the Magnify tool on the waveform to make a small selection box.

2. Toggle-click the mouse until the selection displays as a box.

3. Drag the Magnify tool to create a time/level zoom selection and release the mouse button. The level zoom and time zoom of the 
selection increase.

Selecting audio using start and end values

You can select audio by dragging the mouse or by using keyboard shortcuts (pg. 257). For the sake of accuracy, however, it is often useful to 
create selections by entering specific start and end point values. The Set Selection dialog allows you to create selections in this way or by 
choosing a preset selection from the Selection drop-down list.

1. From the Edit menu, choose Selection, and then choose Set from the submenu (or press Ctrl+Shift+D). The Set Selection dialog is 
displayed.

2. From the Input format drop-down list, choose the format to be used for creating the selection. The values in the Start, End, and 
Length boxes change to reflect the specified format.

3. Configure the selection by entering appropriate values in the Start and End or the Start and Length boxes.

4. If you are working with a stereo file, choose Left, Right, or Both from the Channel drop-down list, or, for a multichannel file, type 
the appropriate channel number(s) in the Channel box.

5. Click OK.

Using the Set Selection dialog

The following sections briefly describe additional controls located in the Set Selection dialog.

Control Description
Play Clicking Play plays the current selection.
Play looped Selecting the Play looped check box allows you to play the selection in Looped Playback mode. 
Snap Zero Clicking Snap Zero forces the Start and End values of the selected area to the next zero-

crossing. 
Snap Time Clicking Snap Time forces the Start and End values of the selected area to a whole time division 

as designated by the markings on the data window’s time ruler.

Selection displays as a box The selection time and level are zoomed
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Zero-crossing preference

When using a Snap-Zero command, you can configure the application to snap to positive slope, negative slope, or either slope zero-
crossings. 

1. From the Options menu, choose Preferences, and click the Editing tab. 

2. From the Snap to zero-crossing slope drop-down list, choose the desired slope and click OK.

Selecting audio during playback 

You can create selections during playback using the Mark In and Mark Out commands. These commands place temporary markers in 
the data window, which are then used to create a loop region. While you can place these markers by choosing Mark In and Mark Out 
from the Special menu, the keyboard equivalents are more useful.

1. Play the audio file in the current data window. 

2. During playback, press I where the selection will begin.

3. Press O where the selection will end. A loop region is created using the in and out points you identified.

Fine-tuning a selection

After creating a selection, you may discover that the start or end point has not been positioned properly. In cases like this, you can try to 
reselect the data, but it can be difficult to accurately create selection points. For this reason, you have a number of tools designed to 
help you fine-tune selections.

If you find that the selection jumps unexpectedly as you fine-tune it, snapping may be turned on. For more information, see 
Understanding snapping on page 80.

Adjusting a selection with the mouse

You can fine-tune selection start and end points by dragging the edge of the selection to a new location.

1. Open a file and create a selection in the waveform.

2. Position the mouse pointer over one of the selection edges. The pointer displays as a bi-directional arrow .

3. Drag the selection edge to a new position.

4. Release the mouse button. The selection updates.

Adjusting a selection with the keyboard

Using the keyboard, you can quickly and accurately select data or update a selection. For more information, see Selecting data on page 
257.

Restoring a selection

If you lose a selection while editing, you can restore it by choosing Toggle Selection from the Special menu or by pressing Backspace.

Drag the edge of the selection to a new position.
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Understanding snapping 

If, when extending a selection, the end points seem to “jump” to a different position, an auto snap option is turned on.

Turn snapping on or off

From the Options menu, choose Enable Snapping to turn snapping on or off. When snapping is enabled, objects will snap to the 
following points:

• The cursor
• Time selection edges

You can also choose to snap events to grid divisions, markers, or zero crossings.

Snapping to the grid

When snapping is enabled, you can also choose to have objects snap to whole time divisions as designated by the marks on the time 
ruler above the data window.

From the Options menu, choose Snap to Grid to toggle snapping to grid lines.

Snapping to markers

When snapping is enabled, you can also choose to have elements in the data windows snap to markers.

From the Options menu, choose Snap to Markers to toggle snapping for the following marker types:

• Markers
• Regions
• Command markers

For more information, see Using Markers, Regions, and the Playlist/Cutlist on page 95.

Snapping to zero-crossings

When snapping is enabled, you can also choose to have elements in the timeline snap to zero-crossings. 

From the Options menu, choose Snap to Zero Crossings to toggle snapping to zero crossings.

Snapping the current selection

From the Edit menu, choose Selection, and then choose a command from the submenu to force the edges of the current selection to 
the points you choose. Snapping helps you align your selection with items in the data window.

Tip: To change the resolution of the grid, choose Status Format from the Options menu and then choose a setting from the submenu 
(or right-click the time ruler and choose a format from the shortcut menu).

Tip: To turn Snap to Zero Crossings on and off, press Ctrl+B.

Note: If you want to use snapping when positioning the cursor and making selections, you can use the commands on the Options menu 
to enable snapping and set snapping options.
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The Selection submenu commands are explained below:

Disabling auto-snapping at high magnifications

When editing an audio file displayed at a high magnification, you may wish to turn off snapping to time or zero-crossings. This allows 
you to position a selection’s start and end points exactly where you choose. 

1. From the Options menu, choose Preferences, and click the Editing tab. 

2. Select the Disable auto-snapping below 1:4 zoom ratios check box and click OK.

Command Description
Snap to Grid This option forces both edges of a selection to a whole time division as designated by the marks on the time ruler above the data 

window.

Tips: 

• You can also press T.

• To change the resolution of the grid, choose Status Format from the Options menu and then choose a setting 
from the submenu (or right-click the time ruler and choose a format from the shortcut menu).

Snap Edge to Grid This option forces the active edge of a selection to a whole time division as designated by the marks on the time ruler above the 
data window.

The active edge of a selection is defined by the blinking cursor. Press Home or End to change the active edge.

Tips: 

• You can also press Shift+T.

• To change the resolution of the grid, choose Status Format from the Options menu and then choose a setting 
from the submenu (or right-click the time ruler and choose a format from the shortcut menu).

Snap to Zero This option forces both edges of a selection to the next zero-crossing of the waveform. Performing edits at zero-crossings reduces 
the possibility of introducing glitches in your sound file.

Tips:

• You can also press Z.

• The Editing tab in the Preferences dialog allows you to choose whether this is a negative, positive or any zero-
crossing.

Snap Edge to Zero This option forces the active edge of a selection to the next zero-crossing of the waveform. Performing edits at zero-crossings 
reduces the possibility of introducing glitches in your sound file.

The active edge of a selection is defined by the blinking cursor. Press Home or End to change the active edge.

Tips:

• You can also press Shift+Z.

• The Editing tab in the Preferences dialog allows you to choose whether this is a negative, positive or any zero-
crossing.

Extend to Next Zero This option forces both edges of a selection to the next zero-crossing of the waveform. Performing edits at zero-crossings reduces 
the possibility of introducing glitches in your sound file.

Tips:

• You can also press Z.

• The Editing tab in the Preferences dialog allows you to choose whether this is a negative, positive or any zero-
crossing.

Extend Edge to Next Zero This option forces the active edge of a selection to the next zero-crossing of the waveform. Performing edits at zero-crossings 
reduces the possibility of introducing glitches in your sound file.

The active edge of a selection is defined by the blinking cursor. Press Home or End to change the active edge.

Tips:

• You can also press Shift+Z.

• The Editing tab in the Preferences dialog allows you to choose whether this is a negative, positive or any zero-
crossing.
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Creating and using views

Views are used to save and recall selections, zoom ratios, and waveform display positions. The Sound Forge software can retain eight 

different views for any audio file, each containing any or all of the following elements: 

• Selection
• Cursor position
• Magnification
• Position scroll bar placement

Displaying the Views toolbar

1. From the View menu, choose Toolbars. 

2. Select the Views check box and click OK. The Views toolbar is displayed.

Creating views

1. Open the Voiceover.pca file and create a selection containing “Wow.”

2. Click the Set button  on the Views toolbar. A view can now be created.

3. Click . The selection is saved as view 1 and  is underscored to indicate that a view was created.

4. Create a new selection anywhere in the audio file, preferably at an increased magnification.

5. Click the Set button  followed by . The selection is saved as view 2.

6. Click . The view 1 selection is displayed.

7. Click . The view 2 selection is displayed.

Tip: Views are discarded when you close the file. To save views with a file, save the file as part of a workspace. For more information, see 
Saving files as a workspace on page 54.

Views toolbar

Click the Set button

The 1 button is underscored
to indicate that a view was created.
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Chapter 5
 Changing File Attributes and Formats

This chapter deals with the supported file attributes and formats in Sound Forge® software and discusses file summary 
information.

Editing file attributes

When you open or create a file, its attributes display in the first four boxes of the status bar at the bottom of the Sound 
Forge workspace. The file attributes are sample rate, bit depth, channels, and length.

With the exception of the file length, you can edit audio file attributes in the Properties dialog or from the status bar.

Editing attributes in the Properties dialog

You can edit file attributes in the Properties dialog. 

1. From the File menu, choose Properties. The Properties dialog is displayed.

2. Click the Format tab.

3. Edit the file attributes as needed and click OK. 

Editing attributes in the status bar

You can quickly edit individual file attributes from the status bar using either of the following methods:

• Right-click the status value to be changed and choose a new value from the shortcut menu.
• Double-click the status value to be changed and type a new value in the edit box.

Tip: You can also access the Properties dialog by performing either of the following actions:

• Right-click the waveform display and choose Properties. 
• Press Alt+Enter.

Sample rate Bit depth Channels Total file length Free storage available

File attributes in the status bar
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Changing the sample rate

The sample rate is the number of samples per second, measured in hertz (Hz), used to record audio. You can specify sample rates from 
2,000 Hz to 192,000 Hz. Typical sample rates are stored as presets in the Sample rate drop-down list. In addition, you can increase or 
decrease the sample rate of an existing audio file.

1. Open and play the Voiceover.pca file.

2. Right-click the Sample Rate status box and choose 48,000 from the shortcut menu.

3. Play the file. Notice that the pitch is higher and the duration is slightly shorter.

4. Right-click the Sample Rate status box and choose 8,000 from the shortcut menu.

5. Play the file. Notice that the pitch is lower and the duration is longer.

Changing the sample rate of a file also changes the pitch and duration. To change the sample rate of a file while preserving its duration 
and pitch, use the Resample command. For more information, see Resample on page 154.

Changing the bit depth

Bit depth refers to the number of bits used to represent a sound. You can increase or decrease a file’s bit depth.

Increasing bit depth

Increasing the bit depth does not improve the quality of a file, but it allows 
subsequent processing to be performed with increased precision. 

1. Open a file with a small bit depth.

2. From the Process menu, choose Bit-Depth Converter. The Bit-Depth 
Converter dialog is displayed.

3. From the Bit depth drop-down list, choose a larger value and click OK.

Decreasing bit depth

To maximize storage space, larger sound files (24- and 16-bit) are frequently converted to smaller (16- and 8-bit) files. However, 
representing a sound file at a decreased bit depth results in audible distortion referred to as quantization error.

1. Open a 16-bit file.

2. From the Process menu, choose Bit-Depth Converter. The Bit-Depth Converter dialog is displayed.

3. From the Bit depth drop-down list, choose 8 bit.

4. If desired, choose an option from the Dither drop-down list. For more information, see Dither on page 85.

5. If desired, choose a Noise shaping type. For more information, see Noise shaping on page 85.

6. Click OK.

Note: This file is located in the same folder as the application.

Note: When increasing a file’s bit depth, the Dither and Noise shaping 
controls should be set to None and Off, respectively.

Note: There are no rules regarding maintaining audio quality when decreasing bit depth. Experiment with the Dither and Noise 
shaping controls to determine the optimum settings for each audio file.
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Understanding dither and noise shaping

You can adjust Dither and Noise shaping settings when decreasing a file’s bit depth.

Dither 

The Dither value determines the randomness of the dither (generated noise) used to mask quantization distortion resulting from 
conversion to a lower bit depth. This drop-down list requires you to select from several shapes, each of which roughly describes the 
pattern that would be produced if you plotted a graph with the dither amplitude on the X-axis and the probability of the dither values 
on the Y-axis. 

As is frequently the case when working with audio, you should experiment with dither values to yield the best results. However, keep 

the following information in mind:

Noise shaping

The Noise shaping value determines the aural positioning of quantization noise. Using this control, you can shift the noise into audio 
registers that are less perceptible to human hearing. This lowers the perceived noise floor and creates the illusion of cleaner audio.

• High-pass contour noise shaping attempts to push all quantization noise and error into high frequencies.
• Equal-loudness contour noise shaping attempts to push the noise under an equal-loudness type of curve.

Noise shaping dangers

Noise shaping places quantization noise near the audio’s Nyquist frequency, a value equal to one-half of the file’s sample rate. Consider 
the following information:

• A file with a sample rate of 44.1 kHz has a Nyquist frequency of 22.05 kHz (at the high end of human hearing). Applying noise shaping 
to this file results in audio perceived to be cleaner than it actually is.

• A file with a sample rate of 22 kHz has a Nyquist frequency of 11 kHz (well within the sensitive range of human hearing). Applying 
noise shaping to this file results in audio that is perceived to be noisier than it actually is. Ironically, this defeats the entire purpose of 
noise shaping.

For this reason, we do not recommend using noise shaping on files with sample rates less than 44.1 kHz. 

Minimizing quantization error

There are at least three methods of minimizing quantization error when decreasing a file’s bit depth: noise gating, compression, and 
normalization. 

Setting Description
Half Rectangular Eliminates distortion resulting from conversion to a lower bit depth, but the noise level is more likely to be dependent on the 

signal. This setting uses a maximum dither noise amplitude of 0.5 LSB (least significant bit).
Rectangular Identical to Half Rectangular, but with a maximum dither noise amplitude of 1 LSB (least significant bit).
Triangular Eliminates distortion products as well as any noise floor modulation, but results in a slightly higher noise level. The option 

typically works well in conjunction with noise shaping. For more information, see Noise shaping on page 85.
Highpass Triangular Behaves like triangular dither, but shifts its noise into higher frequencies. This is typically the best option when used in 

conjunction with noise shaping. For more information, see Noise shaping on page 85.
Gaussian Does not perform as well as Rectangular and Triangular dither, but may be suitable for certain audio.
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Noise gating

Frequently, low-level signals become noise when a file’s bit depth is decreased. For this reason, it is preferable to have complete silence 
between sounds in an audio file.

1. From the Effects menu, choose Noise Gate. The Noise Gate dialog is displayed.

2. Choose a noise gate preset from the Preset drop-down list and click OK. A noise gate is applied to the audio, negating its low-level 
signals. 

Compressing

Decreasing the dynamic range of a sound file makes it easier to represent with decreased bit depth.

1. From the Effects menu, choose Dynamics, and choose Graphic from the submenu. The Graphic Dynamics dialog is displayed.

2. Choose a preset with a small amount of compression (2:1 or less) from the Preset drop-down list and click OK.

Normalizing

Normalizing a file prior to decreasing its bit depth ensures that the entire dynamic range is used. In addition, normalization lowers the 
signal-to-noise ratio. 

1. From the Process menu, choose Normalize. The Normalize dialog is 
displayed.

2. Select the Peak level radio button.

3. Set the Normalize to fader to 0 dB (peak) and click OK. 

Applying compression and normalization simultaneously

1. From the Process menu, choose Normalize. The Normalize dialog is 
displayed.

2. Select the Average RMS level radio button.

3. Specify Apply dynamic compression in the If clipping occurs drop-
down list and click OK. 

Specify a noise gate
86 | CHAPTER 5



Converting mono/stereo channels

You can convert mono files to stereo or stereo files to mono. To perform quick channel conversion without specifying the mix, use the 
Format tab on the Properties dialog or right-click the Channels box in the status bar and choose 2 (Stereo) or 1 (Mono) from the 
shortcut menu.

Converting from mono to stereo

1. Open the Voiceover.pca file. This file is located in the same folder as the application.

2. Right-click the Channels box in the status bar and choose Stereo from the shortcut menu. The 
Mono To Stereo dialog is displayed.

3. Select the Left Channel radio button and click OK. The mono data is placed in the upper half of 
the data window (left channel) and silence is placed in the right channel.

For more information, see Specifying the audio destination on page 87.

4. Play the file. “Wow, sound editing just gets easier and easier” plays in only the left channel.

Specifying the audio destination

The Destination radio buttons in the Mono To Stereo dialog allow you to specify where the mono audio data is placed in a stereo file. 
The following table describes the available data destinations.

Converting from stereo to mono

1. Open the Saxriff.pca file.

2. Right-click the Channels status box (indicating Stereo) and choose Mono from the shortcut 
menu. The Stereo To Mono dialog is displayed.

3. Select the Mix Channels radio button and click OK. The left and right channels combine into a 
mono channel.

For more information, see Specifying the audio source on page 87.

Specifying the audio source

The Source radio buttons in the Stereo To Mono dialog allow you to specify what stereo data is used to create the mono file. The 
following table describes the available data sources.

Tip: If your sound card supports only mono data, stereo files can be played by specifying the Sound Mapper as the playback device. To do 
this, choose Preferences from the Options menu. Click the Audio tab and specify Microsoft Sound Mapper from the Audio device 
type drop-down list.

Destination Description
Left Channel The mono data is placed in the left channel. The right channel is set to silence.
Right Channel The mono data is placed in the right channel. The left channel is set to silence.
Both Channels The mono data is copied into both channels.

Note: This file is located in the same folder as the application.

Source Description
Left Channel Mono data is taken only from the left channel of the stereo file.
Right Channel Mono data is taken only from the right channel of the stereo file.
Mix Channels Mono data is created by mixing both channels of the stereo file.
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Using the Channel Converter

You can also use the Channel Converter to convert files between mono and multichannel formats. Using the Channel Converter 
provides the added flexibility of independent level settings for each channel, thereby allowing you to intermix the channels of a 
multichannel file to create pan effects. To use this tool, choose Channel Converter from the Process menu. For more information, see 
Channel Converter on page 145.

Converting file formats

The previous sections have described changing a file’s sample rate, bit depth, and channel configuration. You can also convert a file’s 
format and compression settings. 

To demonstrate this, open the Voiceover.pca file and choose Save As from the File menu. Notice the Save as Type and Template drop-

down lists. For more information, see Using the Save As/Render As dialog on page 52.

Adding summary information

Specific audio file types allow you to store text fields of summary information in addition to the audio and video data. File types offering 
this feature include WAV, AVI, ASF, and RealMedia™ file formats. You can view and edit these text fields. 

Viewing and editing summary information

The Summary tab is used to view and edit the summary information stored in the file.

1. From the File menu, choose Properties. The Properties dialog is displayed.

2. Click the Summary tab.

3. Edit the summary information as needed and click OK. 

Viewing extended summary information

1. From the File menu, choose Properties. The Properties dialog is displayed.

2. Click the Summary tab. The Summary dialog is displayed.

3. Click the Extended button. The Extended Summary dialog is displayed. The dialog 
is divided into two sections: the Fields pane and the Contents pane. 

The Fields pane

The Fields pane displays the following components for 
each available field: 

• A check box to turn the field on or off.
• The abbreviation of the field type.
• A short description of the field.
• An indication of the field’s current status. 

Option Description
Save as type When the Save As dialog is displayed, the Save as type drop-down list defaults to the Sound Forge project file (.frg) format. 

However, using the Save as type drop-down list, you can specify any supported file type.
Template The Template drop-down list provides standard settings for saving your audio file. If the templates do not match your 

particular needs, click the Custom button to create custom settings.

On/Off check box

Field abbreviation
Field description

Empty field indicator

Full field indicator
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The Contents pane

Located immediately below the Fields pane, the Contents pane displays the current contents of the selected field. 

Editing extended summary information

1. Select the field to be edited in the Fields pane. Its contents display in the Contents pane.

2. Enter the new information in the Contents pane and click OK.

Turning summary fields on and off

Adjacent to each field in the Fields pane is a check box used to turn the corresponding field on and off when saving files in applicable 
formats.

Setting new default summary information

Clicking the Default button in the Extended Summary dialog saves the text in the summary fields as a default setting. This default 
summary information is used when you create a new file or when you click the Load button in the Properties dialog for an existing file.

Saving summary information

You can save files containing summary information that have been edited in Sound Forge software with or without summary 
information. 

1. From the File menu, choose Save As. The Save As dialog is displayed.

2. Select the Save metadata with file check box and click OK.

Including additional embedded information

Some file formats allow non-text data (such as embedded bitmaps and metafiles) to be embedded in files. If you use the Sound Forge 
software to edit a file containing data created in another application, Sound Forge software tracks the embedded data and places it 
back in the file when it is saved in its original format. 

Saving additional embedded information

To save additional embedded information, choose Save As from the File menu and select the Save metadata with file check box. If the 
file type does not support metadata, you are prompted to save the metadata in an external file with an .sfl extension.

Note: If a field is turned on but contains no information, it is not saved with the file. 

Tip: The Creation date field (ICRD) is always filled with the current date for new files.

Note: If you save to a file type that doesn’t support metadata, this check box is unavailable. 
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Removing additional embedded information

To save a file without additional embedded information, choose Save As from the File menu and clear the Save metadata with file 
check box.
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Chapter 6
 Editing Multichannel Audio

With Sound Forge 9, you can edit multichannel audio files in the same way you’ve always worked with mono or stereo 
files.

Sound Forge supports multichannel files in the following formats:

• Wave (.wav)
• Video For Windows (.avi) – specifically DV, SDI
• Material Exchange Format (.mxf)

• Dolby AC-3 (.ac3) (AC-3 is available as a render format only)
• Windows Media Audio/Video (.wma or .wmv)
• ATRAC (.oma)

Routing channels to hardware outputs 

If you’re working with multichannel files and have a sound card with multiple outputs, 
Sound Forge provides you with a great deal of flexibility in routing the channels to the 
outputs on your sound card: you can route each channel to a separate output, or you can 
route all the stereo pairs to a single set of outputs to simulate a stereo downmix.

The Hardware Meters window displays a meter and gain fader for each enabled output 
port. For more information, see Using the hardware meters on page 92.

You can change channel assignments from the Audio tab in the Preferences dialog or the 
Channel Meters window. Changing the setting in either location updates your 
preferences and affects all open data windows. For information about using the Audio tab 
of the Preferences dialog to enable and map channels, please see Audio tab on page 248.

To change a channel’s output device using the Channel Meters window, click the channel 
number and choose a new output port from the menu.

Note: MXF files require a video stream. If you want to save an audio-only file to MXF format, you must first attach a video 
stream. For more information, see Attaching video to an audio file on page 226. 
When working with MXF files, the number of channels in your source media must match the number of output channels 
specified by the rendering template. If necessary, use the Channel Converter before rendering.

Render format Number of channels
DV MXF Always contains 4 audio channels. 

You can use the Channels drop-down list on the Audio tab of the Custom 
Template dialog to choose how many channels will be filled with audio. For 
example, if you choose 2 from the Channels drop-down list, the rendered 
file will contain 4 audio channels: two channels will contain audio, and two 
channels will contain silence.

IMX MXF Always contains 8 audio channels.

You can use the Channels drop-down list on the Audio tab of the Custom 
Template dialog to choose how many channels will be filled with audio. For 
example, if you choose 2 from the Channels drop-down list, the rendered 
file will contain 8 audio channels: two channels will contain audio, and six 
channels will contain silence.

HD MXF Can contain 2 or 4 audio channels.

You can use the Channels drop-down list on the Audio tab of the Custom 
Template dialog to choose how many channels will be rendered. For 
example, if you choose 2 from the Channels drop-down list, the rendered 
file will contain only 2 audio channels.
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Opening and editing multichannel audio files

If you’ve used Sound Forge to edit stereo files before, you already know everything you need to know to edit multichannel files.

You can open multichannel audio files just like any other supported media type. For more information, see Getting media files on page 44.

When you open the file, you’ll notice that the data window displays the channels as stereo pairs:

You can then edit the file just as you would any mono or stereo file.

Click the Minimize button  to reduce the height of individual channels, or click the Restore button  to restore a channel’s height. 

Hold Shift while clicking a Minimize button  to minimize all channels except the one you clicked.

Recording multichannel audio files

With Sound Forge, you have the ability to record multichannel audio if your hardware supports this feature. For more information, see 
Playing back recorded audio on page 120.

Using the hardware meters

From the View menu, choose Hardware Meters to toggle the display of the Hardware Meters window. You can use this window to 
adjust the levels of your audio device’s hardware outputs for monitoring and to view a peak meter, VU/PPM meter, phase scope, and 
mono-compatibility meter.

Tip: You can use the Display tab in the Preferences dialog to change the colors used to represent each channel.

Peak meterVU/PPM meter Phase scope Mono-compatibility 
meter
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Adjusting output levels

The Hardware Meters window displays a gain fader for each output that is enabled on the Audio tab of the Preferences dialog (for more 
information, see Audio tab on page 248). You can use these faders to adjust preview levels.

Drag to adjust the volume of the channel. Double-click the center of the thumb to reset the fader to 0.0 dB.

If the right and left channels are set differently, you can double-click either thumb to force the other channel to match it.

Click the Lock/Unlock Fader Channels button  to lock (gang) the faders so the left and right channels will always move together. Click 
again to unlock the faders.

Showing or hiding meters

You can display a peak meter, VU/PPM, a phase scope, and mono-compatibility meter for each hardware output. To toggle the display 
of each meter, right-click the Hardware Meters window and choose a command from the shortcut menu.

A check mark is displayed to indicate which meters are currently visible.

For more information about peak meters, please see Using the channel meters on page 33.

For more information about VU/PPM meters, please see Using the VU meters on page 35.

For more information about phase scopes, please see Using phase scopes on page 36.

For more information about mono-compatibility meters, please see Using the mono-compatibility meters on page 37.

Important: The faders in the Hardware Meters window are used to control preview volume only. If you want to mix channel levels, use 
the Volume or Envelope plug-in.

Tip: Hold Shift while dragging a fader to temporarily override the current state of the Lock/Unlock Fader Channels button: if the button is 
turned off, you can hold Shift to drag the faders in locked mode; if the button is selected, hold Shift to drag the faders independently.
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Chapter 7
 Using Markers, Regions, and the Playlist/Cutlist

This chapter describes the use of markers, command markers, the Regions List, and the playlist/cutlist. These tools allow 
you to tag and organize audio data and make audio editing more efficient. The Sound Forge® application can save 
marker, Regions List, and playlist/cutlist information as metadata in most file types. You also have the option of saving 
the Regions List and playlist/cutlist to an external file. For more information, see Using the Save As/Render As dialog on page 
59.

Why use markers, regions, and the playlist?

There are at least four reasons for you to master the use of these features:

• Rapid navigation
• Added effects for streaming media
• Multiple versions of edits
• MIDI synchronization and triggering

Rapid navigation

The most obvious use of the Regions List is for dissecting an audio file into multiple regions. Once created, regions can be 
selected and played in the data window. You are also able to tag important time positions with markers. This allows you 
to navigate large files and locate important audio events.

Added effects for streaming media

Command markers allow you to add interactivity to media streamed over the Internet by inserting metadata into 
streaming media files. As your file plays, any number of other actions can be triggered, including opening a Web page in 
a browser or displaying caption text. 

Multiple versions of edits

The playlist and cutlist allow you to try out different edits before committing to them. You can add regions to the playlist 
or cutlist and then rearrange and audition them endlessly without requiring the software to perform an edit on the file.

Another advantage is that you can quickly save regions organized in the playlist or cutlist as a new file based on the 
finished arrangement.

MIDI synchronization and triggering

You can trigger regions created in Sound Forge software using MIDI or SMPTE timecode. This feature is used for 
synchronizing audio files to sequencers, MIDI controllers, or any other time-based media. For example, a MIDI trigger can 
be assigned to an audio file in the software and triggered by a sequencer along with other MIDI instruments. For more 
information, see Triggering region playback on page 236.

You can also assign SMPTE times to special effect audio files. This allows you to match audio to the action on the screen.
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Using markers

A marker is a tag placed in an audio file that is used as a reference point. Markers make navigating a file easier and more efficient.

Markers can be quickly selected from the list in the Go To dialog. Also, markers are displayed in the Regions List for quick playback.

Inserting markers

1. Click to position the cursor in the waveform.

2. From the Special menu, choose Insert Marker (or press M during playback). A marker is placed in the waveform at the exact 
location of the cursor.

3. If you want to name the marker, right-click the tag and choose Rename from the shortcut menu. Type a name for the marker in the 
edit box and press Enter.

Inserting markers during playback

To insert markers in real time during playback, press M.

Inserting markers during recording

To insert markers during recording, click the Drop Marker button  in the Record dialog or press M. For more information, see Inserting 
markers while recording on page 141.

Naming or renaming markers

Right-click the marker tab  and choose Rename from the shortcut menu. Type the name of the marker in the edit box and press Enter 
when you’re finished.

—or—

Double-click to the right of the marker and type a name in the edit box.
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Customizing marker labeling

You can set Sound Forge to automatically label new markers as they are created.

1. From the Options menu, choose Preferences. The Preferences dialog is displayed.

2. Click the Labels tab.

3. In the Marker labels area, adjust the labeling controls as desired:

4. Click OK to close the Preferences dialog.

Changing the marker position

You can change a marker’s position by dragging it to a new location or by updating its position to the current cursor location. You can 
also enter precise values to move a marker to a specific location.

Changing the marker position using drag-and-drop

1. Drag the marker tab  to a new position on the data window ruler.

2. Release the mouse button. The marker is dropped at its new location.

Deleting markers

Right-click the marker tab  and choose Delete from the shortcut menu.

Deleting all markers and regions

Right-click in the marker bar, choose Markers/Regions, and choose Delete All from the submenu. All markers  and regions  are 
removed.

Deleting all markers within the selected area

Right-click above the loop region, choose Markers/Regions, and choose Delete All in Selection from the submenu. All markers  and 

regions  in the selected area are removed.

Control Description
Label Markers Select this check box if you want Sound Forge to automatically name markers when you insert them during playback 

or recording.
Prefix Type a prefix in the box if you want Sound Forge to assign a name to new markers when you insert a marker during 

playback or recording. Clear the box if you do not want to include a prefix (if you want to number markers only, for 
example).

Use counter and 
start at

Select this check box and type a number in the box if you want Sound Forge to number new markers when you insert 
a marker during playback or recording.

Insert leading 
zeros in field 
width of

Select this check box and specify a field width if you want to use leading zeros in marker names when you insert a 
marker during playback or recording. For example, if you specify a field width of 3, markers numbered 1 to 99 would 
be numbered 001 to 099.

Note: Markers will snap to other markers, regions, and command markers. Hold Shift while dragging to override snapping.
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Previewing a marker

Click a marker’s Play button  in the Regions list.

—or—

1. Right-click the marker tag  and choose Edit from the shortcut menu. The Edit Marker/Region dialog is displayed.

2. Click the Play button.

Triggering a marker using MIDI commands

1. Right-click the marker tag  and choose Edit from the shortcut menu. The Edit Marker/Region dialog is displayed.

2. Choose a trigger type from the Trigger drop-down list.

3. In the Channel box, specify the MIDI input channel for triggering.

4. In the Note box, specify the MIDI note that will trigger marker playback. This value can be entered as a MIDI note value such as C4 
or as a MIDI note number such as 60.

Using markers to create regions

Once you have placed markers in a waveform, you can use them to create regions. For more information, see Inserting regions based on 
marker positions on page 103.

Detecting and marking clipping

The clip indicators in the channel meters help you determine whether clipping occurs in your file, and you can use the Find command 
to find audio that matches levels you specify. For more control, however, you can use the detect clipping tool.

From the Tools menu, choose Detect Clipping to scan a selection of audio for clipping and add markers where clipping occurs.

Markers can be quickly selected from the list in the Go To dialog. Also, markers are displayed in the Regions List for quick playback.

1. Select the audio you want to scan.

2. From the Tools menu, choose Detect Clipping. The Detect Clipping dialog is displayed.

3. Choose a setting from the Preset drop-down list or adjust the controls as necessary.

a. Drag the Threshold slider to determine the sound level you want to find.

b. Set a value in the Clip Length box to specify how many sequential samples must meet the Threshold setting to constitute 
clipping.

4. Click the OK button.

The selection is scanned and a marker is added whenever there are a number of sequential samples (determined by the Clip Length 
setting) with the same value above the Threshold setting.

Notes:

• If the Trigger from MIDI Timecode command (Options>MIDI In/Out submenu)is selected while using this dialog, you can auto-
complete the Channel and Note values by pressing a key on your MIDI keyboard.

• Triggers in the Regions List function differently from triggers specified in the MIDI Triggers dialog and the Playlist. When using triggers in 
the Playlist, Regions List, or MIDI Triggers dialog, be aware that they can interact to create unexpected results. Sound Forge software first 
looks at the MIDI Triggers, then the Regions List, and then the Playlist when determining what to do when a MIDI command is detected. If 
you only want to use the triggers in the Regions List, turn off all the triggers in the MIDI Triggers dialog and the Playlist.

Tip: Use Detect all clip-related plateaus from the Preset drop-down list to detect clipped peaks that may exist in your file after 
decreasing the levels in the file. You can then use the Pencil tool or the Clipped Peak Restoration tool in the Sony Media Software Noise 
Reduction plug-in to restore the clipped peaks.
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Using command markers in streaming media files

Command markers add interactivity to media streamed over the Internet by inserting metadata into streaming media files. As your file 
plays, any number of other actions can be programmed to occur. These commands are a part of the Windows Media Audio, Windows 
Media Video, and RealMedia streaming formats. Most frequently, these actions add text or open a related Web site. 

Command markers can also indicate when an instruction (function) occurs in a WAV file being used in a radio broadcast environment 
(Scott Studios data). The following two sections define the markers for both streaming media and Scott Studios files.

Defining streaming media commands

In a streaming media file, command markers can be used to display headlines, show captions, link to Web sites, or any other function 
you define. Some command types are exclusive to either the Windows Media files or RealMedia files.

Notes: 

• While streaming, media files can be played on any hard drive, CD-ROM, or DVD-ROM. They require a special streaming media server 
(provided by your ISP) to stream properly across the Internet.

• Windows Media Player 9 and later will ignore metadata commands unless the Run script commands when present check box is 
selected on the Security tab of the player's Preferences dialog. Be sure to instruct your audience to select this check box before playing 
your file.

Command Player type Description
URL Windows Media 

and RealMedia
Indicates when an instruction is sent to the user’s internet browser to change the content being 
displayed. With this command, you enter the URL that displays at a specific time during the file’s 
playback.

Text Windows Media Displays text in the captioning area of the Windows Media Player located below the video display 
area. You enter the text that displays during playback.

Note: To view captions during playback in Windows Media Player 9 or later, choose Captions and 
Subtitles from the Windows Media Player Play menu, and then choose On if Available from the 
submenu.

Title RealMedia Displays the entered text on the media player’s title bar.

Note: When rendering Windows Media files, title information is based on the settings on the 
Summary tab of the Sound Forge Project Properties dialog or the Index/Summary tab of the 
Custom Template dialog. The summary information from the Project Properties dialog will be used 
if information has been specified in both places.

To view this information during playback, choose Now Playing Options from the Windows Media 
Player View menu and select the items you want to display.

Author RealMedia Displays the entered text (Author’s name) when a user selects About This Presentation from the 
RealPlayer shortcut menu.

Note: When rendering Windows Media files, author information is based on the settings on the 
Summary tab of the Sound Forge Project Properties dialog or the Index/Summary tab of the 
Custom Template dialog. The summary information from the Project Properties dialog will be used 
if information has been specified in both places.

To view this information during playback, choose Now Playing Options from the Windows Media 
Player View menu and select the items you want to display.

Copyright RealMedia Displays the entered copyright information when a user selects About This Presentation from the 
RealPlayer’s shortcut menu or Properties from the Windows Media Player shortcut menu.

Note: When rendering Windows Media files, copyright information is based on the settings on the 
Summary tab of the Sound Forge Project Properties dialog or the Index/Summary tab of the 
Custom Template dialog. The summary information from the Project Properties dialog will be used 
if information has been specified in both places.

To view this information during playback, choose Now Playing Options from the Windows Media 
Player View menu and select the items you want to display.
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Defining Scott Studios data commands

For WAV files using Scott Studios data, command markers can be used to define information about the WAV file.

Inserting command markers

1. Position the cursor where you want to place the command marker.

2. From the Special menu, choose Insert Command (or press C). The Command Properties dialog is displayed.

3. Complete the Command Properties dialog:

a. From the Template drop-down list, select a custom template. For 
more information, see Saving command properties as a custom template 
on page 100.

b. From the Command drop-down list, select the type of command you 
wish to create or type a custom command.

c. Enter parameters to define the behavior of the command in the 
Parameter box.

d. Specify the timing of the command in the Position box. This value is 
automatically set to the current cursor position.

4. Click OK. The new command marker appears in the data window.

Editing command properties

Right-click a command marker and choose Edit from the shortcut menu to 
open the Command Properties dialog and edit the marker.

Saving command properties as a custom template

If you plan to use a command more than once, you can save command 
properties as a template. You can then reuse the command properties by selecting the template from the Template drop-down list.

1. Create a command and complete the Command Properties dialog.

2. Click in the Template box and enter a name for the template.

3. Click the Save Template button .

Moving the cursor to a command marker

Click the command marker to place the cursor at the current command marker position.

Deleting command markers

1. Place the mouse pointer on the command marker. The pointer changes to a hand icon .

2. Right-click to display a shortcut menu.

3. From the shortcut menu, choose Delete. The command marker is removed.

Command Description
SCOTT EOM Calculates when the next queued clip starts playing in a Scott Studios system. For more information, please refer to 

your Scott Studios documentation.
SCOTT Cue In Sets the beginning of a file in a Scott Studios system without performing destructive editing. For more information, 

please refer to your Scott Studios documentation.

Tip: Your metadata command templates are saved in the cmdtemp.xml file in the Sound Forge program folder. You can edit this file 
directly to modify your templates.
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Using regions 

Regions identify ranges of time and provide a way to subdivide an audio file. A region is defined as the area between two region tags. 
Regions can function as semi-permanent time selections that can be saved with the file. For example, regions can be used to indicate 
sections of projects such as choruses or verses, or they can be used to make notes in the project. You can also add regions to the playlist 
and use regions to create new files.

The Regions List window contains all of the regions and markers that exist in the active data window.

Inserting regions

You can use multiple methods of inserting regions including a menu command, drag-and-drop, a time ruler shortcut, and a keyboard 
shortcut. The following sections briefly describe the methods of creating regions. To work through these procedures, use the Fill.pca 
file. This file is located in the Sound Forge folder.

Inserting regions using menu commands

1. Open the Fill.pca file.

2. From the View menu, choose Regions List. The Regions List is displayed. For more information, see Using the Regions List on page 
106.

3. Create a selection containing the final drum hit near the end of the waveform display.

4. From the Special menu, choose Insert Region (or press R). The Insert Marker/Region dialog is displayed.

5. Enter a name for the region in the Name box and click OK. The selection appears in the Regions List.

In addition, notice that region tags now display in the data window. These tags indicate the region’s name and position within the 
original file.
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Inserting regions using drag-and-drop

One of the easiest ways to insert a region is to drag a selection from a data window into the Regions List. 

1. Create a selection containing the opening drum roll in Fill.pca.

2. Drag the selection from the data window to the Regions List. The Insert Marker/Region dialog is displayed.

3. Name the region and click OK.

Inserting regions using the time ruler shortcut

1. Create another selection in the waveform display.

2. Right-click the time ruler and choose Insert Marker/Region from the shortcut menu. The Insert Marker/Region dialog is displayed.

3. Name the region and click OK.

Inserting regions using the keyboard

1. Create a selection in the waveform display.

2. Press R. The region is inserted and numbered region markers  are placed at the start and end of the selected area.

3. Name the region and click OK. 

Inserting regions automatically

In addition to the previously described methods, you can also insert regions automatically.

Inserting regions while recording

The most efficient way of inserting regions is to do it while recording your audio. This is especially useful when working on a project that 
you will piece together from multiple takes. To create regions while recording, specify Multiple takes creating Regions from the Mode 
drop-down list in the Record dialog. For more information, see Multiple takes creating Regions on page 135.

Inserting regions based on rapid sound attacks

1. Open the Fill.pca file.

2. From the Tools menu, choose Auto Region. The Auto Region dialog is displayed.

3. Clear the Build regions using the current tempo check box if it is selected.

Tip: Regions are automatically named for you while recording. You can customize this automatic labeling feature. For more information, 
see Customizing marker labeling on page 97.
102 | CHAPTER 7



4. Specify a preset from the Preset drop-down list or configure a new setting using the dialog’s active parameters shown in the table 
below.

5. Click OK. Regions are inserted in the audio file based on the dialog parameters.

Inserting regions based on musical time intervals

When you select the Build regions using the current tempo check box in the Auto Region dialog (Tools>Auto Region), regions are 
inserted according to the current beats per minute setting. You can change a file’s tempo information (including the measures, beats, 
and beats per minute settings) by choosing Edit Tempo from the Special menu. For more information, see Changing a file’s beat values on 
page 75.

1. Open the Musicbed.pca file.

2. From the Tools menu, choose Auto Region. The Auto Region dialog box is displayed.

3. Select the Build regions using the current tempo check box. 

4. Enter desired values in the Measures and Beats boxes: 

• To create a region on every beat, set Measures to 0 and Beats to 1. 
• To create a region at every measure, set Measures to 1 and Beats to 0.

5. Click OK. Regions are created in the data window based on the Measures value, the Beats values, and the current beats per minute 
setting.

Inserting regions based on marker positions

1. Open the Fill.pca file.

2. Play the file and drop several markers using the M key.

3. From the Special menu, choose Regions List, and choose Markers to Regions from the submenu (or right-click the Regions List 
and choose Markers to Regions from the shortcut menu). You are prompted to verify whether the markers should be used to 
create regions.

4. Click Yes. Regions are created and added to the Regions List.

Parameter Description
Attack sensitivity Determines the sensitivity of the attack-detection algorithm to rapid volume increases.
Release sensitivity Determines the minimum decrease in sound level required to create a region end point. 
Minimum level Determines the threshold audio level required to create a new region. 
Minimum beat duration Specifies the minimum length, in seconds, that must elapse before a new region can be created.
Use release point for end 
of region

Requires a region end when the sound level drops by the factor specified by the Release sensitivity value. 

Note: All regions created using the Auto Region tool are automatically added to the Regions List and playlist. 

Note: This file is located in the same folder as the application.

Markers created 
in data window
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Naming or renaming a region

Right-click the starting region marker  and choose Rename from the shortcut menu. Type the name of the region in the edit box and 
press Enter when you’re finished.

—or—

Double-click to the right of the region marker and type a name in the edit box.

Customizing region labeling

You can set Sound Forge to automatically label new regions as they are created.

1. From the Options menu, choose Preferences. The Preferences dialog is displayed.

2. Click the Labels tab.

3. In the Region labels area, adjust the labeling controls as desired:

4. Click OK to close the Preferences dialog.

Selecting a region

Right-click the starting or ending region marker  and choose Select Region from the shortcut menu. The region is highlighted.

—or—

Double-click the start or end region marker. The region is highlighted.

Moving a region

1. Drag the desired region tag  to a new position. Both associated region tags are highlighted. 

2. Release the mouse button. The region’s values update in the Regions List.

Deleting a region

Right-click the region marker  and choose Delete from the shortcut menu.

Deleting all markers and regions

Right-click above the loop region, choose Markers/Regions, and choose Delete All from the submenu. All markers  and regions  are 
removed.

Control Description
Label Regions Select this check box if you want Sound Forge to automatically name regions when you insert them.
Prefix Type a prefix in the box if you want Sound Forge to assign a name to new regions when you insert one. Clear the box 

if you do not want to include a prefix (if you want to number regions only, for example).
Use counter and 
start at

Select this check box and type a number in the box if you want Sound Forge to number new regions after you insert 
one.

Insert leading 
zeros in field 
width of

Select this check box and specify a field width if you want to use leading zeros in region names when you insert one. 
For example, if you specify a field width of 3, regions numbered 1 to 99 would be numbered 001 to 099.

Tip: To move both region tags at once, press Alt while dragging. 
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Deleting all markers and regions within the selected area

Right-click above the loop region, choose Markers/Regions, and choose Delete All in Selection from the submenu. All markers  and 

regions  in the selected area are removed.

Previewing a region

Click a region’s Play button  in the Regions list.

—or—

1. Right-click the region tag and choose Edit from the shortcut menu. The Edit Marker/Region dialog is displayed.

2. Click the Play button.

Splitting regions

Splitting a region divides an existing region at the current cursor position, producing two separate regions.

1. In the Regions List window (View>Regions List), select the region you want to split.

2. Position the cursor where you want the split to occur.

3. From the Special menu, choose Regions List, and choose Split from the submenu (or right-click a region in the Regions List 
window and choose Split from the shortcut menu).

Triggering a region using MIDI commands

1. Right-click the region tag  and choose Edit from the shortcut menu. The Edit Marker/Region dialog is displayed.

2. Choose a trigger type from the Trigger drop-down list.

3. In the Channel box, specify the MIDI input channel for triggering.

4. In the Note box, specify the MIDI note that will trigger region playback. This value can be entered as a MIDI note value such as C4 or 
as a MIDI note number such as 60.

Using markers to create regions

Once you have placed markers in a waveform, you can use them to create regions. For more information, see Inserting regions based on 
marker positions on page 103.

Notes:

• If the cursor is placed within the region you’re splitting, the region will be split at the cursor position.
• If the cursor is placed outside the region you’re splitting, a new region will be created from the closest edge of the original region to the 

cursor position.

Notes:

• If the Trigger from MIDI Timecode command (Options>MIDI In/Out submenu)is selected while using this dialog, you can auto-
complete the Channel and Note values by pressing a key on your MIDI keyboard.

• Triggers in the Regions List function differently from triggers specified in the MIDI Triggers dialog and the Playlist. When using triggers in 
the Playlist, Regions List, or MIDI Triggers dialog, be aware that they can interact to create unexpected results. Sound Forge software first 
looks at the MIDI Triggers, then the Regions List, and then the Playlist when determining what to do when a MIDI command is detected. If 
you only want to use the triggers in the Regions List, turn off all the triggers in the MIDI Triggers dialog and the Playlist.
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Locking loop and region lengths

From the Options menu, choose Lock Loop/Region Length to force the length of a region to remain constant when changing the start 
or end time of a region or loop.

When this option is not selected, you can hold the Alt key while dragging region markers to lock the length of a region. To move a loop 
without changing its length, drag the bar between the loop markers.

Creating new files from regions

You can quickly create a new file from each region in a file. Each region is named by appending a numerical value to a user-specified 
prefix. 

1. Open an audio file and create several regions in it.

2. From the Tools menu, choose Extract Regions. The Extract Regions dialog appears and all current regions appear in the Regions to 
extract pane.

3. Select the regions to be extracted.

4. If the path in the Destination folder box is not appropriate, click the Browse button and browse to the desired destination folder.

5. Enter the desired prefix in the File name prefix box.

6. If desired, clear the Use long file names for destination file names check box and enter an appropriate numeric value in the Start 
file counter index box.

7. Click Extract.

Using the Regions List

The Regions List contains information pertaining to all regions in the current data window. The Regions List information can be saved as 
metadata in most file types. You also have the option of saving the Regions List to an external playlist file. 

Displaying the Regions List

1. Open the Voiceover.pca file.

2. From the View menu, choose Regions List (or press Alt+2). The Regions List for Voiceover.pca is displayed.

Note: Clearing the Use long file names for destination file names check box forces file names to conform to the 8.3 naming 
convention.
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Working with the Regions List

By default, the Regions List displays the following information for each region in the current data window:

• A small Play button  dedicated to the region.
• The name of the region.
• The region’s start point.
• The region’s end point.
• The region’s length.

Changing region order

By default, the Regions List displays regions in alphabetical order by name, but you may also specify an alternate order by clicking the 

column heading to sort in ascending  or descending  order.

Saving a Regions List file

You can save a file’s Regions List to an external file. This offers the flexibility of using multiple Regions Lists for the same audio file.

1. From the Special menu, choose Regions List, and choose Save As from the submenu (or right-click the Regions List and choose 
Save As from the shortcut menu).

2. Use the Save Regions/Playlist As dialog to specify a folder and filename.

3. Click Save.

Opening a Regions List file

Importing a Regions List file offers the flexibility of using multiple Regions List files for the same audio file. Opening a new Regions List 
file clears the current Regions List. Make sure you have saved the current Regions List before continuing.

1. From the Special menu, choose Regions List, and choose Open from the submenu (or right-click the Regions List and choose 
Open from the shortcut menu).

2. Use the Open Regions/Playlist dialog to locate an existing file.

3. Specify the type of regions you want to import from the Files of type drop-down list:

• Choose Playlist File (.sfl) to import a Sound Forge regions/playlist file.
• Choose Session 8 File (.prm) to import a file that supports both Session 8 and Sound Forge regions.
• Choose Windows Media Script File (.txt) to import a file that includes Windows Media script commands.
• Choose Wave File (.wav) to import markers and regions from another audio file.

4. Click Open.

Copying the Regions List to the clipboard

Editing a Regions List in a text editor allows you to make an annotated list that you can print for reference.

From the Special menu, choose Regions List, and then choose Copy onto Clipboard (or right-click the Regions List and choose Copy 
onto Clipboard from the shortcut menu). The list is copied to the Windows clipboard.
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Using the playlist

Once you create regions, you can arrange them in the playlist. Unlike the Regions List, which displays its contents in alphabetical or 
chronological order, the playlist displays and plays its regions in a user-specified arrangement. In addition, you can rearrange and 
audition regions endlessly in the playlist without performing a destructive edit when you save the file. 

As with the Regions List, you can save the playlist information as metadata in most file types. You also have the option of saving the 
playlist to an external playlist file.

Displaying the playlist

1. Open the Voiceover.pca file.

2. From the View menu, choose Regions List (or press Alt+2). The Regions List window for Voiceover.pca is displayed.

3. From the View menu, choose Playlist (or press Alt+3). The Playlist window for Voiceover.pca is displayed.

Notice that the file contains regions, but the playlist is empty. You must add regions to the playlist before arranging them.

Understanding the playlist display

When you add a region to the playlist, its appearance is similar to its appearance in the Regions List, with the exception of the Count 
(Cnt) column. Located to the left of the Name column, the Count (Cnt) column displays the number of times the corresponding region 
plays before the playlist proceeds to the next region.

Adding regions to the playlist

You can add regions from the Regions List to the playlist using commands or drag-and-drop. You can also add regions to the playlist 
directly from the data window.

Adding regions to the playlist using commands

1. Select a region in the Regions List.

2. From the Special menu, choose Playlist/Cutlist, and choose Add from the submenu (or right-click a region in the Regions List 
window and choose Add to Playlist from the shortcut menu). The region is added to the playlist.

Adding regions to the playlist using drag-and-drop

1. Select a region in the Regions List.

2. Drag the region into the playlist. 

3. Release the mouse button. 
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Arranging the playlist

Moving regions

Once you have added regions to the playlist, you can arrange them using drag-
and-drop.

Replicating a region in the playlist

A major advantage of arranging the playlist is the ability to repeat a region in multiple places without actually copying the audio data. 
This feature is called replicating.

1. Right-click the region to be replicated and choose Replicate from the shortcut menu. The region is replicated in the playlist.

2. Drag the replicated region to its new position in the playlist.

Deleting a region from the playlist

You can delete regions from the playlist without affecting the audio file.

1. Select the region that you would like to delete.

2. From the Special menu, choose Playlist/Cutlist, and then choose Delete from the submenu (or right-click the Playlist window and 
choose Delete from the shortcut menu).

Changing region order

Click the column heading to sort the results in ascending  or descending  order based on the column’s contents.

Editing a playlist/cutlist region

You can edit a Playlist/Cutlist region by typing new values in the Cnt, Start, End, Length, and Name boxes or you can select a box and 
press Enter to display the Edit Playlist dialog. 

Displaying the Edit Playlist dialog

The Edit Playlist dialog allows you to specify the number of times a playlist/cutlist region will be played, set up MIDI triggers, and 
establish pre-roll.

Perform one of the following actions to open the Edit Playlist window:

Tip: You can also replicate a region by holding Ctrl while dragging the region to a new position in the playlist.

Note: You must add regions to your playlist before you can display the Edit Playlist dialog.

Option Action
Option I From the Special menu, choose Playlist/Cutlist, and then choose Edit from the submenu to edit the selected region in 

the Playlist window.
Option II Right-click a playlist region and choose Edit from the shortcut menu.
Option III Select a region in the Playlist window and press Enter.
USING MARKERS, REGIONS, AND THE PLAYLIST/CUTLIST | 109



Repeating a region during playlist playback

You can specify the number of times a region repeats during playlist playback.

Type a value in the Cnt box in the Playlist window (or use the Play Count box in the Edit Playlist dialog) to specify the number of times 
the playlist region will repeat before playing the next region.

Using stop points

You can attach stop points to regions in the playlist. When a stop point is encountered during playback, the corresponding region is 
repeated the number of times specified by the Count value and playback is halted.

Creating a stop point

Perform one of the following actions to set the stop point for a playlist:

A check mark appears adjacent to the command in the shortcut menu and a stop point (indicated by a red circle) appears in the playlist.

Deleting a stop point

Perform one of the following actions to remove the stop point for a playlist:

The corresponding check mark is cleared from the shortcut menu and the stop point (indicated by a red circle) is removed from the 
playlist. 

Playing from the playlist

The playlist displays the sequential order in which regions play. To play a region, click the corresponding Play button . Playback 
begins with the selected region and continues through the end of the playlist, playing a region multiple times when instructed by the 
Count value.

Option Action
Option I Right-click a region in the Playlist window and choose Stop Point from the shortcut menu.
Option II Select a region in the Playlist window and press *. (Not on the numeric keypad.)
Option III Select the Stop point check box in the Edit Playlist dialog to stop playback with the selected region.

Note: When you play your playlist, it will continue to play through the regions until it encounters a stop point. This is useful when 
triggering playback from incoming MIDI or timecode and you only want certain sections of the playlist to be played at a time.

Option Action
Option I Right-click a region in the Playlist window and choose Stop Point from the shortcut menu.
Option II Select a region in the Playlist window and press *. (Not on the numeric keypad.)
Option III Select the Stop point check box in the Edit Playlist dialog to stop playback with the selected region.

Note: Playback is interrupted if a stop point is present. For more information, see Using stop points on page 110.
110 | CHAPTER 7



Creating a new file from the playlist

After you have auditioned and arranged all regions in the playlist, you can create a new file based on the playlist arrangement. To create 
a new file from the playlist, right-click the playlist and choose Convert to New from the shortcut menu.

Configuring the playlist as a cutlist

When trimming lengthy recordings, configuring the playlist as a cutlist can sometimes decrease editing time. In Play as Cutlist mode, 

the original file is played, but all regions placed on the cutlist are ignored. Click the Play as Cutlist button  on the playbar to enter 
Play as Cutlist mode.

Treating the playlist as a cutlist

1. From the View menu, choose Playlist. The Playlist window is displayed.

2. Right-click the playlist and choose Treat as Cutlist from the shortcut menu. A check mark appears adjacent to the command in the 
shortcut menu and the cutlist displays. The Play as Cutlist button  appears in the playbar.

Adding regions to the cutlist

1. Open the Voiceover.pca file and the cutlist.

2. Select the “Silence” region and drag it to the cutlist (or press Delete). The region is added to the cutlist and the selection area in the 
waveform display is shaded.

3. Click the Play Cutlist button  on the data window’s playbar. The file plays with the cutlisted region omitted.

Creating a new file from the cutlist

Once all superfluous regions are placed in the cutlist, you can create a new audio file and Regions List from the remaining region. From 
the Special menu, choose Playlist/Cutlist and choose Convert to New from the submenu (or right-click the cutlist and choose Convert 
to New from the shortcut menu).

Deleting all cutlist regions

1. Select a region in the Playlist/Cutlist window. If the window is not visible, press Alt+3.

2. From the Special menu, choose Playlist/Cutlist and then choose Delete from the submenu (or press Delete).

Reverting to playlist function

To use the cutlist as a playlist again, right-click the cutlist and choose Treat as Cutlist from the shortcut menu. The check mark is cleared 
from the corresponding command in the shortcut menu and the playlist function is restored.

Note: If the original file has both audio and video components (such as an AVI file), the new file created from the playlist contains the 
audio portion only.

New region is added to the cutlist
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Saving a playlist/cutlist file

You can save a file's playlist/cutlist to an external file. This offers the flexibility of using multiple playlists for the same file.

1. From the Special menu, choose Regions List or Playlist/Cutlist, and choose Save As from the submenu (or right-click the playlist/
cutlist and choose Save As from the shortcut menu).

2. Use the Save Regions/Playlist dialog to specify a folder and filename.

3. Click Save.

Opening a playlist/cutlist file

Importing a playlist file offers the flexibility of using multiple playlists for a file. Opening a new playlist file clears the current playlist. 
Make sure you have saved the current playlist before continuing.

1. From the Special menu, choose Playlist/Cutlist, and choose Open from the submenu (or right-click the playlist/cutlist and choose 
Open from the shortcut menu).

2. Use the Open Regions/Playlist window to browse to an existing regions file.

3. Specify the type of file you want to import from the Files of Type drop-down list:

• Choose Playlist File (.sfl) to import a Sound Forge regions/playlist file.
• Choose Session 8 File (.prm) to import a file that supports both Session 8 and Sound Forge regions.
• Choose Windows Media Script File (.txt) to import a file that includes Windows Media script commands.
• Choose Wave File (.wav) to import markers and regions from another sound file.

4. Click Open.

Copying the playlist/cutlist to the clipboard

Editing a playlist/cutlist in a text editor allows you to make an annotated list that you can print for reference.

From the Special menu, choose Playlist/Cutlist, and then choose Copy onto Clipboard (or right-click the playlist/cutlist and choose 
Copy onto Clipboard from the shortcut menu). The list is copied to the Windows clipboard for use with a text editor.
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Chapter 8
 Recording, Extracting, and Burning

This chapter describes the processes for recording audio, extracting audio from a CD, and writing audio to a CD in Sound 
Forge® software. 

Recording audio

Sound Forge has two central methods for recording: manual (normal) and automatic. In normal recording, you choose 
your settings and control your recording session while you’re sitting at your PC. With automatic recording, you can 
choose your settings and set your trigger parameters for recording automatically—whether you’re at your PC or not. 
Sound Forge also allows you to record multichannel audio if your audio device supports multiple inputs.

Specifying recording and playback options

Basic audio preferences

From the Options menu, choose Preferences and select the Audio tab to specify recording and playback options. For 
more information, see Basic audio preferences on page 248.

Advanced audio preferences

The Advanced Audio Configuration dialog allows you to view information about and adjust settings for the playback or 
recording device selected on the Preferences window (from the Options menu, choose Preferences) Audio tab. To view 
advanced preferences, click the Advanced button. For more information, see Advanced audio preferences on page 249.
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Recording manually

You can record into an existing window or create a new window at the time of recording. If you have an audio device that supports 

multiple inputs, you can use Sound Forge to perform multichannel recording.

1. Connect your audio sources to your sound card’s inputs. For more information on connecting audio sources, please refer to your sound 
card’s user documentation.

2. Enable your recording inputs:

a. From the Options menu, choose Preferences, and click the Audio tab.

b. Choose your recording device from the Audio device type drop-down list.

c. Click the Record tab.

d. Select the Enable check box for each input you want to enable for recording, and then select a radio button to assign the input 
to an audio channel.

In the following example, the signal from Analog in 1 is recorded to channel 1, Analog in 2 is recorded to channel 2, and so on.

e. Click OK to close the Preferences dialog and save your changes.

3. From the Special menu, choose Transport, and then choose Record from the submenu. The Record dialog is displayed.

Tips: 

• Sound Forge is not a multitrack editor — check out our Vegas and ACID family of products for full multitrack recording and editing. You 
can use multichannel recording to create surround audio or capture field recordings.

• If you experience gapping or glitching when recording multichannel audio, try increasing your buffer size. You can increase the Record 
buffering setting on the Audio tab of the Preferences dialog or click the Advanced button on the Audio tab of the Preferences dialog to 
increase your device’s buffers.

Tip: You can also open the Record dialog by clicking the Record button  on the transport bar or pressing Ctrl+R.

Recording attributes

Title bar

Recording method

Recording mode

DC adjust

Punch-in spinners

Transport bar

Recording time

Pre/post roll

Prerecording buffer

Click to view meters and meter reset

MTC/SMPTE 
sync settings

Record to new window

Set selection

Remote recording

Set recording destination 
window

Input monitoring

Channel selection
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4. From the Method drop-down list, choose Normal.

5. Choose the destination data window for your recording. By default, the application records into the active data window. If this is 
not where you want to record, use one of the following methods to prepare for recording:

6. Choose a recording mode from the Mode drop-down list. For more information, see Choosing a recording mode on page 119.

7. If necessary, set a start time, duration, or end time for your recording. By default, recording will begin at the current cursor position. 
To record to a different cursor position, use one of the following methods:

• Type a new cursor position in the Start field. If you chose the Punch In recording option in the Mode drop-down list, you can 
also type values in the End or Length fields to define your recording period.

• Click the Go To button  and change the cursor position. Click OK to return to the Record dialog. For more information, see 
Setting the cursor position on page 69.

8. To determine which inputs are recorded, type a value in the Channels box. For example, you could type 1-4 to record channels 1 
through 4, or type 1, 3, 4 to record only channels 1, 3, and 4.

9. Click the Arm button  to have recording begin as soon as possible after you click the Record button . 

Arming Sound Forge software prior to recording opens the wave device and loads all recording buffers in order to minimize the 
amount of time between clicking the Record button and when the recording starts. This optional step can allow for more accurate 
takes when recording in Punch-In mode.

10. If desired,click the Advanced tab and select the Prerecord buffer check box and specify the amount of time to buffer prior to 
recording when the software is armed for recording. A prerecording buffer helps to ensure you won’t miss a perfect take if you’re a 
bit slow to click the Record button.

When you click the Record button, recording begins and the sound data in the buffer is committed to disk. For example, if you set a 
15-second buffer, recording effectively begins 15 seconds before you click the Record button.

11. If necessary, select the DC Adjust check box and calibrate the DC offset adjustment. For more information, see Adjusting for DC offset 
on page 119.

12. Click the Record button  in the Record dialog (or press Alt+R). Recording begins.

If Then
You want to record into a 
different data window

Click the Window button and choose a data window from the Record 
destination window drop-down list. Click OK to return to the Record dialog.

You want to record into a new 
window

Click the New button in the Record dialog and specify the attributes (sample 
rate, bit depth, and channels) for the new file. Click OK to return to the Record 
dialog.

Note: The maximum number of channels recorded depends on the data window where you’re recording. For example, if you enabled six 
inputs on the Record tab in Audio preferences, you need to record into a six-channel data window to record all six inputs. If you record to a 
stereo data window, only two inputs will be recorded. 

To route inputs to channels in the data window, click a channel number and choose a new input port from the menu.

To determine which inputs are recorded, type a value in the Channels box. For example, you could type 1-4 to record channels 1 through 4, 
or type 1, 3, 4 to record only channels 1, 3, and 4.

Note: The prerecord buffer is unavailable in punch-in mode.

Recording message

Time recorded value increases

Stop button displays
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13. Click the Stop button  to stop recording.

14. Click the Close button to close the Record dialog.

Recording automatically

In addition to the normal recording method, there are three automatic recording methods: Time, Threshold, and MIDI Timecode. These 
recording methods enable you to trigger recording to begin automatically, using a specified device, with no intervention necessary, 
using a timer, by detecting when audio exceeds a set threshold, or when MIDI timecode is detected.

When you’re using threshold-triggered recording, you can choose to record continuously: set a buffer size, and the recorded audio will 
fill the buffer, discarding the oldest data as new data is recorded. If you want to save data from the buffer, you can save it to disk.

You can set up multiple automatic recording sessions to take place at different times, and set a session’s recurrence level for one time, 
daily, or weekly. For your recording sessions to take place, the Sound Forge application must be started and armed for recording.

Triggering by time

1. From the Special menu, choose Transport, and then choose Record from the submenu.

2. From the Method drop-down list, choose Automatic: Time.

3. Choose the destination data window for your recording. By default, the software records into the active data window. If this is not 
where you want to record, use one of the following methods to prepare for recording:

4. From the Mode drop-down list, choose a recording mode. For more information, see Choosing a recording mode on page 119.

5. Use the Time Options tab at the bottom of the Record dialog to set the timer:

a. Click the Add button  to create a timer setting. The Record Timer Event dialog is displayed.

b. Type a name in the Name field to create a name to identify the preset.

c. Choose a setting from the Recurrence drop-down list to indicate whether you want to record one time only or repeat the 
selected recording day and time at a regular interval.

d. Use the Start date, Start time, and Duration boxes to indicate when you want to start and stop recording.

e. Click OK to close the dialog and return to the Record dialog.

6. Select a timer setting and click the Arm button  in the Record dialog when you’re ready to start the timer.

If you want to edit a timer setting, select it and click the Edit button  to display the Record Timer Event dialog.

If you want to remove a timer setting, select it and click the Delete button .

If you want to remove all past timer settings, click the Remove All Past Events from List button .

7. To end timed recording, click the Stop button .

8. Click the Close button to close the Record dialog.

Tip: You can also click the Record button  on the transport bar or press Ctrl+R.

If Then
You want to record into a different data window Click the Window button and choose a data window from the Record destination 

window drop-down list. Click OK to return to the Record dialog.
You want to record into a new window Click the New button in the Record dialog and specify the attributes (sample rate, 

bit depth, and channels) for the new file. Click OK to return to the Record dialog.

Note: The maximum number of channels recorded depends on the data window where you'’re recording. For example, if you enabled six 
inputs on the Record tab in Audio preferences, you need to record into a six-channel data window to record all six inputs. If you record to a 
stereo data window, only two inputs will be recorded. 

To route inputs to channels in the data window, click a channel number and choose a new input port from the menu.

To determine which inputs are recorded, type a value in the Channels box. For example, you could type 1-4 to record channels 1 through 4, 
or type 1, 3, 4 to record only channels 1, 3, and 4.
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Triggering by a set threshold 

When you’re using threshold-triggered recording, you can choose to record continuously: set a buffer size, and Sound Forge software 
will record to fill the buffer, discarding the oldest data as new data is recorded. If you want to save data from the buffer, you can save it to 
disk.

1. From the Special menu, choose Transport, and then choose Record from the submenu.

2. From the Method drop-down list, choose Automatic: Threshold.

3. Choose the destination data window for your recording. By default, the software records into the active data window. If this is not 
where you want to record, use one of the following methods to prepare for recording:

4. From the Mode drop-down list, choose a recording mode. For more information, see Choosing a recording mode on page 119.

5. Use the Threshold Options tab at the bottom of the Record dialog to set the audio levels at which recording will start and stop:

a. Drag the Threshold fader to set the audio level at which recording will begin.

b. Drag the Release slider to set the amount of time the audio level should be below the Threshold setting before recording will 
stop. 

c. Select the Automatically rearm after record check box if you want to continue monitoring audio levels and recording until you 
click the Stop button .

6. Click the Arm button  in the Record dialog. Recording will begin when the audio signal meets the threshold level and will stop 
after the level falls below the threshold for the specified release time.

7. To end audio monitoring and recording, click the Stop button .

8. Click the Close button to close the Record dialog.

Setting a prerecord buffer for threshold recording

On the Advanced tab at the bottom of the Record dialog, select the Prerecord buffer check box and type a value in the edit box to 
maintain a set amount of time in a buffer when Sound Forge software is armed for recording. A prerecording buffer helps to ensure you 
won’t miss a perfect take if you’ve set the threshold a bit too high.

When the prerecording buffer is enabled, recording begins when the audio input reaches the threshold level and the sound data in the 
buffer is committed to disk. For example, if you set a 15-second buffer, recording effectively begins 15 seconds before the input reaches 
the set threshold level.

Tip: You can also Click the Record button  on the transport bar or press Ctrl+R.

If Then
You want to record into a different data window Click the Window button and choose a data window from the Record destination 

window drop-down list. Click OK to return to the Record dialog.
You want to record into a new window Click the New button in the Record dialog and specify the attributes (sample rate, 

bit depth, and channels) for the new file. Click OK to return to the Record dialog.

Note: The maximum number of channels recorded depends on the data window where you'’re recording. For example, if you enabled six 
inputs on the Record tab in Audio preferences, you need to record into a six-channel data window to record all six inputs. If you record to a 
stereo data window, only two inputs will be recorded.

To route inputs to channels in the data window, click a channel number and choose a new input port from the menu.

To determine which inputs are recorded, type a value in the Channels box. For example, you could type 1-4 to record channels 1 through 4, 
or type 1, 3, 4 to record only channels 1, 3, and 4.
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Triggering by MIDI timecode

1. From the Special menu, choose Transport, and then choose Record from the submenu.

2. From the Method drop-down list, choose Automatic: MIDI Timecode.

3. Choose the destination data window for your recording. By default, the software records into the active data window. If this is not 
where you want to record, use one of the following methods to prepare for recording:

4. From the Mode drop-down list, choose a recording mode. For more information, see Choosing a recording mode on page 119.

5. Use the MIDI Timecode Options tab at the bottom of the Record dialog to set the MIDI timecode interval you want to record:

a. Select the MIDI timecode start check box and type a value in the edit box to indicate the timecode location when recording will 
begin.

b. Select the MIDI timecode end check box and type a value in the edit box to indicate the timecode location when recording will 
end. If you don’t indicate a stop time, recording will continue until you click the Stop button  to stop recording.

6. Click the Arm button . Recording will begin when Sound Forge software detects the timecode specified in the MIDI timecode 
start box and will stop when the software detects the timecode specified in the MIDI timecode end box.

7. To end recording, click the Stop button .

8. Click the Close button to close the Record dialog.

Note: You can specify a MIDI input port in the MIDI/Sync tab in the Preferences dialog (from the Options menu, choose Preferences). 
For more information, see Synchronizing with other devices on page 120.

Tip: Click the Record button  on the transport bar or press Ctrl+R.

If Then
You want to record into a different data window Click the Window button and choose a data window from the Record destination 

window drop-down list. Click OK to return to the Record dialog.
You want to record into a new window Click the New button in the Record dialog and specify the attributes (sample rate, 

bit depth, and channels) for the new file. Click OK to return to the Record dialog.
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Choosing a recording mode

You can choose any of several recording modes in the Record dialog’s Mode drop-down list:

Adjusting for DC offset

Use the Record dialog’s DC adjust check box to compensate for DC offsets generated by your system’s sound card during recording. A 
DC offset of approximately 30 dB is not uncommon for sound cards (even with very low noise floors) and this displays in the record 
meter as -60 dB. This does not mean that the system is losing 30 dB of resolution, but for the meters to accurately display ranges to 
-90 dB, you must calibrate the DC adjust. 

Calibrating the DC adjustment

Before using the DC adjust feature, you must calibrate it for the selected recording device. 

1. Select the DC adjust check box. The Calibrate button activates along with displays labeled Left and Right.

2. Click the Calibrate button. Sound Forge software listens to the selected recording device and calculates the offset.

Recalibrating the DC adjustment

If you have multiple sound cards, you should recalibrate the DC adjust each time you select a new recording device. Certain sound cards 
must also be recalibrated each time the sample rate changes or when switching between mono and multichannel recording.

Mode Description
Automatic retake (automatically 

rewind)
Automatic retake mode is the easiest method of recording. Recording begins at the position displayed in the Start box 

when you click the Record button  and continues until you click the Stop button . When you stop recording, the 
start position resets to the beginning of the take, allowing for immediate review and retake.

Note: Automatic retake is the default mode when recording into an empty data window or when recording with no data 
selected in the current data window.

Multiple takes creating Regions Multiple takes creating Regions mode allows you to record several takes with each take defining a region in the 

Regions List. Recording begins at the position displayed in the Start box when you click the Record button  and 

continues until you click the Stop button . When you stop recording, the stop position becomes the start position for 

the next take, which can be recorded immediately. For more information, see Using the Regions List on page 
106.

Multiple takes (no Regions) Multiple takes (no Regions) mode also allows several takes to be recorded without these takes being defined as regions. 

Like the previous mode, recording starts at the position displayed in the Start box when you click the Record button  

and continues until you click the Stop button . When you stop recording, the stop position becomes the start position 
for the next take, which can be recorded immediately.

Create a new window for each take Create a new window for each take is similar to Multiple takes creating Regions, but creates a new data window 
for each take. This is useful when recording audio data in which you will save each take as an individual file.

Punch-In (record a specific length) Punch-In mode is used to record over a specific selection in an existing data window. Specifying Punch-In activates the 

Start, End, and Length boxes. Recording begins at the position displayed in the Start box when you click the Record 

button  and continues until one of the following occurs: 

• You click the Stop button .

• The cursor in the data window reaches the position displayed in the End box.

• The length of the recorded data equals the value in the Length box.

Punch-In mode makes it possible to record over a specific section of audio without the risk of affecting the remainder of the 

audio file. You can preview the punch-in region by clicking the Play button .

Note: Punch-In is the default mode when recording with a selection in the data window.

Tip: You can recalibrate at any time, even during recording. However, it is preferable to perform recalibration with silence at the record 
inputs.

Set the DC adjust check box to activate the Calibrate button
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Playing back recorded audio

Audition your recorded audio by playing it back in the Record dialog. Click the Play button  to begin playback and click the Stop 

button  to end playback. You can use the other buttons on the mini-transport bar in the Record dialog to navigate to different 
locations in the file.

Adjusting pre/post-roll for punch-in and automatic retake recording playback

Once you have recorded a punch-in or an automatic retake, you can audition it with user-configured pre-roll and post-roll to evaluate 
the performance. This option allows you to indicate the amount of sound data that should be played preceding or following your 
recorded take when you review your takes. Reviewing with pre- and post-roll helps you review your takes in context.

1. Select the Review pre/post-roll check box in the Record dialog. The two corresponding boxes become active.

2. Enter appropriate pre-roll and post-roll values in the respective boxes.

3. Click the Play button . The punch-in segment plays with the configured pre-roll and post-roll.

Synchronizing with other devices

Sound Forge software can generate MTC/SMPTE synchronization while recording.

1. From the Options menu, choose Preferences, and click the MIDI/Sync tab.

2. On the MIDI/Sync tab, choose the trigger device from the Input drop-down list and click the OK button.

3. From the Options menu, choose MIDI In/Out, and then choose Generate MIDI Timecode from the submenu to enable MIDI 
timecode output.

4. Click the Record button .

5. Click the Advanced tab at the bottom of the Record dialog.

6. Select the Enable MTC/SMPTE Output Synchronization check box.

7. Select the Start check box and specify the time you want to start recording.

8. Select the Pre Roll check box and type a value in the edit box to begin SMPTE output at a specified time before recording.

9. Click the Close button.

Arm Go to start of file

Record Go to start of last take

Play Go to end of file

Drop marker Go to

Note: In Automatic retake mode, the post-roll control is unavailable.

Note: Regardless of the data window’s current status format, pre-roll and post-roll values are measured in seconds.
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Monitoring audio input

The input meters in the Meters tab at the bottom of the Record dialog show the level of the incoming signal. For recording purposes, 
the incoming audio should remain primarily in the yellow, only occasionally entering the red.

Enabling the recording meters

Recording meters are displayed in the Meters tab at the bottom of the Record dialog so you can check your input level before recording.

Click the Meters tab at the bottom of the Record dialog to display recording meters, and then select the Monitor check box to enable 
the recording meters.  The peak meters represent the volume of the recording input. For best results, the peak level should be 
somewhere in the yellow range with an occasional red: you want your input to be as loud as possible without clipping.

You can display a peak meter, VU/PPM, a phase scope, and mono-compatibility meter for each channel. To toggle the display of each 
meter, right-click the Meters tab in the Record dialog and choose a command from the shortcut menu. A check mark is displayed to 
indicate which meters are currently visible.

For more information about the VU/PPM meters, please see Using the VU meters on page 35.

For more information about the phase scopes, please see Using phase scopes on page 36.

For more information about the mono-compatibility meters, please see Using the mono-compatibility meters on page 37.

You can work with the record input meters in much the same way you do with other meters in the application. For more information, see 
Monitoring levels in digital audio on page 32.

Enabling input monitoring

Click the Advanced tab at the bottom of the Record dialog and select the Enable audio input monitoring check box if you want to 
route the audio received by the input device to the current output device.

Inserting markers while recording

Click the Drop Marker button  in the Record dialog’s mini-transport bar (or press M) to insert a marker in the data window during 
recording. 

You can then use the Markers to Regions command to convert markers into regions. For more information, see Inserting regions based on 
marker positions on page 103.

Automatically labeling windows and regions

Files and regions can be automatically named for you as you record. This automatic labeling feature is particularly useful when recording 
in Multiple takes creating Regions mode or Create a new window for each take mode. For more information, see Choosing a recording 
mode on page 119.

Right-click the Record dialog and choose Automatic Labeling from the shortcut menu to access the Automatic Labeling dialog. For 
more information, see Customizing region labeling on page 104.

Tips: 

• Click the Reset button (or press Alt+T) to reset clip indicators or held peaks or valleys.
• Right-click the meters and choose a setting from the shortcut menu to change the meters’ scale.
• If you are going to decrease the bit depth of your sound file after recording, it is particularly important that you record with the loudest 

possible levels. High recording levels ensure that you will use the maximum possible dynamic range in the converted file.

Note: This check box is available only when the Monitor check box is enabled.
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Changing blinking status

The Recording message located to the right of the mini-transport bar in the Record dialog can display within a flashing or solid red 
frame.

To toggle between the blinking status settings, right-click the Record dialog and choose Blinking Status from the shortcut menu. A 
check mark displays adjacent to the command to indicate that the frame is configured to flash.

Extracting audio from CDs

You can extract data from CD and open tracks in the Sound Forge workspace.

1. Insert a CD in the drive.

2. From the File menu, choose Extract Audio from CD. The system’s drive(s) are identified. The Extract Audio from CD dialog is 
displayed. If the system is equipped with multiple CD-ROM or DVD-ROM drives, you must select the desired drive from the Drive 
drop-down list near the bottom of the dialog.

3. From the Action drop-down list, choose the method you want to use for extracting the CD audio:

4. If you choose Read by track or Read by range from the Action drop-down list, select the tracks or time range you want to extract.

5. Select extraction options as needed:

• Select the Create regions for each track check box to add each extracted track to the file’s Regions List. 
• Select the Create markers for each index change check box to place markers in the extracted file at all points where indices 

occur in the original track.

6. From the Drive drop-down list, choose the CD drive that contains the CD from which you want to extract audio.

Tip: Double-click a .cda file in the Explorer window (or drag it to the workspace) to extract a CD track without opening the Extract Audio 
from CD dialog. You can also extract audio from the Open dialog by choosing CD Audio (*.cda) from the Files of type drop-down list in 
the Open dialog.

Method Description
Read by track Use this option to select the tracks you want to extract from the CD. Each track is extracted into a unique data window.
Read entire disc Use this option to automatically extract all tracks on the disc. The entire CD is extracted into a single data window.
Read by range Use this option to extract audio from a specified range of time. Type appropriate values in the Start and End (or 

Length) boxes. The range of audio is extracted into a single data window.

Note: Click Play to preview your selection. During playback, the button changes to a Stop button.
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7. Click the MusicID button if you want to obtain CD information using Gracenote MusicID. 

If CD information is not available, you can click the CD Info button to display a dialog box where you can edit the CD information 
and submit it for inclusion in the Gracenote Media Database. For more information, see Obtaining or editing CD information on page 
45.

8. From the Speed drop-down list, choose the rate at which you want to extract audio. If you experience gapping or glitching, 
decrease the speed or click Configure and adjust the Audio extract optimization setting.

9. Click OK. The data extraction from the CD begins, and a progress meter is displayed.

Previewing CD tracks

In the Extract Audio from CD dialog, select a track and click the Play button to preview a track prior to extracting it from the CD. To end 
the preview, click Stop.

Refreshing the Extract Audio from CD dialog

Click the Refresh button after you insert a new CD in the system’s CD-ROM or DVD-ROM drive. This allows you to view the contents of 
the new CD without closing and reopening the Extract Audio from CD dialog.

Burning CDs

You can write audio to CD if your system is configured with a supported CD-R/RW drive and the necessary drivers. CDs are burned using 
the track-at-once method, meaning that additional tracks can be added to the CD over a period of time. Once all desired tracks are 
added, you must close the CD before it can be played in a consumer CD player. However, once you have closed a CD, you can no longer 
add tracks to it.

Correcting the sample rate for CD burning

Sample rates deviating from 44,100 Hz cause CD track lengths to be miscalculated. When attempting to write a file to CD that deviates 
from the 44,100 Hz sample rate, you are prompted to change the sample rate. Selecting Yes automatically resamples audio to 44,100 Hz.

In addition, you can use the Resample tool to change the sample rate of a file prior to burning the CD. For more information, see 
Resample on page 154.

Writing mono tracks to a CD

If you attempt to write mono audio tracks to a CD, you are prompted to create a stereo file by copying the mono data to both channels.

Adding tracks to a CD

You should always save your audio files prior to writing them to CD. 

1. From the Tools menu, choose Burn Track-at-Once Audio CD. The Burn Track-at-Once Audio CD dialog is displayed. The bottom of 
the dialog displays the length of the current audio file and the amount of time remaining on the CD currently in the CD-R/RW.

Note: To eject the CD at any time prior to beginning the extraction process, click the Eject button.

Note: If there is no CD in the current drive, only the Drive and Speed drop-down menus and the Close button are 
available in this dialog. If you insert a disc or select a different drive after this dialog is displayed, it takes a moment to 
recognize the disc and make all options available.
RECORDING, EXTRACTING, AND BURNING | 123



2. Choose a setting from the Action drop-down list:

3. Select your burning options:

4. From the Drive drop-down list, choose the CD-R/RW drive that you want to use to burn your CD.

5. From the Speed drop-down list, choose the speed at which you want to burn. Max will use your drive’s fastest possible speed; 
decrease the setting if you have difficulty burning.

6. Click the Start button.

After the audio is written to CD, the CD Operation dialog indicates whether the writing was successful. 

7. Click OK to clear the message.

Setting Description
Burn audio Begins recording audio to your CD when you click the Start button. You will need to close the disc before it 

can be played in an audio CD player.
Test, then burn audio Performs a test to determine whether your files can be written to the CD recorder without encountering 

buffer underruns. Recording begins after the test if it is successful.
Test only Performs a test to determine whether your files can be written to the CD without encountering buffer 

underruns. No audio is recorded to the CD.
Close disc Closes your disc without adding any audio when you click the Start button. Closing a disc allows your files 

to be played on an audio CD player.
Erase RW disc Erases your rewritable CD when you click the Start button. You should use this option if your rewritable CD 

already has data on it.

Option Description
Buffer underrun protection Select this check box if your CD recorder supports buffer underrun protection. Buffer underrun protection 

allows a CD recorder to stop and resume burning.
Erase RW disc before burning If you’re using a rewritable CD, select this check box to erase the CD before you begin burning if your 

rewritable CD already has data on it.
Close disc when done 
burning

Select this check box to close the CD after burning. Closing a disc allows your files to be played on an audio 
CD player.

Note: You can close the disc using a separate step later. For more information, see Closing a CD on page 125.

Eject disc when done Select this check box to eject the CD automatically when burning has completed.
Burn selection only Select this check box to burn only the audio within the loop region.

Important: Clicking Cancel after the CD writing process begins renders the CD unusable.
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Closing a CD

Closing the CD allows you to listen to it in an audio CD player. However, you cannot add tracks to a CD once it is closed. 

1. From the Tools menu, choose Burn Track-at-Once Audio CD. The Burn Track-at-Once Audio CD dialog is displayed.

2. From the Action drop-down list, choose Close Disc. 

3. If desired, select the Eject disc when done check box to eject the CD automatically when the disc has been closed.

4. Click the Start button. The Sound Forge application begins closing the CD and displays a progress meter in the dialog.

After the CD is closed, the CD Operation dialog indicates whether the closing was successful. 

5. Click OK to clear the message.

Proper use of software

Sound Forge software is not intended for, and should not be used for, illegal or infringing purposes, such as the illegal copying or 
sharing of copyrighted materials. Using Sound Forge software for such purposes is, among other things, against United States and 
international copyright laws and contrary to the terms and conditions of the End User License Agreement. Such activity may be 
punishable by law and may also subject you to the breach remedies set forth in the End User License Agreement.
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Chapter 9
 Editing, Repairing, and Synthesizing Audio

This chapter introduces some of the Sound Forge® advanced editing, repair, and synthesis features. 

Overwriting and replicating

Earlier in this manual, paste and mix were described as ways of adding clipboard contents to the current data window. As 
your audio editing projects become more elaborate, you may discover the need for three more sophisticated paste 
operations: overwrite and replicate.

Overwriting

Overwriting allows you to replace the current selection with the contents of the clipboard and has two basic guidelines:

Overwriting a selection

1. Open the Voiceover.pca file.

2. Create a selection containing “Wow.”

3. Copy the selection. The data is placed on the clipboard.

4. Create a selection of approximately the same length containing the final “...and easier.”

5. From the Edit menu, choose Paste Special, and choose Overwrite from the submenu or right-click the data window 
and choose Overwrite from the shortcut menu. The selection is overwritten with the clipboard contents.

If Then
The selection is longer than the clipboard contents Data is overwritten from the beginning of the selection for the 

length of the clipboard contents only.
The clipboard contents are equal to or longer than the 
selection

Data is overwritten for the length of the selection only.

Note: If any of the selection data remains, it is because the length of the clipboard contents was less than the length of 
the selection.

Copy the selection Create a second selection

Overwrite the selection
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Replicating

Replicating allows you to overwrite your current data window selection with several copies of the clipboard contents. When replicating, 
you must specify whether you want to use partial copies of the clipboard contents or only complete copies.

• Using partial copies of the clipboard content completely overwrites the selected data window area.
• Using complete copies of the clipboard content prevents a portion of the data window selection from being overwritten unless the 

selection length is an exact multiple of the length of the clipboard contents.

Replicating a selection

1. Open the Voiceover.pca file.

2. Create a selection containing “Wow.”

3. Copy the selection. The data is placed on the clipboard.

4. Create a selection containing “Sound editing just gets easier.”

5. From the Edit menu, choose Paste Special and choose Replicate from the submenu. The Replicate dialog is displayed.

6. Select the Copy partials radio button and click OK. The selection is overwritten with multiple copies of the clipboard contents. A 
partial copy of the clipboard contents is used where appropriate.

Note: The Replicate command will paste as many copies of the clipboard as will fit in the current selection. If no selection exists in the data 
window, the command is not available.
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Repeating an operation

Once you perform an operation on an audio file, you can quickly repeat it with the same parameters by choosing Repeat from the Edit 
menu. This allows you to reapply the same effect, process, or function to a different section of audio using the same parameters.

You can also repeat an operation by doing any of the following actions:

• Hold Shift while choosing the command from its menu.
• Press Ctrl+Y.
• Click the Repeat button  on the Standard toolbar.

Using drag-and-drop

You can take advantage of using drag-and-drop to perform many common tasks. Drag-and-drop operations make controlling the 
Sound Forge software faster and more intuitive and allow for increased editing power. The major drag-and-drop editing operations are 
paste and mix.

Dragging mono selections into multichannel destinations

When pasting or mixing a mono selection into a multichannel file, you can mix the selection to both channels by dropping it on the 
destination data window’s center line. Otherwise, the selection is mixed into the left or right channel exclusively.

Snapping to events in drag-and-drop operations

A major advantage of drag-and-drop editing is the ability to snap to markers, regions, time increments, or other events in the 
destination window. All drag-and-drop operations can be configured to snap (or align) to points in the destination file based on the 
events established within that file. 

The following table describes all events that drag-and-drop selections snap to in the destination file.

Pasting and mixing with drag-and-drop

You can drag an audio selection and paste or mix it into another data window.

Pasting

1. Open the Voiceover.pca and Drumhit.pca files.

2. Select all audio data in Drumhit.pca.

Note: In the Edit menu, the Repeat command displays in conjunction with the name of the previous function.

Events Description
Cursor Start of block snaps to cursor position.
Selection Start of block snaps to start or end points of a selection.
Start Start of block snaps to start of file.
End Start of block snaps to end of file.
Markers Start of block snaps to marker.
Regions Start and End Markers Start of block snaps to region start or end.
Time, Measures, etc. Start of block snaps to labeled divisions on time ruler.
Video Frames Start of block snaps to the start of video frames appearing in the video strip.
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3. Hold the Alt key and drag the selection to the Voiceover data window. 

• A vertical dotted line representing the leading edge of the source selection appears in the destination window.
• The letter “P” appears in the box adjacent to the pointer.

4. Use the mouse to position the dotted line in the destination window where the source data will be pasted.

5. Release the mouse button. The selection is pasted into the destination window.

Mixing

1. Open the Voiceover.pca and Drumhit.pca audio files.

2. Select all audio data in the Drumhit data window.

3. Drag the selection to the Voiceover data window.

• A shaded region representing the source selection appears in the destination window.
• An “M” appears in the box adjacent to the pointer.

Tip: When dragging a selection to paste sound data, drag up or down before moving the mouse left or right. Dragging left or right before 
moving the mouse vertically adjusts the selection length.

Tip: When dragging a selection to paste sound data, drag up or down before moving the mouse left or right. Dragging left or right before 
moving the mouse vertically adjusts the selection length.

Create a selection in the 
source window

Hold the Alt key and drag the 
selection into the destination 
window

Drag the selection to the 
destination window

Drag-and-drop 
paste indicator

Selection is pasted into 
the destination window
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4. Position the leading edge of the shaded region in the Voiceover data window where the mixing of the selection will begin.

5. Release the mouse button. The Mix dialog is displayed. 

6. Verify that both Volume levels are set to 0 dB and click OK.

Toggling the Mix/Paste functions

An alternate way of specifying a mix or paste is the mouse toggle method.

1. Open the Voiceover.pca and Drumhit.pca files.

2. Select all audio data in the Drumhit data window.

3. Drag the selection to the Voiceover data window. A shaded region representing the source selection appears in the destination 
window and a letter appears in the box adjacent to the pointer.

4. Continue holding the left mouse button while clicking the right mouse button. The letter in the box and the appearance of the 
selection region change to indicate the current drag-and-drop mode. 

5. Release the left mouse button. The source audio data is pasted or mixed into the destination data.

Creating new windows with drag-and-drop

Drag-and-drop also allows you to create a new data window from a selection. 

1. Open the Voiceover.pca file.

2. Create a selection containing “Wow.”

3. Drag the selection to an empty area of the Sound Forge workspace and drop it. A new data window is created containing the 
selection data with the attributes of the original file.

Tip: When dragging a selection to paste sound data, drag up or down before moving the mouse left or right. Dragging left or right before 
moving the mouse vertically adjusts the selection length.

Tip: When dragging a selection to paste sound data, drag up or down before moving the mouse left or right. Dragging left or right before 
moving the mouse vertically adjusts the selection length.

Drag-and-drop mix 
indicator

Selection is mixed into the 
destination window
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Finding and repairing audio glitches

Glitches are commonly the result of analog audio editing, analog to digital transfer, or electronic noise. Sound Forge software provides 
you with a tool for locating audio glitches and three distinct tools for repairing them: channel, interpolate, and replace. In addition, you 
can repair audio glitches manually using the Pencil tool.

Locating glitches

The Find tool allows you to quickly locate glitches, specific volume levels, or silence in a file. The Find tool’s glitch algorithm locates 
glitches by examining the file for instances where the waveform matches the specified threshold slope and sensitivity criteria. The 
cursor then moves to the location of the glitch to allow you to repair it. This tool only locates one glitch at a time. Therefore, it may be 
necessary to execute this command several times on a file to locate all glitches.

1. Open any audio file containing glitches.

2. From the Tools menu, choose Find. The Find dialog is displayed.

3. From the Find drop-down list, choose Glitch.

4. Adjust the Threshold slope fader to configure the minimum slope that constitutes a glitch.

• A high value detects only glitches with steep slopes.
• A lower value detects glitches with both steep and more gradual slopes.

5. Adjust the Sensitivity fader to determine the sensitivity of the detection algorithm.

• A high value results in any part of the waveform with a slope greater than the Threshold slope being detected as a glitch.
• A lower value forces the algorithm to verify that the slope is indeed a glitch, and not simply a portion of the smooth waveform.

6. Click OK. The first glitch in the file is found and its location is marked with the cursor.

Locating additional glitches using the same settings

Once you have configured the settings in the Find dialog, you can find the next glitch in the file without viewing the Find dialog. To find 
the next glitch using the current settings, hold Shift while choosing Find from the Tools menu or hold Shift while clicking the Find 

button  on the Tools toolbar.

Using the Shift key in this way is not limited to finding glitches. You can hold Shift and choose any command from a menu to repeat the 
command with the same settings. For more information, see Repeating an operation on page 129.

Repairing audio

There are several ways to repair audio glitches.

Copying the other channel

For glitches in a single channel of a multichannel file, you can replace the glitched section of damaged channel with the corresponding 
data from a “good” channel.

1. Open the file containing the glitch.

2. Create a selection in the channel containing the glitch, three or four times longer (maximum 50 ms) than the glitch itself.

Tip: If you can hear glitches that the Find tool does not locate, decrease the Threshold slope and increase the Sensitivity. 

Note: This method only works if the channels contain similar audio.
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3. From the Tools menu, choose Repair, and choose Copy Other Channel from the submenu. The selected data is replaced with the 
corresponding data from the “good” channel. In addition, rapid crossfades are created at the beginning and end of the replacement 
selection to prevent a new glitch from being created.

Interpolating new audio

This is the most basic method of repairing glitches. New audio data is simply interpolated based on the data at the beginning and end of 
the selection. This method results in a straight line connecting the beginning and end of the selection. Interpolation should only be 
used to repair small (less than 2 ms) glitches.

1. Open the file containing the glitch.

2. Right-click the data window and choose Zoom from the shortcut menu, and choose In Full from the submenu. The file displays at a 
24:1 zoom ratio.

3. Create a selection containing the glitch.

4. From the Tools menu, choose Repair, and choose Interpolate from the submenu. The glitch data is replaced with interpolated 
data.

Replacing audio with preceding data

The Replace tool allows you to repair audio files by replacing the damaged data with the data immediately preceding it. This repair 
method is useful for repairing longer glitches such as needle drops and scratches.

1. Open the file containing the glitch.

2. Create a 5 to 50 ms selection containing the damaged audio.

Tip: If this method fails to repair the glitch, undo it and apply Copy Other Channel again, this time using a longer selection.

Tip: To improve the accuracy of this feature, the selection should be as small as possible while still containing the glitch.

Note: The maximum allowed replace time is 0.5 seconds.

Data is interpolated within the 
selection
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3. From the Tools menu, choose Repair, and choose Replace from the submenu. The selection is replaced with the selection of 
identical length immediately preceding the damaged data. In addition, rapid crossfades are created at the beginning and end of 
the replacement selection to prevent a new glitch from being created.

Repairing audio glitches manually with the Pencil tool

The Pencil tool is for users who prefer to repair their audio glitches manually. This tool allows you to repair waveform glitches by 
redrawing the damaged waveform section. However, the Pencil tool can only be used when a file’s waveform displays at a zoom ratio of 
1:32 or lower.

1. Open the file containing the glitch.

2. Zoom in tightly on the glitch.

3. Select the Pencil tool using any of the following methods:

• From the Edit menu, choose Tool, and choose Pencil from the submenu.
• Click the Pencil Tool button  in the Standard toolbar.
• Click the Edit Tool Selector in the top-left corner of the data window until the Pencil tool is displayed.

4. Drag to draw a new waveform section. The new section is integrated into the original waveform, replacing the section containing 
the glitch.

Repairing audio using Audio Restoration plug-in

Sound Forge software includes an ExpressFX™ plug-in called Audio Restoration that you can use to remove surface noise from old 
recordings. For more information on this plug-in, please see the Sound Forge online help file (accessible from the Help menu by 
choosing Contents and Index).

Selection data

Replacement data
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Synthesizing audio

You can generate custom tones and waveforms for use in your audio projects. 

Generating DTMF/MF tones

You can generate standard dial tones used by telephone companies. 

1. From the Tools menu, choose Synthesis, and choose DTMF/MF Tones from the submenu. The DTMF/MF Tones dialog is displayed.

2. Enter the phone number to be generated in the Dial string edit box, including pause characters. 

3. Use the Amplitude fader to set the peak level of the waveform.

4. Select the Tone style to generate radio button corresponding to the tone to be generated.

• DTMF (Dual Tone Multi-Frequency) signals are used by standard push-button telephones and are generated using 
combinations of 679, 770, 852, 941, 1209, 1336, 1477, and 1633 Hz sine waves.

• MF signals are used internally by the telephone networks and are generated with a combination of 700, 900, 1100, 1300, 1500, 
and 1700 Hz sine waves.

5. Specify the output length (in seconds) of each tone in the Single tone length box.

6. Specify the length (in seconds) of silence between tones in the Break length box.

7. Specify the pause length (in seconds) to be inserted for a pause character in the Pause length box.

8. Select the Fade the edges of each tone check box to help prevent glitching.

9. Specify the pause character in the Pause character box.

10. Use the Insert new tone sequence at drop-down list to specify where the generated tone is placed in the audio file.

11. Click OK.

Generating audio with frequency modulation

The Sound Forge FM Synthesis feature can be used to create complex sounds from simple waveforms using frequency modulation (FM). 

In frequency modulation, the frequency of a waveform (carrier) is modulated by the output of another waveform (modulator) to create 
a new waveform. If the frequency of the modulator is low, the carrier is detuned slowly over time. If the frequency of the modulator is 
high, the carrier is modulated so quickly that numerous additional frequencies (or sidebands) will be created.

Using the FM Synthesis tool, up to four waveforms (operators) can be used in a variety of configurations. Depending on the 
configuration, a waveform can be a carrier, a modulator, or a simple, unmodulated waveform.

Note: Unknown characters are ignored.
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Generating a waveform

1. From the Tools menu, choose Synthesis, and choose FM from the submenu. The FM Synthesis dialog is displayed.

2. Specify the length (in seconds) of the generated waveform in the Total output waveform length box.

3. Use the Configuration slider to configure the arrangement and number of operators used to generate the waveform. For more 
information, see Specifying the number and arrangement of operators on page 136.

4. Modify individual operators as needed. For more information, see Modifying an operator on page 136.

5. From the Insert waveform at drop-down list, choose a position to determine where the generated waveform is placed in the file.

6. Click OK.

Specifying the number and arrangement of operators

Dragging the Configuration slider changes the graphical representation of the arrangement and number of operators used to generate 
the waveform. When configuring your waveform, keep the following guidelines in mind:

• The outputs of horizontally joined operators are simply mixed. The outputs of the bottom operators are mixed to form the final 
output. Mixing unique simple waveforms is referred to as additive synthesis.

• Operators joined vertically are FM carrier-modulator pairs. The bottom operator is the carrier and the top operator is the modulator.
• Operators without other operators directly above are simple waveform generators.
• When three or more operators are stacked, the top operator modulates the operator below it, which modulates the following 

operator, and so on.

Modifying an operator

1. Select the Current radio button corresponding to the operator to be modified.

2. Use the envelope graph to modify the amplitude of the operator over time. For more information, see Envelope graphs on page 38.

3. From the Operator shape drop-down list, choose a waveform shape.

4. Specify the frequency of the operator in the Frequency box.

5. Use the Feedback slider to determine the amount of the operator's output that is used to modulate itself. If the operator is also 
being modulated by another waveform, the feedback path and the modulator output are mixed together to modulate the carrier.

Notes: 

• If Frequency is set to 0.00, a DC (zero-frequency) waveform is produced regardless of the waveform specified.
• When you choose Filtered Noise from the Operator shape drop-down list, Frequency determines the high-frequency content of the 

noise.
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6. Use the Amplitude fader to determine the output gain that is applied to the current operator after the amplitude envelope.

Generating simple waveforms

The Simple Synthesis tool is used to generate simple waveforms of a given shape, pitch, and length.

1. From the Tools menu, choose Synthesis, and choose Simple from the submenu. The Simple Synthesis dialog is displayed.

2. From the Waveform shape drop-down list, choose a shape to specify the shape of a single period of the current operator’s 
waveform.

3. In the Length box, specify the length (in seconds) of the generated waveform.

4. In the Start Frequency box, specify the frequency of the waveform.

5. If you want to sweep a range of frequencies, select the End Frequency check box and specify an ending frequency in the box. 

Select the Log Sweep check box if you want to sweep the range logarithmically; when the check box is cleared, the sweep is linear.

6. Use the Amplitude fader to set the peak level of the waveform.

7. From the Insert new waveform at drop-down list, choose a position to determine where the waveform is placed in the data 
window.

8. Click OK.

Note: If the operator is a modulator, this control (along with the envelope) determines the amount of frequency modulation applied to 
the carrier. If the amplitude of a modulator is high, harsh audio may result.

Note: When you choose Noise in the Waveform shape drop-down list, the amplitude is affected by the specified cutoff frequency.
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Chapter 10
 Processing Audio

This chapter provides descriptions of processing presets and previews as well as an overview of all functions in the Sound 
Forge® Process menu.

Applying presets

Many Sound Forge dialogs contain drop-down lists of presets used to quickly apply processes and effects. Presets are 
especially useful when you are learning the application, as they allow you to hear the results of processing as well as view 
the control settings used to produce these results.

Using presets

1. Open the Voiceover.pca file. 

2. From the Process menu, choose Fade, and choose Graphic from the submenu. The Graphic Fade dialog is displayed.

3. From the Preset drop-down list, choose the -20 dB exponential fade out preset. Notice that the dialog’s controls 
change to reflect the -20 dB exponential fade out.

4. Click the Preview button. The following actions occur:

• The Preview button changes to a Stop button.
• The effect previews on a brief selection of audio.

For more information, see Previewing processed audio on page 141.

5. From the Preset drop-down list, choose the -3 dB exponential fade out preset. Notice that the dialog’s controls 
update to reflect the new preset and the effect automatically previews.

6. Select the Bypass check box. The original audio previews with no effects. For more information, see Bypassing a 
process while previewing on page 141.

7. Clear the Bypass check box and click OK. The -3 dB exponential fade out preset is applied to the audio file.

Note: All information regarding presets in this chapter is applicable to DirectX® Plug-Ins (effects) from Sony Media 
Software.

Note: An effect or process is not applied to the audio data until you click OK.
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Creating presets

You can also create custom effects and save them as presets. 

1. Open the Voiceover.pca file.

2. From the Process menu, choose Fade, and choose Graphic from the submenu. The Graphic Fade dialog is displayed.

3. From the Preset drop-down list, choose the -3 dB exponential fade out preset. The dialog’s controls change to reflect the preset.

4. Drag any of the graphic fade points to a new position.

5. Click the Save Preset button . The Save Preset dialog is displayed.

6. Enter a name for the preset and click OK. The new preset is saved and added to the dialog’s drop-down list. 

Deleting presets

To delete a preset, choose it from the Preset drop-down list and click the Delete Preset button .

Resetting parameters

To reset all dialog controls to their default settings, right-click the dialog and choose Reset All from the shortcut menu.

Managing presets

Once you have created custom presets, you can use the Sound Forge Preset Manager to back up, transfer, or delete custom presets from 
any of the installed effects, processes, tools and plug-ins. You can also use the Preset Manager to manage your ACID® and Vegas® 
presets. For more information, see Using the Preset Manager on page 167.

Note: Built-in presets cannot be deleted.

Edit the graphic fade 
and click the Save 
Preset button.
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Previewing processed audio

You can preview the effect that a process has on a file by using the Preview button found in most audio processing dialogs. You can use 
previews to fine-tune effect parameters without leaving the dialog. More importantly, using previews reduces wasted processing time.

Setting custom preview parameters

You can customize the preview parameters to satisfy your editing preferences. You can save custom previewing settings for the current 
process alone or for all processes.

1. From the Options menu, choose Preferences. The Preferences dialog is displayed.

2. Click the Previews tab.

3. Edit the preview parameters as desired. For more information, see Previews tab on page 246.

4. Click OK. The new preview parameters are updated and saved for all effects.

Bypassing a process while previewing

You are also able to A/B test an effect by using the Bypass check box to switch between previewing the processed and unprocessed 
audio file. 

• If you select the Bypass check box, the unprocessed audio file is played when you click the Preview button.
• If you clear the Bypass check box, the processed audio file is played when you click the Preview button.

Adjusting the data window selection

You can easily adjust your data window selection from within most processing dialogs by clicking the More button on the right side of 

the dialog and specifying the selection parameters explained below.

Control Description
Start Determines the starting point for your selection in the data window. The Length field adjusts automatically according to your 

input in this box.
End Determines the ending point for your selection in the data window. The Length field adjusts automatically according to your 

input in this box.
Length

Determines the length of your selection in the data window. Click the Lock Length button  to lock or unlock the current 

selection length. When the selection length is locked, Sound Forge will adjust the values in the Start or End boxes to retain the 
specified selection length.

Channels Determines the channel(s) included in the data window selection. Type a number in the box to change the channel selection 
while retaining the start, end, and length selections.

The Preview button 
and the Bypass check 
box
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Sound Forge processes

The remainder of this chapter describes the functions located in the Process menu.

Auto Trim/Crop

Auto Trim/Crop removes silence from an audio file. In addition, this function automatically fades the endpoints of a phrase. 

Using Auto Trim/Crop

1. Open the Voiceover.pca file.

2. From the Process menu, choose Auto Trim/Crop. The Auto Trim/Crop dialog is displayed.

3. From the Preset drop-down list, choose Phrase Concatenator 1 and click OK. The Auto Trim/Crop function deletes silence in the 
file and creates new regions based on the preset’s parameters. For more information, see Auto Trim/Crop controls on page 143.

Clicking the More button displays 
additional information you can use to 
adjust your data window selection. To hide 
this information, click the Less button.
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Auto Trim/Crop controls

The following controls are located in the Auto Trim/Crop dialog.

Bit-Depth Converter

The Bit-Depth Converter is used to increase/decrease the bit depth of a file while concealing the resulting quantization noise.

• Decreasing a file’s bit depth decreases the overall size of the file, but results in added quantization noise, which can be masked using 
dither and noise shaping.

• Increasing a file’s bit depth—while not improving the quality of the audio—allows subsequent audio processing to be performed 
with greater accuracy and resolution.

Prior to decreasing a file’s bit depth, you should optimize the audio for conversion. For more information, see Minimizing quantization 
error on page 85.

Converting a file’s bit depth

1. Open the Musicbed.pca file.

2. From the Process menu, choose Bit-Depth Converter.

3. From the Bit depth drop-down list, choose the desired bit depth.

Control Description
Function This drop-down list contains five modes:

• Keep edges outside of the selection - Removes silence within the selection, but retains all data outside of the 
selection.

• Remove edges outside of the selection - Removes silence within the selection and deletes all data beyond the 
selection. 

• Remove silence between phrases (creates regions) - Removes silence within the selection and creates regions from 
individual phrases. For more information, see Minimum inter-phrase silence on page 143.

• Remove data beyond loop points - Removes all data beyond the selected loop. For more information, see 
Minimum length following loop end on page 143.

• Remove data from start and limit file length - Allows you to specify an amount of sound to be deleted from the 
beginning of each file and specify a maximum length for converted files. If a file is longer than this length, it is trimmed. This 
preset is useful for creating sample clips.

Attack threshold Determines the threshold level for detection of the trim/crop start point: -Inf. indicates complete silence, and 0 dB indicates 
maximum amplitude level.

Release threshold Determines the threshold level for detection of the trim/crop end point: -Inf. indicates complete silence, and 0 dB indicates 
maximum amplitude level.

Fade in Determines the length (in milliseconds) of the fade applied to a section of audio prior to the detected trim/crop start point. 
Fade out Determines the length (in milliseconds) of the fade applied to a section of audio following the detected trim/crop end point.
Minimum inter-phrase silence When you choose the Remove silence between phrases mode, the Minimum inter-phase silence value determines 

the minimum amount of silence needed between phrases for a new region to be created.
Minimum length following 
loop end

When you choose the Remove data beyond loop points mode, the Minimum length following loop end value 
determines the number of samples that must follow a loop.

More Click this button to view additional options that you can use to adjust your data window selection. For more information, 
see Adjusting the data window selection on page 141.

Note: There are no rules regarding maintaining audio quality when decreasing bit- depth. For this reason, you should always 
experiment with the Dither and Noise shaping controls to determine the optimum settings for each file.
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4. If necessary, use the Dither drop-down list to specify the type of dither used to mask the quantization noise results from lowering a 
file’s bit depth. For more information, see Dither on page 144.

5. If desired, use the Noise shaping drop-down list to specify any noise shaping to be applied to the file. For more information, see 
Noise shaping on page 144.

Bit-Depth Converter controls

The following controls are located in the Bit-Depth Converter dialog.

Noise shaping dangers

Noise shaping places quantization noise near the audio’s Nyquist frequency, a value equal to one-half of the file’s sample rate. Consider 
the following information:

• A file with a sample rate of 44.1 kHz has a Nyquist frequency of 22.05 kHz (at the high end of human hearing). Applying noise shaping 
to this file results in audio perceived to be cleaner than it actually is.

• A file with a sample rate of 22 kHz has a Nyquist frequency of 11 kHz (well within the sensitive range of human hearing). Applying 
noise shaping to this file results in audio that is perceived to be noisier than it actually is. Ironically, this defeats the entire purpose of 
the Noise shape control.

For this reason, we do not recommend using noise shaping on files with sample rates less than 44.1 kHz.

Note: When increasing a file’s bit depth, set the Dither and Noise shaping controls to None and Off respectively.

Control Description
Bit depth Choose a setting to specify the number of bits that should be used to store each sample.
Dither This control allows you to specify the randomness of the dither (generated noise) used to mask quantization distortion resulting 

from conversion to a lower bit depth. You can select from several shapes, each roughly describing the pattern that would be 
produced if you plotted a graph with the dither amplitude on the X-axis and the probability of the dither values on the Y-axis. 

As is frequently the case when working with audio, experimentation with dither values yields the best results; however, keep the 
following information in mind:

Half Rectangular - Eliminates distortion resulting from conversion to a lower bit depth, but the noise level is more likely to be 

dependent on the signal. This setting uses a maximum dither noise amplitude of 0.5 LSB (least significant bit).

Rectangular - Identical to Half Rectangular, but with a maximum dither noise amplitude of 1 LSB (least significant bit).

Triangular - Eliminates distortion products as well as any noise floor modulation, but results in a slightly higher noise level. The 

option typically works well in conjunction with noise shaping.

Highpass Triangular - Behaves like triangular dither, but shifts its noise into higher frequencies. This is typically the best 

option when used in conjunction with noise shaping.

Gaussian - Does not perform as well as Rectangular and Triangular dither, but may be suitable for certain audio.
Noise shaping Determines the aural positioning of quantization noise. Using this control, you can shift the noise into audio registers that are 

less perceptible to human hearing. This lowers the perceived noise floor and creates the illusion of cleaner audio.

High-pass contour noise shaping attempts to push all quantization noise and error into high frequencies.

Equal loudness contour noise shaping attempts to push the noise under an equal loudness-type of curve.
More Click this button to view additional options that you can use to adjust your data window selection. These options are explained 

below.
Start Determines the starting point for your selection in the data window. The Length field adjusts automatically according to your 

input in this box.
End Determines the ending point for your selection in the data window. The Length field adjusts automatically according to your 

input in this box.
Length

Determines the length of your selection in the data window. Click the Lock Length button  to lock or unlock the current 

selection length. When the selection length is locked, Sound Forge will adjust the values in the Start or End boxes to retain the 
specified selection length.

Channels Determines the channel(s) included in the data window selection. Type a number in the box to change the channel selection 
while retaining the start, end, and length selections.
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Channel Converter

The Channel Converter is used to convert audio files between mono and multichannel formats. The Channel Converter dialog can also 
be used to reverse the channels of a stereo file or intermix the channels of a multichannel file to create interesting panning effects.

Converting a mono file to stereo (or multichannel)

1. Open the Voiceover.pca file. Notice that this is a mono file.

2. From the Process menu, choose Channel Converter. The Channel Converter dialog is displayed.

3. Choose a setting from the Preset drop-down list, or adjust the controls as needed:

a. Choose a setting from the Output channels drop-down list to indicate the number of channels in the converted file.

b. Click in the Output box for each output channel and type a gain value (or drag the fader) to adjust the amount of the original 
mono file that will be mixed to the new channel.

c. Select the Invert Mix check box if you want to reverse the phase of the new channel’s content.

4. Click the OK button.

Notes:

• To perform quick channel conversion without specifying the mix, use the Format tab on the Properties dialog (accessible from the File 
menu by choosing Properties).

• If you want to apply a panning envelope to a mono file, use the Channel Converter to convert the file to stereo first. 
• You can use mono files in the Pan/Expand dialog (accessible from the Process menu by choosing Pan/Expand) if you choose Pan 

(preserve stereo separation) or Pan (mix channels before panning) from the Process mode drop-down list. When you click OK to 
apply your changes, the file will be converted to stereo and your panning settings will be applied.

The file is converted to stereo.
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Converting a stereo file to mono

1. Open the saxriff.wav file. Notice that this is a stereo file.

2. From the Process menu, choose Channel Converter.

3. Choose a setting from the Preset drop-down list, or adjust the controls as needed:

a. Choose 1 from the Output channels drop-down list to create a mono file.

b. Click in the Source 1 box and type a gain value (or drag the fader) to adjust the amount of the original left channel that will be 
mixed to the new mono file.

c. Click in the Source 2 box and type a gain value (or drag the fader) to adjust the amount of the original right channel that will be 
mixed to the new mono file.

d. Select the Invert Mix check box if you want to reverse the phase of the new left-channel mix.

4. Click the OK button.

Intermixing channels in a file

1. From the Process menu, choose Channel Converter.

2. Adjust the controls as needed:

a. Choose a setting from the Output channels drop-down list to indicate the number of channels in the converted file.

b. Click in the Source box for each output channel and type a gain value (or drag the fader) to adjust the amount of the original 
channel that will be mixed to the new channel.

c. Select the Invert Mix check box if you want to reverse the phase of the new channel’s content.

3. Click the OK button.

Swapping stereo channels

1. From the Process menu, choose Channel Converter.

2. From the Preset drop-down list, choose the Stereo to Stereo - Swap Channels preset.

3. Click the OK button.

Channel Converter controls

The following controls are located in the Channel Converter dialog.

Control Description
Output channels This drop-down determines the number of channels in the output file.
Source Determines the amount of the original channel data that will be mixed to the new file. 
Invert Mix Select this check box to reverse the polarity of the new channel.
More Click this button to view additional options that you can use to adjust your data window selection. These options are explained 

below.
Start Determines the starting point for your selection in the data window. The Length field adjusts automatically according to your 

input in this box.
End Determines the ending point for your selection in the data window. The Length field adjusts automatically according to your 

input in this box.
Length

Determines the length of your selection in the data window. Click the Lock Length button  to lock or unlock the current 

selection length. When the selection length is locked, Sound Forge will adjust the values in the Start or End boxes to retain the 
specified selection length.

Channels Determines the channel(s) included in the data window selection. Type a number in the box to change the channel selection 
while retaining the start, end, and length selections.
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DC Offset

Audio that is not centered around the zero baseline in the waveform display is said to have a DC offset. DC offsets are typically caused 
by electrical conflicts between the sound card and input device. The DC Offset function (located on the Process menu) is used to 
change the baseline of an audio file by adding a constant value to each sample to compensate for offsets.

Estimating DC Offset

You can estimate the DC offset of an audio file by choosing Statistics from the Tools menu.

DC Offset controls

Choose DC Offset from the Process menu to display the DC Offset dialog. The following controls are located in the DC Offset dialog.

EQ

Three EQ options are available in the Process menu: Graphic, Paragraphic, and Parametric. Each of these options launch the 

appropriate XFX effect. For more information on using the XFX EQ effects, click the  button in the effect dialog. 

Fade - Graphic fade

Graphic fade allows you to create custom fade envelopes to apply to audio data. You can use up to sixteen envelope points to create 
complex graphic fades. 

Control Description
Automatically detect and 
remove

Calculates and corrects the DC offset for each channel individually.

Adjust DC offset by Allows you to specify a DC offset value manually. 

• -2,147,483,648 to 2,147,483,647 for 32-bit data
• -8,388,608 to 8,388,607 for 24-bit data
• -32,768 to 32,767 for 16-bit data 
• -128 to 127 for 8-bit data

Compute DC offset from first 
5 seconds only

Selecting this check box specifies that only the first five seconds of a file are analyzed when measuring the DC offset. Be aware 
that five seconds is not sufficient if the beginning of a file has a long fade-in or mute.

Average DC offset value
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Creating a graphic fade

1. Open the Musicbed.pca file.

2. Select the last half of the audio (approximately 5 seconds).

3. From the Process menu, choose Fade, and choose Graphic from the submenu. The Graphic Fade dialog is displayed.

4. From the Show wave drop-down list, choose Mono source. The Musicbed.pca waveform displays in the graph. For more 
information on the dialog controls, see Graphic Fade controls on page 149.

5. From the Preset drop-down list, choose -6 dB exponential fade out. The fade’s envelope displays in relation to the waveform in 
the graph.

6. Click OK. The specified fade is applied to the selection.

Creating a custom graphic fade

1. Open the Musicbed.pca file.

2. Select the first half of the audio (approximately 5 seconds).

3. From the Process menu, choose Fade, and choose Graphic from the submenu. The Graphic Fade dialog is displayed.

4. From the Show wave drop-down list, choose Mono source. The Musicbed.pca waveform displays in the graph. For more 
information on the dialog controls, see Graphic Fade controls on page 149.

5. Edit the fade envelope using the following controls:

• Click the envelope to create a new point.
• Drag a point to move it to a new position.
• Double-click or right-click a point to delete it.
• Right-click an envelope segment and choose a new fade type from the shortcut menu.

For more information, see Envelope graphs on page 38.

6. Click OK. The custom graphic fade is applied to the selected audio.

Full volume at start of selection

Zero volume at end of selection

Musicbed.pca with a -6dB 
exponential fade out
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Graphic Fade controls

The following controls are located in the Graphic Fade dialog.

Fade - Fade In

The Fade In command is used to linearly fade a selection from a volume of -Inf. to a volume of 0 dB. The size of the selection determines 
the length of the fade. 

1. Open the Musicbed.pca file.

2. From the Process menu, choose Fade, and choose In from the submenu. The fade is applied, and volume increases over the length 
of the entire file.

Fade - Fade Out

The Fade Out command is used to linearly fade a selection from a volume of 0 dB to a volume of -Inf. The size of the selection 
determines the length of the fade. 

1. Open the Musicbed.pca file and select all audio data.

2. From the Process menu, choose Fade, and choose Out from the submenu. The fade is applied, and the volume decreases over the 
length of the entire file.

Insert Silence

The Insert Silence command allows you to place sections of silence in audio files.

Inserting silence into a file

1. Open the Musicbed.pca file.

2. From the Process menu, choose Insert Silence. The Insert Silence dialog is displayed.

Control Description
Maximum Gain Select a radio button to adjust the range of the envelope graph.
Show wave The Show wave drop-down list provides several settings for drawing the current selection’s waveform on the envelope 

graph. This function is available only for small selections.
Reset Envelope Clicking the Reset Envelope button clears the envelope of all points except the original two.

Audio file fades in from -Inf. 
to 0 dB

Audio file fades out from 0 dB 
to -Inf.
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3. Perform one of the following actions:

• From the Preset drop-down list, choose a preset that has been stored for the plug-in.
• Specify the length of silence that you want to add in the Insert box and choose a setting from the at drop-down list to specify 

where the silence should be inserted.

4. Click the OK button.

Invert/Flip

The Invert/Flip command inverts the audio selection at its baseline, in effect reversing its polarity. Inverting a file, while creating no 
audible difference, is occasionally useful for matching sample transitions when executing certain pastes, mixes, or loops.

1. Create a selection in the data window.

2. From the Process menu, choose Invert/Flip. The selection is inverted.

Mute

The Mute command forces the selection to a volume of -Inf. dB (silence).

Muting an audio selection

1. Create a selection in the data window.

2. From the Process menu, choose Mute. The selection is muted.

Setting Description
Cursor Inserts silence at the current cursor position.
Start of file Inserts silence at the beginning of the file.
End of file Inserts silence at the end of the file.

Create a selection in the data window
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Normalize

The Normalize command maximizes the overall volume of a file without introducing clipping. When you normalize a file, the entire file 
is scanned and a constant gain is applied to raise the file’s level to a specified value.

Normalizing audio

1. Open the Musicbed.pca file.

2. From the Process menu, choose Normalize. The Normalize dialog is displayed.

3. From the Preset drop-down list, choose Normalize RMS to -16 dB (music) and click OK. The file is normalized and its overall 
“loudness” is increased.

Selected audio is muted

Normalized file
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Normalize controls

The following controls are located in the Normalize dialog.

Control Description
Normalize using Peak level This radio button normalizes the audio file using the maximum (instantaneous) sample values detected. A constant gain is then 

applied to the audio.
Normalize using Average RMS 
level (loudness)

This radio button normalizes the audio file using the detected average RMS value of the audio file. This is helpful for matching 
the apparent loudness of a number of individual recordings.

Normalize to This fader specifies the level to which the highest peak should be set.

With Peak level, if the peak level is -10 dB and the Normalize to value is -3 dB, a constant boost of 7 dB is applied to the 
entire file.

With Average RMS level, normalizing to 0 dB means boosting the signal until it has the same apparent loudness as a 0 dB 
square wave. This results in all the dynamic range of the signal being flattened and all peaks being either clipped or seriously 
compressed.

Note: As a rule, normalizing using Peak levels to 0 dB is acceptable, but normalizing using Average RMS level to anything 
above -6 dB is not recommended.

Ignore below Determines the level of audio data included in the RMS calculation. Data below the threshold is ignored, effectively eliminating 
silent sections from RMS calculation. The Ignore below fader should be set a few dB above perceived silence. If Ignore 
below is set to -Inf., all audio data is used. However, if the value is set too high (above -10 dB) the RMS value may never rise 
above the threshold. In this case, normalization cannot occur. For this reason, you should evaluate the threshold by clicking the 
Scan Levels button.

Attack time Determines how quickly the scan responds to transient peaks.
Release time Determines how quickly the scan should stop using transient peak material after it begins to drop in level. Slower release times 

result in more data being included in RMS calculation.
Use equal loudness contour Allows the scan to compensate for the Fletcher-Munson Equal Loudness Contours. The Fletcher-Munson Equal Loudness 

Contours illustrate that very low- and high-frequency audio is less perceptible to the human ear than mid-range audio. 
Therefore, selecting this option forces the scan to factor this into RMS calculation.

Scan Levels Clicking Scan Levels initiates Peak and RMS scans on the audio and displays the RMS level and the highest peak level 

detected. When previewing a normalize effect, the entire file must be scanned to preview even a small selection. Clicking Scan 
Levels saves the current Peak and RMS values and allows you to preview different Normalize to settings without re-scanning 
the entire file.

An asterisk adjacent to a level value indicates that the value is not current. This occurs when the selection is updated or the 
dialog is initially opened. To update values, click Scan Levels.

If values have never been calculated, two dashes display. Click Scan Levels to calculate values.

Note: If the RMS level never reaches the Ignore below threshold, a value of -96 dB displays. If this occurs, decrease the Ignore 
below threshold level and rescan.

If clipping occurs The If clipping occurs drop-down list is used to specify how the normalize function handles clipping that may occur when an 
audio file is processed using the RMS option. This list provides four options:

• Apply dynamic compression - Audio peaks that will result in clipping are limited below 0 dB using non-zero attack and 
release times to minimize distortion. This mode is useful for getting loud and clear audio during mastering.

• Normalize peak value to 0 dB - The selection’s peak amplitude level is normalized to 0 dB, thereby allowing the maximum 
possible constant gain without clipping the selection. However, less gain is applied than would be necessary to achieve the 
Normalize to RMS level.

• Ignore (saturate) - Audio is permitted to clip and distort. 
• Stop processing - Audio peaks that will result in clipping force the normalize function to cease processing and alert you that 

clipping will occur at the current level.

Note: When normalizing multichannel audio, normalization is computed on the loudest sample value found in a channel and 
identical gain is applied to all channels. If a single channel is selected in a multichannel file, normalization processes only that 
channel.

Use current scan level (do not 
scan selection)

When you select the Use current scan level check box, the current scan levels are used without initiating a new scan. This is 
useful when applying scan levels from a different selection or file to the current selection, thereby allowing identical gains to be 
applied to multiple files. This option can also be used to scan a selection of an audio file containing the loudest or most constant 
levels and then apply that scan to normalize the entire file.

Current Peak and RMS levels

Noncurrent Peak and RMS levels

Nonexistent Peak and RMS levels
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Pan/Expand

Pan/Expand allows you to create panning effects and stereo compression/expansion in selections.

Creating a pan

A pan is used to control the apparent position of a sound between the left and right channels of a stereo file. 

1. Open the Musicbed.pca file.

2. From the Process menu, choose Pan/Expand. The Pan/Expand dialog is displayed.

3. From the Preset drop-down list, choose Left to right (linear). The pan envelope displays on the graph.

4. Click OK. The file is converted to stereo and a left-to-right pan is added.

5. Play the file. The audio source seems to move from the left channel to the right channel during playback.

Creating a custom pan

You can create complex custom panning effects using up to sixteen envelope points. 

1. Open the Musicbed.pca file.

2. In Sound Forge Pro software, choose Pan/Expand from the Process menu. The Process dialog is displayed.

3. Configure the pan envelope using the following controls:

• Click the envelope to create a new point.
• Drag a point to move it to a new position.
• Double-click or right-click a point to delete it.
• Right-click an envelope segment and choose a new fade type from the shortcut menu.

For more information, see Envelope graphs on page 38.

4. Click OK. The custom pan is applied to the file.

Note: A pan, by nature, cannot be created in a mono file.

Hard left at start of audio

Hard right at end of audio

The pan envelope displays 
on the graph.
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Pan/Expand controls

The following controls are located in the Pan/Expand dialog.

Resample

The Resample command allows you to change the sampling rate of a file 
without altering its pitch or duration. 

• Resampling to a lower sample rate results in less frequent samples and a 
decreased file size, but adds aliasing noise to the audio. For more 
information, see Apply an anti-alias filter during resample on page 155.

• Resampling to a higher sample rate results in extra samples being created 
through interpolation and an increased file size. Like increasing bit depth, 
up-sampling does not improve the quality of an audio file, but permits 
subsequent audio processing to be performed with greater precision.

Downsampling audio 

1. Open the Musicbed.pca file. 

2. Right-click the data window and choose Properties from the shortcut menu. The Properties dialog is displayed. Notice that this file 
has 44,100 Hz sample rate and a file size of 0.48 MB.

3. Click OK.

4. From the Process menu, choose Resample. The Resample dialog is displayed.

5. From the Preset drop-down list, choose Resample to 8,000 Hz with anti-alias filter and click OK. The audio is resampled at 
8,000 Hz.

6. From the File menu, choose Save As. Save the resampled file with a new name and close it.

7. Open the resampled file and view its Properties dialog. The sample rate is lower (8,000 Hz) and the file size is smaller.

8. Play the file. Notice the obvious decrease in audio quality.

Upsampling audio

1. Verify that the file created in the previous procedure is the active data window. 

2. From the Process menu, choose Resample. The Resample dialog is displayed.

3. From the Preset drop-down list, choose Resample to 48,000 Hz with anti-alias filter and click OK. The audio is resampled at 
48,000 Hz.

Control Description
Process mode The Process mode drop-down list contains the following options:

• Pan (preserve stereo separation) - Applies the pan effect without mixing the channels, thereby simulating the spectral 
positioning of stereo recordings.

• Pan (mix channels before panning) - Mixes the left and right channels prior to applying panning effects.
• Stereo expand - Allows you to contract or expand the image of stereo audio from dead center (mono) to completely 

panned wide (no center channel). 
• Mix mid-side (MS) recording to left and right channels - Simulates a recording technique in which one microphone 

is pointed directly at the source and used to record the center (mid) channel, and a second microphone is pointed 90 
degrees away from the source (side) and used to record the stereo image. 
For proper playback on most systems, MS recordings must be converted to standard left/right orientation. 
To convert an MS-recorded track to a left/right track, first ensure that the center channel is in the left track and the side 
channel on the right. The MS mix function is then used to set the width of the stereo image for the converted track.

Output gain Determines the amount of gain applied to the signal following pan/expand processing.
Show wave The Show wave drop-down list provides several settings for drawing the current selection’s waveform on the envelope graph. 

This function is available only for small selections.
Reset Envelope Clicking the Reset Envelope button clears all but the two original envelope points. 

• For the Pan modes, these two points prevent unintended panning. 

• For the Stereo expand and Mix Mid-Side modes, these two points prevent unintended expansion.

Note: Use this new file to perform the following up-sampling procedure.
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4. From the File menu, choose Save As. Save the resampled file with a new name and close it.

5. Open the new file and view its Properties dialog. Notice that the sample rate is higher (48,000 Hz) and the file size is larger.

6. Play the file. Notice that resampling to a higher sample rate produces an audio quality at 48,000 Hz that is indistinguishable from 
the quality at 8,000 Hz.

Resample controls

The following controls are located in the Resample dialog.

Reverse

The Reverse command reverses the audio selection. 

1. Open the Musicbed.pca file.

2. From the Process menu, choose Reverse. The reversed audio data displays in the data window.

Smooth/Enhance

To start Sony Media Software’s XFX Smooth/Enhance plug-in, choose Smooth/Enhance from the Process menu. For more information 

on using the XFX Smooth/Enhance plug-in, click the  button in the Smooth/Enhance dialog or refer to Sound Forge online help (from 
the Help menu, choose Contents and Index).

Time Stretch

To start Sony Media Software’s XFX Time Stretch plug-in, choose Time Stretch from the Process menu. For more information on using 

the XFX Time Stretch plug-in, click the  button in the Time Stretch dialog or refer to Sound Forge online help (from the Help menu, 
choose Contents and Index).

Control Description
New sample rate Determines the sample rate (in Hz) at which the file is resampled.

Tip: Processing is quicker when downsampling by an even multiple (such as when going from 44 kHz to 22 kHz).
Interpolation accuracy The Interpolation accuracy value determines the complexity of the interpolation method used during resampling. 

Interpolation accuracy is most apparent in high frequencies, but the audible difference between the values is subtle and often 
undetectable without the use of test tones. 

A value of 1 is suitable for general-purpose audio. 

A value of 2 or 3 is good for high-end audio applications.

A value of 4 results in professional-quality audio, but requires substantial processing.
Apply an anti-alias filter 
during resample

Selecting this check box applies an anti-aliasing filter during the resampling process. Remember that the maximum frequency 
that can be represented by a sample rate is one-half of the sampling rate (the Nyquist frequency). Therefore, high frequencies 
cannot be accurately represented when downsampling. The anti-aliasing filter prevents high frequencies from becoming low-
frequency distortion.

Tip: It is also advisable to apply an anti-aliasing low-pass filter to an audio file prior to resampling to a lower sample rate.
Set the sample rate only (do 
not resample)

If this check box is selected, the playback rate is changed without resampling the data. This means that the pitch of the original 
file is not preserved. For this reason, this option is only useful for quickly converting between two similar sample rates.

Original audio data Reversed audio
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Volume

The Volume command alters the volume of an audio selection.

Increasing the volume of a selection

1. Open the Voiceover.pca file.

2. Create a selection containing the word “Wow.”

3. From the Process menu, choose Volume. The Volume dialog is displayed.

4. From the Preset drop-down list, choose 6 dB boost (200%) and click OK. The specified boost is applied to the selection.

5. Play the file. The “Wow” data clips and distorts upon playback.

Exercise caution when using the Volume command. Unlike Normalize, Volume performs no pre-processing scans and offers no 
options for clipping audio data.

Note: Once audio data is clipped, it cannot be restored by performing a second Volume operation. The initial Volume operation must be 
undone.

Audio following volume increase

Create a selection
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Volume control

The Volume dialog contains only one control: Gain. The Gain fader determines the new volume of a selection. Negative decibel values 
decrease the selection’s volume, while positive decibel values increase the selection’s volume.

Note: A value of -Inf. corresponds to mute (0%).
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Chapter 11
 Working with Effects

Effects, or plug-ins, can be used to improve the quality of the audio or to create special artistic effects. Additional DirectX® 
and VST plug-in effects, both from Sony and other third-party vendors, can also be used.

Adding effects

You can choose an effect from the Effects menu to apply to a file or just a portion of a file. If you’ve added an effect to the 
FX Favorites menu, you can select it from that location as well. For more information, see Organizing effects in the FX 
Favorites menu on page 166.

Applying an effect

1. Select the data you want to process. If no data is selected, the effect is applied to the entire file.

2. Choose a command from the Process, Effects, or FX Favorites menu. The dialog for the selected effect is displayed.

3. Choose a preset from the Preset drop-down list and adjust the parameters in the dialog to achieve the effect you 
want. For help on the different controls in the effect dialog, click the Help button ( ).

4. Click the Preview button to test out the effect. Adjust the settings as needed and click Stop to end the preview.

5. Click OK. During processing, a progress meter is displayed at the bottom of the data window. You can cancel the 
operation at any time by clicking the Cancel button to the left of the progress meter, or you can press the Escape 
key.

Saving effect settings as a custom preset

Once you have adjusted the parameters in the effect dialog, you may want to save your settings as a custom preset for 
later use. You can select the preset from the Preset drop-down list to apply the same settings at a later time.

Note: When you’re working with multichannel files, only the selected region in the selected channel is processed. Most 
functions can be applied to the individual or all channels. However, since the channels in a multichannel file must be equal 
in length, functions that affect the length of the data cannot be performed on individual channels. These functions include 
Insert Silence, Resample, Time Stretch, Gapper/Snipper, Pitch Bend, and Pitch Shift (without preserving duration).

If you want to apply one of these processes in a single channel, convert the file into separate mono files (you can select a 
channel and drag it to the Sound Forge workspace to create a new file quickly), apply the process, and merge the files into 
a new multichannel file.

Tip: If the selection you made in the data window needs to be adjusted, click the Selection button to adjust the selection.

Preset

Effect 
controls

Preview/Stop

Plug-In 
online help
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1. Adjust the parameters in the effect dialog to achieve the effect you want.

2. Click Save As. The Save Preset dialog is displayed.

3. Enter a new preset name and click OK. The new preset is added to the Preset drop-down list.

Using the Plug-In Chainer

The Plug-In Chainer allows you to create a chain of 32 DirectX® and VST plug-ins. You can preview each plug-in in the chain 
simultaneously in real time as long as your computer has adequate processing power.

You can switch between the Plug-In Chainer window and data windows without leaving the Plug-In Chainer. This means you can 
change your selection in the data window or even switch to another data window—all without closing the Plug-In Chainer window. 

Because the Plug-In Chainer offers these advanced features, you may want to use the chainer to create a single-effect chain instead of 
applying an effect from the Effects or FX Favorites menu. For more information, see Adding effects on page 159.

Creating a plug-in chain

1. Select the data you want to process. If no data is selected, the effect chain is applied to the entire file.

2. From the View menu, choose Plug-In Chainer or click the Open Plug-In Chainer button  on the data window. The Plug-In 
Chainer window is displayed.

3. To use an existing chain preset, choose the chain from the Chain Preset drop-down list. For more information, see Saving plug-in 
chains on page 163. Otherwise, add the desired plug-ins to a new custom chain. For more information, see Adding a plug-in to a chain 
on page 161.

4. Configure the parameters of each plug-in. For help on the different plug-in controls, click the Help for Plug-In button  or click a 
control and press Shift+F1.

Effect preset

Effect controls

Effects chain

Chain preset

Preview
Process 
Selection

Add Plug-Ins to Chain

Remove Selected Plug-In
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5. Click the Preview button  to test the effect chain. If needed, you can select different parts of the audio in the data window to 
preview different sections before applying the effect chain. You can also click the Bypass button  to temporarily bypass the 
effect. For more information, see Bypassing effects on page 162.

6. If the effect changes the duration of a sound (for example, Reverb or Simple Delay), choose how the audio tail created by the effect 
should be processed. For more information, see Selecting the processing mode for audio tail data on page 163.

7. Click the Process Selection button  (or press Ctrl+Shift+P) to apply the effect chain.

Adding a plug-in to a chain

You can add plug-ins to a chain in the Plug-In Chainer in several ways.

1. Click the Add Plug-Ins to chain button  on the Plug-In Chainer window (or press Ctrl+E). The Plug-In Chooser dialog is 
displayed, listing all available DirectX plug-ins installed on your system.

2. Select the desired plug-in(s).

3. Click Add. The selected plug-ins are added to the chain and can be configured and arranged as needed.

Tip: You can also click the Play Plug-in Chainer button  on the data window to preview the effects chain. Use the Play Normal 
button  to bypass the effects.

Note: The Insert Tail Data and Mix Tail Data commands may not function when using third-party reverb plug-ins.You can use the 
Insert Silence command to make room for the tails or apply the reverb in a new data window that has room for the tails and then mix the 
processed audio back into your source file.

Tip: You can also double-click a plug-in to add it to the chain.
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Removing a plug-in from a chain

To remove a specific plug-in from a chain, select it and click the Remove Selected Plug-In button . The plug-in is removed and the 
remaining plug-ins are adjusted. 

You can arrange the order of plug-ins in the chain in either the Plug-In Chainer or the Plug-In Explorer.

Arranging plug-in order in the Plug-In Chainer

In the Plug-In Chainer window, drag an effect to a new location in the chain.

Arranging plug-in order in the Plug-In Explorer

You can drag an effect to a new location in the chain in the Plug-In Explorer in the same way you can in the Plug-In Chainer. In addition, 

you can rearrange the chain by selecting a plug-in and clicking the Shift Plug-In Left button  or the Shift Plug-In Right button  to 

move it forward or backward in the chain. To access the Plug-In Explorer, click the Add Plug-Ins to chain button  in the Plug-In 
Chainer window.

Configuring chained plug-ins

To configure the parameters of specific plug-in, select it from the chain. The plug-in’s parameters display, allowing you to adjust all 

controls as needed. For help on the different plug-in controls, click the Help for Plug-In button  or click a control and press Shift+F1.

Bypassing effects

You can bypass single effects or all effects in a chain while previewing the file.

Tip: You can also remove plug-ins by performing one of the following actions:

• Press Ctrl+Tab to select the next plug-in or Ctrl+Shift+Tab to select the previous plug-in, and then press Ctrl+Delete to remove the selected 
plug-in from the chain.

• Right-click a plug-in in the chain and choosing Remove from the shortcut menu.

Note: The order of plug-ins in a chain can have a dramatic effect on the final product of audio signal processing.

Tip: You can also change the plug-in order by right-clicking a plug-in in the chain and choosing either Move Left or Move Right from the 
shortcut menu.

Drag a plug-in in the Plug-In Chainer to a 
new location in the chain.
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Bypassing a plug-in on a chain

To bypass a plug-in, clear its check box in the Plug-In Chainer window. A 
bypassed plug-in does not process the audio signal, allowing you to preview the 
effect of the remaining plug-ins.

Bypassing the plug-in chain

To bypass the entire chain, click the Bypass button  (or press Ctrl+B) in the Plug-In Chainer window. Click the Bypass button again to 
restore the chain’s processing of the audio.

Selecting the processing mode for audio tail data

Some effects, such as Reverb or Simple Delay, create a “tail” at the end of the selected audio. This tail consists of the echo or reverb 
created by the effect that lasts beyond the end of the selection. When you select a portion of a file and apply the effect using the Plug-In 

Chainer, you can select one of three buttons to determine how the audio tail is processed:

Saving plug-in chains

Once you’ve set up an effect chain, you may want to save it for later use. When you save a plug-in chain, you not only save the order of 
the effects in the chain but also the parameters of each individual effect.

1. Create an effects chain in the Plug-In Chainer window.

2. Enter a name for the new chain in the Chain Preset box.

3. Click the Save Chain Preset button . The new chain is saved in the Chain Preset drop-down list.

Notes: 

• You can bypass multiple plug-ins.
• You can also bypass the plug-in by right-clicking a plug-in in the chain and 

choosing Bypass from the shortcut menu.

If Then
You want to ignore the tail Select the Ignore Tail Data button .

The effect ends abruptly at the end of the selection.
You want to mix the tail into the adjacent 
material

Select the Mix Tail Data button .

This is the most natural-sounding option.
You want to insert the audio tail Select the Insert Tail Data button .

All audio to the right of the tail moves over to accommodate the extra audio.

Notes: 

• Press Ctrl+T to toggle through the three audio tail data processing modes.
• The Insert Tail Data and Mix Tail Data commands may not function when using third-party reverb plug-ins.You can use the Insert 

Silence command to make room for the tails or apply the reverb in a new data window that has room for the tails and then mix the 
processed audio back into your source file.

Tip: You can also save a chain preset by pressing Ctrl+S, entering a name for the preset, and pressing Enter.

Bypassed plug-in

Enter a name in the 
Chain Preset box.

Click the Save Chain 
Preset button to save 
the new chain.
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Saving individual plug-in settings as a custom preset

Once you have adjusted effect parameters in the Plug-In Chainer window, you can save your settings as a custom preset for later use. 
You can select a custom saved preset from the Preset drop-down list to apply the same effect settings at a later time.

You also have the option of saving the entire chain as a chain preset. For more information, see Saving plug-in chains on page 163.

Saving a preset for an individual Direct X plug-in

1. Adjust the effect parameters in the Plug-In Chainer window to achieve the effect you want.

2. Enter a name for the new preset in the Preset box.

3. Click the Save Preset button . The new preset is saved in the Preset drop-down list.

Saving a preset for an individual VST plug-in

1. Adjust the effect parameters in the Plug-In Chainer window to achieve the effect you want.

2. Enter a name for the new preset in the Preset box.

3. Click the Save VST Preset As button . The VST Preset dialog is displayed.

4. Browse to the folder where you want to save the .fxp file and type a name in the File name box.

5. Click the Save button. The current plug-in settings are saved in the .fxp file.

Saving a bank of VST plug-in presets

1. Adjust the effect parameters in the Plug-In Chainer window to achieve the effect you want.

2. Click the Save VST Bank As button . The Save VST Preset Bank dialog is displayed.

3. Browse to the folder where you want to save the .fxb file and type a name in the File name box.

4. Click the Save button. All presets for the current plug-in are stored in the bank.

Loading plug-in chains or plug-in presets

Once you have saved a plug-in chain, you can easily load it into the Plug-In Chainer.

Loading a plug-in chain preset

Choose a setting from the Chain drop-down list. The preset chain loads into the window using the saved settings for each DirectX and 
VST plug-in in the chain.

Loading an individual DirectX plug-in preset

Choose a setting from the Preset drop-down list. The plug-in settings stored in the preset are loaded.

Loading an individual VST plug-in preset

1. Click the Open VST Preset button . The Open VST Preset dialog is displayed.

2. Browse to the .fxp file that you want to use.

3. Click the Open button. The current VST preset is replaced with the settings stored in the .fxp file.

Note: Effect automation envelope points are not saved with presets. If you are using effect automation envelopes and save a preset 
during playback, the effect’s settings at the playback cursor position are saved.
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Loading a bank of VST plug-in presets

1. Click the Open VST Bank button . The Open VST Bank dialog is displayed.

2. Browse to the .fxb file that you want to use.

3. Click the Open button. All presets for the current VST plug-in are replaced with the settings stored in the .fxb file and the first preset 
in the bank is loaded by default.

Using the Plug-In Manager 

You have several tools to help you manage your plug-ins, including the Plug-In Manager, FX Favorites menu, and the Preset Manager.

The Plug-In Manager window not only allows you to add plug-ins and saved plug-in chains (pg. 165), but it provides a way to manage 
your plug-in files—to rename plug-ins, hide plug-ins, create folders, add plug-ins to a FX Favorites folder, and perform other standard 
file management tasks.

Applying a plug-in or chain to a media file

You can add a plug-in to a chain in the Plug-In Chainer by dragging an effect from the Plug-In Manager window.

1. From the View menu, choose Plug-In Manager. The Plug-In Manager window is displayed.

2. Select the data you want to process. If no data is selected, processing will be applied to the entire file.

Note: When you're working with multichannel files, only the selected region in the selected channel is processed. Most functions can be 
applied to individual or all channels. However, since all channels in a multichannel file must be equal in length, functions that affect the 
length of the data cannot be performed on individual channels. These functions include Insert Silence, Resample, Time Stretch, Gapper/
Snipper, Pitch Bend, and Pitch Shift (without preserving duration).

If you want to apply one of these processes in a single channel, convert the file into separate mono files (you can select a channel and drag 
it to the Sound Forge workspace to create a new file quickly), apply the process, and merge the files into a new multichannel file.

Views

Delete

New Folder

Refresh

Up One Level

Plug-In Manager window
WORKING WITH EFFECTS | 165



3. Select the desired plug-in(s).

4. Drag the plug-in(s) from the Plug-In Manager window to the Plug-In Chainer window. The selected plug-in(s) are added to the 
chain.

5. Use the Audio Plug-In Chainer to preview your effects and adjust settings as needed. You can select the Bypass button  to hear 
the original, unprocessed audio.

6. When you are satisfied with the chain, click the Process Selection button  in the Plug-In Chainer to apply the effect.

Renaming a plug-in

You can customize the names of plug-ins within the software.

1. Right-click a plug-in in the Plug-In Manager and choose Rename from the shortcut menu. 

2. Type a new name and press Enter. 

Hiding a plug-in

All DirectX plug-ins on your system are automatically available to you. You may want to hide a plug-in within the software without 
removing the plug-in from your system.

1. Right-click a plug-in in the Plug-In Manager and choose Hide from the shortcut menu. You are prompted to confirm that you want 
to permanently hide the plug-in.

2. Click Yes. The plug-in no longer appears in Sound Forge software.

Organizing effects in the FX Favorites menu

The FX Favorites menu provides easy access to the plug-ins you use most frequently. You can add and remove plug-ins and folders to 
organize the menu however you like. You can also automatically add all plug-ins on your system to the menu. For more information, see 
Automatically adding and organizing plug-ins on page 167.

Once you add a plug-in to the FX Favorites menu, you can apply the plug-in to a file by selecting it from the menu. For more information, 
see Adding effects on page 159.

1. From the FX Favorites menu, choose Organize. The Organize Favorites dialog is displayed.

2. Organize your plug-ins:

• Drag plug-ins to the FX Favorites folder to add them to the FX Favorites menu.
• Create submenus in the FX Favorites menu by clicking the FX Favorites folder and clicking the Create New Folder button . 

Once you have created a new folder, drag plug-ins to the folder to add them to the submenu in the FX Favorites menu.
• Remove plug-ins or folders from the FX Favorites menu by selecting the plug-in or folder and clicking the Delete button . 

Deleting a plug-in from the FX Favorites folder removes it from the FX Favorites menu but does not delete the plug-in from 
your system.

3. Close the Organize Favorites dialog. The new plug-ins and/or submenus appear in the FX Favorites menu.

Note: Effects chains—including packages created in Sony Vegas or ACID—are displayed in the DirectX Chains folder in the Plug-In 
Manager.

Tip: You can also drag plug-ins or a plug-in chain from the Plug-In Manager window to a data window. The Plug-In Chainer window is 
opened with the selected effects in a new chain.

Tip: To restore hidden plug-ins, you can force Sound Forge to rescan your system for plug-ins by deleting the 
HKEY_LOCAL_MACHINE\SOFTWARE\Sony Media Software\Sound Forge\9.0\FXCache key in the Windows Registry.

Tip: You can also add plug-ins to the FX Favorites menu using the Plug-In Manager.
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Automatically adding and organizing plug-ins

You can automatically add all the plug-ins on your computer to your FX Favorites folder and organize them by the first word in the plug-
in name (usually the company name). This replaces any menu structure you may have created with a rebuilt FX Favorites menu.

1. From the FX Favorites menu, choose Recreate by Plug-In Name. You are prompted to confirm the reorganization of the FX 
Favorites folder. 

2. Click Yes to continue. 

Folders are created and the plug-ins are organized based on the first word in the names of the plug-ins.

Using the Preset Manager

Once you have created custom presets for effects or effect chains, you can use the Sound Forge Preset Manager to back up, transfer, or 
delete custom presets from any of the effects, processes, tools and plug-ins installed in the software. The Preset Manager also functions 
as a standalone application, meaning that you can use the Preset Manager outside of Sound Forge software to manage ACID and Vegas 
presets as well.

To display the Preset Manager, choose Preset Manager from the Tools menu. In the Preset Manager, choose Contents and Index from 
the Help menu for instructions on how to manage your presets.

Automating Effect Parameters

When you add an effect that supports automation to the Plug-In Chainer, a list of the effect’s automatable parameters is displayed on 
the right side of the window. You can use these controls to add, show/hide, and enable/bypass automation envelopes.

Plug-in parameters can be edited using the automation envelope in the data window.

Adding an effect automation envelope

1. In the Plug-In Chainer, select the button  for an effect that includes automatable parameters. The plug-in's controls are 
displayed, and a list of the effect’s automatable parameters is displayed on the right side of the Plug-In Chainer.

2. Select the Automate check box for each parameter you want to control with an envelope. An envelope is added to the data 
window for each selected check box.

Adding a volume or panning envelope

Panning envelopes will have no effect on mono source data. Convert mono sound data to stereo before adding a panning envelope.

1. Click within a data window to give it focus.

2. Press V to add a volume envelope, or press P to add a panning envelope.

An envelope is added to the data window and the Sound Forge Volume or Sound Forge Pan plug-in is added to the Audio Plug-In 
Chainer. If the Plug-In Chainer is not visible, it will be opened.

3. Adjust volume or panning with the envelope in the data window.

Note: Choosing a new effect chain preset will clear the current effect automation settings. 

Tip: The Parameter Chooser is displayed on the right side of the Plug-In Chainer window when you add a plug-in that supports 
automation. Click the Show Parameter Chooser button  or press Ctrl+H to show or hide the chooser.

Note: If a data window already has a volume envelope, pressing P or V will hide the envelope.
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Adjusting effect parameters with envelopes

An envelope is displayed in the data window for each effect parameter that you've chosen to automate. Envelope points represent 
plug-in parameter settings at a specific point in time. 

You can add points, adjust their positions, and change the fade curves between points to modify effect parameters and the transitions 
between them.

Previewing effect automation

To hear the results of your effect automation without applying it to the sound file, click the Preview button  in the Plug-In Chainer 
window.

You can select the Bypass button  in the Plug-In Chainer to bypass all effects in the chain, or clear an effects check box  to 
bypass individual effects. 

You can also click the Play Plug-In Chainer button  in a data window’s playbar to hear the effects of a chain on the data window. 

Click the Play Normal button  in the playbar to hear the unprocessed sound.

Applying effects automation

To apply effect automation to a data window, click the Process Selection button  in the Plug-In Chainer window.

Showing or hiding effect automation envelopes

1. In the Plug-In Chainer, select the button  for an effect that includes automatable parameters. The plug-in’s controls are 
displayed, and a list of the effect’s automatable parameters is displayed on the right side of the Plug-In Chainer.

2. Select the Show check box to display a parameter’s envelope, or clear the check box to hide it. Hiding an envelope simply removes 
the line from the data window while it retains the playback properties.

Enabling or bypassing effect automation envelopes

1. In the Plug-In Chainer, select the button  for an effect that includes automatable parameters. The plug-in’s controls are 
displayed, and a list of the effect’s automatable parameters is displayed on the right side of the Plug-In Chainer.

2. Select the Enable check box to apply an automation envelope to your audio signal, or clear the check box to ignore it.

When the check box is cleared, an effect automation envelope is ignored and the effect’s initial state is used for the duration of the 
data window.

Bypassed envelopes are drawn with a dashed line in the data window.

Removing effect automation envelopes

Click the Automate None button  in the Plug-In Chainer to remove all automation envelopes for the selected plug-in.

Choose (Empty Chain) or another preset from the Chain Preset drop-down list at the top-left corner of the Plug-In Chainer to clear the 
plug-in chain and remove all effect automation envelopes.

Note: When you automate an effect’s frequency parameter — such as the modulation frequency parameter in the amplitude 
modulation effect — you may notice that the frequency changes are more apparent when moving through the lower frequencies. This is 
because frequency scales plug-ins use a logarithmic scale, but effect automation uses linear interpolation.To make the automated 
frequency changes sound more natural, change the fade curve types to change the interpolation rates between envelope points. For high-
to-low frequency sweeps, use a fast fade curve; for low-to-high frequency sweeps, use a slow curve.
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Adjusting envelopes

When the Envelope tool  on the main workspace is selected, you can add, remove, select or adjust envelope points on effect 
automation envelopes.

The Edit tool  allows you to add, remove, or adjust envelope points, but you cannot select envelope points with the Edit tool.

By default, a new envelope will contain a single envelope point. If you want to adjust the overall level of an envelope, drag the envelope 
up or down. A floating ToolTip will show you the envelope’s current setting.

If an envelope has multiple points, you can drag each point, or you can drag envelope segments up or down.

Adding envelope points

To create more complex envelopes, you will need to add points. To add an envelope point, double-click the envelope. You can then 
drag and position the point as necessary.

To delete a point, right-click it and choose Delete from the shortcut menu.

Flipping an envelope

You can flip an envelope to invert the envelope around its center. Volume, panning, and effect automation envelopes can be flipped.

Flipping all points

1. Right-click an envelope or a point. A shortcut menu is displayed.

2. Choose Flip All Points from the shortcut menu.

Flipping selected points

1. Create a time selection with the Envelope tool  to select the points you want to flip.

2. Right-click an envelope in the time selection. A shortcut menu is displayed.

3. Choose Flip Selected Points from the shortcut menu.

Setting fade properties

You can adjust the fade curve for each envelope segment individually. To change the fade curve, right-click an envelope segment and 
choose a fade command (such as Linear Fade or Fast Fade, for example) from the shortcut menu.

Cutting, copying, and pasting envelope points

1. Select the Envelope tool .

2. Click within a data window to select it.

3. Drag horizontally in a data window to select envelope points.

4. From the Edit menu, choose Cut or Copy.

Tips: 

• Hold Ctrl while dragging an envelope point or segment to adjust the value in fine increments without changing the envelope points' 
horizontal positions.

• Hold Ctrl+Alt while dragging an envelope point or segment to adjust the value in normal increments without changing the envelope 
points' horizontal positions.

• Hold Alt while dragging an envelope point to move the point's horizontal position without changing its value. 
With the Envelope tool, you can drag horizontally to select multiple envelope points in the selected data window.
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5. Click to position the cursor where you want to paste envelope points.

6. From the Edit menu, choose Paste.

Copying an envelope to another data window

1. Select the Envelope tool .

2. Click within a data window to select it.

3. From the Edit menu, choose Select All.

4. From the Edit menu, choose Copy.

5. Click within a data window to select it.

6. Click Go to Start  if you want the envelope to appear exactly as it was in the original data window, or click to position the cursor 
where you want the envelope to start.

7. From the Edit menu, choose Paste.

Tip: Click within a different data window if you want to paste envelope points across data windows.

Tip: You can paste envelope points to a different envelope type by selecting the envelope where you want to paste.
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Chapter 12
 Using Acoustic Mirror and Wave Hammer

This chapter is designed to familiarize you with the Sound Forge® Acoustic Mirror™ and Wave Hammer™ effects. The 
Acoustic Mirror effect is a powerful digital signal processing tool that allows you to add environmental coloration to your 
existing recordings. The Wave Hammer effect is an audio mastering tool that features a classic compressor and volume 
maximizer. 

What are the Acoustic Mirror effects?

The Acoustic Mirror effects represents an advance in reverb technology in that it incorporates the acoustical responses of 
a given environment or venue into your audio files. You may never play Carnegie Hall, but that does not mean that your 
recordings can’t sound like it. Taking this concept even further, this effect allows you to simulate the signal response of 
vintage musical equipment. Imagine the money you’ll save not having to buy those paired U-47s.

The acoustic signature

Acoustic Mirror effects use the environment’s acoustic signature, or impulse response. These acoustic signatures are 
saved as impulse files and given the extension .wav or .sfi. An extensive library of high-quality impulse files are included. 
In addition, you can collect your own acoustic signatures and create custom impulse files.

Adding an acoustic signature to an audio file

1. Open and play the Saxriff.pca file.

2. From the Effects menu, choose Acoustic Mirror. The Acoustic Mirror dialog is displayed.

3. Click the Browse button located next to the Impulse field and locate the Acoustic Mirror Impulse Files folder on the 
Sound Forge CD.

4. Double-click the folder. Several impulse subfolders display.

5. Double-click the Large venues folder. Several impulse files display.

6. Double-click Stadium, Camp Randall 50 yrd line.sfi. This impulse file’s acoustic signature is added to the Saxriff.pca 
file and you are returned to the Acoustic Mirror dialog.

7. Click Preview. The processed file plays and the sax riff is virtually placed in a football stadium-sized venue.

8. Select or clear the Bypass check box to toggle between the processed and unprocessed audio.

Adjusting the acoustic signature

Once you add an acoustic signature to a file, you can use the controls of the Acoustic Mirror dialog to precisely configure 
the reverb effect. More importantly, you can preview configuration changes as quickly as you make them. 

1. Open a file and display the Acoustic Mirror dialog.

2. Verify that the Real-time check box is selected. 

3. From the Impulse drop-down list, choose the desired impulse file and click Preview. The processed audio file plays. 
Notice that all dialog controls are set to their default values.

Note: This file is located in the same folder as the application.

Note: You must have an active file in the Sound Forge workspace to start the Acoustic Mirror tool.
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4. Drag the Dry Out fader up. Notice the audible change in output as the balance between the Wet Out and Dry Out values changes.

5. Drag the Response delay slider to the right. Notice the audible change in the reverb’s delay.

The Acoustic Mirror dialog contains four tabs: General, Envelope, Summary, and Recover. Each tab contains controls that allow you to 
precisely configure the effect as well as recover custom impulses. Notice that the Acoustic Mirror dialog contains the preset and preview 
controls found in all of the Sound Forge process and effect dialogs. For more information, see Applying presets on page 139 and Previewing 
processed audio on page 141.

General tab controls

The following sections describe all controls located in the General tab.

Tip: If you are experiencing difficulty previewing processing in real-time, decrease the Quality/speed value.

Control Description
Impulse The Impulse drop-down list allows you to specify an impulse file from a list of those previously 

used. Clicking Browse displays the Open Impulse File dialog and allows you to locate an 
impulse file from your local system or network.

Response width You can use the Response width slider to create some simple stereo expansion and stereo 
collapsing effects. This control’s default setting of 50 represents normal stereo operation and is 
recommended to maintain the stereo field of the impulse response. A higher setting expands 
the stereo field, but may result in an unnatural sounding effect. Lowering this setting narrows 
the stereo field. A setting of 0 is essentially mono.

Response delay The Response delay slider controls the time, in milliseconds, that elapses between the dry 
signal and the processed output. This control can be used to create interesting effects and add 
new dimensions to an acoustic signature. Configuring this control with a positive value results 
in the processed output following the dry output. A negative value results in the processed 
output preceding the dry signal, or a pre-delay.

Pan (left to right) The Pan slider controls the balance between the left and right channels in stereo files. The 
default value is 0 and indicates a typical center position.

Dry Out The Dry Out fader controls the amount of unprocessed signal mixed into the output.
Wet Out The Wet Out fader controls the amount of processed signal mixed into the output.
Apply envelope and limit decay 
to (seconds)

When you select this check box, the length of the impulse is limited to the time specified in the 
adjacent box. Limiting the length of an impulse file shortens the decay of the reverberation and 
decreases the amount of processing required.

In addition, selecting this check box results in the impulse fading according to the Envelope 
Graph configured on the dialog’s Envelope tab. For more information, see Envelope Graph 
on page 173.

Low-shelf start frequency/High-
shelf start frequency

Acoustic Mirror high- and low-shelving filters to allow you to tailor the frequency response of 
the impulse. Notice that you can adjust the cutoff frequency and boost/attenuation of each 
filter independently.

Convert mono to stereo Selecting the Convert mono to stereo check box converts a mono signal to stereo output. If 
the impulse file is in stereo, selecting this check box imparts a pseudo-stereo effect on the 
mono input.

Quality/speed The Quality/Speed slider allows you to strike a balance between the quality and speed of the 
audio processing. Lowering this value immediately affects the frequency response of the 
impulse. The processed signal sounds dull and high frequencies sound unnatural. At very low 
values, the length of the impulse is shortened. When this control is set to a high value, the audio 
quality is excellent, but the processing takes longer.

If you are experiencing difficulty previewing processing in real-time, decrease the Quality/
speed value. However, you must return this value to 5 prior to actually processing the file to 
output the highest possible quality.
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Envelope tab controls

The following sections describe all controls located on the Envelope tab.

Adjusting the impulse length

Drag the vertical Envelope Endpoint line to the desired location. The Envelope Endpoint repositions and the length of the impulse 
adjusts.

Control Description
Impulse This control is identical to the Impulse drop-down list on the General tab. This allows you to 

view the envelope graphs for the specified impulse file. For more information, see Impulse on 
page 172.

Dry Out This control is identical to the Dry Out fader on the General tab. For more information, see 
Dry Out on page 172.

Wet Out This control is identical to the Wet Out fader on the General tab. For more information, see 
Wet Out on page 172.

Apply envelope and limit decay This control is identical to the Apply envelope and limit decay check box on the General tab. 
For more information, see Apply envelope and limit decay to (seconds) on page 172.

Envelope Graph Selecting the Apply envelope and limit decay check box turns on the Envelope Graph. You 
can use the envelope graph to decrease the length of the specified impulse file, which 
consequently decreases the reverberation decay time and processing time. You can also use 
the envelope graph to apply fades to the specified impulse file.

The horizontal axis of the graph represents the time of the impulse file and the vertical axis 
represents peak amplitude in dB. Specifying an impulse file from the Impulse drop-down list 
automatically displays its envelope in the graph.

Note: If the impulse file is greater than 6 seconds in length, it does not display in the envelope 
graph.

Envelope points Envelope points are used in the envelope graph to specify a fade curve. The fade amount can 
vary from 0% to 100%. You can create, delete, and arrange envelope points just as you can in all 
of the Sound Forge envelope graphs. For more information, see Envelope graphs on page 
38.

Note: The fade value at any point in a curve does not use the same vertical logarithmic (dB) 
scale used for displaying the impulse file.

Reset Clicking this button resets the envelope points to 100%, indicating no fade.
Package Impulse into Preset Clicking this button creates a link between the current preset and the selected impulse file, 

along with encoding the impulse information. You can use the Preset Manager to share presets 
and the accompanying impulse files between computers without losing information. For more 
information, see Using the Preset Manager on page 167.

Repositioning the 
envelope endpoint line
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Summary tab controls

The Summary tab provides information about the impulse file. The following section describes all controls located on the Summary 

tab.

Recover tab controls

The Recover tab is used in creating your own impulse files. For more information, see Creating impulse files on page 175. The following 

section describes all controls located on the Recover tab.

Control Description
Impulse This control is identical to the Impulse drop-down list on the General tab. For more 

information, see Impulse on page 172.
Dry Out This control is identical to the Dry Out fader on the General tab. For more information, see 

Dry Out on page 172.
Wet Out This control is identical to the Wet Out fader on the General tab. For more information, see 

Wet Out on page 172.
Quality/speed This control is identical to the Quality/speed check box on the General tab. For more 

information, see Quality/speed on page 172.

Control Description
Recorded file The Recorded file box allows you to select the file containing the test tone recorded in the field. 

You can enter the path directly into the box or click Browse to locate and select a file.
Test file used The Test file used box allows you to select the file that was used as a test tone. You can enter 

the path directly into the box or click Browse to locate and select a file.

Note: You should use one of the test files included in the Acoustic Mirror Impulse Files\Test 
Tones folder on the Sound Forge application disc.

Impulse output The Impulse output box allows you to specify where the recovered impulse response file is 
saved. You can enter the path directly into the box or click Browse to locate and select a folder.

Remove very low frequencies When you select this check box, very low frequencies (which are typically comprised of noise) 
are removed from the impulse response. This increases the impulse response’s signal-to-noise 
ratio. 

Recover Impulse Clicking the Recover Impulse button starts the impulse recovery process. After the process is 
complete, an impulse file is created and saved in the folder specified in the Impulse output file 
box.

Impulse recovery mode You can choose from three Impulse recovery mode options to determine the method used to 
recover the impulse: Use the start and end of the recorded file as timing spikes, Auto-detect 
timing spikes, or Do not use timing spikes. Each of these modes is described below.

• Use the start and end of the recorded file as timing spikes - This option specifies that the 
beginning and end of the recorded file are used as timing spikes. This option is 
recommended for the best results during impulse recovery.

You must trim the file as close to the timing spikes as possible for this method of recovery to 
work most effectively. The first sample of the file should contain the start of the first spike 
and the last sample of the file should contain the start of the second spike. Therefore, most of 
the second spike is deleted.

• Auto-detect timing spikes - This option specifies that the timing spikes exist near the start 
and end of the recorded file and that they should be auto-detected. Timing spikes are used 
to correct for clock or tape speed mismatches. If you have not trimmed the recorded file so 
that the timing spikes are at the very beginning and end, select this option for the best 
results.

With this option, you need only ensure that the first spike occurs within one second of the 
start of the file and that the second spike exists in the file. To improve detection accuracy, 
you can also boost the level of the start and end spikes in the recorded file.

Tip: If the spike’s level is close to the noise floor, select the Use the beginning and end of the 
recorded file as timing spikes option.

• Do not use timing spikes - This option specifies that no timing spikes are used. This is the 
least desirable option as no timing information is used. To use this option, you must trim the 
recorded file so that the test tone starts and ends at the start and end of the file, with no 
blank audio before or after. This option should only be used if the timing spikes are lost in the 
recording or if you are certain that the play and record clocks are synchronized (such as when 
using an ADAT).
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Creating impulse files

You can obtain impulse responses from anything that accepts test tone input and supports recording the output. This includes physical 
spaces as well as electronic audio equipment. Creating custom impulse files requires planning, work, and additional audio equipment.

What you need to create custom impulses

The equipment required to create custom impulses depends upon whether you want to create the impulse from a physical acoustic 
space or from a piece of equipment. Regardless of the method, you need a playback device that reproduces test tones and a recording 
device that has microphone or line-level inputs. Be aware that the quality of the impulse is directly affected by the quality of your 
playback and recording devices. The flatter your system’s response, the more accurate the impulse response.

Recovering an impulse from an acoustic space

To recover an impulse from an acoustic space, you need the following equipment:

• A playback device and speakers
• A stereo pair of microphones to record the test tone
• A recording device for recording the signal captured by the microphones

Recovering an impulse from an electronic device

To recover an impulse from an electronic device, you need the following equipment:

• A playback device that connects to the device’s inputs
• A recording device that connects to the device’s outputs

Recording the impulse in an acoustic space

Once you have assembled the required equipment, you are ready to begin recording the impulse. The following sections describe the 
typical impulse recording procedure.

Transferring the test tone

The first step in recording the impulse is to transfer the desired test tone to your playback device. The Sound Forge application disc 
contains two test tones: a 24-second test tone and a 48-second test tone. We typically recommend that you use the 24-second tone 
because longer tones result in greater signal-to-noise ratios. The 48-second tone should be used in particularly noisy environments or 
when the decay time of the acoustic space is greater than six seconds.

Placing equipment

When recording the test tone in an acoustic space, you must determine where to place your playback system, speakers, microphones, 
and recording system to produce optimal results. Microphone placement is crucial to the quality of the impulse. The distance between 
the speakers and the microphone is the perceived distance of audio processed with the impulse you create. For example, if you record 
the test tone with the speakers positioned 100 feet from the microphones, all sounds processed with the resulting impulse sound as if 
they are originating 100 feet from the listener.

Note: Impulses derived from electronic devices that produce nonlinear effects such as overdrives, distortion pedals, pitch shifters, 
harmonic enhancers, chorus pedals, or flange pedals cannot be modeled using the Acoustic Mirror tool. While they produce interesting 
effects, the acoustic signature cannot be correctly replicated.

Tip: There are spikes at the beginning and end of each test tone. You should include the spikes in the recording to simplify the recovery of 
the impulse in the later stages of the process.
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Setting levels

After the devices are positioned, you should begin playback of the test tone. The test tone should be played as loudly as possible (or 
practical) to produce the best signal-to-noise ratio. With the test tone playing at optimum volume, set the levels on the recording 
device. Recording devices levels should also be set as high as possible, but not permitted to clip or distort. Safe levels are determined by 
whether you are recording to an analog or digital medium.

Recording the test tone

Begin recording on the recording device and begin playback of the test tone. Remember to include the spikes at the beginning and end 
of the test tone. Record the test tone several times using the initial setup, then move the microphones and record the test tones several 
more times. Continue moving the microphones and recording until you have exhausted the space’s acoustic possibilities. Recording 
impulses in this manner provides you with several distinct impulses for each space.

Recording the impulse through an electronic device

The recording process is similar if you are recording the output of an electronic device, but there are no speakers or microphones to be 
placed.

Using the appropriate cables, connect the playback system’s outputs to the electronic device’s inputs and the electronic device’s 
outputs to the recording system’s inputs. Once the devices are connected, play the test tone through the electronic device and record 
its output on the recording system.

Other impulses

Any number of methods can be used to create an impulse, including starter pistols, clap boards, or even a sharp hand clap. The 
drawback of these “impulse generators” is that they add their own coloration to the sound. For best results, we recommend using the 
test tones included on the Sound Forge application disc.

Recovering the impulse

Once you have recorded your test tones, they must be processed and converted into impulse responses. The following sections 
describe the typical impulse recovery procedure.

Trimming the test tone

1. Open your test tone file (the “room processed” output test tone) in the software. 

2. Locate the first timing spike and delete all audio before it. Cut as close to the beginning of the timing spike as possible, but do not 
delete the spike itself. 

3. Locate the second timing spike and delete all data from the start of the second spike to the end of the file. Again, cut as close to the 
start of the timing spike as possible. 

You should now have an audio file with a spike at the beginning, a test tone, and silence.

4. Save the test tone file.

Naming, configuring, and recovering the impulse

1. From the Effects menu, choose Acoustic Mirror. The Acoustic Mirror dialog is displayed.

2. Click the Recover tab. 
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3. Enter the name and path of your impulse file in the Recorded File box or click Browse and locate the file. 

4. Enter the name of the original test tone file in the Test file used box. 

5. Enter the desired name for the impulse response file to be created in the Impulse output box. If necessary, click Browse and specify 
the folder in which the impulse file will be saved.

6. Select the Remove very low frequencies check box.

7. If the recorded file was trimmed exactly to the start and end spikes using the procedure described previously, choose Use start and 
end of the recorded file as timing spikes from the Impulse recovery mode drop-down list. For more information, see Trimming the 
test tone on page 176.

8. Click the Recover Impulse button to begin recovering the impulse. 

After processing is complete, you can open the impulse file in the Sound Forge software and perform any necessary trimming or 
editing. For more information, see Trimming the impulse file on page 177.

Trimming the impulse file

After the impulse file is recovered, it may still require minor trimming. In general, you should try to make the impulse response as short 
as possible to increase processing speed when using the Acoustic Mirror tool. Impulse files greater than 131,071 samples (about 3 
seconds) in length require substantial processing time. When possible, trim the impulse response to less than 65,535 samples (about 1.5 
seconds). In addition, we recommend fading the tail of the impulse. Of course, this is not always an option when dealing with spaces 
that produce extended reverberations. 

1. Open the recovered impulse file in the Sound Forge software and play it.

2. Delete any silence or low-level noise that occurs before or after the actual audio data. Typically there are between 900 and 1100 
samples of data at the beginning of the impulse that should be removed. 

3. Save the trimmed impulse response file using the standard WAV format.

Tip: To prevent phase problems when mixing the dry and wet signals, you may also want to verify the phase of the impulse file. The file 
should begin by going positive (above the centerline). If the impulse file has a negative (below the centerline) phase, choose Invert/Flip 
from the Process menu.
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Adding summary information to your impulse file

If you plan on sharing impulses with other Sound Forge users, we recommend adding summary information and BMP images to your 
files. 

1. Open the impulse file in the software.

2. From the File menu, choose Properties. The Properties dialog is displayed.

3. Click the Summary tab.

4. Enter the appropriate information in each box.

5. Click the Picture button. The Open Picture dialog is displayed.

6. Locate the desired image and click Open. The image is linked to the impulse 
file.

7. Click OK.

Using the new impulse file

To use your new impulse file, open the Acoustic Mirror dialog and choose it from 
the Impulse drop-down list as you would any other impulse file. If you performed 
the previous procedures properly, the custom impulse file should realistically recreate the reverberation characteristics of the electronic 
device or acoustic space.

Using impulse files in creative ways

Now that you understand the use and creation of impulse files, you may want to begin using the Acoustic Mirror tool in more 
interesting ways than simply applying an impulse to an audio file. The following sections describe some creative and advanced uses for 
Acoustic Mirror technology that can contribute to the professionalism of your work.

Processing individual audio elements

Instead of applying an impulse file to an entire song, try applying an impulse to individual elements of the song. Applying an impulse to 
specific notes, chords, riffs, or phrases can quickly change the dynamics of a song. This technique is possible because the tail of 
processed audio is automatically mixed with the adjacent unprocessed audio.

Adding realistic stereo to mono recordings

You can give mono recordings realistic stereo characteristics by selecting the Convert mono to stereo check box in the General tab of 
the Acoustic Mirror dialog when applying the specified impulse file. The stereo image produced using this method is virtually 
indistinguishable from an actual stereo recording.

If you choose to use the Acoustic Mirror effect for stereo simulation, you may find the output too reverberant. If this is the case, decrease 
the Apply envelope and limit decay value. Frequently, setting this value to as little as 0.1 seconds provides stereo realism without 
adding a distracting amount of reverb.

Note: If you are using a palletized display setting (256 colors or less) and attach 
a bitmap to an impulse file, the bitmap colors are distorted when viewed in the 
Acoustic Mirror tool. This is because the bitmap is converted using the default 
palette at the time of attachment, which is not optimal. For this reason, you 
should set the display settings to at least a 16-bit palette prior to attaching 
bitmaps to impulse files.

Properties dialog with an attached image
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Creating special effects

Processing an audio file using a non-impulse WAV file can produce any number of unexpected and interesting special effects. To 
demonstrate this concept, create several short (less than 12 seconds) audio files using the FM Synthesis tool and save them as 
individual WAV files. Now choose any of these files from the Impulse drop-down list and preview the results. 

We have included several short files on the Sound Forge application disc to allow you to experiment with this technique. After some 
experimentation, you should begin to notice a few general rules regarding this use of the tool:

• Impulse files that cover the entire frequency spectrum prevent the output from sounding too filtered.
• Using a frequency sweep as an impulse creates a frequency-dependent delay effect.
• Panning within the impulse causes the stereo image of the output to flutter between channels.
• Using staccato sounds (such as drum hits) creates a variety of echo effects.

Recreating spaces for foley effects and dialog replacement

Frequently, dialogue recorded in the field is rendered unusable by ambient noise. If you are shooting in the field and realize that 
overdubbing will be necessary, you should create an impulse in each filming location. This allows you to overdub dialog during post-
production that is indistinguishable from dialog recorded on location.

If you intend to use the Acoustic Mirror effect as a film/video post-production tool, there are some factors to keep in mind:

• Distance information is determined by the distance between the source and the microphone when creating the impulse. Record 
multiple impulses at various distances for each location to create realistic dialog effects when matching audio processing to 
approximate camera positioning.

• The frequency response of the human ear changes as the volume of a sound increases. As a result, impulses created from a significant 
distance may sound unusual at high volumes.

• Placing a microphone off center allows you to create directional information in the recovered impulse. For example, placing a 
microphone to the left of the speaker produces an impulse that approximates a source located on the left side of the screen.

Panning with head-related transfer functions

A head-related transfer function (HRTF) contains the frequency and phase response information required to make a sound seem to 
originate from a specific direction in a three-dimensional space. The Acoustic Mirror Impulse Files\HRTF Impulses folder on the Sound 
Forge application disc contains a collection of impulse files that contain directional cues. 

To achieve optimal results using these impulse files, the original file should be mono and playback should be monitored using 
headphones. To begin, convert the mono file to stereo by replicating the mono signal in each channel. After the audio is converted to 
stereo, choose an impulse file from the HRTF Impulses folder. You will notice that the HRTF Impulses folder is further divided into Left 
and Right directories. Opening the desired folder displays the available impulse files, all of which are named based on their elevation 
(up or down) and azimuth (left or right) angles in degrees. The following table provides some examples:

File Name Impulse positioning
0E000L Straight ahead
0E090L Far left
0E090R Far right
90E000L Directly above your head
0E180L Directly behind you
-20E120L Below, behind, and to your left

Note: Refer to Readme.doc in the HRTF Impulses folder for more information.
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Troubleshooting the Acoustic Mirror effect

The following sections describe problems that may be encountered when working with the Acoustic Mirror tool.

Stuttering during real-time previewing

It is not uncommon to experience problems when previewing processing in real-time. The following sections contain several 
suggestions to remedy the situation.

Lower the Quality/speed setting

Lower the value of the Quality/speed control on the General page. When previewing lengthy impulse responses, a setting of 1 or 2 may 
be necessary; however, the quality suffers. This setting should always be returned to 5 prior to processing to maintain effect quality.

Increase the DirectX buffering size

1. Open the Acoustic Mirror dialog.

2. Right-click an empty area of the dialog outside of the four tabs and choose Configuration from the shortcut menu. The Real-Time 
Preview Configuration dialog is displayed.

3. Reconfigure the Buffers to process per second and Total playback buffers controls. Typically, lowering the Buffers to process per 
second value and increasing the Total playback buffers value reduces gapping during real-time previewing.

Close all memory-intensive applications

Real-time previewing may be limited by any additional applications operating on the desktop. To avoid this situation, close all memory-
intensive applications prior to using this effect.

Add additional RAM to the system

We recommend at least 64 MB of RAM to operate Sound Forge software and its related tools.

Add a faster floating point arithmetic processor 

Many high-speed processors are still lacking in speed when processing floating point arithmetic. We recommend using high-speed 
processors that provide exceptional floating point arithmetic for reliable real-time previewing.

Impulses do not recover properly

If you experience problems recovering custom impulse recordings, verify each of the following: 

a. Verify that you have trimmed the recorded test tone based on the mode chosen from the Impulse recovery mode drop-down 
list. For more information, see Trimming the test tone on page 176.

b. Verify that the second spike is present in the recorded test tone if the Auto-detect timing spikes options is specified.

c. Verify that the file specified in the Test file used box is the exact test tone used to make to field recording and that neither its 
length or data has been changed.

d. If the impulse still does not recover properly in Auto-detect timing spikes mode, normalize the spikes in the recorded test tone 
file. This should aid the auto-detect algorithm in detecting the timing spikes and recovering the impulse.

Recovered impulse is too noisy

To maximize the impulse’s signal-to-noise ratio, you should verify that the field recording’s noise floor is not too high. When recording 
in noisy environments, increase the test tone’s amplitude until the test tone is at least 25 dB louder than the noise floor. At least 40 dB of 
signal-to-noise is recommended for optimal impulses. If you cannot avoid noise when recording in the field, Sony Media Software’s 
Noise Reduction tool can salvage a session.
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Speaker nonlinear distortion can also cause noisy impulses. The most common source of nonlinear distortion is loudspeaker harmonics. 
Most speakers display substantial harmonic distortion at low frequencies. For example, when you play a 60 Hz tone, the speaker 
vibrates at 60 Hz, but also outputs lower-level audio at multiples of 60 Hz (120, 180, etc.). The impulse recovery method greatly 
minimizes these low-frequency distortions; however, inexpensive tweeters often display substantial high-frequency distortion that can 
disrupt the recovery process. When possible, use high-quality components and do not overdrive the speakers.

Error message explanations

The following sections briefly describe Acoustic Mirror error messages that you may encounter.

The selected file is not a valid test file

The file specified in the Test file used box is not a test tone file included on the Sound Forge application disc. 

The level of the first spike is low. Do you wish to use it as a timing spike?

This typically means that no actual timing spike was detected. Verify that the first spike is within one second of the start of the recorded 
file. If the recording is noisy and the spike is not very pronounced, you can aid detection by muting the audio immediately before and 
after the spike.

An error occurred reading the test tone file

Either the test tone file was not found or is not a valid test tone file. Always use a test tone file provided on the Sound Forge application 
disc.

The selected Recorded file is much smaller than the test tone size

This may indicate that the test tone or the recorded file specified in the Recover tab is not correct. Verify that the length of the recorded 
file roughly the same size as the test tone file. 

The end spike was not found

Verify that the spike following the test tone is present in the recorded file when recovering impulses in Auto-detect timing spikes 
mode.

What is the Wave Hammer plug-in?

Sony Media Software’s Wave Hammer DirectX plug-in is an audio mastering tool consisting of a classic compressor and a volume 
maximizer. 

The Wave Hammer tool can be used in any Microsoft DirectX-compatible host application (for example, Sound Forge and ACID® Pro 
software), and the quality and functionality of the Wave Hammer plug-in is the same in each host application; however, the method of 
previewing effects is different. Consult your host application’s documentation to determine the available previewing methods.

Displaying the Wave Hammer plug-in

To display the Wave Hammer tool, choose Wave Hammer from the Effects menu.

The Wave Hammer dialog

The Wave Hammer controls are divided into two tabs: Compressor and Volume Maximizer.
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Compressor tab

The controls on the Compressor tab are used to compress the audio signal. When applied properly, compression reduces the dynamic 
range of audio and allows you increase overall loudness. Compression has various uses. For example, applying heavy compression at a 

low threshold to electric guitar produces distortion. The controls are explained below.

Control Description
Threshold The Threshold fader is used to adjust the audio level at which compression is applied. Audio 

with levels higher than the Threshold value are compressed, while audio at levels lower than 
this value pass through the compressor uninterrupted.

Ratio The Ratio slider determines the amount of compression applied to audio signals surpassing the 
threshold. A ratio of 1:1 applies no compression to audio surpassing the threshold, while a ratio 
of 2:1 requires a 2 dB increase in actual volume to raise the processed volume 1 dB. A ratio of 
Inf:1 is considered a limiter.

Output gain The Output gain fader allows you to determine how much the audio signal is boosted 
following its compression.

Attack time The Attack time slider allows you to determine how soon after rising above the threshold the 
audio signal is attenuated.

Release time The Release time slider allows you to determine how soon after falling below the threshold the 
audio signal attenuation is interrupted.

Smart release The Smart Release slider allows you to configure the compressor to automatically increase the 
release time for sustained notes and decrease the release time for sharp transients. Setting this 
value higher increases the internal variability of the specified Release value. 

Generally, louder overall audio levels can be achieved with lower Release values. However, low 
Release values can also lead to an increase in “pumping” artifacts. Configuring a Smart Release 
value increases the release time during sustained sounds, thereby preventing release changes 
from occurring too rapidly.

Scan mode The Scan mode radio buttons allow you to specify whether Peak or RMS mode is used to 
determine the loudness of an audio file, which in turn determines the amount of compression 
that is applied. When compressing in Peak mode, the compressor applies compression where it 
detects audio signal peaks that surpass the threshold.

However, when compressing using RMS mode, the compressor processes the audio using the 
detected average RMS value of the entire file. The Root Mean Square (RMS) of audio is a 
measure of its intensity over a period of time. Therefore, the RMS level of audio corresponds to 
the loudness perceived by a listener when measured over small intervals of time. As a result, 
rapid transient peaks may not be processed when compressing in RMS mode.

Auto gain compensate When you select the Auto gain compensate check box, the compressor output is boosted by a 
constant amount derived from the Threshold and Ratio settings. This option prevents a loss in 
overall level when compressing audio.

Tip: When using the Auto gain compensate option, the Output gain fader should be used to 
fine tune the signal output level.

Use longer look-ahead When you select the Use longer look-ahead check box, the compressor scans farther ahead in 
the incoming audio to determine how much compression is needed. This results in 
compression being applied before the threshold-surpassing audio actually occurs, thereby 
allowing for a slower Attack time value. However, the pre-compression effect (fades that occur 
prior to attacks) of this option may be distracting. 

Smooth saturation Selecting the Smooth saturation check box lowers the amount of distortion caused when 
applying heavy compression. When this option is turned on, the compressed audio sounds 
warmer and not overly bright. 

Input/Output meter This meter allows you to monitor the level of the incoming and outgoing signals. When the 
Input button is displayed, the meters display the incoming signal level. Clicking Input toggles 
the button to an Output button and displays the outgoing signal level. Clicking Output returns 
you to the incoming signal display.

Attenuation meter This meter allows you to monitor the audio signal attenuation derived from the current 
settings.
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Volume Maximizer tab

The controls on the Volume Maximizer tab are used to limit the peak amplitude of an audio file or to boost the overall level without 
clipping the waveform and distorting the audio. These controls are explained below.

Control Description
Threshold The Threshold fader is used to adjust the audio level at which the volume maximizer activates. 

Audio with levels higher than the Threshold value are affected, while audio at levels lower than 
this value pass through the volume maximizer uninterrupted.

Output level The Output level fader allows you to determine the level to which peaks above the Threshold 
setting are boosted or cut.

Release time The Release time slider allows you to determine how soon after falling below the threshold the 
audio signal attenuation is interrupted.

Use longer look-ahead When you select the Use longer look-ahead check box, the volume maximizer scans farther 
ahead in the incoming audio to determine the amount of limiting that is needed. This results in 
limiting being applied before the threshold-surpassing audio actually occurs. However, the pre-
limiting effect (fades that occur prior to attacks) of this option may be distracting. 

Input/Output meter This meter allows you to monitor the level of the incoming and outgoing signals. When an 
Input button is displayed, the meters are displaying the incoming signal level. Clicking Input 
toggles the button to an Output button and displays the outgoing signal level. Clicking Output 
returns you to the incoming signal display.

Attenuation meter This meter allows you to monitor the audio signal attenuation derived from the current 
settings.
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Chapter 13
 Utilizing the Scripting Feature

You can use scripting to streamline repetitive tasks and implement customized features. When the Script Editor window 
displays, you can use it to create, edit, or run scripts.

Sound Forge® software can use scripts written using JScript, VBScript, or C# as well as scripts that have been compiled as 
DLLs.

Scripting references

Sample scripts

You can find the most recent scripting API (application programming interface) and sample scripts on our Web site http:/
/www.mediasoftware.sonypictures.com/download/step1.asp?catid=15 in the Plugin Development Kits section.

Additional scripting information

For additional information about scripting, we encourage you to check out the Sound Forge scripting forum on our Web 
site: http://www.mediasoftware.sonypictures.com/forums/ShowTopics.asp?ForumID=27
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Opening the Script Editor window

From the View menu, choose Script Editor to display the Script Editor window. You can use the Script Editor window to open, run, 
create, or edit scripts.

• Script area - Displays the current scripts written code.
• Output area - Displays text results for the current script.
• Splitter panel - Allows you to adjust the size of the output area window by dragging it up or down.

The Script Editor toolbar displays by default when you open the Script Editor window.

Open: opens the Open Script dialog. New Script Template: opens a basic C# or 
JScript template needed to write a script.

Save: saves the current script. Run Script: runs the current script.

Save As: saves the current files with a new 
name or format.

Compile Script: compiles and tests your 
script.

Script area

Output area
Splitter panel
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Opening and running a script

You can open and run a script that has already been developed.

Running a script from the Script Editor window

1. Click in the data window where you want to apply the script to establish focus.

2. From the View menu, choose Script Editor to display the Script Editor window if it isn’t already displayed.

3. Click the Open button  in the Script Editor toolbar. The Open Script window is displayed.

4. Select the script file (.vb, .js, .cs, or .dll) that you want to run. The script data is displayed in the top portion of the Script Editor 
window.

5. Click the Run Script button .

Running a script from the Scripting menu

1. Click in the data window where you want to apply the script to establish focus.

2. From the Tools menu, choose Scripting.

3. Choose a script from the submenu or choose Run Script from the submenu to browse to the script file (.vb, .js, .cs, or .dll) that you 
want to run.

Adding scripts to the Scripting menu

When you start the program, Sound Forge software looks at the Script Menu folder in the Sound Forge program folder to determine 
which scripts appear in the Scripting submenu. This folder is C:\Program Files\Sony\Sound Forge 9.0\Script Menu by default.

1. To change the contents of the submenu, add or delete scripts in the Script Menu folder.

2. From the Tools menu, choose Scripting and then choose Rescan Script Menu Folder to update the menu.

Warning: Scripts can pose a security risk to your computer. A script has the power to delete files, read files, write files, execute programs, 
access the Internet, access files on your network, and so on. Always examine the contents of a script before running it. If you don't 
understand the script, do not run it unless it comes from a trusted source. In general, take the same precautions you would take for any 
program you download from the Internet or receive in an e-mail attachment.

Tip: To prevent duplication of script files, you can use shortcuts in the Script Menu folder.
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Creating a script

Sound Forge scripting uses the Microsoft .NET framework for scripting. You can write scripts in JScript, Visual Basic .NET, or C#.

1. From the View menu, choose Script Editor to display the Script Editor window if it isn’t already displayed.

2. Click the New Script Template button  and choose 
C# or JScript. A new script is displayed in the Script Editor 
window, with what is needed to write a script.

3. Replace the /*begin here*/ text with your script.

4. Click the Compile Script button  to compile and test 
your script. If there are any errors, they will be displayed at 
the bottom of the window.

5. Click the Save button  to choose the file name and 
location that you want to use to save your script.

Editing an existing script

Editing a script in the Script Editor window should not be very 
difficult as the scripts that are included with Sound Forge 
software are fully commented to help you find and edit the 
parameters you need.

1. From the View menu, choose Script Editor to display the Script Editor window if it isn’t already displayed.

2. Click the Open button  in the Script Editor window, choose the script you want to edit and then click Open. The script data is 
displayed in the top portion of the Script Editor window.

3. Edit the script as necessary. The comments in the script will help you find the parameters you need to edit.

4. Click the Compile Script button  to compile and test your edited script. If there are any errors, they will be displayed at the 
bottom of the window.

5. Click the Save button  to replace the script you edited or click the Save As button  to save the edited script with a different 
name or in a different location.

Note: You cannot edit scripts that have been compiled as DLLs.

Note: Comments are indicated with double forward slashes: //.
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Using the Scripting toolbar

Adding or removing toolbar buttons

1. From the View menu, choose Toolbars. The Preferences dialog appears with a list of available toolbars.

2. Select the Scripting check box.

3. Click Customize. The Customize Toolbar dialog is displayed.

4. Use the controls in the Customize Toolbar dialog to add, remove, or rearrange the buttons on the selected toolbar. All scripts from 
the Script Menu folder are listed in the Available tools column.

5. Click the OK button.

If you want to Then
Add a script to the toolbar Select a script in the Available tools column and click the Add button.

Note: The script will appear before the currently selected button.
Remove a script from the toolbar Select a script in the Current tools column and click the Remove button.
Rearrange the buttons Select a script in the Current tools column and click the Move Up or Move 

Down button.

Restore the toolbar to its default setting Click the Reset button.
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Creating custom button images

You can display custom button images for the scripts that you have added to the toolbar by adding .png files to your Script Menu folder.

As an alternative to creating your own custom button images, you can use the default Script*.cs.png files, which were installed by 
default in your Script Menu folder.

1. Create a PNG file with the icon that you want to use.

2. Save the PNG file in your Script Menu folder using the same name as the name of the script that you want it to represent (i.e. to 
assign a custom icon to the HelloWorld.js script, the icon should be saved as HelloWorld.js.png)..

3. Customize the toolbar as needed. The custom icons will display on the Scripting toolbar the next time you start the application.

Running a script

You can run scripts using a single click if you have customized the Scripting toolbar to include buttons for scripts that you have created.

1. Click in the data window where you want to apply the script to establish focus.

2. Click the button of the script that you would like to run on the Scripting toolbar.

Note: Icons should be 16x16 pixels and transparency is supported.

Note: The Script Menu folder can typically be found in the following location: C:\Program Files\Sony\Sound Forge 9.0\Script Menu.

Tip: You may need to hover a button to display a ToolTip, which displays the name of the script associated with the button.
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Using the Batch Converter script

You can use the Batch Converter script to modify and manipulate audio files without having to process each file individually.

Converting using an existing batch job

1. From the Tools menu, choose Batch Converter. The Batch Converter window is displayed.

2. Open the batch job that you want to run.

a. Click the Open Job button . The Open dialog is displayed.

b. Browse to the folder where your batch job (.bj) file is saved.

c. Select a batch job and click the Open button.

3. Select the Files to convert tab and add the files that you want to process. When you start Batch Converter, any open data windows 
will be included in the list. 

4. Select the Process tab and verify the processing settings. For more information, see Creating or editing a batch job on page 192.

5. Select the Metadata tab and type values for any metadata (file information) that you want to save in the output files.

If Then
You want to add individual files Click the Add File button, browse to a file, and click the Open button.
You want to add all files within a folder Click the Add Folder button, select a folder, and click the OK button.

Note: Subfolders are not included when selecting a folder.
You want to add files by dragging Drag files from the Windows Explorer to the Files to convert tab.

Tip: When you convert files to a compressed format such as MP3, peaks that are at or near 0 dB may be clipped by the compression 
process. You may want to consider normalizing first to reduce the possibility of clipped peaks (normalizing to a peak level of -0.9 dB is 
a good starting point).

If Then
The Overwrite check box is not selected and the 
destination file already includes information for a 
metadata item

The existing information is preserved (keywords; 
however, will be appended).

The Overwrite check box is selected and the destination 
file already includes information for a metadata item

The existing information is overwritten with the 
information from the Metadata tab (existing information 
will be erased if the box is blank).

Note: If a metadata type is not supported by the output format, it will be ignored.
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6. Select the Save tab and verify the file output settings. For more information, see Creating or editing a batch job on page 192.

7. Click the Run Job button to start processing. The Batch Converter will then display the Status tab to allow you to monitor the 
progress of your batch job.

Creating or editing a batch job

1. From the Tools menu, choose Batch Converter. The Batch Converter window is displayed.

2. Create a new batch job or open the batch job that you want to edit.

3. Select the Process tab to choose the processing settings that you want to apply.

a. Choose a plug-in from the Select drop-down list and click the Add Effect button to add it to the end of the list. The plug-in 
dialog is displayed.

b. Adjust the effect’s settings and click the OK button. For more information about an individual effect’s settings, click the Help 
button  in the plug-in window.

c. Repeat steps 3a and 3b as necessary to create your effects list.

d. Perform the following actions as needed:

4. Select the Metadata tab and type values for any metadata (file information) that you want to save in the output files.

Note: If you want to convert to multiple formats at once, click the Add Save Options button to create a setting for each file type 
that you want to convert.

If Then
You want to create a new batch job Click the New Batch Job button .

You want to edit an existing job Click the Open Job button , select a batch job and click the Open button.

Tip: When you convert files to a compressed format such as MP3, peaks that are at or near 0 dB may be clipped by the compression 
process. You may want to consider normalizing first to reduce the possibility of clipped peaks (normalizing to a peak level of -0.9 dB is 
a good starting point).

If Then
You need to change an effect’s preset Select the effect in the list and click the Change Preset button.
You need to change an effect’s position in the chain Select the effect in the list and click the Move up or Move down 

button.

If Then
The Overwrite check box is not selected and the destination file already 
includes information for a metadata item

The existing information is preserved (keywords; however, will be 
appended).

The Overwrite check box is selected and the destination file already 
includes information for a metadata item

The existing information is overwritten with the information from the 
Metadata tab (existing information will be erased if the box is blank).
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5. Select the Save tab to choose file output settings for rendered files.

a. Click the Add Save Option button to create a new setting or select an existing setting and click the Change Save Options 
button. The Output Options dialog is displayed. 
 
If you want to convert to multiple formats at once, click the Add Save Options button to create a setting for each file type that 
you want to convert.

b. In the File Format section, select a radio button to indicate the format that you want to use for processed files:

c. In the File Names section, select a radio button to indicate the format that you want to use for processed files:

d. In the File Folder section, select a radio button to indicate where you want to save processed files:

e. Click the OK button.

6. Click the Save Job button  to save the updated batch job or click the Save As  button to save the edited batch job with a 
different name.

Note: If a metadata type is not supported by the output format, it will be ignored.

Button Description
Same as source Select this radio button if you want to save converted files using the same format as the original file.
Convert to Select this radio button and choose a file type from the Type drop-down list if you want to convert your files to 

a new format. The parameters that will be used for rendering your file are displayed in the Template box. You 
can click Change to choose a new template.

For any output format, choose Default Template to preserve the source file's format (sample rate, bit-depth, 
and number of channels) in the output file.

Button Description
Same as source Select this radio button if you want to save converted files using the same name as the original file.
Append to name Select this radio button and type text in the Append to name box if you want to add a descriptor to the file 

names of converted files.

The text you enter will be added to the original file name during conversion. For example, if your source file is 
C:\Audio\DoorSlam.wav, the file could be saved as C:\Audio\DoorSlam-BatchConverted.wav during 
conversion.

Button Description
Same as source Select this radio button if you want to save converted files in the same folders as the original files.
Save files to Select this radio button and type a path in the edit box (or click Browse) in the Append to name box if you 

want to save all converted files in a specific folder.

You can select the Preserve source subfolders check box if you want to use the same folder structure in your 
source and converted files. For example, if your source file is C:\Audio\DoorSlam.wav, you could specify D:\ as 
your output folder, and the file will be saved as D:\Audio\DoorSlam.wav during conversion.
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Chapter 14
 Working with MIDI/SMPTE

This chapter describes using Sound Forge® software in conjunction with internal and external MIDI devices. 

What is MIDI?

The musical instrument digital interface (MIDI) is a set of commands or a language that music software and hardware use 
to communicate. The most common way to utilize MIDI is to have a device, such as a MIDI sequencer, generating and 
sending MIDI commands to another device, such as a synthesizer. 

MIDI triggers

You can use numerous internal and external devices to generate MIDI commands and trigger audio playback in the 
software.

Playback versus triggered playback

Procedures in this section use the Sound Forge MIDI Keyboard as the MIDI device for triggering audio playback.

For more information, see Using the MIDI Keyboard on page 209.

Simple playback

When you click the Play button in the transport bar or playbar, the audio file in the active data window plays and you 
hear the audio. MIDI is not involved.

Triggered playback

When the MIDI keyboard triggers playback of the same file, the following items occurs:

• The MIDI Keyboard transmits MIDI commands to the MIDI router.
• The MIDI router transmits the MIDI commands to the Sound Forge MIDI input port. 
• The audio file plays.

Triggering file playback

Using the MIDI Keyboard or any other MIDI device to trigger audio playback involves three separate procedures:

• Configuring the MIDI device (in this case, the MIDI Keyboard).
• Enabling MIDI input synchronization.
• Configuring the MIDI trigger.

Note: In the case of triggered playback, MIDI commands may come from any software or hardware device that 
generates MIDI.
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Configuring the MIDI device

1. From the View menu, choose Keyboard. The MIDI Keyboard is displayed.

2. Open the Voiceover.pca file.

3. Click the MIDI Out button  and choose the appropriate MIDI router from the menu. 

4. Set the keyboard’s Output channel value to 1. The MIDI device is configured. 

Turning on MIDI input synchronization 

1. From the Options menu, choose Preferences. The Preferences dialog is displayed.

2. Click the MIDI/Sync tab.

3. From the Input drop-down list, choose the appropriate MIDI router and click OK.

Configuring the MIDI trigger

1. From the Options menu, choose MIDI Triggers. The MIDI Triggers dialog is displayed.

2. Select Play All from the Event list box. 

3. In the Trigger section, select the Note radio button. The Channel and Note boxes activate.

4. Enter 1 in the Channel box.

5. Enter C4 in the Note box and click OK. 

The Sound Forge software is now configured to play the Voiceover.pca file when it receives a C4 Note-On command on MIDI 
Channel 1.

MIDI Out

On/Off Note/ChordVoice Output Channel

Output Velocity
Octave
196 | CHAPTER 14



Starting playback

1. From the Options menu, choose MIDI In/Out, and choose Trigger from MIDI Timecode from the submenu. A check mark appears 
adjacent to the command, indicating that it is active and the software is ready to receive MIDI commands.

2. Click the C4 key on the MIDI Keyboard. 

The Voiceover.pca file plays in its entirety.

Resetting MIDI triggers

Once set, MIDI triggers are not permanent. They can be edited or deleted as needed. 

1. From the Options menu, choose MIDI Triggers. The MIDI Triggers dialog is displayed.

2. From the Preset drop-down list, choose Reset all triggers to (none) and click OK.

Triggering region playback

Frequently, it is preferable to use a MIDI device to control the triggering of the individual regions within a file. As in the previous 
example, the MIDI Keyboard will be used to demonstrate this function.

Configuring region playback triggers

1. Display and configure the MIDI Keyboard. For more information, see Configuring the MIDI device on page 196.

2. Set up the MIDI input synchronization. For more information, see Turning on MIDI input synchronization on page 196.

3. Open the Voiceover.pca file and display its Regions List.

4. Select the “Wow” region and press Enter. The Edit Marker/Region dialog is displayed.

5. From the Trigger drop-down list, choose MIDI: Note On - Play. 

6. Enter 1 in the Channel box and C-4 in the Note box.

7. Click OK. A small musical note appears adjacent to the “Wow” region in the Regions List to indicate that a trigger has been 
configured.

Note: Before performing this procedure, reset all triggers. For more information, see Resetting MIDI triggers on page 197.

Click the C4 key to begin playback
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8. Repeat steps 4 through 7, providing each region with a unique MIDI trigger.

Using region playback triggers

1. From the Options menu, choose MIDI In/Out, and choose Trigger from MIDI Timecode from the submenu. A check mark appears 
adjacent to the command, indicating it is active and the software is ready to receive MIDI commands.

2. Click C4 on the MIDI Keyboard. The “Wow” region plays.

3. Click other trigger keys on the MIDI Keyboard and observe how this feature can be used to play regions on cue or quickly rearrange 
an audio file.

Triggering playback from additional internal/external MIDI devices

The basic concepts of MIDI routing and triggering from the Sound Forge MIDI Keyboard described in previous sections apply to any 
hardware or software device capable of generating MIDI commands. Follow the same basic steps to trigger playback:

1. Install and configure the MIDI controller (refer to the product-specific documentation for installation procedures).

2. Set up MIDI input synchronization. For more information, see Turning on MIDI input synchronization on page 196.

3. Configure the MIDI triggers to respond to the corresponding controls on the controller. For more information, see Configuring the 
MIDI trigger on page 196.

Advantages of external MIDI controllers

In addition to simple playback, MIDI commands can be used to control a wide array of the Sound Forge navigation and editing 
functions. In fact, a quick look at the Event drop-down list in the MIDI Triggers dialog can provide you with an idea of the power of MIDI 
commands used in conjunction with Sound Forge software. 

Using external MIDI controller presets

Sound Forge system presets support the sequencer, cursor, dial, and function buttons on the following external MIDI controllers:

• Roland MCR-8 Multi-Controller
• JLCooper Media Control Station 2

The system presets for these controllers allow you to perform the following actions: 

• Move the cursor using the controller’s dial. 
• Drop markers by clicking the dial.
• Zoom in and out of the waveform using the cursor keys (vertically and horizontally). 
• Start and stop audio playback using the sequencer controls.

Note: Only one region can be played at any given time. Overlapping causes the active region’s playback to be interrupted and the new 
region’s playback to begin.

Note: Users of the aforementioned external MIDI controllers need not limit themselves to Sony Media Software’s default configurations. 

A small musical note 
indicates a region trigger
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Sound Forge software and MIDI timecode synchronization

MIDI timecode (MTC) is a method of using SMPTE timing signals to synchronize multiple devices. Although MIDI timecode is typically 
used to synchronize audio and video, it can also be used to synchronize playback devices. You can synchronize to external MTC or 
generate MTC for other devices to follow. For more information, see SMPTE Timecode on page 265.

You can also specify start times of regions in the Regions List to synchronize digital audio with additional timed events. For example, if a 
MIDI sequencer generates SMPTE timecode, you can synchronize to it with its own SMPTE timecode and initiate region playback at 
specified times. 

MTC synchronization versus Note-On MIDI triggering

Synchronizing to MTC is similar to synchronizing to other MIDI events and can be used in many of the same situations. The major 
advantage of MTC synchronization is that it allows for you to specify accurate SMPTE start times. However, MTC synchronization 
requires more of your system’s processing power. 

When triggering a limited number of sounds in the software from a sequencer, it is preferable to use Note-On MIDI Triggering. For more 
information, see Triggering file playback on page 195.

Playing regions using MTC from a sequencer

Triggering region playback in Sound Forge software from a sequencer using MTC involves three procedures:

• Configuring the regions.
• Enabling MIDI input synchronization.
• Configuring the sequencer.

Configuring the regions

1. Open the Voiceover.pca file and view the Regions List and Playlist windows. 

2. Select the “Wow” region in the Regions List and drag it to the playlist. The “Wow” region is added to the playlist.

3. Select the “Wow” region in the playlist and press Enter. The Edit Playlist dialog is displayed.

4. From the Trigger drop-down list, choose SMPTE: Play at Time. The SMPTE time box is activated.

5. Enter an appropriate SMPTE start time using the hours:minutes:seconds:frames format and click OK. A small musical note appears 
adjacent to region in the playlist to indicate that a start time for this region’s playback is configured.

Turning on MIDI input synchronization

1. From the Options menu, choose Preferences. The Preferences dialog is displayed.

2. Click the MIDI/Sync tab.

3. Specify the MIDI input that corresponds to the output port of the sequencer and click OK.

4. From the Options menu, choose MIDI Triggers. The MIDI Triggers dialog is displayed.

The “Wow” region is added to the playlist.

A small musical note 
indicates a start time
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5. From the Preset drop-down list, choose Reset all triggers to (none). This prevents other MIDI commands from creating additional 
triggers.

6. Click OK.

7. From the Options menu, choose MIDI In/Out, and choose Trigger from MIDI Timecode from the submenu. A check mark appears 
adjacent to the command to indicate that synchronization to MTC is ready. 

Configuring the sequencer

1. Set the sequencer’s MIDI output port to correspond with the Sound Forge MIDI input port.

2. Turn on the sequencer’s MTC output. If the sequencer supports generating MTC, it is now ready to sync.

3. Press the sequencer’s Play button. The Sound Forge MIDI In status box displays the same SMPTE time as the sequencer’s SMPTE 
time. At the specified SMPTE time, playback of the region is started without interrupting the sequencer’s output to other devices.

Playing regions using MTC from an external device

When using a hardware device that generates MTC, the configuration procedure is basically the same as outlined above. Simply specify 
the device’s MTC output driver as the Sound Forge MIDI input port in the Preferences dialog’s MIDI/Sync tab.

Using Sound Forge software to generate MTC for a MIDI sequencer

You can generate MTC for other devices to follow. However, it is important to understand that the software only generates MTC while 
playing a file or from a playlist. Generating MTC involves two procedures:

• Configuring the Sound Forge software.
• Configuring the sequencer.

Configuring Sound Forge software

1. Open an audio file. 

2. From the Options menu, choose Preferences. The Preferences dialog is displayed.

3. Click the MIDI/Sync tab. 

4. Specify the Sound Forge MIDI output that corresponds to the input port of the sequencer and click OK.

5. From the Options menu, choose MIDI Triggers. The MIDI Triggers dialog is displayed.

6. From the Preset drop-down list, choose Reset all triggers to (none). This prevents other MIDI commands from creating additional 
triggers.

7. Click OK.

8. From the Options menu, choose MIDI In/Out, and choose Generate MIDI Timecode from the submenu. A check mark appears 
adjacent to the command, indicating that the software is ready to generate MTC.
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Configuring the sequencer

1. Specify the sequencer’s MIDI input port that corresponds to the Sound Forge MIDI output port. 

2. Set the sequencer’s SMPTE offset time value as needed.

3. Turn on the sequencer’s MTC input.

4. If required by the sequencer, press the Play button. The sequencer does not begin playback, but switches to “Waiting for MTC” 
mode.

5. Start playback of the file in the software. When the SMPTE offset time is satisfied, the sequencer locks to and follows the MTC 
generated by the Sound Forge application.

Using Sound Forge software to generate MTC for an external device

To use the software to send MTC to an external device, follow the previous instructions, but configure the Sound Forge MIDI output port 
to send directly to the device’s MIDI driver.

Note: Sound Forge software uses 00:00:00:00 as its output start point, but certain sequencers recommend a SMPTE offset 
time of at least four seconds to ensure synchronization.
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Chapter 15
 Optimizing for Sound Forge Software

This chapter contains information on configuring your system to optimize the performance of Sound Forge® software. 

Defragmenting your hard drive

The Sound Forge application is a disk-based digital audio editor that allows editing operations to be performed on the 
system’s hard drive rather than in memory. Because of this, you are able to edit large files as well as retain extensive 
undo/redo information and clipboard data.This also means that the hard drive specified for temporary storage must have 
sufficient free space to store large quantities of data.

With time and usage, hard drives become fragmented, leading to discontiguous files and slow access. This is particularly 
true for older hard drives. Since the software is hard drive intensive, faster disk access equates better performance. 
Therefore, the initial step in improving system performance is hard drive defragmentation. The computer’s operating 
system is typically equipped with a defragmenting program that should be run prior to using Sound Forge software.

Increasing total buffer size

The total buffer size value determines the amount of RAM used for recording to/playing from the hard drive. A total 
buffer size of 512 KB is recommended, but increased buffering may be necessary if you detect gaps during playback. 

Increasing the total buffer size requires additional memory. Combined with a large preload size, this may result in a delay 

when starting and stopping playback. 

1. From the Options menu, choose Preferences. The Preferences dialog is displayed.

2. Click the Audio tab.

3. Use the Playback buffering slider to configure an appropriate buffer size value and click OK.

Turning off the playback cursor and record counter

The playback cursor and record counter options determine whether these displays are updated during recording and 
playback. If you detect dropouts and skipping at high sample rates (greater than 44,100 Hz), turn these displays off to 
minimize processing overhead.

1. From the Options menus, choose Preferences. The Preferences dialog is displayed.

2. Click the General tab.

3. Clear the Show the position of the playback cursor and Show the record counter while recording check boxes and 
click OK.

Turning off the channel (output) meters

Sound Forge channel meters use a small amount of processing overhead during playback. However, if you detect 
dropouts during playback and previous fixes have failed, try turning off these meters. 

From the View menu, choose Channel Meters. The check mark adjacent to the command is cleared, indicating that the 
channel meters are turned off.

Turning on passive updating for time and video displays

Passive update options lower the priority of redrawing the time and video displays during playback. When these options 
are turned on, the displays update only if there is ample time. Frequently this goes unnoticed, and enabling these options 
minimizes playback overhead with little or no inconvenience.
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Time displays

From the Options menu, choose Time Display, and choose Passive Update from the submenu. A check mark appears next to the 
command to indicate that this option is turned on.

Video displays

From the Options menu, choose Video, and choose Passive Update from the submenu. A check mark appears next to the command to 
indicate that this option is turned on.

Synchronizing audio and video

If your video has been opened from a slow device, such as a CD-ROM, DVD-ROM, or network drive, Sound Forge software may have 
trouble accurately playing back the audio and video in sync. You should always copy your video files to a fast hard drive. Listed below 
are a few tips that can help when trying to synchronize the audio and video:

• After assembling or editing the audio you wish to use with your video, place markers during video playback to correspond to any 
major synchronization points. You can locate a particular frame by dragging the cursor along the audio if the Video Preview window 
is open (from the View menu, choose Video Preview) or the Animate Video Strip option is enabled (from the Options menu, choose 
Video>Animate Video Strip. After primary locations have been identified, drag your audio to these markers to mix and paste audio.

• Features such as Insert Silence, Delete/Clear, and Time Stretch are commonly used to correct synchronization. Another useful trick is 
to create a region representing the offset between a video frame and audio event. Then you can enable Lock Loop/Region Length 
and drag the offset region to a preceding silent section. Use the region as a template for adjusting the audio stream length—either 
copying and pasting to insert time or deleting to remove time.
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Chapter 16
 Sampling

Used in conjunction with the Sampler Tool, the Sound Forge® software’s powerful editing capabilities allow you to create, 
edit, and transfer samples between external and internal samplers. This chapter describes the procedures used to transfer 
(dump) samples between the computer and sampler with the Sampler Tool.

Samplers

Samplers are devices that produce on-demand playback of audio samples at varying pitches. For the purposes of this 
manual, we will concentrate on two basic varieties: external samplers and internal samplers.

External samplers

External samplers are typically capable of recording samples or transferring prerecorded samples into their memory. You 
can choose between two methods to transfer samples to external samplers:

• MIDI Sample Dump Standard (SDS) 
• SCSI MIDI Device Interface (SMDI)

MIDI Sample Dump Standard (SDS)

The MIDI SDS is used to send and receive digital samples using normal MIDI hardware and cable connections. Due to the 
limited bandwidth of the MIDI protocol and the large amount of data required by digital samples, a MIDI SDS transfer can 
be time consuming. Furthermore, SDS is limited to mono samples, though certain samplers allow two mono samples to 
be joined as a stereo sample.

SCSI MIDI Device Interface (SMDI)

The SCSI MIDI Device Interface (SMDI) allows music hardware and software to communicate using SCSI hardware and 
cables. Because SCSI hardware has a greater bandwidth than MIDI, SMDI transfers are considerably faster than SDS 
transfers. In addition, SMDI supports mono and stereo sample transfers.

Internal samplers

Internal samplers are cards installed in your system that, unlike typical sound cards, actually allow sounds to be 
downloaded into memory and played at varying pitches to simulate a musical instrument. 

Using an unsupported internal sampler

If you have an internal sampler not directly supported by the Sampler Tool, you have two options:

• Use the MIDI SDS transfer protocol. 
• Use an open loop transfer.

Configuring the Sampler Tool

Configuring the Sampler Tool is fairly straightforward, especially if the desired configuration exists in the list of presets. 

Note: If you have a Windows-compatible internal sampler, contact the manufacturer about supporting SDS in Windows 
drivers.
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1. From the Tools menu, choose Sampler. The Sampler dialog is displayed.

2. From the Configuration drop-down list, choose the desired configuration. If the desired configuration is not listed, you must create 
it in the Sampler Configuration dialog. For more information, see Creating a sampler configuration on page 206.

3. Enter a value in the Logical send/receive sample number box. 

This value determines the number that the sampler uses as its location reference when sending or receiving samples. This number 
can be biased for specific samplers with the Sample bias option in the Sampler Configuration dialog. For more information, see 
Creating a sampler configuration on page 206.

4. Begin the process of sending or receiving samples. For more information, see Sending and receiving samples on page 208.

Creating a sampler configuration

The Sampler Configuration dialog allows you to create new sample configurations that can be saved as presets and accessed from the 
Sampler dialog. Creating new custom configurations requires you to specify the sampler and sample transfer mode. However, the 
process of creating a custom sampler configuration differs based on which transfer mode is used. 

1. From the Tools menu, choose Sampler. The Sampler dialog is displayed.

2. Click the Configure button. The Sampler Configuration dialog is displayed.

3. From the Sampler model drop-down list, choose the appropriate sampler. If the desired sampler is not included in the drop-down 
list, choose the generic SMDI or SDS capable sampler option. If the sampler supports the specified protocol, the Sampler Tool 
should interface with the sampler. 

4. Specify input/output settings for the sampler:

If Then
Your sampler uses MIDI/SDS transfer Select the MIDI radio button and choose input and output ports in the MIDI In and 

MIDI Out boxes

Your sampler uses SCSI/SMDI transfer Select the SCSI radio button and select your sampler in the Sampler box.
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5. If desired, enter a value in the Sample bias box. Sample bias is a user-specified value that is added to the logical sample number to 
determine the actual sample number used for sending or receiving. 

Additionally, sample bias can be used to define unique biases for multiple projects. For example, when composing multiple pieces 
using different samples, it is possible to create unique sampler configurations for each project. Simply establish a unique sample 
bias to segregate the samples within the sampler.

6. Enter a value in the MIDI channel box to specify which MIDI channel (1-16) is used when transferring samples. 

7. Select the Open loop check box if you want to send SDS sample data immediately upon clicking the Send Sample button. This is 
an unconditional transfer of sample data (no handshake). 

8. Select the Send request when retrieving samples check box if you want the Sampler Tool to send a request for the sample to the 
sampler when you click Get Sample.

Clearing the Send request check box requires that the sample transfer be initiated from the sampler, even after you click Get 
Sample. Typically, pressing the appropriate button on the sampler satisfies this request.

9. Select the Wait for request when sending samples check box if you want the Sampler tool to wait for the sampler to request the 
sample transfer before sending the sample, even after you click Send Sample. Typically, pressing the appropriate button on the 
sampler satisfies this request.

Clearing the Wait for request check box configures the Sampler Tool to send the sample as soon as you click Send Sample.

Open loop versus closed loop

Open loop describes a unidirectional communication protocol. When the Open loop check box is selected, the source transmits all data 
to the destination without listening for instruction from the destination. The destination has no control over how the data is sent and 
cannot ask for information to be repeated. This lack of feedback makes open-loop transfers prone to error.

If the Open loop check box is cleared, the communication protocol is referred to as closed loop. A closed loop allows information to 
flow in both directions. Using closed-loop transfers, the source sends data in small packets and the destination, upon receiving the 
packet, either retains the data or discards the packet and requests the data to be resent. Using closed-loop protocol, the source does 
not send the next packet of data until the destination requests it. This makes closed-loop transfers more reliable than open-loop 
transfers.

In addition to being less reliable, open-loop transfers are slower than closed-loop transfers, especially when sending samples using the 
Sampler Tool. This is due to intentional delays placed between data packets to compensate for varying sampler speeds. Closed-loop 
transfers typically guarantee the most efficient timing between packets.

If possible, avoid using an open loop to receive samples from a sampler. The Sampler Tool cannot control the flow of data packets and 
there is a high probability that data will be missed.

Note: The Sampler box lists all devices connected to the selected SCSI host, including devices that are not samplers.

Tip: Open-loop transfers can be useful when you do not have enough cables to connect both the MIDI input and MIDI output ports.

The Open Loop check box in the
Sampler Configuration dialog
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Saving sampler configurations

Once you complete a sampler configuration, you can save it as a preset and quickly access it in the future. 

1. From the Sampler Configuration dialog, click Save As. The Save Preset dialog is displayed.

2. Enter a descriptive name in the New preset name box and click OK. The new configuration is saved and can now be chosen from 
the Configuration drop-down list in the Sampler dialog.

Sending and receiving samples

Once you have accurately configured the sampler setup, you can send and receive samples using the Send Sample and Get Sample 
buttons in the Sampler dialog. 

Sending a sample

1. From the Tools menu, choose Sampler. The Sampler dialog is displayed.

2. From the Configuration drop-down list, choose the sampler configuration.

3. Enter the sample number to be sent in the Logical send/receive sample number box. The Sampler Tool takes into account the 
configuration’s sample bias and displays values for the Actual send sample number and Actual receive sample number. For more 
information, see Creating a sampler configuration on page 206.

4. Click Send Sample. Sample transfer starts. A meter in the status bar indicates the progress of the transfer. You can cancel a transfer 
at any time by clicking Cancel or pressing Esc.

Receiving a sample

1. From the Tools menu, choose Sampler. The Sampler dialog is displayed.

2. From the Configuration drop-down list, choose the sampler configuration.

3. Enter the sample number to be received in the Logical send/receive sample number box. The Sampler Tool takes into account the 
configuration’s sample bias and displays values for the Actual send sample number and Actual receive sample number. For more 
information, see Creating a sampler configuration on page 206.

4. Click Receive Sample. Sample transfer starts. A meter in the status bar indicates the progress of the transfer. You can cancel a 
transfer at any time by clicking Cancel or pressing Esc.

MIDI unity note and Fine tune

Once you specify a configuration in the Sampler dialog, the Sampler area near the bottom of the dialog displays all relevant sampler 
configuration information. 

The bottom pane of the dialog contains two additional parameters: MIDI unity note and Fine tune. 

Note: To delete a preset, choose it from the Preset drop-down list and click Delete.
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Editing MIDI unity note and Fine tune

Both values can be edited and used with samplers that support tuning information by choosing Edit Sample from the Special menu.

Using the MIDI Keyboard

With the MIDI Keyboard, you can control internal/external synthesizers and samplers from the Sound Forge application. The MIDI 
Keyboard can also be used to listen to the sounds on a synthesizer or in the synthesis section of the sound card.

Displaying the MIDI Keyboard

To display the MIDI Keyboard, choose Keyboard from the View menu. The keyboard can be resized, moved, or docked within the 
workspace.

Turning on the MIDI Keyboard

Clicking any key turns the keyboard on. If you do not hear any sound, verify that the output is connected to the MIDI Output device.

Parameter Description
MIDI unity note The MIDI unity note value indicates the pitch to which the sample is tuned. 
Fine tune The Fine tune value indicates any minor tuning differences (measured in cents) in 

the sample. 

Note: The software does not use this information.

MIDI Out

On/Off Note/ChordVoice Output Channel

Output Velocity
Octave
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Configuring the MIDI Keyboard output port and channel

1. Click the MIDI Out button  and choose an output device from the menu. 

2. Choose Send Program Changes from the menu if the keyboard will be used to choose instrument voices. A check mark appears 
adjacent to the command to indicate that this option is turned on.

3. Configure the MIDI input channel of the selected device to correspond to the keyboard’s output channel.

Troubleshooting the MIDI Keyboard

If after configuration, the keyboard fails to produce sound, check the following items:

• Verify that the output velocity of the keyboard is set to a value greater than 100.
• Verify that the MIDI input channel in the sound module is set to the same channel as the keyboard. 
• Verify that the device is configured to receive MIDI input.
• Verify the device output volume level. 
• Verify external MIDI connections, if applicable.

Specifying instruments

1. Choose Send Program Changes from the MIDI Out button  menu. A check mark appears adjacent to the command to indicate 
that this option is turned on. If this option is turned off, patches cannot be switched.

2. From the Voice drop-down list, choose the new voice and click any key.

Generating chords

You can also generate chords instead of single notes by choosing a chord structure from the keyboard’s Note/Chord drop-down list. 
Chords are generated using the specified note as the root of the chord or interval.

Note: Most MIDI devices are configurable to accept MIDI commands on any channel.

Note: Patch names are arranged as specified in the General MIDI Standard. For synthesizers not using the General MIDI convention, use 
the patch number instead of the instrument name. 

Specify the output
device from the
shortcut menu
210 | CHAPTER 16



Setting up MIDI/SDS hardware

To use MIDI/SDS protocol with an external sampler that supports MIDI/SDS, you must install a MIDI card with MIDI input and output 
ports in the system. 

1. Using a MIDI cable, connect the MIDI output port of the sampler to the MIDI input port of the MIDI card.

2. Connect the MIDI input port of the sampler to the MIDI output port of the card.

Internal samplers do not require a MIDI card and MIDI cables; however, an open-loop protocol may be required when sending samples 
to an internal sampler. The sampler’s documentation should specify the requirements for performing SDS transfers if the sampler 
supports this action.

Troubleshooting MIDI/SDS with open loop

Open-loop transfers, while not recommended for sending or receiving samples, can assist you in troubleshooting SDS hardware setup 
problems. If the Sampler Tool does not transfer data to (or from) the sampler, select the open-loop option and attempt single cable 
transfers. If open-loop transfers are successful, but closed-loop transfers are not, any of the following items may be the cause:

• The sampler does not support closed-loop transfers (handshaking).
• One or more of the MIDI cables or connections is faulty.
• The MIDI card is not receiving MIDI input (send) or sending MIDI output (receive). Interrupt conflicts are common for MIDI input.

Setting up SCSI/SMDI hardware

To use the SCSI/SMDI protocol with an external sampler that supports the SCSI/SMDI protocol under Windows 98SE, Windows Me, 
Windows 2000, or Windows XP, only a compatible SCSI adapter is needed. The computer and sampler must be powered-down prior to 
connecting or disconnecting SCSI cables to prevent damage to the computer and/or hardware. 

Troubleshooting SCSI/SMDI

A brief description of some common problems encountered with SCSI and samplers follows. 

Conflicting SCSI IDs

When connecting devices on a SCSI chain, each device must have a unique device identifier (ID). SCSI allows for up to eight unique ID 
values, numbered 0 to 7. Typically, device ID 7 is used for the internal SCSI controller card, leaving ID 0 through 6 for other devices.

The following table describes a typical SCSI configuration:

Note: This is the same configuration used to connect a MIDI keyboard to a computer for sequencing.

Note: The ID of a bootable SCSI hard drive must be set to 0.

ID Device(s)
0 Hard Drive
1 CD-ROM/DVD-ROM Drive
2-6 Samplers
7 SCSI Controller Card
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Periodic transfer failures

Messages such as “The SCSI Device is not responding” or “A problem was encountered while transferring the sample” may indicate a 
problem with a SCSI bus. 

1. From the Tools menu, choose Sampler. The Sampler dialog is displayed.

2. Click Configure. The Sampler Configuration dialog is displayed.

3. Repeat the selection of the SCSI host. This causes a series of SCSI commands to be executed that may settle the bus. 

If the problem persists, power-down and restart all equipment.

Sampler is recognized but does not transfer reliably

The following items are possible causes of unreliable SCSI transfers.

Synchronous transfer mode

Select samplers (the Kurzweil K2000 among them) do not operate properly if there is a SCSI device set to synchronous transfer mode on 
the same SCSI chain. SCSI hard drives and CD-ROMs or DVD-ROMs often have the option of using a synchronous transfer mode. If there 
is a host versus device synchronous transfer option, select the host option. Refer to the SCSI device’s documentation for more 
information.

SCSI termination

If the SCSI chain is not properly terminated, unreliable SCSI transfers may be experienced. Refer to the SCSI card and SCSI device 
documentation for more information.

Long or faulty SCSI cables

SCSI cables that are very long or not properly shielded may not operate reliably. In addition, do not use cables that are not certified SCSI 
cables.

Adaptec 1540/1542CF does not recognize a sampler

If the Adaptec 1540/1542CF does not recognize the sampler, a change may be required in the configuration of the Adaptec controller. 
Some samplers do not operate when the Reset SCSI Bus at Power-On option of the Adaptec controller is turned on. This is the default 
operation for the 1540/1542CF and must be turned off to allow the system to work with the sampler.

SCSI/SMDI-compatible menu is not displayed under Windows 98SE and Windows Me

Verify proper SCSI termination and check for multiple devices on the SCSI chain using the same SCSI ID. If this fails to solve the problem, 
Adaptec SCSI card users may need to update the system’s mini-port drivers. Adaptec has a series of updated mini-port drivers available 
for Windows 98SE and Windows Me on the Web.

After you download the file, you must create a temporary directory or folder on the system and run the WIN95MPD.EXE program. Follow 
the directions in the readme.txt file to update the drivers for the Adaptec SCSI card.

Note: Turning off the Reset SCSI Bus at Power-On option may keep other devices on the SCSI chain from resetting correctly when using 
the system’s soft boot feature. Other systems may freeze temporarily. To guarantee that devices are reset when rebooting with this option 
turned off, use the system’s reset button or power-down and up to reset the system.
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Chapter 17
 Looping

Sound Forge® software is an excellent tool for creating loops and provides the perfect compliment to Sony Media 
Software’s revolutionary ACID® line of loop-based music creation tools.

Creating loop regions in files is useful only when you intend to transfer the files to a hardware sampler that supports the 
loop regions.

Loops 

A loop is a sample or region in an audio file that is repeated during playback. Samples are finite and frequently very short 
in length. Therefore, they must be repeated (or looped) to create longer or sustaining sounds.

Sustaining and release loops

A sound envelope contains four elements: attack, decay, sustain, and release.

Typically, the sustain portion of the envelope is looped to lengthen the duration of a sound. This is referred to as the 
sustaining loop. 

While sustaining loops are useful, it is frequently necessary to create a second loop, taken from later in the envelope. This 
allows you to reproduce longer, more complex sounds, such as a piano chord struck with the sustain pedal depressed. 
This second type of loop is referred to as the release loop.

Creating a sustaining loop

1. Open the Drumhit.pca file and create a selection containing the snare hit at the beginning of the waveform. 

2. With the Loop Playback button  selected in the transport bar, click the Play Normal button  on the playbar to 
preview the loop. 

3. From the Special menu, choose Insert Sample Loop (or press Alt+Shift+L). The Edit Sample dialog is displayed.

4. Choose the Sample type by selecting the Sustaining radio button if it is not already selected. The controls in the 
middle pane of the dialog activate.

Note: Loops can also be used to repeat entire sections of music, although the playlist is better suited to this purpose.

Attack
Decay Sustain

Release

Create and preview the selection
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5. Select the Loop count radio button.

6. Enter a value of 10 in the Loop count box and click OK. The data window displays the appropriate tags in the ruler to specify the 
loop’s start and end points. The Play as Sample button  appears on the playbar.

7. Click the Play as Sample button  on the playbar. The looped snare selection repeats ten times before the cymbal crash.

Creating a sustaining loop with a release loop

To add a release loop to the sustaining loop created in the previous procedure, you must reconfigure the dialog and rearrange the loop 
tags in the data window.

Configuring the dialog

1. Right-click either of the loop tags and chose Edit from the shortcut menu. The Edit Sample dialog is displayed.

2. In the Edit Sample dialog, select the Sustaining with Release radio button.

3. Verify that the Release radio button is selected in the Loop to edit area of the dialog.

4. Select the Loop count radio button. The edit box is activated.

5. Enter a value of 5 in the Loop count box and click OK. Both loops (sustaining and release) are configured.

Arranging the loop tags

Once the dialog is properly configured to support a release loop, release loop tags are created in the data window beneath the 
sustaining loop tags. The sustaining and release loops temporarily contain identical data. 

1. Drag the sustaining loop end tag toward the left side of the data window to reveal the release loop end tag.

2. Drag the sustaining loop start tag toward the right side of the data window. This reveals the release loop start tag.

Select the Loop Count radio button 
and enter a loop count value

Loop start and 
end tags

Drag the sustaining 
loop end tag

Release loop end tag

The release loop end 
tag is revealed
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3. Arrange the loop tags so that the snare hit is contained within the sustaining loop and the cymbal crash is contained within the 
release loop.

4. Click the Play as Sample button  in the playbar. The entire file plays with the snare hit repeated ten times followed by the 
cymbal crash five times.

Looping techniques

Depending upon the source material, creating a natural-sounding loop can be a difficult task. Many factors beyond your control may 
produce distracting pops and glitches, thereby calling unwanted attention to the loop. Although looping skill is largely the product of 
practice and experimentation, there are some guidelines to consider.

Match endpoint amplitudes 

One of the easiest ways to minimize the occurrence of glitches when creating loops is to select loop endpoints that have an amplitude 
of zero. These points are known as zero-crossings. For more information, see Finding zero-crossings on page 236.

Match endpoint waveform slope

Another technique for reducing loop glitches is to avoid matching loop endpoints where the waveform slope does not match. If the 
waveform slope changes drastically, a pop plays when the sample is looped.

Match endpoint sound levels

The overall amplitude (or loudness) approaching the loop’s endpoints should be as similar as possible to prevent distracting glitches. 
Unfortunately, it is frequently difficult to avoid this problem, particularly with rapidly decaying source material. For more information, see 
Viewing loop amplitude on page 236.

Avoid very short loops

If the loop is shorter than ~50 ms (1/20 Hz), the pitch of the loop may not equal the sample pitch. Pitch-tuning a loop is accomplished by 
creating short loops with a length equal to 1/frequency. For example, a sample of pitch 440 Hz corresponds to A5 on the keyboard, 
meaning the loop can be pitch-tuned 2.27 ms. However, pitched loops do not sound like the original sample.

Arrange the sustaining and 
release loops in the data window

Non-matching slope Matching slope
LOOPING | 215



Editing loops

The loop you initially create in any situation is rarely perfect. Frequently, loops require some degree of editing before they are usable. 
Once you create a loop, you can quickly edit its beginning and end (and subsequently its length) by dragging the markers to a new 
location.

Crossfading loops

You can use the Crossfade Loop tool to loop audio from difficult source material. It allows you to crossfade the end of a loop with the 
beginning of the loop in order to create a smoother, more natural-sounding transition. In addition, you can configure the Crossfade 
Loop tool to crossfade the beginning of the audio loop with the beginning of the post-loop audio on the loop’s final pass. This smooths 
the occasionally awkward transition from looped to non-looped audio.

Using the Crossfade Loop tool

1. Open the Loop.pca file. A sustaining loop appears in the data window.

2. From the Tools menu, choose Crossfade Loop. The Crossfade Loop dialog is displayed.

3. Drag the Loop slider to configure the percentage of the loop to be crossfaded. 

4. If desired, select the Post-Loop check box and drag the slider to configure the percentage of the loop to be crossfaded into the 
post-loop audio. 

5. From the Preview mode drop-down list, specify how the Preview button operates: Loop the Loop, Play Loop through Post-Loop, 
or Play as One Shot. 

6. Preview and tune the crossfade until you cannot detect the loop transitions.

7. Click OK. 
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Creating loops for ACID software

The Sound Forge application is an excellent tool for creating and editing loops to be imported into any of the ACID family of products. 
You can create four different types of files for ACID use:

• One-shot file
• Loop file
• ACID 2.0 disk-based file
• ACID 3.0 or later beatmapped file

Creating an ACID one-shot file

One-shots are files that do not stretch with tempo or change pitch to match the key of the ACID project. This behavior makes one-shots 
particularly suited for audio such as cymbal crashes, sound effects, and short vocal lines.

1. Open the Voiceover.pca file.

2. Create a selection containing the “Wow” and drag it to the workspace. A new data window is created containing the “Wow” audio 
data.

3. From the Special menu, choose Edit ACID Properties. The Edit ACID Properties dialog is displayed.

4. Select the One-Shot radio button and click OK.

5. From the File menu, choose Save As and save the file with a descriptive name. 

Creating an ACID loop file

Loops are musical building blocks and are by far the most common type of file used in the ACID application. Loops stretch with an ACID 
project’s tempo and can be configured to change pitch. When creating Sound Forge files for use in ACID software, the Edit ACID 
Properties dialog defaults to the loop setting.

1. Open the Voiceover.pca file.

2. Create a selection containing the “And easier” and drag it to the workspace. A new data window is created containing the “And 
easier” audio data.

3. From the Special menu, choose Edit ACID Properties. The Edit ACID Properties dialog is displayed.

4. Select the Loop radio button. The Root note for transposing and Number of beats boxes activate.

5. Choose one of the following options:

6. In the Number of beats box, specify the length of the loop in beats. The default value is four beats.

7. Click OK. 

8. From the File menu, choose Save As and save the file with a descriptive name. 

If Then
The loop should be transposed when inserted in an 
ACID project

Choose it’s root note from the Root note for 
transposing drop-down list.

The loop should not be transposed in an ACID project Choose Don’t transpose from the drop-down list.

Select the Loop radio button
LOOPING | 217



Creating an ACID 2.0 disk-based file

ACID 2.0 disk-based files can stretch to comply with an ACID project’s tempo, but require that you specify the file’s original tempo upon 
configuration. If the original tempo is not specified in the Edit ACID Properties dialog, no stretching occurs. 

While ACID 2.0 disk-based files can change tempo, they cannot change pitch. Disk-based files are typically used in ACID 2.0 software for 
extended vocal tracks or other long audio files that do not loop.

1. Open the Voiceover.pca file and select the entire waveform.

2. From the Special menu, choose Edit ACID Properties. The Edit ACID Properties dialog is displayed.

3. Select the ACID 2.0 Disk-Based radio button. The Tempo check box activates.

4. If the file should stretch to match the ACID 2.0 project’s tempo, select the Tempo check box. The Tempo box activates.

5. Specify the file’s original tempo (60-240 bpm) in the Tempo box and click OK. For more information, see Setting loop tempo on page 
221.

6. From the File menu, choose Save As and save the file with a descriptive name. 

Creating an ACID beatmapped file

ACID beatmapped files can change tempo and pitch to match an ACID project. You must specify the file’s original tempo and root note 
for transposing upon configuration. If you do not specify these values, no tempo or key changes occur. Beatmapped files are typically 
used in ACID software version 3.0 or later for extended vocal tracks or other long audio files that do not loop.

1. Open the Voiceover.pca file and select the entire waveform.

2. From the Special menu, choose Edit ACID Properties. The Edit ACID Properties dialog is displayed.

3. Select the ACID Beatmapped radio button. Complete the information for an ACID beatmapped file:

• Select a value from the Root note for transposing drop-down list so that the ACID application can transpose the file to match 
the project key. Select Don’t transpose from this list to keep the key from being changed.

• Specify the file’s original tempo (40-300 bpm) in the Tempo box so that the ACID application can stretch the file to match the 
project tempo. For more information, see Setting loop tempo on page 221.

• Enter a value in the Downbeat offset (samples) box to indicate the location of the first downbeat.

4. Click OK.

5. From the File menu, choose Save As and save the file with a descriptive name. 
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Using the ACID Loop Creation Tools toolbar

The ACID Loop Creation Tools toolbar provides quick access to the commands used to create and edit files for the ACID software. 

1. From the View menu, choose Toolbars. The Preferences dialog appears with a list of available toolbars.

2. Select the ACID Loop Creation Tools check box and click OK.

Editing loops for ACID software

You can use a number of tools to prepare audio for use in ACID software.

Halving or doubling a loop

These commands allow you to quickly change the size of a selection.

Halving a loop

From the Special menu, choose ACID Looping Tools, and choose Halve Selection from the submenu.

Doubling a loop

From the Special menu, choose ACID Looping Tools, and choose Double Selection from the submenu.

Edit ACID Properties: displays the Edit ACID 
Properties dialog.

Shift Selection Right: shifts the current 
selection to the right so the current end point 
becomes the start point.

Edit Tempo: calculates the musical tempo 
(beats per minute) based upon the current 
selection.

Rotate Audio: moves the current selection to 
the opposite end of the file.

Double Selection: doubles the size of the 
current selection.

Selection Grid Lines: toggles the selection 
grid line display on/off.

Halve Selection: divides the current selection 
in half.

Tempo: displays the current loop tempo.

Shift Selection Left: shifts the current 
selection to the left so the current start point 
becomes the end point.

Tip: You can also click the Halve Selection button  on the ACID Loop Creation Tools toolbar or press ; (semicolon key). 

Tip: You can also click the Double Selection button  on the ACID Loop Creation Tools toolbar or press ‘ (apostrophe key).

Loop Half loop Double loop
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Shifting a selection left or right

The shift selection commands allow you to quickly create a new selection adjacent to the current selection while maintaining the size of 
the original.

Creating a new selection to the left of the current selection

From the Special menu, choose ACID Looping Tools, and choose Shift Selection Left from the submenu.

Creating a new selection to the right of the current selection

From the Special menu, choose ACID Looping Tools, and choose Shift Selection Right from the submenu.

Rotating audio

You can move the beginning of a loop to the end, or the end of a loop to the beginning by rotating the audio. From the Special menu, 
choose ACID Looping Tools, and choose Rotate Audio from the submenu.

• If no audio is selected, Rotate Audio transfers the first 25% of the loop to the end of the loop.

• If audio is selected from the start of a loop, Rotate Audio transfers the selection to the end of the loop.

• If audio is selected from the end of a loop, Rotate Audio transfers the selection to the start of the loop.

Tip: You can also click the Shift Selection Left button  on the ACID Loop Creation Tools toolbar or press <.

Tip: You can also click the Shift Selection Right button  on the ACID Loop Creation Tools toolbar or press >.

Notes: 

• You can also click the Rotate Audio button  on the ACID Loop Creation Tools toolbar or press : (colon).
• If the selected audio does not originate from the start or end of a loop, Rotate Audio has no effect.
• Rotating the audio has different effects, depending on what is selected.
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Setting loop tempo

You can calculate, and if necessary edit, the tempo of your loops. Loop tempo is especially important if the loop will be used for building 
a project in any ACID product. For more information, see Creating loops for ACID software on page 217.

Calculating loop tempo

1. Select the loop.

2. From the Special menu, choose Edit Tempo. The Edit Tempo dialog is displayed.

3. Specify the number of beats the loop represents in the Selection length in beats box.

4. Click the mouse pointer in the Tempo in beats per minute box. The loop tempo calculates and displays.

Calculating loop tempo using the ACID Loop Creation Tools toolbar

To calculate loop tempo using the ACID Loop Creation Tools toolbar, select the looped audio in the data window. The tempo pane 
indicates the loop tempo based on the current Beat Length value.

Saving loop points

To save loop information with the file, select the Save metadata with file check box in the Save As dialog. For more information, see 
Using the Save As/Render As dialog on page 52. 

Loop tempo displays

in the Tempo pane
LOOPING | 221



222 | CHAPTER 17



Chapter 18
 Working with Video

Sound Forge® software supports opening and saving Microsoft® Audio and Video Interleave (AVI), Windows Media® 
Video (WMV), QuickTime® (MOV), and MPEG video files. You can edit a video file’s audio track with single-frame accuracy. 

Viewing video

You can view the video portion of a file in the data window’s video strip and in the Video Preview window. You can also 
view video on an external monitor.

Using the video strip

Though Sound Forge software does not perform video editing, the video strip display allows you to navigate video files. 

By default, the video strip displays when you open a file containing video. If the video strip is not displayed, right-click the 
data window’s Edit Tool Selector and choose Video from the shortcut menu. A check mark appears adjacent to the 
command and the video strip is displayed. To hide the video strip, choose Video from the shortcut menu again.

Changing video strip height

You can change the video strip height by dragging the thin bar at the bottom of the video strip. To change the default 
height for all video files you open, choose Preferences from the Options menu and set a Default video strip height on 
the Display tab.

Enabling frame animation

When playing a video file, you can specify whether frames are animated or displayed as still frames. To turn on frame 
animation, right-click the video strip and choose Animate from the shortcut menu. A check mark appears adjacent to the 
command to indicate this feature is turned on.

Using the cursor to select a frame

When frame animation is turned on, clicking anywhere within the audio portion of the data window displays the 
corresponding video frame in the video strip. To move the cursor by single frames, press Alt+  or Alt+ .

Video 

Thumbnail

Right-click the Edit Tool Selector
to view the video strip

Small triangle indicates 
the location of the frame
on the timeline

strip

Drag the bar below the video strip
to change the video strip height.
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Viewing frame numbers

You can display frame numbers on each frame in your video strip, which can assist you in 
positioning your audio. As you zoom in more tightly, each frame in the strip represents one frame in 
the video.

1. Open a video file and display the video strip.

2. From the Options menu, choose Video, and then choose Number Frames. A check mark 
appears next to this option on the menu when the feature is enabled, and a small box with a 
number appears at the bottom of each frame. The small black arrow marks the exact position of the frame.

3. Using the data window’s zoom ratio controls, zoom in/out on the waveform several times and observe the numbering of the video 
frames.

Animating the video strip

During playback of a video file, the video strip can display animated or still frames. This can visually aid in editing and positioning your 
audio to match the video. From the Options menu, choose Video, and then choose Animate Video Strip (or right-click the video strip 
and choose Animate from the shortcut menu). A check mark appears next to this option on the menu when the feature is enabled. 
When the video strip is animated, the video strip always displays the frame that corresponds to the cursor position. Press Alt+  or  
to move the cursor one frame.

When frame animation is turned off, the video strip always shows the frame that corresponds to the left edge of each image in the video 
strip.

Copying the current video frame to the clipboard

You can use the clipboard to copy the video frame at the current cursor position. From the Options menu, choose Video, and then 
choose Copy Frame (or right-click the video strip and choose Copy Frame from the shortcut menu). The current frame is copied to the 
clipboard.

Previewing files with video

If you are working with a media file that contains video, you can use the Video Preview window for previewing. You must have the Video 
Preview window displayed to preview the audio stream. You can hide or display the Video Preview window by choosing Video Preview 

from the View menu. To begin previewing the current data window, click the Play All button  on the transport bar.

Tip: You can also right-click the video strip and choose Number Frames from the shortcut menu.

Tip: Select a frame number format by choosing Preferences from the Options menu and selecting an option from the Frame 
numbering on thumbnails drop-down list on the Video tab.

Tip: If you experience slow or stuttering video preview, turn off animated video to reduce the load on your CPU.

Tip: To display the Video Preview window, press Alt+4.

Frame 
number
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Changing the Video Preview settings

The Video Preview window can be configured in a number of ways to make it more useful. The Video Preview window can be used on a 
separate monitor (if your video hardware supports this feature), docked at the bottom of the workspace, or floated freely on the screen.

You can quickly access settings for the Video Preview window using the shortcut menu. Right-click the Video Preview window to adjust 

the following options:

Resizing the Video Preview

Double-click the title bar of the Video Preview window to automatically resize the window to fit the current video file. Double-click the 
title bar again to resize the window to half its previous size. This smaller size window allows for faster video frame previewing.

Option Description
Copy Frame Copies the contents of the frame to Windows Clipboard.
Default Background Sets the Video Preview window background color to the system default color.
Black Background Sets the Video Preview window background color to black.
White Background Sets the Video Preview window background color to white.
Integral Stretch When selected, the Video Preview frame will only be stretched by integral amounts. Turning this setting on usually provides faster 

drawing.
Simulate Device 
Aspect Ration

Compensates for any spatial distortion due to non-square pixel aspect ratios when viewed on a computer monitor.

External Monitor Sends the preview out to an external monitor. This only functions if your hardware supports this feature. If you have not configured your 
external monitor settings, clicking this button displays the Video tab of the Preferences dialog, allowing you to choose your external 
monitor device. For more information, see Configuring your video settings on page 228.

Important: Pulldown is automatically added when you preview 24p video on an external monitor.
Passive Update Reduces the overhead needed to update the Video Display window. The Video Display is updated when the processor is idle.
Show Toolbar Toggles the display of the toolbar at the top of the window.
Show Status Bar Toggles the information display at the bottom of the window.

Copies the current frame to the clipboard

Sets up previewing on an external monitor

Original Frame Size

Current Display Size

Frame Rate

Frame Number

Video Preview window
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Using an external monitor

You have the option of viewing video on an external monitor. To use this feature, you must have an OHCI-compliant IEEE-1394 DV 
interface and a device to convert the DV signal to video, such as a DV camcorder, deck, or media converter.

1. From the Options menu, choose Preferences and click the Video tab (or click the External Monitor button  on the Video 
Preview window).

2. From the External monitor device drop-down list, select the appropriate device.

3. Click Properties and adjust the following settings as needed:

4. Click Close to close the External Monitor dialog.

5. Click OK to close the Preferences dialog.

Attaching video to an audio file

Once you have edited an audio file to your satisfaction, you can attach it to a video file and save it as a video file.

1. Open the audio file you want to use. For more information, see Getting media files on page 44.

2. From the File menu, choose Properties. The Properties dialog is displayed.

3. Click the Video tab. 

4. On the Video page, click the Attach button. The Open dialog is displayed. 

5. Locate and select a video file you want to attach, and click the Open button. The Open dialog closes and you return to the Video 
page.

6. Click Apply to attach the video file.

7. To change the field order setting for the video file, choose an option from the Field order drop-down list. The options are 
explained below:

8. To change the video’s pixel aspect ratio, choose an option from the Pixel aspect ratio drop-down list. The pixel aspect ratio should 
be based on the destination and use of the final media file.

Note: Pulldown is automatically added when you preview 24p video on an external monitor.

If Then
Your source media does not conform to DV standards Choose a setting from the If project format is invalid for DV output, conform to 

the following drop-down list. The video is automatically adjusted to display 
properly on your external monitor

Your audio is not synchronized with your external 
monitor

You can configure an offset for your hardware. Drag the Sync offset (frames) slider 
to synchronize audio and video. This setting affects synchronization for previewing 
on an external monitor only; audio and video synchronization in the file is 
unaffected.

Option Use
None (Progressive) For video to be viewed on a computer monitor.
Lower Field First For DV output
Upper Field First For output that is jittery or shaky, or if specified by your hardware manual.
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9. Click OK to close the Properties dialog.

Detaching video from an audio file

You can detach the video stream from a media file.

1. Open the media file you want to use. For more information, see Getting media files on page 44.

2. From the File menu, choose Properties. The Properties dialog is displayed.

3. Click the Video tab.

4. On the Video page, click the Detach button.

5. Click OK. The video stream is removed, and the video strip is hidden.

Setting video options

Video file properties

The video properties for a file affect how video is displayed and rendered when you save the file. In most situations, you can leave these 
settings at their default values. However, you can adjust the video properties of a file as needed.

1. From the File menu, choose Properties.

2. Click the Video tab.

3. Choose a setting from the Field order drop-down list. This setting affects how the video is displayed and rendered when you save 
the file.

• None (progressive scan) treats video as non-interlaced.
• Upper field first treats video as interlaced and reads the interlaced video as upper field first.
• Lower field first treats video as interlaced and reads the interlaced video as lower field first.

4. Choose a setting from the Pixel aspect ratio drop-down list to determine the ratio used to display and render the video. In most 
cases, this value is auto-detected for you.

5. Click OK.

Note: The file must be saved in a video file format to permanently attach the video. For more information, see Saving a video file on page 
228.

Note: The Field order setting remains in effect only as long as the file is open; the setting is not retained when you save or close the file.
WORKING WITH VIDEO | 227



Configuring your video settings

You can use the Video tab on the Preferences dialog to choose your video settings. From the Options menu, choose Preferences, and 
then click the Video tab.

The items on this tab are explained below.

Saving a video file

1. From the File menu, choose Save As. The Save As dialog is displayed.

2. From the Save as type drop-down list, choose a video file format. 
3. Name the file in the File name box.

4. Select or clear the following check boxes as needed:

• Stretch video to fill output frame (do not letterbox): Selecting this check box stretches the source video frame if the 
destination frame size differs. When this check box is cleared, letterboxing or pillarboxing is used to keep the frame aspect 
correct.

• Fast video resizing: Selecting this check box speeds the process of saving video. When this check box is cleared, the time 
required to save the file can increase dramatically. Clear this check box only when you have critical material where nothing but 
the highest quality video rendering will do.

5. From the Template drop-down list, select a template for rendering and compressing the file. 

You can click Custom to customize the settings in the Custom Settings dialog. For help on the different settings, click the Help 
button  or press Shift+F1. Click OK to close the Custom Settings dialog and return to the Save As dialog.

6. Click Save. 

Items Description
Resample source video when 
rendering to a higher frame rate

Select this check box if you want to interpolate video frames when you render to a frame rate that is greater than the 
source file's frame rate.

Deinterlace method Choose a setting from the drop-down list to determine how the two fields that make up a video frame are separated when 
you render to a progressive format:

• Blend Fields: Maintains the data in the two fields by blending them together. This method can produce a smooth, 
motion-blurred image.

• Interpolate: Deletes one field and uses the remaining field to interpolate the deleted lines. This produces sharper 
images than Blend Fields but can introduce jagged motion or stair-stepping artifacts.

Allow pulldown removal when 
opening 24p DV

If you want to automatically remove pulldown fields when opening 24 fps progressive-scan DV video files, select this check 
box. To open your 24p DV video files as 29.97 fps interlaced video (60i), clear this check box.

Frame numbering on thumbnails This drop-down list determines how the frame information is displayed on the video strip when you have frame number 
display enabled. To display frame numbers, choose the Frame number option. To display timecode, choose the Media 
timecode option.

External monitor device Allows you to identify an external video device with which Sound Forge software can communicate. This video device is 
used to display previews on an external monitor.

Important: Pulldown is automatically added when you preview 24p video on an external monitor.

Tip: You can save the custom settings to use again by entering a template name in the Template box and clicking the Save Template 
button .
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Chapter 19
 Using Spectrum Analysis 

This chapter introduces you to the concept of frequency and describes the Sound Forge® Spectrum Analysis. Spectrum 
Analysis allows you to examine audio frequencies and overtones using either spectrum graphs or sonograms. 

Working in the frequency domain 

Unlike the waveform display, which represents audio in the time domain (amplitude vs. time), Spectrum Analysis allows 
you to examine sound by representing the sound in the frequency domain (amplitude vs. frequency).

Consider the following graphic, which depicts the same audio event as a waveform and as a spectrum graph.

Data displayed in the frequency domain (whether in the form of a spectrum graph or sonogram) shows the amplitudes 
and frequencies of sine waves that, if mixed together, would sound much like the original sound. Since it’s relatively easy 
to remember how a sine wave sounds at different frequencies, it’s possible to visualize how simple waveforms sound by 
looking at the spectrum of the sound.

Learning to “read” the frequency components of a sound in conjunction with their corresponding amplitudes makes it 
possible to determine the fundamental frequency of a sound, as well as its overtones. Similarly, you can identify 
unwanted noise, thereby allowing filtering to be applied where needed.

Fast Fourier Transform

A Fourier transform is computationally intensive, and for this reason it is common to use a technique called a Fast Fourier 
Transform (FFT) to perform spectral analysis. The FFT utilizes mathematical shortcuts to reduce the processing time at the 
expense of putting limitations on the analysis size.

The analysis size, also referred to as the FFT size, indicates the number of samples from the audio signal used in analysis 
and also determines the number of discrete frequency bands. When a large number of frequency bands are used, the 
bands have a smaller bandwidth and this provides for more accurate frequency readings.

However, since complex sounds have a rapidly changing spectrum, a large analysis size can blur the time-changing 
frequencies of a sound. For example, when performing FFT analysis of an audio file sampled at 44,100 Hz using an 
analysis size of 4096, almost 100 milliseconds (44,100/4096) of sound are analyzed. If the sound is not constant for those 
100 milliseconds, it is impossible to focus on the instantaneous spectrum at smaller time intervals. This is the trade-off 
between time resolution and frequency resolution encountered when analyzing audio signals.

Spectrum Analysis allows you to perform precise FFT analysis and displays the resulting data in a spectrum graph or a 
sonogram display. The spectrum graph allows real-time monitoring of playback or input, while the sonogram displays a 
playback cursor for real-time preview. Both formats make it easy to navigate data and read audio frequency and position.

Waveform display

Spectrum graph
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Using a spectrum graph

In the spectrum graph, the horizontal axis represents frequency in Hertz (Hz), while the vertical axis represents amplitude in decibels 
(dB).

Displaying a spectrum graph

1. Open an audio file.

2. Select the portion of the waveform you want to analyze. The sound or note you want to analyze should be in the center of the 
highlighted area.

3. From the View menu, choose Spectrum Analysis. The Spectrum Analysis window is displayed.

4. Use the toolbar at the top of the window to set your display options.

The spectrum graph displays the amplitude (in dB) of each frequency component from 0 Hz (DC) to the Nyquist frequency. 
Frequency is displayed along the X (horizontal) axis, and the amplitude is displayed along the Y (vertical) axis.

Note: Analyzing long sections of audio can take a long time and decreases the time resolution, so your selection should be relatively 
short. Also, if the audio has a low amplitude level, you can boost it by using the Volume or Normalize functions. For more information, see 
Volume on page 156 and Normalize on page 151.

Tip: You can also click the Settings button ( ) in the Spectrum Analysis window to set additional options.

Tip: You can continue to make selections in the sound file with the Spectrum Analysis window open (just move the cursor or make 
selections as you normally would). Click the Refresh button ( ) in the Spectrum Analysis toolbar to update the display. If no selection is 
made, analysis is performed on the samples immediately following the cursor position.
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Monitoring an input and output source

Click the Real Time Monitoring button  to turn real-time spectrum analysis on or off. Click the down arrow next to the button and 
choose a command from the menu to specify whether you want to monitor your sound card’s input or output:

• When you choose Monitor Input, Sound Forge will monitor the recording devices selected on the Record page of the Audio tab in 
the Preferences dialog. For more information, see Audio tab on page 248.

• When you choose Monitor Output, Sound Forge will monitor the playback devices selected on the Playback page of Audio tab in the 
Preferences dialog. For more information, see Audio tab on page 248.

Viewing frequency and amplitude values, notes and statistics

As you move the cursor through the spectrum graph, the amplitude and frequency values at the current position are displayed in a 
ToolTip next to the cursor and in the Statistics area at the bottom of the window:

Right-click the graph and choose Show Position from the shortcut menu to toggle the display of ToolTips. The setting for each graph in 
a multichannel file is independent.

If you want to display the nearest musical note equivalent of the cursor position in a ToolTip, right-click the graph and choose Show 
Notes from the shortcut menu:

Right-click the Spectrum Analysis window and choose Show Statistics from the shortcut menu to toggle the display of the Statistics 
area at the bottom of the Spectrum Analysis window.

Notes:

• When Monitor: Output is selected, the post-processing signal is monitored when you start playback from the Plug-In Chainer.
• Real-time spectrum analysis can require significant processing power. If the spectrum graph’s refresh rate seems sluggish, set the display 

mode to Line Graph, decrease the FFT size, or turn off snapshots.

Use the cursor to 
display amplitude and 
frequency values

Statistics area

Use the cursor to display 
musical note equivalent
USING SPECTRUM ANALYSIS | 231



Navigating a spectrum graph 

After a spectrum graph displays, Grab/Pan mode allows you to scroll vertically and horizontally. To enable Grab/Pan mode, right-click 
the Spectrum Analysis dialog and choose Grab/Pan from the shortcut menu. A check mark appears next to this option when Grab/Pan 

mode is enabled. The cursor displays as a hand , and you can drag horizontally or vertically to scroll through the graph. 

When you are zoomed into a selection of the spectrum graph, you can drag the horizontal and vertical sliders to scroll through the 
graph. The thumbnail image in the lower-left corner of the Spectrum Analysis window will show you which part of the graph is being 
displayed.

To turn off Grab/Pan mode, choose Grab/Pan from the shortcut menu again.

Changing the graph type

Click the down arrow next to the Normal Display button  and choose Line Graph, Filled Graph, or Bar Graph from the menu to 
change the type of graph displayed in the Spectrum Analysis window. A check mark is displayed next to the selected graph type.

If you’re analyzing a multichannel file, you can click the down arrow next to the Normal Display button and choose Single Graph to see 
all channels in a single graph.

Right-click the graph and choose Logarithmic from the shortcut menu to toggle the x-axis between logarithmic and linear mode. In 
logarithmic mode, more of the graph is devoted to lower frequencies.

Changing the zoom level of the graph

Zooming can be accomplished in several ways:

1. Drag on the graph to draw a box around the area you want to magnify. You can toggle through mouse selection mode by right-
clicking while holding the left mouse button:

• The first type is a vertical zoom window. This will allow you to zoom to a frequency range.
• The second type is horizontal zoom window. This will allow you to zoom to an amplitude range.
• The third type is a combination of vertical and horizontal zoom. This will allow you to zoom to a frequency and amplitude 

range.

2. Right-click the graph and choose Zoom Out Full to view the entire amplitude and frequency range.

3. Right-click the graph and choose Normalize dB to set the Spectrum Graph amplitude range equal to the maximum and minimum 
values in the graph.

Synchronizing graphs in a multichannel file

When viewing a spectrum graph for a multichannel file, an individual graph displays for each channel. Click the Sync button  to 
synchronize the displays so you can view the same region of the FFT in all channels.

Updating a spectrum graph

Select the Auto Refresh button  if you want the Spectrum Analysis display to refresh automatically updated when you change your 
selection in the data window.

When the button is not selected, the display is not updated until you click the Refresh button .

If you want the graph to refresh automatically during playback or input monitoring, select the Real Time Monitoring button .

Note: Some video drivers have problems displaying Filled Graph and Bar Graph modes. If you encounter problems such as incorrect 
shading or very slow drawing, use the Line Graph option or change video drivers.
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Viewing multiple spectrum graphs

Once you create a selection in the data window, you can display up to 64 individual spectrum graphs (each representing a specific point 
in time). 

1. Open an audio file. 

2. From the View menu, choose Spectrum Analysis. The Spectrum Analysis window is displayed.

3. Click the Settings button . The Spectrum Settings dialog is displayed. For more information, see Adjusting Spectrum Analysis 
settings on page 237.

4. Type a number in the Slices displayed box. The Forward and Backward radio buttons activate.

5. Select either the Forward or Backward radio button. 

• Selecting the Forward radio button displays the first slice of the selection in the foreground of the spectrum graph. 
• Selecting the Backward radio button displays the last slice of the selection in the foreground of the spectrum graph.

6. Click OK. 

7. Use the Slice slider to add/remove slice graphs in the Spectrum Analysis dialog.

Creating and comparing snapshots of the Spectrum Analysis window

You can store up to four snapshots to compare multiple spectrum graphs. You can take snapshots from a single data window or from 
different data windows.

Taking a snapshot

1. Navigate to the portion of the graph you want to capture.

2. Click the Set button, and then click a snapshot button  in the Spectrum Analysis toolbar. 

Available snapshots buttons are displayed in black, and buttons that are in use are displayed in blue and underlined.

Showing and hiding snapshots

1. Select a numbered button in the Spectrum Analysis toolbar to display a stored snapshot. All selected snapshots will be displayed in 
the Spectrum Analysis window at the same time.

2. Click a selected snapshot button to exclude it from the display.

3. Select the Hide active plot button  to hide the current spectrum so you can concentrate on your snapshots.

Note: Snapshots are not available in sonogram display or when the Slices displayed setting in the Spectrum Settings dialog is greater 
than 1.

Use the Slice slider 
to add or remove 
slice graphs
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Erasing snapshots

You don't need to erase individual snapshots to update or replace them. Simply click the Set button , and then click a snapshot 

button  in the Spectrum Analysis toolbar to update its image.

If you want to erase all snapshots, click the Clear all snapshots button .

Viewing snapshot statistics

Information about each snapshot is displayed at the bottom of the Spectrum Analysis window:

Printing the graph

Click the Print button  to print the contents of the Spectrum Analysis window, including the graph and statistics data.

Using a sonogram

The sonogram is another way of displaying spectral data variations over time. In a sonogram, the X (horizontal) axis represents time, and 
the Y (vertical) axis represents frequency. 

The amplitude of each frequency component in the sonogram is represented by the color intensity of each point in the graph. This 
method of displaying spectral information is useful for identifying distinctive spectral patterns created from sounds such as speech, 
musical instruments, and ambient noise.

Displaying a sonogram

1. Open an audio file and select the portion of the waveform you want to analyze. The sound or note you want to analyze should be 
in the center of the highlighted area.

2. From the View menu, choose Spectrum Analysis. The Spectrum Analysis dialog is displayed.

3. Click the Sonogram button  to display your data as a sonogram.

Note: Analyzing long sections of audio can take a long time and decreases the time resolution, so your selection should be relatively 
short. Also, if the audio has a low amplitude level, you can boost it by using the Volume or Normalize functions. For more information, see 
Volume on page 156 and Normalize on page 151.

Sonogram
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4. Use the toolbar at the top of the window to set your other display options.

If there is no selection in the waveform display window, the sonogram analyzes the sound data from the current cursor position to the 
end of the file.

Displaying frequency and amplitude values, notes and statistics

As you move the cursor through the sonogram, the amplitude and frequency values at the current position are displayed in a ToolTip 
next to the cursor and in the Statistics area at the bottom of the window:

Right-click the sonogram and choose Show Position from the shortcut menu to toggle the display of ToolTips. The setting for each 
sonogram in a multichannel file is independent.

If you want to display the nearest musical note equivalent of the cursor position in a ToolTip, right-click the sonogram and choose Show 
Notes from the shortcut menu:

Right-click the Spectrum Analysis window and choose Show Statistics from the shortcut menu to toggle the display of the Statistics 
area at the bottom of the Spectrum Analysis window.

Updating a sonogram

A sonogram updates in the same method as a spectrum graph. For more information, see Updating a spectrum graph on page 232.

Tip: You can also click the Settings button  in the Spectrum Analysis window to set additional options.

Use the cursor to display 
amplitude and frequency 
values

Statistics area

Use the cursor to display 
musical note equivalent
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Monitoring an input and output source

Click the Real Time Monitoring button  to turn real-time spectrum analysis on or off. Click the down arrow next to the button and 
choose a command from the menu to specify whether you want to monitor your sound card’s input:

• When you choose Monitor Input, Sound Forge will monitor the recording devices selected on the Record page of the Audio tab in 
the Preferences dialog.

• When you choose Monitor Output, a cursor is displayed in the sonogram to indicate the play position (real-time output monitoring is 
not available in sonogram display mode).

Tuning a sonogram

It is frequently necessary to experiment with the control parameters in the Spectrum Settings dialog to produce the best possible 
sonogram. For more information, see Adjusting Spectrum Analysis settings on page 237.

Improving the graph’s contrast

To improve the contrast of the sonogram, decrease the frequency and amplitude ranges as much as possible.

Smoothing the graph’s display

If the graph appears too pixelated, raise the Set sonogram resolution value to 200. 

Improving the frequency resolution

For greater frequency resolution, choose a higher value from the FFT size drop-down list. 

Reducing the processing time

To reduce processing time, decrease the Set sonogram resolution value and/or choose a lower value from the FFT size drop-down list. 

Adjusting color intensity

Adjust the sonogram’s color intensity using the Color slider located directly beneath the 
sonogram. Notice that the bottom pane of the dialog depicts the color scale in dB.

Synchronizing sonograms in a multichannel file

When viewing a sonogram for a multichannel file, an individual graph displays for each channel. Click the Sync button  to 
synchronize the displays so you can view the same region of the FFT in all channels.

Returning to a spectrum graph

To return to the spectrum graph, click the Normal Display button  in the toolbar.

Printing the sonogram

Click the Print button  to print the contents of the Spectrum Analysis window, including the sonogram and statistics data.

Tip: This function may be fairly slow if you do not have a palletized driver or if Video for 
Windows is not installed.

Adjust the color 
intensity
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Adjusting Spectrum Analysis settings

From the Spectrum Analysis toolbar, click the Settings button  to display the Spectrum Settings dialog. The following table explains 
the role of each control in audio spectrum analysis. 

Item Description
FFT size Choose a value from the FFT size drop-down list to set the size in samples of the analysis window and number of 

discrete frequencies analyzed. Higher numbers produce increased frequency resolution at the expense of lower time 
resolution and longer computational time.

FFT overlap The value in the FFT overlap box specifies the percentage of overlap between FFT analysis windows. Overlapping 
allows for more accurate analysis. Lower settings decrease the number of distinct analysis functions performed, 
which decreases processing time. High settings allow for more analysis, but can result in slow processing.

Smoothing window Choose a setting from the Smoothing window drop-down list to determine the window function applied to the 
input data before analysis. The window function affects the sharpness of peaks in an FFT graph and the leakage into 
neighboring frequencies.

• Choose Rectangle to apply no window. This results in a very sharp peak, but high leakage.

• Choose Triangular (also called a Bartlett or Parzen window) to apply a window that results in less leakage than the 
rectangle window.

• Hamming, Hanning, and Blackman windows are commonly used in audio applications.

• Choose Blackman-Harris to obtain the least sideband leakage of the six options. The major drawback of 
Blackman-Harris is rounded graph peaks.

Slices displayed The Slices displayed value determines the number of FFT slices displayed. When displaying multiple slices in the 
spectrum graph, slices are displayed chronologically forward or backward based on whether you have the Forward 
or Backward radio button selected.

Set sonogram 
resolution

The Set sonogram resolution value determines the number of FFT samplings used in a sonogram. This keeps the 
processing time and graph resolution constant. Increasing this value increases the horizontal graph resolution, but 
requires more processing time.

When this check box is cleared, the number of samplings is determined by the length of the selection and the FFT 
overlap setting.

Note: Increasing the samplings increases the horizontal graph resolution but requires more processing time.
Channel Choose a setting from the drop-down list to specify which graph you want to edit.
Sync graphs If you are analyzing a multichannel file, select the Sync graphs check box to synchronize the displays so you can view 

the same region of the FFT in all channels.
Logarithmic graphing Select the Logarithmic graphing check box to display the X-axis in logarithmic mode rather than linear mode. In 

logarithmic mode, more of the graph is devoted to lower frequencies.

Note: Logarithmic graphing affects the display only when Normal Display is selected.
Freq. Min. (Frequency 
minimum)

Determines the lowest frequency displayed in the graphs.

Max. (Frequency 
maximum)

Determines the highest frequency displayed in the graphs.

Ceiling Determines the highest amplitude displayed in the graphs.
Floor Determines the lowest amplitude displayed in the graphs.
Hold peaks during 
monitoring

Select this check box to indicate the highest value of each frequency on the spectrum graph with a small horizontal 
line. The length of time (in seconds) that the peak is held is determined by the value entered in the edit box.

Maintain last 
monitored view

Select this check box if you want to maintain the state of the Spectrum Graph when you stop playback. Clearing this 
check box results in the graph resetting to the cursor position when playback stops.
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Saving spectrum graph settings

After you configure the controls in the Spectrum Settings dialog, you can save the settings as a custom preset by clicking Save As and 
entering a name for the new preset. Click OK to save the new preset.
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Chapter 20
 Customizing Sound Forge

You can customize Sound Forge® software to suit your project needs and working references. Many of the settings 
depend on your equipment or studio set-up. Sound Forge software can be set to work with the components that you use 
in your studio.

Setting preferences

Preferences affect how Sound Forge software functions. Any changes that you make to the preferences remain set until 
you change them again or reset Sound Forge software to use the default presets.

You can access the Preferences dialog by choosing Preferences from the Options menu. This dialog contains tabbed 
pages. The following sections explain the settings on each tab.
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General tab

The General tab allows you to set miscellaneous Sound Forge options.

Option Description
Show logo splash-screen on startup When this check box is selected, the Sound Forge splash screen will be displayed briefly upon startup.
Open default Workspace on startup If this check box is selected, files that were open when you last exited the program will be opened automatically.
Default to slow scroll when drag 
selecting

In some very fast computers, automatic scrolling while selecting is too fast to use accurately. When this option is 
turned on, drag-selecting will cause a slow scroll.

Tip: Click the right mouse button while selecting to toggle slow scrolling.
Warn when Paste or Mix formats do not 
match

Select this check box if you want to be warned before mixing data that has different sample rates.

Mixing data of different sample rates may produce unintended results.
Confirm on close Select this check box if you want the application to present a confirmation message box before exiting.
Compatible draw mode (for broken 
video drivers)

Because the application's drawing routines are highly optimized, they increase the chance of causing little-known 
video card problems to arise. Some video cards have bugs in their drivers that can make your system lock up when the 
application tries to draw a waveform.

Compatible draw mode uses a different method of drawing the waveform that, although not as smooth, puts less 
stress on the video card. With some video cards, this mode actually increases the draw speed. However, more flashing 
can occur.

Compatible scroll mode (for other 
broken video drivers)

When this check box is selected, a less optimized method of scrolling the data window will be used. In some instances, 
this can reduce interference problems between your audio and video card when Smooth Scrolling playback is 
selected.

Show a textured background on the 
Workspace

When this check box is selected, a stucco texture will be used for the application background.

Ignore fact chunk when opening 
compressed WAV files

When this check box is selected, the software will ignore fact chunks in compressed WAV files.

Compressed WAV files use fact chunks to specify how many actual samples are represented in the file. If a compressed 
file is improperly authored, this may cause some of the compressed data to not be loaded. If you suspect that not all 
sound data is being loaded from a compressed file, try checking this option and reopening the file.

Tip: If you change the setting of this check box, please delete any proxy (.sfap0) files associated with compressed WAV 
files.

Show free storage space on Status Bar When this check box is selected, the total amount of free disk space available on your specified temporary drive is 
displayed on the status bar.

Use the Temporary files and record folder box at the bottom of the General tab to set the folder that will be used 
for temporary files and recorded data.

Show shuttle controls on Data Window 
transport

When this check box is selected, Rewind and Forward buttons will appear on each data window's transport 
controls.

Auto-power MIDI keyboard window Select this check box if you want to open the MIDI device assigned to the MIDI keyboard (if it is not already open) when 
you click a key on the MIDI keyboard. You may want to turn off this option if you are using the same MIDI output device 
for MIDI synchronization or for your sequencer.

If this option is turned off, you need to click the On button on the keyboard prior to using it to send notes.
Use Net Notify to stay informed about 
Sony products

When this check box is selected, information from Sony will be displayed periodically at startup. Clear the check box to 
bypass the Net Notify dialog.

Allow floating windows to dock When this check box is selected, windows will automatically be docked when you drag them to the edges of the Sound 
Forge workspace. You can hold the Ctrl key while dragging a window to prevent it from docking.

When this check box is cleared, windows will not dock unless you hold the Ctrl key.
Spacebar and F12 Play/Pause instead of 
Play/Stop

Select this check box if you want the F12 and spacebar keyboard shortcuts to toggle between Play and Pause mode. In 
this mode, the cursor will maintain its position.

Warn when metadata cannot be saved in 
the file

Select this check box if you want to be prompted to save metadata to a separate file if it cannot be saved within the 
media file.

When the check box is cleared, metadata will automatically be saved to a separate file if necessary.
Show the position of the playback cursor When this check box is selected, the Position field in the status bar will show the cursor position during playback. 

Turn off this option if you have a very slow computer or video card.
Show the record counter while recording Select this check box if you want the record time displayed in the Record dialog. Clear the check box if you have a very 

slow computer or video card.
Automatically reopen file after Save As Select this check box if you want to automatically reopen files when you save to a different format. Changes in bit 

depth, channels, or compression format will result in reopening and will allow you to listen to any changes in sound 
quality.

Clear the check box and select the Prompt to open new file after Save As check box if you want to be prompted 
to open the saved file in a new data window.

When both check boxes are cleared, Sound Forge software does nothing after saving to a different format. If you’re 
saving a file to several compressed formats, clearing these check boxes prevents you from having to reopen the file 
after saving each format.

Prompt to open new file after Save As When the Automatically reopen files after Save As check box is cleared, select this check box if you want the 
application to prompt you to open the destination file to a new data window after saving a sound file to a different 
format.

Opening the file in a new data window will allow you to hear any changes in quality between the original file and the 
result of the Save As operation.
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Keep media files locked Select this check box if you want to lock media files after you've opened them.

Clear the check box if you want to unlock media files when you switch to another application.
Delete temporary files on close Select this check box if you want to delete the peak (.sfk) and proxy (.sfap0) files associated with a media file when you 

close a data window.
Hide new temporary files Select this check box if you want to turn on the Hidden file attribute when creating new peak (.sfk) and proxy (.sfap0) 

files.

In the Windows Control Panel, double-click Folder Options and select the View tab. Select the Show hidden files 
and folders radio button if you want to be able to see hidden files.

Always proxy compressed formats Select this check box if you want to create an uncompressed proxy (.sfap0) file when you open a compressed file 
format.

Selecting this check box can improve performance on slower computers or for formats that cannot be decompressed 
quickly for real-time playback.

Remember last-used sample rate for .vox 
and .ivc files

Select this check box if you want the software to remember the last-used sample rate when you open a .vox file. When 
the check box is cleared, you will be prompted to choose a sample rate each time you open a .vox file.

Remember last-used settings for .raw 
files

Select this check box if you want the software to remember the last-used settings when you open .raw files. When the 
check box is cleared, you will be prompted to choose a settings each time you open a .raw file.

Allow Undo past Save When this check box is selected, your undo history is maintained until you close the data window (or exit the 
application) so you can undo edit operations even if you’ve saved your file.

When this check box is selected, quick file saving may not be available.

Tip: If you want to be able to undo edit operations even after closing and reopening your file, save a Sound Forge 
project.

Use floating point temporary files Select this check box if you want to use higher precision IEEE floating-point temporary files for audio files. This setting 
results in more accurate processing but requires more disk space and yields slower processing.

When the check box is cleared, the bit depth of the temporary file will match the source file.
Use SPTI for CD burning Select this check box if you want to use SPTI (SCSI Pass-Through Interface) to communicate with your CD burning 

drive.
Enable Windows XP Theme support When this check box is selected, the Sound Forge window will inherit the appearance of the current theme when using 

Windows XP. When the check box is cleared, user interface elements will maintain the classic Windows operating 
system appearance.

Automatically detect plug-and-play CD/
DVD drives

Select this check box if you want the software to check the capacity of the media when you insert a CD. 
Selecting the check box can prevent a hang that can occur with some external drives.

When the check box is cleared, the software will not scan the media each time you insert a disc.
Allow Ctrl+drag style cursor scrub in data 
windows

When this check box is selected, you can hold Ctrl while dragging the cursor to scrub in data windows.

Automatically name regions and markers 
if not playing

When regions and markers are added, this option automatically prompts you for a name. This does not 
happen when adding markers on-the-fly during playback.

Always open dropped files in new 
window

When this check box is selected, files that are dropped onto the Sound Forge workspace are 
automatically opened in a new data window.

Recently used file list Select the check box if you want to display a list of recently used files on the File menu. Use the edit box to specify the 
number of files you want to display.

Temporary files and record folder Specify a folder for storing temporary files and recorded audio, or click the Browse button to specify a new folder.

Using temporary file space allows you to edit very large files and keeps Sound Forge from using large portions of RAM 
on your computer. Your temporary directory must have enough space to accommodate the total size of all files you 
plan to edit along with space for any clipboard data and undo buffers.

If you change the temporary storage folder, you will have to restart Sound Forge for the change to take effect.

Option Description
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Display tab

The Display tab allows you to specify options for adjusting the appearance of the Sound Forge window.

Description Option
Default sound file window height Drag the slider to specify the default data window height for a sound file. This magnification level is used when you 

load a sound file or create a new window.
Default video strip height Drag the slider to specify the default height of the video strip when you open a video file.
Peak ratio default for new sound files Choose a ratio from the drop-down list to specify the zoom ratio above which the application will use a peak file 

instead of the original file to draw the waveform.

If you notice problems with waveform scrolling, try decreasing this setting so it is less than your current zoom ratio. 

To calculate the size of the resulting peak files, divide the size of the file by the peak ratio. For example, a 100 MB sound 
file will need a 0.39 MB (100/256) peak file when using 1:256.

Normal zoom ratio Choose a zoom ratio from the drop-down list to specify the default horizontal magnification. This magnification level is 

used when you load a sound file, create a new window, or use the Zoom Normal command.

High values show more data, and small values show more detail.
Custom zoom ratio 1

Custom zoom ratio 2

Choose a zoom ratio from the drop-down list to specify a custom level of horizontal magnification.

This zoom ratio will be used when you perform any of the following actions:

• Click the Custom Zoom 1 or Custom Zoom 2 button on the Navigation toolbar.

• From the View menu, choose Zoom Time, and then choose a Custom Zoom command from the submenu.

• Right-click in a data window, choose Zoom from the shortcut menu, and then choose a Custom Zoom 
command from the submenu.

Color preference for The color preferences section allows you set a custom color for a variety of graphics within the Sound Forge interface.

1. Choose a screen element from the Color preference for drop-down list.

2. Set the color of the selected item:

• Drag the Hue slider to change the color of the selected item.
• Drag the Saturation and Brightness sliders to adjust the intensity of the selected color. 

Note: When adjusting the display color for channel waveforms, the Saturation and Brightness sliders are not 
available. To adjust saturation and brightness for all channels, choose Wave: All Channels from the Color 
preference for drop-down list and then adjust the controls.

•Click the Default button to restore a custom color the default setting.

3. Click the OK button.
Icon color saturation Drag the slider to adjust the color intensity of icons in the Sound Forge window. Drag to the left to decrease the color 

saturation, or drag to the right to increase it.
Icon color tint Drag the slider to adjust the amount of tinting that is applied to the icons in the Sound Forge window. Drag the slider 

to the right to add an average of the title bar colors to the icons. Drag to the left to decrease the amount of tinting 
applied.

Tip: You can use the Display Properties control panel to change your active window title bar colors. 

• In Windows 2000, open the Display Properties control panel and select the Appearance tab. Then choose Active 
Title Bar from the Item drop-down list. 

• In Windows XP, open the Display Properties control panel and select the Appearance tab. Then click the 
Advanced button and choose Active Title Bar from the Item drop-down list. 
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Editing tab

The Editing tab allows you to specify preferences for editing and undo operations.

Labels tab

The Labels tab allows you modify the default names that are assigned to data windows, regions, and markers.

Edit default data window names

The Window labels section of the Labels tab allows you to modify the names that are assigned to new data windows when you create a 
new data window or choose Create a new window for each take from the Mode drop-down list in the Record dialog.

1. From the Options menu, choose Preferences, and click the Labels tab.

2. Select the New window prefix check box and type a prefix in the box if you want to display a name in the new window's title bar. 
Clear the check box if you do not want to include a prefix (if you want to number windows only, for example).

3. Select the Use counter and start at check box and type a number in the box if you want to number new data windows.

4. Select the Insert leading zeros in field width of check box and specify a field width if you want to use leading zeros in window 
names. For example, if you specify a field width of 3, windows numbered 1 to 99 would be numbered 001 to 099.

5. Click the OK button.

Option Description
Disable triple-clicking to select all sound 
file data

Select this check box if you don’t want to select all data when you triple-click in a data window. You might want to 
select this option if triple-clicks are falsely detected when you make a selection and then try to perform a drag 
operation. Otherwise, decrease Windows’ double-click threshold time.

When this check box is cleared, you can triple-click anywhere in a data window to select all data.
Disable auto-snapping below 1:4 zoom 
ratios

Select this check box if you do not want selections to snap to time or zero-crossings when the data window zoom ratio 
is less than 1:4.

This is useful if you commonly zoom in fully to adjust selection points manually yet still want to use automatic 
snapping when zoomed out.

Force loop bar to match selection Select this check box if you want the loop region to always match the current time selection. Clicking to position the 
cursor in a data window will clear the loop region. When no loop region exists and looped playback is enabled, the 
entire data window will play looped. When the check box is selected, the behavior is similar to Sound Forge 8.0.  

Clear the check box if you want to be able to position the cursor without clearing the loop region.
Drag & drop auto rise delay Drag this slider to specify the time before a window underneath the cursor becomes active during drag-and-drop 

operations.
Snap to zero-crossing slope Use this drop-down list to specify how zero-crossings are detected when you choose Snap to Zero:

• Negative Slope - Zero-crossings are detected only on a negative slope.
• Any Crossing - Zero-crossings are detected on both positive and negative slopes.

• Positive Slope - Zero-crossings are detected only on a positive slope.

Tip: It is usually best to use either Positive Slope or Negative Slope so that noticeable pops and clicks are not 

generated by cutting data.
Zero-cross scan time Specify the maximum time (in samples) that will be used to search for the next zero-crossing.
Zero-cross level threshold Specify the sample value below which data will be considered a zero-crossing.

Note: Setting this value above zero can compensate for DC offset. However, if possible, you should remove DC offset 
first.

Pencil tool maximum zoom ratio Choose a setting from the drop-down list to specify the maximum zoom ratio at which the Pencil tool will be available.
JKL / shuttle speed Choose a setting from the drop-down list to set the speed that will be used for scrubbing the timeline with the JKL keys 

or with a multimedia controller.
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Editing default region names

The Region Labels section of the Labels tab allows you to modify the names that are assigned to regions when you insert regions or 
choose Multiple takes creating regions from the Mode drop-down list in the Record dialog.

1. From the Options menu, choose Preferences, and click the Labels tab.

2. Select the Label Regions check box to display text labels for regions in the data window when you insert regions or choose 
Multiple takes creating regions from the Mode drop-down list in the Record dialog.

3. Adjust additional settings as necessary:

4. Click the OK button.

Editing default marker names

The Marker labels section of the Labels tab allows you to modify the names that are assigned to markers when you insert markers 
during playback or recording.

1. From the Options menu, choose Preferences, and click the Labels tab.

2. Select the Label Markers check box to to display text labels for markers in the data window when you insert markers.

3. Adjust additional settings as necessary:

4. Click the OK button.

File Types tab

The File Types tab allows you to indicate which types of files you want to associate with Sound Forge software. When file is associated 
with Sound Forge software, you can double-click a sound file in the Windows Explorer and it will open for editing.

1. Select a file type from the list. The File association details box near the bottom of the tab displays information about the selected 
file type, as well as the current association.

2. Select the check box for each sound file format you want to associate with Sound Forge software, or clear the check box to remove 
a file association.

3. Click the OK button.

Item Description
Prefix Type a prefix in the box if you want to assign a name to new regions. Clear the check box if you do not want to include 

a prefix (if you want to number regions only, for example).
Use counter and start at Select this check box and type a number in the box if you want to number new regions.
Insert leading zeros in field width of Select this check box and specify a field width if you want to use leading zeros in region names. For example, if you 

specify a field width of 3, regions numbered 1 to 99 would be numbered 001 to 099.

Item Description
New marker prefix Type a prefix in the box if you want to assign a name to new markers. Clear the check box if you do not want to 

include a prefix (if you want to number markers only, for example).
Use counter and start at Select this check box and type a number in the box if you want to number new markers.
Insert leading zeros in field width of Select this check box and specify a field width if you want to use leading zeros in marker names. For example, if you 

specify a field width of 3, markers numbered 1 to 99 would be numbered 001 to 099.
244 | CHAPTER 20



MIDI/Sync tab

The MIDI/Sync tab allows you to specify preferences for MIDI and synchronization.

Item Description
Output Choose a MIDI device from the drop-down list to specify the MIDI output device for synchronization when Generate 

MIDI Timecode is enabled.
Input Choose a MIDI device from the drop-down list to specify the MIDI input device for synchronization and triggering 

when Trigger from MIDI Timecode is enabled.
This is the device through which Sound Forge will receive all MIDI triggering and synchronization input, including 
SMPTE/MTC, MIDI triggers, and Regions/Playlist triggers.

Bound record time on SMPTE record sync When this check box is selected, Sound Forge software will not allow recording beyond the specified end time. This 
ensures that your record length is exact regardless of any inaccurate timecode.

Use internal timer for SMPTE generation Select this check box if you want to use the internal timer for SMPTE generation rather than position values reported by 
the sound card driver. Since many sound cards do not report their position accurately, it is usually better to use the 
internal timer for SMPTE generation.

Choose a value from the Internal timer resolution drop-down list to specify the internal timer accuracy used for 
generating SMPTE. Low values produce more accurate SMPTE generation, but may also decrease system performance.

Use free-wheel for SMPTE loss Select this check box to stop playback if the incoming MIDI timecode signal stops. When this check box is not selected, 
Sound Forge playback will continue until the user stops playback manually.

In the Free-wheel time box, specify the amount of time that Sound Forge playback will continue after the incoming 

MIDI timecode signal stops. If timecode starts again during this time, playback will continue.

In the Free-wheel slack box, specify how fast the software should expect timecode updates before going into Free-
wheel mode. If you have a fast computer, this value can be set to a lower value if you want to stop playback 
immediately when timecode is interrupted.

Enable SMPTE playback offset Select this check box to specify an offset that will be added to the time displayed in the Sound Forge play counter. For 
example, if you want to generate MIDI timecode starting at 01:00:00:00, instead of inserting 1 hour of silence at the 
beginning of your sound file, you can specify that amount in this box.
When using Record Sync, you’ll often want to set this value to the Enable MTC/SMPTE Input Synchronization Start time. 
The Sound Forge ruler and play counter will not display this offset.
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Previews tab

The Previews tab allows you to specify options for previewing files.

Item Description
Limit non-realtime previews to Select this check box and specify the length of audio that will be used when generating a preview. Low values 

decrease the amount of time needed to generate a preview when tuning effects or processing values.
Pre-roll Select this check box and specify how many seconds of unprocessed audio will be played before the processed 

selection. Use this to listen to the transition from unprocessed to processed data.

Tip: Pre-roll can be toggled on and off by right-clicking the dialog and choosing Pre-roll from the shortcut menu.
Post-roll Select this check box and specify how many seconds of unprocessed audio will be played after the processed selection. 

Use this to listen to the transition from processed to unprocessed data.

Tip: Post-roll can be toggled on and off by right-clicking the dialog and choosing Post-roll from the shortcut menu.
Reactive previewing Select this check box to automatically recalculate and play back the preview buffer if the parameters of an effect 

change. This allows for immediate feedback of the effects of a change.

This option is most useful when using a fast computer, limiting preview times, and not using processor-intensive 
effects.

Note: You can temporarily suspend Reactive Previewing by holding down the Shift key while making parameter 
changes.

Audio event locator:

Pre-roll/Loop time

Use the Pre-roll and Loop time settings to control how the audio event locator plays audio:

• In the Pre-roll box, specify the amount of data played prior to the cursor position.

• In the Loop time box, specify the amount of time that will loop when you stop the cursor while clicking and 
dragging in the overview bar.

To use the audio event locator, click the overview bar and drag the mouse. Similar to a scrub control, playback follows 
mouse movement and loops around the cursor position when the mouse is still. Playback stops when the mouse 
button is released.

Cut preview configuration:

Pre-roll/Post-roll

Use the Pre-roll and Post-roll settings to control the amount of data that is played back when you choose Preview 

Cut/Cursor from the Edit menu:

• In the Pre-roll box, specify the amount of data played prior to the selection or cursor position.

• In the Post-roll box, specify the amount of data played after the selection or cursor position.
Play Looped adjust pre-roll

When Loop Playback  mode is turned on and you make a selection during playback, playback is pre-rolled from 

the end of the selection to help you tune long loops.

Specify the number of seconds before the end of the selection that you would like to pre-roll.
Playlist pre-roll Enter a value in the edit box or use the up and down arrows to specify the amount of pre-roll that will be used when 

playing entries in the Playlist/Cutlist window. This allows you to easily hear the transition from one region to another 
without having to play all the way through the first region.
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Status tab

The Status tab allows you to specify preferences for displaying information in the status bar.

Toolbars tab

The Toolbars tab allows you to specify which toolbars you want to display.

Display or hide toolbars

Select the check box to display a toolbar; clear a check box to hide a toolbar.

Display or hide Tool Tips

Select the Show Tool Tips check box if you want to display pop-up descriptions when the mouse is held over certain items.

Customizing a toolbar

1. From the View menu, choose Toolbars. The Preferences dialog appears with a list of available toolbars.

2. Select the check box for a toolbar and click Customize. The Customize Toolbar dialog is displayed.

3. Use the controls in the Customize Toolbar dialog to add, remove, or rearrange the buttons on the selected toolbar. Click Reset to 
restore the toolbar to its default setting.

4. Click the OK button.

Item Description
Default frames per second The default frame rate used to calculate frame values.

Frame values are useful when trying to synchronize sound with animation. Most animation players specify a playback 
frame rate at which video frames are shown to the user. If you are using an animation that has a frame rate of 15.0 
frames per second, you would set the frame rate to 15.0. When status values are displayed, they will be shown in values 
of frames. This allows you to find the frame to which a given point in the sound file corresponds.

Default beats per measure The number of beats in each measure for displaying in measures and beats. For example, 2/4 time would have two 
beats per measure.

This setting will be also be used in the Edit Tempo dialog.
Default beats per minute The number of beats per minute, i.e. the tempo of a song for displaying lengths.

This setting will be also be used in the Edit Tempo dialog.
RMS level scan time The amount of sound data surrounding the cursor used to calculate the RMS level in the Levels toolbar.
Peak level scan time The amount of sound data surrounding the cursor used when searching for a peak level to display in the Levels 

toolbar.
0 VU (+4 dBu) level Choose a setting from the drop-down list or type a value in the box to calibrate the VU/PPM meters to their associated 

levels on the peak meters.

VU meters display sound in dB VU, where 0 VU is a reference level, and there is headroom above 0 VU. The Sound Forge 
peak meters display peaks in dB FS (decibels relative to full scale). 

In digital audio, there is no headroom above 0 dB FS. Choosing a setting from this drop-down list subtracts a nominal 
dB value from the VU meters so that a signal displayed on the VU meters remains slightly below 0 dB on the peak 
meters.

VU meter integration time Type a value in the box to set the amount of data surrounding the cursor that will be used to calculate levels in the VU 
meters.

This setting has no effect on the PPM scales, which use fixed integration times:
• UK PPM: 10 ms
• EBU PPM: 10 ms
• DIN PPM: 5 ms
• Nordic PPM: 5 ms
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Audio tab

The Audio tab allows you to specify playback and recording options.

Basic audio preferences

Item Description
Audio device type Choose a driver type from the drop-down list.

• Microsoft Sound Mapper - The default setting. Allows the Sound Mapper to choose appropriate playback and 
recording devices.

• Windows Classic Wave - Allows you to choose a specific audio device using a classic Wave driver.

• ASIO - Allows you to choose a specific audio device using a low-latency ASIO driver. 

Playback Click the Playback tab to adjust playback routing and buffering settings.

- Playback device routing Use this control to assign channels from multichannel audio files to outputs on your sound card: the numbered 
columns represent audio channels, and the rows represent the selected playback device's outputs. Select the Enable 
check box to enable an output, and select a radio button to assign the channel to an output.

In the following example, channel 1 is routed to the sound card's first output, channel 2 is routed to the second output, 
and so on.

- Playback buffering (seconds) Specifies the total amount of buffering that is used during playback.

The larger the number, the more buffering is performed during playback. This value must be as low as possible without 
gapping. To set it, start at .25 and play back a typical song. Move some of the track faders. If the playback gaps, try 
increasing this slider in small increments until the gapping goes away. 
If you simply cannot get playback to be free of gapping, you need to install more RAM in your computer so you can 
increase buffering, buy a faster access hard drive, or minimize the number of audio plug-ins you are trying to use 
simultaneously.

Record Click the Record tab to adjust record input routing and buffering settings.
- Recording device routing Use this control to assign channels from multichannel audio files to outputs on your sound card: the numbered 

columns represent audio channels, and the rows represent the selected record device’s inputs. Select the Enable check 
box to enable an input, and select a radio button to assign the input to a channel.

In the following example, the signal from Analog in 1 is recorded to channel 1, Analog in 2 is recorded to channel 2, 
and so on.

- Record buffering (seconds) Specifies the total amount of buffering that is used during recording.

If you use your computer for other tasks while recording, increasing this setting can reduce the likelihood of those 
tasks interrupting recording.

Advanced Click this button to open the Advanced Audio Configuration dialog. For more information on these options, see below.
Default All Click to restore the Audio tab to the default settings.
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Advanced audio preferences

You can click the Advanced button on the Audio tab to access the advanced audio preferences.

Video tab

Use the Video tab to specify preferences for displaying video.

Setting Description
Audio devices This list contains all of the audio devices that are installed in your computer. Select a device from the list to set the 

options below for that device.
Interpolate position When this check box is selected, the software will attempt to compensate for inaccurate devices by interpolating the 

playback or recording position. If you notice that your playback cursor is offset from what you are hearing, enable this 
option for the playback device.

Position bias If the position of playback or recording does not match what you hear after you enable Interpolate position, you 
can attempt to compensate using the Position bias slider.

Moving this slider will offset the position forward or backward to compensate for the inaccuracies of the device.
Do not pre-roll buffers before starting 
playback

When this check box is selected, the software will not create buffers prior to starting playback. Some devices do not 
behave properly if this check box is cleared.

If your audio stutters when you start playback try selecting this check box.
Audio buffers Drag the slider to set the number of audio buffers that will be used. Adjusting this setting can decrease gapping or 

help you synchronize the input and output.

Buffer size Choose a setting from the drop-down list to indicate the buffer size you want to use. Choose MME to use the 

Playback buffering setting on the Audio tab in the Preferences dialog.

For example, if you choose MME from the Buffer size drop-down, set the Audio buffers slider to 5, and set 

Playback buffering to 0.35 seconds, five 0.07-second buffers are created.

If you choose 1024 from the Buffer size drop-down and set the Audio buffers slider to 5, five 1024-byte buffers are 
created.

Priority Choose a setting from the drop-down list to set the priority that is assigned to your audio buffers.

Increasing the buffers' priority can help you attain smoother playback, but it can also adversely affect other processes.

Item Description
Frame numbering on thumbnails Determines how individual frame information, located in a box at the lower left-hand corner of each frame, will be 

displayed in the video strip when frame numbering is turned on.

The frame information box can include Frame Numbers or Media Timecode.
Allow pulldown removal when opening 
24p DV

Select this check box if you want to remove pulldown when you open 24 fps progressive-scan DV video files. 

When the check box is cleared, Sound Forge software will read 24p video as 29.97 fps interlaced video (60i).
Deinterlace method Choose a setting from the drop-down list to determine how Sound Forge software separates the two fields that make 

up a video frame when you render to a progressive format:

• Blend Fields: Maintains the data in the two fields by blending them together. This method can produce a smooth, 
motion-blurred image.

• Interpolate: Deletes one field and uses the remaining field to interpolate the deleted lines. This produces sharper 
images than Blend Fields but can introduce jagged motion or stair-stepping artifacts.

Resample source video when rendering 
to a higher frame rate

Select this check box if you want to interpolate video frames when you render to a frame rate that is greater than the 
source file's frame rate.

External monitor device Choose a device from the drop-down list to configure an IEEE-1394 device for use with an external monitor. Sound 

Forge will send your video output to this device when you click the Preview on External Monitor button  in the 
Video Preview window.

More information on this device are displayed in the Details pane.

You can make additional preview playback adjustments near the bottom of the Video tab once you’ve selected an 
external monitor device:

• If necessary, you can adjust the video to display properly on your external monitor. Choose the desired format from 
the drop-down list.

• If audio and video do not play back in synchronization, drag the Sync offset slider to specify a frame offset to 
restore synchronization.

Details Displays information about the device selected in the External monitor drop-down list.

If project format is invalid for DV output, 
conform to the following

If your source media does not conform to DV standards, choose a setting from the drop-down list. The video is 
adjusted to display properly on your external monitor.

Sync offset (frames) If your audio is not synchronized with your external monitor, you can configure an offset for your hardware. Drag the 
slider to synchronize audio and video.

This setting affects synchronization for previewing on an external monitor. Audio and video synchronization in the 
Sound Forge workspace is not affected.
CUSTOMIZING SOUND FORGE | 249



VST Effects tab

The VST Effects tab allows you to specify where your VST plug-ins are installed.

Customizing keyboard shortcuts

From the Options menu, choose Customize Keyboard to customize the keyboard shortcuts available in the Sound Forge interface.

The Shortcut keys box displays the currently assigned shortcut keys for the selected command. Click a tab in the middle of the dialog to 
choose which shortcuts you want to see.

Editing or creating new shortcuts

1. From the Options menu, choose Customize Keyboard. The Customize Keyboard dialog is displayed.

2. Click a tab in the middle of the dialog to indicate the type of command you want to assign to a keyboard shortcut.

3. Select a command in the list.

4. Click the Shortcut keys box and press the key combination you want to assign to the selected command.

5. Click the Add button to assign the key combination in the Shortcut keys box to the selected command.

Saving a keyboard mapping

1. From the Options menu, choose Customize Keyboard. The Customize Keyboard dialog is displayed.

2. Click the Save as button and type a name to save your current keyboard shortcuts to an .ini file in the C:\Documents and 
Settings\[user name]\Application Data\Sony\Sound Forge\9.0 folder.

You can use this file as a backup or to share your keyboard shortcuts with other Sound Forge users.

Deleting a keyboard mapping

1. From the Options menu, choose Customize Keyboard. The Customize Keyboard dialog is displayed.

2. Choose a mapping from the Keyboard map drop-down list and click the Delete button to remove the selected keyboard mapping.

Item Description
Default VST search folder This is the folder in which the application looks for VST effects during startup.
Alternate VST search folder 1 Enter a path in the edit box or click Browse to indicate where the application can find VST effects.
Alternate VST search folder 2 Enter a path in the edit box or click Browse to indicate where the application can find VST effects.
Select VST effects to be available as 
audio plug-ins

Lists the VST effects that are currently available. Select a VST effect’s check box to make it available for use as a plug-in. 
Note: When you use a VST plug-in, the software will lock it for the remainder of your session. A lock is displayed next to 
the check box to indicate that the plug-in cannot be removed until you close and restart the application.

Tip: You can type a word in the Show commands containing box to filter the list of commands to display only commands that contain 
the word you typed.

Tip: If you type a key combination that has already been assigned to another command, the Shortcut currently assigned to box 
displays the existing assignment. To find the existing command, click the Locate button.

Note: The Application Data folder is not visible unless the Show hidden files and folders radio button is selected on the View tab of the 
Windows Folder Options control panel.

Note: You cannot delete the default Sound Forge keyboard mapping.
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Importing or renaming a keyboard mapping

Copy a Sound Forge keyboard mapping .ini file to the C:\Documents and Settings\[user name]\Application Data\Sony\Sound 
Forge\9.0 folder.

The next time you start Sound Forge, the new keyboard mapping will be available from the Keyboard map drop-down list in the 
Customize Keyboard dialog.

Resetting the default keyboard mapping

1. From the Options menu, choose Customize Keyboard. The Customize Keyboard dialog is displayed.

2. Choose [Default] from the Keyboard map drop-down list and click OK to restore the default configuration.

Note: The Application Data folder is not visible unless the Show hidden files and folders radio button is selected on the View tab of the 
Windows Folder Options control panel.

Tip: If you want to edit a the name used to identify a keyboard mapping in the Customize Keyboard dialog, open the .ini file in a text 
editor and change the <Display Name> portion of the Name=<Display Name> entry. Save the .ini file and restart Sound Forge to use 
the new name.
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Appendix A
 Shortcuts

Keyboard shortcuts

The following shortcuts represent the default configuration. Your system may differ if you've used the Keyboard tab in the 
Preferences dialog to customize your keyboard shortcuts in Sound Forge software. Click the Default All button on the 
Keyboard tab to restore the default configuration, or you can click the Export button on the Keyboard tab to save the 
current shortcuts in a map file. 

The available shortcut keys are arranged in tables according to function.

Project file commands

Press Result

Ctrl+N Create a new data window.

Ctrl+Shift+N Create a new data window without displaying the New Window dialog

Ctrl+O Open a sound file or project.

Ctrl+S Save modified sound data back to the file.

Alt+Enter Display the Properties dialog for the active data window.

Ctrl+W Close the active data window.

Alt+F4 Exit the application.
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Magnification and view commands

Press Result
Alt+0 Set input focus to the waveform display in the active data 

window.

Alt+1 Show/set input focus to the Explorer window.

Alt+2 Show/set input focus to the Regions List.

Alt+3 Show/set input focus to the Playlist/Cutlist window.

Alt+4 Show/set input focus to the Video Preview window.

Alt+5 Show/set input focus to the Time Display window.

Alt+6 Show/set input focus to the Channel Meters window.

Alt+7 Show/set input focus to the Undo/Redo History window.

Alt+8 Show/set input focus to the Spectrum Analysis window.

Alt+9 Show/set input focus to the Plug-In Chainer window.

Ctrl+Alt+0 Show/set input focus to the Plug-In Manager window.

Ctrl+Alt+1 Show/set input focus to the MIDI Keyboard window.

Ctrl+Alt+2 Show/set input focus to the Script Editor window.

Ctrl+Alt+3 Show/set input focus to the Hardware Meters window.

Shift+F4 Tile the data windows vertically.

Alt+F5 Restore the Sound Forge application window.

Shift+F5 Cascade the data windows.

Ctrl+F5 Restore the active data window.

F6 Toggle playback scrolling on and off.

Shift+F6 Toggle smooth playback scrolling on and off.

Ctrl+F6 Go to the next data window.

Ctrl+Shift+F6 Go to the previous data window.

Ctrl+F10 Maximize the active data window.

Alt+F10 Maximize the Sound Forge application window.

F11 Show/hide windows docked at the bottom of the workspace.

Shift+F11 Show/hide windows docked at the sides of the workspace.

Ctrl+F11 Show/hide all docked windows.

Ctrl+Enter Maximize the width of the active data window.

V Insert/show/hide volume envelope.

Shift+V Insert/remove volume envelope.

P Insert/show/hide pan envelope.

Shift+P Insert/remove pan envelope.
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Data window edit commands

Press Result

D/Shift+D Select the previous/next editing tool (Edit tool, Magnify tool, Pencil tool).

Ctrl+D Select the Edit tool.

Ctrl+A Select all data in the active window.

Ctrl+C Copy the selected data onto the clipboard.

Ctrl+E Paste the clipboard contents into a new data window.

Ctrl+M Mix data from the clipboard with the active window.

Ctrl+T Trim (crop) to the current selection.

Ctrl+V Paste data from the clipboard into the active window.

Ctrl+X Move (cut) the selected data onto the clipboard.

Ctrl+Y Repeat last process, effect, or tool.

Ctrl+Z Undo the last action.

Ctrl+Shift+Z Redo the last undone action.

Delete Clear (delete) the selected data; nothing is placed on the clipboard.

Note: If the Treat as Cutlist command (available in the Special menu, Playlist/
Cutlist submenu) is selected, deleting a selection creates a region in the Cutlist 
window, but does not remove the selection.

C Insert a command marker at the current cursor position.

M Insert a marker at the current cursor position.

Ctrl+B Toggle Auto Snap to Zero on and off.

V Insert/show/hide volume envelope.

Shift+V Insert/remove volume envelope.

P Insert/show/hide pan envelope.

Shift+P Insert/remove pan envelope.

Alt+Shift+L Create a loop from the current selection.

Alt+L Create a loop from the current selection without displaying the Edit Sample 
dialog.

Esc Stop or cancel the current action (including playback).

F8 Toggle drag-and-drop snapping on and off.
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Cursor movement

Press Cursor moves to

 (right arrow)/  (left arrow) Move one pixel right/left.

Ctrl+Alt+  (right arrow)/Ctrl+Alt+ 

 (left arrow)

Move one audio sample right/left.

Alt+  (left arrow)/Alt+  (right 
arrow)

Previous/next video frame (video files).

Note: This is only available if the data window contains a video file.

Ctrl+G Display the Go To dialog.

Home Go to the first sample visible in the waveform display.

End Go to the last sample visible in the waveform display.

Ctrl+Home Go to the first sample in the data window.

Ctrl+End Go to the last sample in the data window.

Page Up Move 10% of the current view prior to the cursor position.

Page Down Move 10% of the current view past the cursor position.

Ctrl+Page Up Move 100% of the current view prior to the cursor position.

Ctrl+Page Down Move 100% of the current view past the cursor position.

Ctrl+  (right arrow) Go to end of file. If regions, loops, or markers exist in the file, this keystroke moves 
to the next region, loop, or marker boundary.

Ctrl+  (left arrow) Go to beginning of file. If regions, loops, or markers exist in the file, this keystroke 
moves to the previous region, loop, or marker boundary.

. (period) or \ Center the cursor in the waveform display.

+ (numeric keypad) Go to the next sample.

- (numeric keypad) Go to the previous sample.

Ctrl+numeric keypad + Move 10 samples past the current cursor.

Ctrl+numeric keypad - Move 10 samples prior to the current cursor.
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Selecting data

Press To select from cursor to

Ctrl+Shift+D Show the Set Selection dialog.

Shift+  (right arrow)/Shift+  (left 
arrow

Select from the cursor to the next/previous screen pixel.

Shift+Ctrl+Alt+  /

Shift+Ctrl+Alt+

Select from the cursor to the next/previous sample.

Shift+Alt+  / Shift+Alt+ Select from the cursor to the next/previous video frame.

Note: This is only available if the data window contains a video file.

Shift+Home Select from the cursor to the first sample visible in the waveform display.

Shift+End Select from the cursor to the last sample visible in the waveform display.

Ctrl+Shift+Home Select from the cursor to the first sample in the data window.

Ctrl+Shift+End Select from the cursor to the last sample in the data window.

Shift+Page Up Select from the cursor to 10% of the current view prior to the cursor position.

Shift+Page Down Select from the cursor to 10% of the current view past the cursor position.

Ctrl+Shift+Page Up Select 100% of the current view prior to the cursor position.

Ctrl+Shift+Page Down Select 100% of the current view past the cursor position.

Ctrl+Shift+ Select 10 pixels past the cursor position. If regions, loops, or markers exist in the file, this 
keystroke selects to the next region, loop, or marker boundary.

Ctrl+Shift+ Select 10 pixels prior to the cursor position. If regions, loops, or markers exist in the file, this 
keystroke selects to the previous region, loop, or marker boundary.

Shift+numeric keypad + Select from the cursor to the next sample.

Shift+numeric keypad - Select from the cursor to the previous sample.

Ctrl+Shift+numeric keypad + Select 10 samples past the current cursor.

Ctrl+Shift+numeric keypad - Select 10 samples prior to the current cursor.

T Snap to time.

Shift+T Snap edge to time.

Z Snap to next zero crossing.

Shift+Z Snap edge to next zero crossing.

Tab/Shift+Tab Switch the selection through the channels in a multichannel file.

< Shift current selection to the left by the length of the selection.

> Shift current selection to the right by the length of the selection.

; Cut the current selection length in half.

‘ Double the current selection length.

: Rotate audio.

S or Backspace Toggle current selection on and off.

Alt+Shift+L Create a loop from the current selection.

Alt+L Create a loop from the current selection without displaying the Edit Sample dialog.
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Navigation and playback 

Record dialog keyboard shortcuts

Press Result

Ctrl+<Number> Save a view in cell <Number> where <Number> ranges from 1 to 8.

<Number> Restore a view using cell <Number> where <Number> ranges from 1 to 8.

 (up arrow) or mouse wheel up Increase time magnification (zoom in).

 (down arrow) or mouse wheel down Decrease time magnification (zoom out).

Shift+ Increase level magnification.

Shift+ Decrease level magnification.

Ctrl+ Zoom to selection if a selection exists; otherwise Zoom In Full.

Ctrl+ Zoom normal (zooms to default zoom ratio set in Preferences).

1 (on numeric keypad) Display custom zoom ratio 1.

2 (on numeric keypad) Display custom zoom ratio 2.

Ctrl+Shift+ Pan data window up if zoomed in vertically.

Ctrl+Shift+ Pan data window down if zoomed in vertically.

5 (on numeric keypad) Switch cursor to opposite end of selection.

I Set Mark In at the current cursor position.

O Set Mark Out at the current cursor position.

Spacebar or F12 Play or stop the contents of the data window in default mode.

Shift+Spacebar or Shift+F12 Play all.

Enter or Ctrl+F12 Play/Pause.

X Switch play mode between Normal, Plug-In Chainer, Play as Sample, and Play as 
Cutlist playback modes.

Enter Pause playback and leave the cursor at the current position.

Esc Stop or cancel the current action (including playback).

Q Toggle looped playback.

Ctrl+K Preview cut (skip selection on playback with pre-roll).

Ctrl+Shift+K Play to cursor with pre-roll.

J, K, or L Scrub playback

F6 Toggle playback scrolling on and off.

Shift+F6 Toggle smooth playback scrolling on and off.

F7 Generate MIDI timecode.

Ctrl+F7 Trigger from MIDI timecode.

Press Result

Ctrl+R Open Record dialog.

Alt+R Start/stop recording.

Alt+P Play.

Alt+T Reset clip indicators.

Esc Stop recording or playback.

Alt+Z Go to the start of the file.

M Insert a marker while recording.
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Plug-In Chainer

Regions List 

Playlist/Cutlist

Script Editor

Press Result

Ctrl+P Preview audio through plug-in chain.

Ctrl+Shift+P Process selection using the plug-in chain.

Ctrl+B Bypass the plug-in chain while previewing audio.

Ctrl+S Save chain preset.

Ctrl+T Toggle through audio tail processing modes (Ignore Tail Data, 
Mix Tail Data, Insert Tail Data).

Ctrl+E Open the Plug-In Chooser dialog to add plug-ins to chain.

Ctrl+Delete Remove selected plug-in from chain.

Ctrl+Tab Select the next plug-in in the chain.

Ctrl+Shift+Tab Select the previous plug-in in the chain.

Ctrl+H Shows/hides the effect automation parameter chooser.

Press Result

Spacebar Play or stop playback of the active marker or region.

Enter or Shift+E Edit the active marker or region.

Delete Delete the active marker or region.

R Create region from the current selection.

Shift+R Create region without displaying dialog.

Press Result

Spacebar Play or stop playback of the active playlist entry.

Enter Edit the active playlist entry.

Delete Delete the active playlist entry.

+ (plus sign) Add one to the active playlist entry play count.

- (minus sign) (not numeric keypad) Subtract one from the active playlist entry play count.

* (asterisk) (not numeric keypad) Add or remove a stop point on the active playlist entry.

/ (forward slash) (not numeric keypad) Toggle pre-roll on and off for the playlist.

Press Result

F3 Find next instance of last-searched text

Shift+F3 Find previous instance of last-searched text

Ctrl+F3 Find next instance of the selected text

Ctrl+Shift+F3 Find previous instance of the selected text

Ctrl+N Create a new script

Ctrl+O Open a script

Ctrl+R Run the current script.

Ctrl+Shift+R Compile the current script.

Ctrl+S Save the current script.
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Mouse wheel shortcuts

Additional mouse shortcuts

Select all

Double-click the waveform display to select the entire sound file. Triple-click when regions, loops, or markers are present.

Zoom time and level

Double-click the level ruler to zoom the current selection vertically and horizontally. If no selection exists, all waveform data is zoomed. 

Return control value to default

Double-click a slider, fader, or spinner to return the control to its default value.

Fine-tune control value

To fine-tune a slider, fader, or spinner, hold the right and left mouse buttons (or hold Ctrl) while dragging.

Preview

Hold Shift and click the Preview button to hear the original audio. This is equivalent to selecting the Bypass check box.

Hold Ctrl and click the Preview button to display the Preview Configuration dialog.

Status bar

The status bar is displayed across the bottom of the Sound Forge window. Right-click the Sample Rate, Bit Depth, or Channels box and 
choose a setting from the shortcut menu, or double-click a box to edit the setting directly. Right-click the Total Length box and choose 
a format from the shortcut menu.

Mouse wheel action Result

Wheel Up Zoom in horizontally.

Wheel Down Zoom out horizontally.

Ctrl+Wheel Up Zoom in vertically.

Ctrl+Wheel Down Zoom out vertically.

Shift+Wheel Up Scroll left (in 10ths of screen width).

Shift+Wheel Down Scroll right (in 10ths of screen width).

Ctrl+Shift+Wheel Up Cursor left or current selection point left (if there is a 
selection).

Ctrl+Shift+Wheel Down Cursor right or current selection point right (if there is a 
selection).

Tip: You can turn off the triple-click feature on the Editing tab of the Preferences dialog.
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Selection status bar

The selection status bar is displayed at the bottom of Sound Forge data windows. There are several shortcuts for the selection status bar:

• Double-click the Selection Start, Selection End, or the Selection Length boxes to type values in the boxes to specify or edit a 
selection.

• Right-click any of the boxes and choose Go To from the shortcut menu to display the Go To dialog and specify a start position for your 
selection. 

• Right-click any of the boxes and choose Set Selection from the shortcut menu to display the Set Selection dialog and specify your 
selection position and length.

• Right-click any of the boxes and to choose a time format.

Go to marker

Double-click a marker tag in the ruler to move the cursor to the position of the marker.

Set selection to region/loop

Double-click a region or loop tag in the ruler to change the current selection to the region or loop end points.

Edit region or marker

Double-click a region or marker in the Regions List to display the Edit Region/Marker dialog.

Edit playlist

Double-click a playlist entry to display the Edit Playlist dialog. For more information, see Editing a playlist/cutlist region on page 109.

Play Normal button

Hold Ctrl and click to preview a Cut operation. Hold Ctrl+Shift and click to play to the cursor with pre-roll.

Slow and fast selection scroll toggle

To create a selection extending past the start or end of the waveform display, hold the left mouse button while clicking the right mouse 
button to toggle between fast and slow scrolling.
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Appendix B
 Microsoft Audio Compression Manager

The Microsoft Audio Compression Manager (ACM) is a standard interface for audio compression in Windows. This 
interface allows applications such as Sound Forge® to use compression algorithms provided by other companies.

Sound Forge software fully supports audio compression through the ACM. This allows you to use any ACM-compatible 
compression. Compressed WAV files are transparently opened and all available compression formats for WAV files are 
provided in the Save As dialog. 

There are two major components to the ACM:

• Audio data compression and decompression
• Transparent playback and recording of non-hardware supported audio files

Audio data compression and decompression

The first component of the ACM allows audio data to be compressed and decompressed. Audio compression is used to 
decrease the amount of data required to represent a sound and results in smaller sound files. However, there are 
drawbacks to using audio compression on sound files:

• Most audio compression algorithms degrade sound quality. This is referred to as lossy compression because 
information contained in the sound is lost when it is compressed. The amount of sound degradation is dependent 
upon the algorithm.

• Compressed audio requires more processing time than uncompressed data. The amount of processing time is 
dependent on the algorithm as well as the system’s hardware. Typically, opening and saving compressed files takes 
longer than uncompressed files.

• Compressed files are not as portable as uncompressed files. To distribute WAV files in a compressed format, you must 
verify that the audience can use them. Also, not all audio software can use compressed WAV files, which may make 
using other applications with the Sound Forge software difficult.

In Sound Forge software, any compressed WAV file can be opened if a compatible ACM driver is installed. If no 
compatible ACM driver is available for a compressed WAV file, you are alerted to the problem.

Saving compressed WAV files is as simple as specifying the compression algorithm in the Format drop-down list of the 
Custom Settings dialog. Once a compressed file is saved, updates to the file are automatically saved using the selected 
compression algorithm. The compression format can be changed later—or reverted to an uncompressed format—using 
the Save As dialog.
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Transparent playback and recording of non-hardware supported audio files

The second component of the ACM is called the Sound Mapper. It allows playback and recording of audio data formats that are not 
directly supported by the sound card. You can select the Sound Mapper as the Playback and Record devices on the Audio tab of the 
Preferences dialog. You can perform any additional configuration of the Sound Mapper from the Windows Control Panel.

The Sound Mapper functions as follows. When faced with a sound file recorded at an unusual sample rate such as 22,257 Hz and a sound 
card that supports 22,050 Hz, the sound file normally cannot be played. The sample rate of the file must be changed to 22,050 Hz before 
it can be played back, but changing the sample rate without resampling causes a pitch shift. However, the Sound Mapper plays this file 
without resampling by mapping the sound to the best format possible and performing the resampling in real time. 

In addition, the Sound Mapper plays compressed sound files, even on sound cards that do not support compression directly. A file 
compressed with Microsoft ADPCM or The DSP Group’s TrueSpeech plays on any sound card without first decompressing the file.

The Sound Mapper can, under the right circumstances, record compressed sound files. Compressing sound data can be 
computationally expensive, and the amount of time required is dependent upon the specific compression algorithm and how it is 
implemented. Decompressing sound data is typically faster than compressing the same sound data.

It should be noted, however, that the Sound Forge application does not play and record compressed sound files directly. Rather, all 
compression and decompression is performed while opening and saving the files. This limitation is fairly insignificant, and the 
compressed sound files are saved using the best possible quality—something that cannot always be done in real time. Compressed 
sound files saved with the software typically sound better than those recorded with audio compression.

After you save uncompressed audio data to a compressed format, you should audition the file. Compression and decompression are 
performed during opening and saving; therefore, the compressed file is not accurately represented until it has been reopened.
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Appendix C
 SMPTE Timecode

The Society of Motion Picture and Television Engineers (SMPTE) timecode may be one of the most misunderstood 
concepts among individuals within the music industry. The problem with SMPTE timecode formats is that they may mean 
different things to people in the audio and video fields. What follows is a brief description of each SMPTE timecode 
format.

SMPTE 25 EBU (25 fps, Video)

SMPTE 25 EBU timecode runs at 25 fps (frames per second), and matches the frame rate used by European Broadcasting 
Union (EBU) television systems.

SMPTE 25 EBU format is used for PAL DV/D1 video projects.

SMPTE Drop Frame (29.97 fps, Video)

SMPTE Drop Frame timecode runs at 29.97 fps, and matches the frame rate used by NTSC television systems (North 
America, Japan). 

SMPTE Drop Frame format is used for NTSC DV/D1 video projects.

Both SMPTE Drop and SMPTE Non-Drop run at 29.97 fps. In both formats, the actual frames are not discarded, but they 
are numbered differently. SMPTE Drop removes certain frame numbers from the counting system to keep the SMPTE 
clock from drifting from real (“wall clock”) time. The time is adjusted forward by two frames on every minute boundary 
except 0, 10, 20, 30, 40, and 50. For example, when SMPTE Drop time increments from 00:00:59.29, the next value is 
00:01:00.02. 

SMPTE Non-Drop Frame (29.97 fps, Video)

SMPTE Non-Drop Frame timecode runs at a rate of 29.97 fps. This leads to a discrepancy between real (“wall clock”) time 
and the SMPTE time, because there is no compensation in the counting system as there is in SMPTE Drop Frame.

SMPTE Non-Drop format is used for NTSC D1 video projects that are recorded on master tapes striped with Non-Drop 
timecode.

SMPTE 30 (30 fps, Audio)

SMPTE 30 is an audio-only format and runs at exactly 30 fps. SMPTE 30 is commonly used when synchronizing audio 
applications such as multitrack recorders or MIDI sequencers. This format is not used when working with video.

SMPTE Film Sync (24 fps)

The SMPTE Film Sync time format runs at 24 fps (frames per second). This frame rate matches the standard crystal-sync 
16/33 mm film rate of 24 fps.

Important: When synchronizing audio to video, it is crucial that the SMPTE timecode format used in the sequencer or 
digital audio workstation is the same as the SMPTE timecode striped onto the video. This guarantees that the SMPTE times 
on the video screen and computer monitor synchronize during playback.
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Appendix D
 Using CSOUND, MTU, IRCAM, BICSF, and EBICSF Files

Although Sound Forge® software supports a large number of sound file formats directly, it does not support the 
CSOUND, MTU, IRCAM, BICSF or EBICSF file types. However, you can use the Sound Forge Raw File Type capabilities to 
extract sound data from these file types.

About IRCAM files

The IRCAM or IRCAM-Gross format consists of a 1024-byte header prior to the audio data. This header contains standard 
information like the number of channels, sampling rate, and data format, but can also contain the name of the sample 
and comments. This format is used by the MTU system and these files are frequently referred to as MTU files. IRCAM files 
support two types of data formats: 16-bit linear PCM and floating point data.

About BICSF and EBICSF files

BICSF and EBICSF files (Berkeley/IRCAM/CARL Sound File or Extended BICSF) are extensions of the IRCAM format. Instead 
of using the standard IRCAM header, these files replace the first 28 bytes of the header with a standard NeXT/Sun header. 
This allows the IRCAM format to store additional information in its 1024-byte header, while also allowing the files to be 
read by software that supports the NeXT/Sun file format, such as the Sound Forge application.

Opening files

BICSF and EBICSF files

When reading BICSF and EBICSF files, the software identifies them as NeXT/Sun files. This is because the header of the 
BICSF file has been modified to allow it to be read as a NeXT/Sun file. These files are read as long as they are in one of the 
supported NeXT/Sun data formats.

IRCAM, CSOUND and MTU files

To read these formats, users must import them as Raw data files. This is best accomplished by configuring the parameters 
in the Raw File Type dialog and saving them as presets. The Raw File import function allows these files to be opened 
providing they are stored in 16-bit linear format. Sound Forge software does not open floating point format IRCAM files.
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Opening an IRCAM file

1. From the File menu, choose Open. The Open dialog appears.

2. Specify Raw Audio from the Files of type drop-down list.

3. Select an IRCAM file to open and click Open. The Raw File Type dialog appears.

4. Configure the following parameters:

• Specify a sample rate from the Sample rate drop-down list.
• In the Sample type area, select the 16-bit PCM radio button.
• In the Format area, select the Signed radio button.
• Select the appropriate Byte order radio button.
• Choose a setting from the Channels drop-down list to select the number of channels stored in the file.
• Set the Header value to 1024 bytes.
• Set the Trailer value to 0 bytes.
• To automatically use these settings to open all Raw files, select the Remember my preference and apply it in the future check 

box.

5. Click OK.

6. Click Save As. The Save Preset dialog is displayed.

7. Enter a name for the preset in the New preset name box and click OK. The preset is saved and the Raw File Type dialog is displayed.

8. Click OK. The file opens.

Remember that the byte order of files generated by CSOUND is not constant. CSOUND executables for PC generate files that use Little 
Endian byte ordering, while CSOUND for other platforms tends to generate files with Big Endian ordering. In addition, MTU files use Big 
Endian byte ordering. Sony Media Software recommends initially trying a file in Big Endian. 

Saving files

You cannot save these files in their original format. You must select a Sound Forge-supported file format.

To save files for use with software that supports the BICSF/EBICSF format, use the NeXT/Sun format. This format does not save the 
additional information found in BICSF/EBICSF files, but allows the data to be read as a NeXT/Sun file.

Tip: If you select the Remember my preference and apply it in the future check box, Sound Forge will bypass the Raw File Type 
dialog. However, you can access and change these settings from the Open dialog by selecting a Raw file and then clicking the 
Custom button.

Notes: 

• The settings you choose for opening the file — with the exception of the sample rate — will be used when you click Save or save the file 
using the Default Template setting in the Save As dialog as long as the number of channels in the source file matches the number of 
channels in the file you’re saving. The sample rate will be determined from the source file.

• If you do not always use the same settings for reading raw files, make sure the Keep media files locked check box is selected on the 
General tab of the Preferences dialog. Otherwise, the individual settings will be lost if you have multiple raw files open and switch away 
from the Sound Forge window.

Note: You may want to save presets for byte ordering, as well as mono or multichannel, when receiving CSOUND files from a number of 
source computers.
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Index
A

ACID
Creating loops for, 217–221
Loop Creation Tools toolbar, 31, 219

Acoustic Mirror, 171–181
Adjusting impulse length, 173
Apply envelope and limit decay to check box, 172
Auto-detect timing spikes mode, 174
Convert mono to stereo check box, 172
Do not use timing spikes mode, 174
Envelope tab, 173
Error messages, 181
General tab, 172
Head-related transfer functions, 179
Impulse control, 172
Impulse output control, 174
Impulse recovery modes, 174
Limiting length of impulse, 172
Low-shelf start frequency/High-shelf start frequency 
control, 172
Package Impulse into Preset button, 173
Pan control, 172
Recorded file control, 174
Recover Impulse button, 174
Recover tab, 174
Remove very low frequencies check box, 174
Reset button, 173
Response delay control, 172
Response width control, 172
Saving the impulse with a preset, 173
Summary tab, 174
Test file used control, 174
Troubleshooting, 180
Use the start and end of the recorded file as timing spikes 
mode, 174
Using, 171

Acoustic signature, 171
Adjusting, 171

Active data windows, 51
Adding regions to the playlist, 108
Adding tracks to a CD, 123
Additional embedded information, 89
Adjusting envelopes, 169
Adjusting VU meter sensitivity, 36
Animating the video strip, 224
Applying effects automation, 168
Arranging the playlist, 109
ASIO driver support, 113
Attaching video to an audio file, 226
Attributes

file, 83

Audio
digital, monitoring, 32
editing file attributes in Properties, 83
editing file attributes in status bar, 83
increasing volume, 156
mixing from the clipboard, 61
normalizing, 151
reversing, 155
setting volume, 156

Audio device
adjusting hardware outputs, 92

Audio editing, 57–62, 127–128, 129–131
Copying, 57
cutting selections, 59
deleting selections, 60
Mixing, 130
mixing, 60
Overwriting, 127
Pasting, 57, 129
Replicating, 128
Trimming/Cropping, 60

Audio event locator
configuring, 72
scrubbing with, 72

Audio file
detaching video, 227

Audio files
Saving all open, 54

Audio glitches
Finding and repairing, 132

Audio Restoration, 134
Audio spectrum analysis, 229
Audio synthesis, 135–137

DTMF/MF Tones, 135
FM, 135
Simple, 137

Auto Region tool
musical time intervals, 103
Rapid sound attacks, 102

Auto Trim/Crop, 142
Attack threshold fader, 143
Fade in, 143
Fade out, 143
Function drop-down list, 143
Release threshold fader, 143

Automatic labeling for files, regions, and markers, 121
Automatic labeling for Markers, 97
Automatic labeling for regions, 104
Automatic recording, 116
Automatic retake, 119

Adjusting pre/post-roll, 120
Automating effect parameters, 167
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Automation
effects, 168

Auto-snapping
disabling at high magifications, 81

B

Batch Converter, 191
creating or editing batch job, 191
existing batch job, 191
metadata, 192

BICSF, 267
Bit depth, 144

Changing, 84
Converter, 143
editing in Properties, 83
editing in status bar, 83
For CD burning, 123

Bit-Depth Converter
bit depth, 144
controls, 144
dither, 144
noise shaping, 144

Blinking status while recording, 122
Burning CDs, 123

proper use of software, 125

C

Calculating loop tempo, 221
Calibrating DC adjustment for recording, 119
CD

Adding tracks, 123
Bit depth for burning, 123
Burning, 123
Closing the disc, 125
Extracting audio from, 122
Sample rate for burning, 123

CD Architect
exporting to, 66

CD information, 46
editing, 45
obtaining, 45
submitting to Gracenote, 46

Changing the region order, 107, 109

Channel Converter, 88, 145
Channels, 146
dialog controls, 146
End, 146
intermixing channels, 146
Invert Mix, 146
Length, 146
mono to multichannel, 145
mono to stereo, 145
Output channels, 146
Source, 146
Start, 146
stereo to mono, 146
swapping stereo channels, 146

Channel Meters, 22
Channel meters, 33, 203

showing/hiding, 33
Channel repair, 132
Channels, 87

intermixing, 146
routing to hardware outputs, 91
swapping in stereo file, 146

Clipboard
copying cutlist to, 112
copying playlist to, 112
copying Regions List to, 112
mixing audio from, 61

Clipped audio
marking, 98

Clipping indicators, 34
Clips

detecting, 98
Closing a CD, 125
Command descriptions, 32
Command markers

deleting, 100
Editing, 100
Inserting, 100
Scott Studios, 100

Commands
customizing shortcut assignment, 250

Commands for streaming media, 99
Compression, 86
Configuring

Measures and beats format, 65
MIDI devices, 196
MIDI Keyboard, 210
MIDI triggers, 196
Plug-ins on a chain, 162

Controls
Envelope graphs, 38
Faders and slider, 37
Using the mouse, 19, 79, 260

Convert to New, 111
Converting file formats, 88
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Converting mono files to stereo or multichannel, 145
Converting stereo files to mono, 146
Copying, 57
Copying current video frame, 224
Count, 108
Crash recovery, 67
Creating

Automatic regions, 102
CDs, 123
Graphic fades, 147
Impulse files for Acoustic Mirror, 175
Markers, 96
Markers during playback, 96
Markers during recording, 96, 121
Markers for each index change in extracted CD track, 122
New data windows, 51
New files from the playlist, 111
New windows for each recorded take, 119
Pans, 153
Presets, 140
regions, 101
Regions for each extracted CD track, 122
Regions from markers, 98
regions from markers, 105
Release loops, 214
Sampler configurations, 206
Selections, 78
Selections on the fly, 79
Stop points, 110
Sustaining loops, 213
Views, 82

Creating custom pans, 153
Cropping audio, 60

Using Auto/Trim Crop, 142
Crossfade Loop tool, 216
CSOUND, 267
Cursor position, 69
Custom graphic fade, 148
Customizing keyboard shortcuts, 250
Customizing Sound Forge

Preferences, 239
Cutlist, 111–112

Adding regions to, 111
copying to the clipboard, 112
Creating a new file from, 111
Deleting all cutlist regions, 111
Opening cutlist files, 112
Reverting to playlist, 111
Saving cutlist files, 112

Cutting
previewing cuts, 59
selections, 59
selections in multichannel files, 59

D

Data window, 23
arranging, 24
Components, 23
Displaying/hiding elements, 24
Overview bar, 70

DC Offset
Adjust DC offset by, 147
Compute DC offset from first 5 seconds only, 147

DC offset, 119
Automatically detect and remove, 147
calibrating adjustment for recording, 119
calibrating the DC adjustment, 119
compensating for, 147
dialog controls, 147
estimating, 147
recalibrating the DC adjustment, 119
recalibrating the DC adustment, 119

Defragmenting the hard disk, 203
Deleting

all regions, 104
all regions within selected area, 105
Command markers, 100
Presets, 140
Recovered files, 67
regions, 104
Regions from the playlist, 109
selections, 60
selections in multichannel files, 60
Stop points in the playlist, 110

Deleting a keyboard map, 250
Deleting all markers and regions, 97
Deleting markers, 97
Digital audio

monitoring, 32
DirectX Plug-ins, See Effects
Display resolution

VU/PPM meter, 36
Displaying

Data window elements, 24
Playlist, 108
Regions List, 106
Sonogram, 234
Video strip, 223
Wave Hammer, 181

Dither, 85, 144
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Docking windows, 21
Explorer, 22
Keyboard, 23
Playlist, 22
Plug-In Chainer, 23
Plug-In Manager, 23
Regions List, 22
Script Editor, 23
Spectrum Analysis, 22
Time Display, 22
Undo/Redo History, 22
Video Preview, 22

Drag-and-drop
Creating new windows, 131
Editing, 129
Mixing, 130
Mono selections to multichannel destinations, 129
Pasting, 129
Snapping to events, 129

Dropping Markers, 96
Dropping markers

During recording, 121
DTMF/MF Tones, 135
DX Favorites menu, 166

E

EBICSF, 267
Editing

command markers, 100
Drag-and-drop, 129
Loops, 216
media file’s source project, 56
multichannel audio, 91, 92
regions in the data window, 104
Sample rate, 84
Sample size, 84
Summary information, 88

Effects, 159
adding, 159
Adding a chain of effects, 160
applying, 159
applying automation, 168
applying in multichannel files, 159
Audio tail data processing mode, 163
Automatically organizing, 167
automating, 167
automating with envelopes, 167
Bypassing effects on a chain, 163
Configuring plug-ins on a chain, 162
DX Favorites menu, 166
Hiding effects, 166
Loading saved chains, 164
Loading saved presets, 164
Plug-In Manager, 165
Preset Manager, 167
previewing automation, 168
removing automation envelopes, 168
Removing plug-ins from a chain, 162
Renaming effects, 166
Saving chains, 163
Saving settings as a preset, 159, 164

Effects toolbar, 30
Embedded information, 89
Envelope graphs, 38
Envelopes

adding points, 169
adjusting, 169
adjusting effect parameters, 168
bypassing effect automation, 168
copying to another data window, 170
cutting, copying, and pasting points, 169
effect automation, 167
enabling effect automation, 168
flipping, 169
removing effect automation, 168
setting fade properties, 169
showing/hiding effect automation, 168
volume or panning, 167

EQ, 147
Error messages for Acoustic Mirror impulse files, 181
Estimating DC offset, 147
Explorer, 22
Explorer window, 45

Extracting audio from CD, 46
Opening media, 45
Previewing media, 45
views, 47

Exporting, 66
all audio files, 67
single audio file, 66
to CD Architect, 66
to Net MD devices, 67
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Exporting to CD Architect
All audio files, 66
Single audio file, 66

Extend edge to next zero
selection, 81

Extend to next zero
selection, 81

Extended summary information, 88
External

MIDI devices, 198
Monitors, 226
Samplers, 205

Extract Regions, 106
Extracting audio

proper use of software, 125
Extracting audio from CD, 122

Creating markers for each index change, 122
Creating regions for each track, 122

F

Fade, 147
Graphic, 147
In, 149
Out, 149

Fade properties
envelopes, 169

Faders and sliders, 37
Fast Fourier Transform (FFT), 229
File properties

editing, 83
Files

attributes, 83
Automatically naming, 121
Channels, 87
Converting, 88
Creating from the playlist, 111
Explorer window, 45
Opening, 44
opening, 44
Playing, 48
rendering, 66
Sample rate, 84
Saving, 52

Finding and repairing audio glitches, 132
Fine-tuning selections

Keyboard methods, 79
Mouse methods, 79

Flipping envelopes, 169
Floating windows, 21
FM synthesis, 135
Format conversion, 88
Frame animation, 223
Frame numbering, 224

G

Generating MTC with Sound Forge software, 200

Getting Media, 44
Glitches

Finding, 132
Repairing by copying the other channel, 132
Repairing by interpolating audio, 133
Repairing by replacing with preceding audio, 133
Repairing with the Pencil tool, 134

Go To, 69
Gracenote, 45, 46
Graphic fade, 147

Creating a custom fade, 148
Maximum Gain control, 149
Reset Envelope button, 149
resetting the envelope, 149
Show wave control, 149
showing the waveform, 149

H

Halving/doubling loops, 219
Hard disk defragmentation, 203
Hardware meters, 92

adjusting output levels, 93
adjusting preview levels, 93
showing/hiding, 93

Hardware setup
External monitor, 226
MIDI/SDS, 211
SCSI/SMDI, 211

Help
On the Web, 17

Hiding
Data window elements, 24
Docked windows, 22
Effects (plug-ins), 166
Video strip, 223

Holding peaks/valleys, 36

I

Importing
Keyboard shortcut map, 251

Impulse files
Adding summary information, 178
Creating, 175
Equipment needed, 175
Equipment placement, 175
Head-related transfer functions, 179
Recording the test tone, 176
Recovering from an acoustic space, 175
Recovering from an electronic device, 175
Recovering the impulse, 176
Setting levels, 176
Transferring the test tone, 175
Trimming impulse files, 177
Trimming the test tone, 176
Using in creative ways, 178

Increasing the volume of a selection, 156
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Initiating MIDI playback, 197
Inserting

Command markers, 100
Silence, 149

Installing
Sound Forge software, 16

Intermixing channels in a file, 146
Internal

MIDI devices, 198
Samplers, 205

Interpolating audio to repair glitches, 133
Introducing Sound Forge software, 15
Invert/Flip, 150
IRCAM, 267

K

Keyboard
MIDI, 209

Keyboard mapping
saving, 250

Keyboard shortcuts, 253
creating new, 250
customizing, 32, 250
deleting a keyboard map, 250
editing, 250
importing a keyboard map, 251
renaming a keyboard map, 251
resetting the default keyboard map, 251
saving a keyboard map, 250

Keyboard window, 23

L

Labels
Automatically generating for files, regions, and 
markers, 121
automatically generating for markers, 97
automatically generating for regions, 104

Level ruler, 74
Levels toolbar, 31
Locking loop and region lengths, 106
Looped playback, 49
Loops, 213–221

Creating for ACID, 217–221
Editing, 216
Halving/doubling, 219
Release, 213
Rotating audio, 220
Saving, 221
Setting tempo, 221
Shifting selections left/right, 220
Sustaining, 213

M

Magnify tool, 76
Mapping

keyboard, 250, 251

Markers, 96–100
Automatically naming, 121
automatically naming, 97
changing position, 97
clipped audio, 98
Creating, 96
Creating during playback, 96
Creating during recording, 96, 121
Creating regions from, 98, 103, 105
deleting, 97
deleting all within a selection, 97
editing default names, 244
moving, 97
naming, 96
previewing, 98
renaming, 96
snapping to, 80
triggering using MIDI commands, 98

Measures and Beats
Configuring, 65

Media
getting, 44

Media files
Auto preview setting, 45
publishing to the Web, 66

Meters
audio input, 121
channel, 33
disabling, 203
hardware, 92
mono-compatibility, 37
phase scopes, 36
showing/hiding, 33, 34, 93
VU, 35
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MIDI, 195–201
Conflicting SCSI IDs, 211
Device configuring, 196
Devices, 198
Fine-tune value, 208
Initiating playback, 197
Input synchronization, 196
Keyboard, 209
Open loop versus closed loop, 207
Periodic transfer failures, 212
Playback and triggered playback, 195
Resetting triggers, 197
Sample Dump Standard (SDS), 205, 211
SCSI MIDI Device Interface (SMDI), 205
SMPTE, 195
Synchronizing when recording, 120
Timecode synchronization, 199–201
Trigger configuring, 196
Triggered playback, 195
Triggers, 195
Unity note, 208
using commands to trigger markers, 98
using commands to trigger regions, 105

MIDI Keyboard, 209
Configuring, 210
Displaying, 209
Generating chords, 210
Specifying instruments, 210
Troubleshooting, 210
Turning on, 209

Minimizing quantization error, 85
Mixing, 60, 130

audio from the clipboard, 61
by dragging and dropping, 60

Monitor for video previewing, 226
Monitoring audio input levels, 121
Monitoring levels in digital audio, 32
Mono files

converting from stereo, 146
converting to stereo or multichannel, 145

Mono to stereo conversion, 87
Mono-compatibility meters, 37
Mouse shortcuts, 19, 79, 260
Moving markers, 97
MTC sync, 199–201
MTU, 267
multichannel, 60

Multichannel audio
applying effects, 159
deleting selections in, 59, 60
editing, 91
opening and editing, 92
recording, 120
routing channels to hardware outputs, 91
synchronizing sonograms, 236
synchronizing spectrum graphs, 232

Multichannel files
creating from mono, 145
Selecting data, 40
Single-channel editing, 42
Working with, 40

Multiple takes (no Regions), 119
Multiple takes creating regions, 119
Musical time intervals, 103
Mute, 150

N

Naming
Automatically naming files, regions, and markers, 121
automatically naming markers, 97
automatically naming regions, 104
markers, 96

Naming a region, 104
Navigating

In the overview bar, 71
Spectrum graphs, 232

Navigation toolbar, 28
Net MD devices

exporting to, 67
New window

Creating, 51
Creating for each recorded take, 119
Creating through drag-and-drop, 131

Noise gate, 86
Noise shaping, 85, 144
Normalize, 86, 151

Applying dynamic compression, 86
dialog controls, 152
INDEX | vii



Normalize dialog
Attack time, 152
Average RMS level, 152
controls, 152
If clipping occurs, 152
If clipping occurs, Apply dynamic compression option, 152
If clipping occurs, Ignore (saturate) option, 152
If clipping occurs, Normalize peak value to 0 dB option, 152
If clipping occurs, Stop processing option, 152
Ignore below, 152
Normalize to, 152
Normalize using average RMS level, 152
Normalize using peak level, 152
Peak level, 152
Release time, 152
Scan Levels, 152
Use current scan level, 152
Use equal loudness contour, 152

Normalizing audio, 151

O

obtaining from Gracenote, 46
Online help

Via the web, 17
Open dialog, 44
Opening

Cutlist files, 112
Files, 44
multichannel audio, 92
Playlist files, 112
Regions List files, 107
Workspaces, 54

Opening files
Explorer window, 45

Optimization
Hard disk defragmentation, 203
meters, 203
Passive update, 203
Playback cursor and record counter, 203
Total buffer size, 203

Overview bar
Navigating, 71
Playback, 71
Using, 70

Overwriting, 127

P

Pan/Expand, 153
creating custom pan, 153
creating pans, 153
dialog controls, 154

Pan/Expand dialog, 154
controls, 154
Process mode, 154
Process mode, Pan (preserve stereo separation) option, 154

Panning, 153
creating a custom pan, 153

Passive updating of displays, 203
Paste Special, 127

Overwriting, 127
Replicating, 128

Pasting, 57, 129
by dragging and dropping a selection, 58
Drag-and-drop, 129
In existing data windows, 58
In new data windows, 58

Peak files, 47
Pencil tool, 134
Phase scopes, 36
Playbar

Current playback mode, 25
Optional shuttle control buttons, 25
Using, 25

Playing
Files, 48
From a specific point, 48
From the cutlist, 111
From the playlist, 110
Loop Playback mode, 49
Selections, 49

Playlist, 22, 108–112
Adding regions, 108
Arranging, 109
copying to the clipboard, 112
Count, 108
Creating new files from, 111
Deleting regions from, 109
Displaying, 108
Opening playlist files, 112
Playing from, 110
Replicating regions, 109
Saving playlist files, 112
Stop points, 110
Treating as cutlist, 111

Plug-In Chainer, 23
Adding plug-ins, 161, 165
Audio tail data processing mode, 163
Bypassing plug-ins, 163
Configuring plug-ins, 162
Loading saved chains, 164
Loading saved presets, 164
Plug-In Manager, 165
Preset Manager, 167
Removing plug-ins, 162
Saving chains, 163
Saving settings as a preset, 164
VST Effects, 160

Plug-In Manager, 23, 165
Plug-ins, See Effects
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Preferences
Audio, 248
Display, 242
Editing, 243
File Types, 244
General, 240
Labels, 243
MIDI/Sync, 245
Previews tab, 246
Status, 247
Toolbars, 247
Video, 249
VST Effects, 250

Pre-roll to cursor, 69
Preset Manager, 167
Presets, 139

Creating, 140
Deleting, 140
Managing, 167
saving in Spectrum Analysis graph, 238
Using, 139

Previewing
cuts, 59
markers, 98
Operations, 141
regions, 105
video, 224

Previewing effect automation, 168
Previews, 141

Bypass, 141
Parameters, 141

Printing
sonogram, 236
spectrum graph, 234

Process mode, Mix mid-side (MS) recording to left and right 
channels option, 154

Process mode, Pan (mix channels before panning) option, 154
Process mode, Stereo expand option, 154
Process toolbar, 30

Processes, 139–157
Auto Trim/Crop, 142
Bit-Depth Converter, 143
Channel Converter, 145
DC Offset, 147
EQ, 147
Fade, 147
Fade In, 149
Fade Out, 149
Insert Silence, 149
Invert/Flip, 150
Mute, 150
Normalize, 151
Pan/Expand, 153
resample, 154
reverse, 155
smooth/enhance, 155
time stretch, 155
volume, 156

Processing dialogs
Adjusting the data window selection, 141
Channel box, 141
End box, 141
Length box, 141
More button, 141
Start box, 141

Projects
creating, 43

Proper use of software, 125
Properties

editing file attributes, 83
Publishing to the Web, 66
Punch-In

Adjusting pre/post-roll, 120
Recording mode, 119

Q

Quantization error, 85

R

Rapid sound attacks, 102
RealMedia (.rm) commands, 99
Receiving samples, 208
Record meters, 121
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Recording, 113–122
Acoustic Mirror test tone, 176
adjusting pre/post-roll, 120
audio configuration

Audio configuration, 113
automatically, 116
Automatically labeling files and regions, 121
Changing blinking status, 122
DC offset, 119
Inserting markers, 121
Modes, 119
multichannel, 120
normal mode, 114
Playing back recorded audio, 120
Punch-In, 119
Synchronizing with other devices, 120
triggering by set threshold, 117
triggering by time, 116
viewing audio input levels, 121
with a timer, 116

Recovering files after a crash, 67
Recovering the impulse for Acoustic Mirror, 176
Region

deleting, 104
naming, 104
renaming, 104

Regions, 101–106
Automatically naming, 121
automatically naming, 104
creating, 101
Creating automatically, 102
Creating from markers, 98
creating from markers, 105
deleting all, 104
deleting all in a selected area, 105
deleting all within a selection, 97
editing default names, 244
editing in data window, 104
Extracting, 106
inserting using drag-and-drop, 102
inserting using the keyboard, 102
inserting using time ruler shortcut, 102
Playback using MTC, 199
previewing, 105
triggering using MIDI commands, 105

Regions List, 22, 106
Changing the region order, 107, 109
copying to the clipboard, 107
Displaying, 106
opening Regions List files, 107
Saving Regions List files, 107

Regions/Playlist toolbar, 29
Release loops, 213

Creating, 214

Renaming
markers, 96

Renaming a region, 104
Renaming effects (plug-ins), 166
Rendering files, 66

saving the project path, 56
Repairing audio

Audio Restoration plug-in, 134
Copying the other channel, 132
Interpolating audio, 133
Replacing with preceding audio, 133
Using Pencil tool, 134

Repeating an operation, 129
Replacing glitches, 133
Replicating

Audio, 128
Regions in the playlist, 109

Resample
dialog controls, 155

Resample dialog
controls, 155
Interpolation accuracy control, 155
New sample rate control, 155

Resampling, 154
downsampling, 154
upsampling, 154

Resetting default keyboard map, 251
Restoring a selection, 79
Reverse, 155
Reversing audio, 155
Rotating audio, 220

S

Sample rate, 84
Editing, 84
editing in Properties, 83
editing in status bar, 83
For CD burning, 123

Sample size
Editing, 84

Sampling, 205
Configuring the sampler, 205
External samplers, 205
Internal samplers, 205
MIDI Keyboard, 209
Open loop versus closed loop, 207
Sample Dump Standard (SDS), 211
Sampler Tool, 205
Saving sampler configurations, 208
SCSI/SMDI hardware and setup, 211
Sending and receiving samples, 208

Save All, 54
Save As, 52, 88
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Saving
All open files, 54
Cutlist files, 112
Files, 52
Loop points, 221
Playlist files, 112
project path in rendered file, 56
Regions List files, 107
Sampler configurations, 208
Summary information, 89
Video files, 228
Workspaces, 54

Scott Studio
commands, 100

Script commands, 99
Script Editor, 23
Scripting, 185

Additional online information, 185
API and sample scripts, 185
Batch Converter, 191
Creating a script, 188
Editing an existing script, 188
Opening and running a script, 187
Script Editor window, 186
Scripting toolbar, 189

Scripting toolbar, 189
Adding or removing toolbar buttons, 189
Creating custom button images, 190
Running a script from, 190

Scrubbing, 72
on the timeline, 72
with the audio event locator, 72
with the keyboard, 72
with the scrub control slider, 72

SCSI MIDI Device Interface (SMDI), 205
SCSI/SMDI

Hardware setup, 211
Troubleshooting, 211

Selection, 81
extend edge to next zero, 81
extend to next zero, 81
snap edge to grid, 81
snap edge to zero, 81
snap to grid, 81

Selections
Auto snap to, 80
Creating on the fly, 79
deleting all markers and regions within, 97
Fine-tuning, 79
Restoring, 79
Selection status boxes, 49
Set Selection dialog, 78
Statistics, 50

Sending samples, 208

Sensitivity
VU meters, 36

Set Selection dialog, 78
Setting digital audio levels, 33
Setting volume, 156
SFK files, 47
Shifting a selection left/right, 220
Shortcuts

creating new, 250
customizing, 250
deleting a keyboard map, 250
editing, 250
importing a keyboard map, 251
Keyboard, 253
renaming a keyboard map, 251
resetting the default keyboard map, 251
saving a keyboard map, 250

Simple synthesis, 137
Smooth/Enhance, 155
SMPTE, 195, 265
Snap edge to grid

selection, 81
Snap edge to zero

selection, 81
Snap to grid

selection, 81
Snap to zero

selection, 81
snap to zero, 81
Snapping, 80

current selection, 80
disabling at high magnifications, 81
to grid, 80
to markers, 80
to whole time divisions, 80
to zero-crossings, 80

Snapshot
viewing statistics in spectrum graph, 234

Snapshots
creating and comparing, 233
erasing in spectrum graph, 234
showing and hiding in spectrum graph, 233
taking in a spectrum graph, 233
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Sonogram, 234
adjusting color intensity, 236
Displaying, 234
Displaying frequency and amplitude values, 235
Displaying notes, 235
Displaying statistics, 235
improving contrast, 236
improving frequency resolution, 236
printing, 236
reducing processing time, 236
smoothing display, 236
synchronizing for multichannel file, 236
Tuning, 236
Updating, 235

Sound Forge software
Command descriptions, 32
Controls, 37–39
Crash recovery, 67
Data window, 23
Installation, 16
Introduction, 15
Playbar, 25
Status formats, 65
Toolbars, 26
ToolTips, 32

Spectrum Analysis, 22
changing spectrum graph zoom level, 232
changing the graph type, 232
printing graph, 234
printing sonogram, 236
Refreshing graphs, 232
saving custom settings, 238
settings, 237
snapshots, 233

Spectrum analysis, 229
FFT, 229
Sonogram, 234
Spectrum graph, 230

Spectrum graph, 230
Ceiling setting, 237
changing zoom level, 232
Channels setting, 237
Displaying, 230
Displaying frequency and amplitude values, 231
Displaying notes, 231
Displaying statistics, 231
erasing snapshots, 234
FFT overlap setting, 237
FFT size setting, 237
Floor setting, 237
Freq. Min. (Frequency minimum) setting, 237
Hold peaks during monitoring setting, 237
Logarithmic graphing setting, 237
Maintain last monitored view setting, 237
Max. (Frequency maximum) setting, 237
Monitoring input/output source, 231, 236
Navigating, 232
printing, 234
saving custom settings, 238
Set sonogram resolution setting, 237
showing and hiding snapshots, 233
Slices displayed setting, 237
Smoothing window setting, 237
snapshots, 233
Sync graphs setting, 237
synchronizing for multichannel file, 232
taking snapshots, 233
thumbnail image, 232
updating, 232
Viewing multiple, 233
viewing snapshot statistics, 234

Spectrum graph type
changing, 232

Spectrum graphs
automatically updating, 232
refreshing, 232

Standard toolbar, 27
Statistics, 50
Status bar

editing file attributes, 83
Status boxes, 49
Status formats, 65
Status/Selection toolbar, 29
Step-down conversion, 84
Step-up conversion, 84
Stereo

compressing selections, 153
expanding selections, 153
swapping channels, 146
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Stereo files
Converting to mono, 87
converting to mono, 146
creating from mono, 145
Previewing data, 41

Stop points
Creating, 110
Deleting, 110

Streaming media commands, 99
for RealPlayer, 99
for Windows Media, 99

Summary information, 88
Editing, 88
Saving, 89
Viewing, 88

Sustaining loops, 213
Swapping stereo channels, 146
Synchronizing MIDI timecode, 199–201
Synthesizing audio, 135–137
System requirements, 15, 187

T

Tempo
Calculating for loops, 221
Changing a file’s beat values, 66
Creating regions using current tempo, 103
Specifying for ACID loops, 218

Test tone for Acoustic Mirror, 175
Threshold recording, 117

setting prerecord buffer, 117
Time Display, 22
Time ruler, 73
Time Stretch, 155
Timecode

SMPTE, 265
Toolbars, 26

ACID Loop Creation Tools, 31, 219
Customizing, 26, 247
Displaying, 26
Effects, 30
Levels, 31
Navigation, 28
Process, 30
Regions/Playlist, 29
Standard, 27
Status/Selection, 29
Tools, 31
Transport, 27
Views, 28

Tools
Crossfade Loop, 216
Find, 132
Magnify, 76
Pencil, 134
Sampler, 205

Tools toolbar, 31

ToolTips, 32
Total buffer size, 203
Transport bar, 27
Triggered playback, 195
Triggered region playback, 197
Triggering markers with MIDI commands, 98
Triggering regions with MIDI commands, 105
Triggers, 195

Resetting, 197
Trimming audio, 60

Using Auto/Trim Crop, 142
Trimming impulse files for Acoustic Mirror, 177
Troubleshooting

Acoustic Mirror, 180
MIDI Keyboard, 210
SCSI/SMDI, 211
System performance, 203–204

Tuning a sonogram, 236

U

Undo/Redo, 62
Undo/Redo History, 22
Unity note, 208
Updating

Displays, 203
Sonograms, 235
spectrum graphs

Refreshing spectrum graphs, 232

V

Video, 223–228
Attaching video to audio, 226
detaching from audio file, 227
External monitor, 226
Frame animation, 223
Frame numbering, 224
previewing, 224
Saving, 228
Video preview window, 224
Video strip, 223

Video files
working with, 47

Video frame
copying current, 224

Video Preview, 22
Video Preview window

settings, 225
Video strip

animating, 224
copying current video frame, 224
hiding, 223
showing, 223

Viewing audio input levels, 121
Viewing extended summary information, 88
Views, 82

Creating, 82
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Views toolbar, 28
Volume, 156

dialog controls, 157
increasing, 156

Volume dialog
controls, 157

VU meters, 35
adjusting sensitivity, 36
changing display resolution, 36

W

Wave Hammer
Compress tab, 182
Displaying, 181
Limit tab, 183

Web
publishing, 66

Windows Media files
Markers and script commands, 99

Workspaces, 54
Writing to CD, 123

Z

Zero-crossings
Preferences, 79
snapping current selection to, 80
snapping to, 80

Zooming, 73
Level ruler, 74
Time ruler, 73
Zoom ratio, 73
Zoom tricks, 76
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