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Chapter 1  - Introduction

Overview
adCode is a media ingest station for MPEG 2 standard definition 

encode, review and approval of commercial and program material 
from FireWire (DV25), SDI, analog composite or YC sources. adCode 
includes control of professional VTRs over serial RS-422 or FireWire 
for accurate selection of acquisition material. Live feeds from satellite 
or newsroom sources can also be recorded on command by adCode. If 
you work in a non-linear editor like Final Cut, you can export directly 
to adCode without rolling tape in real time. Regardless of your source, 
adCode provides high quality MPEG 2 SD encoding for the best on-air 
presentation.

Applications

• Commercial Insertion: Encode commercials from tape or directly 

from Final Cut ready for digital program insertion (DPI) or linear 

insertion. Review encoded files from any source before they are 

released to the enterprise.

• Program Acquisition: Encode long form material from tape or 

crash record from satellite.

• Multimedia: Create files that provide the best quality playback on 

any Adtec digital media player.

• Non-Linear Editing: Use adCode to offload the rendering process 

in Final Cut for real-time production of your work for use with video 

servers or DVD content creation.

Benefits

• Ingest with less work: adCode is designed to make the tedious 

task of media ingest more streamlined and accurate with configurable 

work profiles that set up parameters with just one click. All you have 

to do is select your source material, encode and review while adCode 

copies the approved file where you want it automatically.

• See what you encode: Real-time confidence decode of the 

ingested material lets you immediately see what you have captured 

with control to abort and re-encode right away. After content is 

encoded, it can also be reviewed as many times as you want before 

final approval. 

• Control with accuracy: adCode can control VTR sources from RS-

422 and FireWire for accurate mark in/out of material to ensure that 

you get what you want.

• Get the highest quality MPEG 2 SD: When it comes to the best 

on-air look, adCode delivers with CableLabs VOD compliant files or 

ramp up to full frame D1 quality MPEG 2 standard definition video 

encoded up to15Mbps with Dolby Digital 2/0 (AC-3) and mixed MPEG 

1 Layer 2 Musicam audio.

• Ingest what you need: adCode can connect to the adManage 

content management server to provide a prioritized list of 

commercials which are scheduled for ad insertion. When the file 

is encoded and accepted, the adManage database is updated with 

valuable metadata including actual duration, ingest time, operator 

and optional expiration date.

• Crash record anytime: For live “crash recording” from satellite 

or newsroom sources, simply press encode or schedule a time and 

duration with adCode to automate the encode process.

• Encode right from Final Cut Pro: If you spend most of your day 

in Final Cut, you will love the way adCode offloads your work using 

Print To Video for real time and near frame accurate media acquisition 

over FireWire.

• Create DPI-ready files: Whether you currently splice local 

content into a digital transport stream or you are planning for DPI 

in the future, adCode can create files that work in both linear ad 

insertion and DPI ad servers. 
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Feature Highlights

Encode Features

• SDI: SDI input video with embedded SMPTE 259M AES-EBU channel 1, 2, 
3, 4 audio.

• Analog: Composite or YC video 

• Dual Stereo analog audio input.  

• Dual Stereo Digital AES-EBU audio input.

• Supports mixed, SDI embedded, Analog, AES-EBU, or FireWire audio 
inputs

• FireWire (DV25): Video, audio and VTR control on one FireWire cable.

• Non-Linear Editors (NLE): Final Cut Print To Video via FireWire or SDI, 
Composite or YC if third part card (Decklink Pro or equivalent) is available.

• VOD Compliant to MD-Sp-VOD-CEP-101-040107 excluding HD.

VTR Control Features 

• Frame accurate Sony Protocol compatible RS-422 control. 

• FireWire protocol compatible. Note: Some FireWire decks are not frame 
accurate and may provide +/- 1 to 3 frame accuracy.

• Source control with Play, Stop, FF, RW, Jog, Shuttle, Set In/Out, Goto 
In/Out and Duration.

Decode Features

• Composite video and analog audio decode.

• Real time confidence decode during encode with abort.

• Decode playback of encoded file. 

• Monitor video from composite or S-Video (YC). 

• Select audio track 1 or 2 to quality control both audio tracks.

Availability 

Model Description

adCode Server • Embedded Linux real time OS.
  >  80GB internal storage.
• Adtec adCode application
• Physical  19” width, 1.75” height, 16” 
depth,  14lbs. weight. 

What’s Included

•  adCode Server, a 1RU encode/decode server.

•  adCode Java Application control & configuration software for 

Windows 2000 or XP,  Macintosh OS X (10.2 or greater), and Linux.

•  Connection Kit: Five audio removable screw terminal (RST) 

connectors, power cord, Ethernet cable, serial adapter

•  Manual

System Requirements
•  Communication: 10/100baseT TCP/IP compatible computer network
•  Power: 70-240 VAC 50-60Hz and 65 Watts (20 Watts typical) of power.
•  Software: adCode configuration and control application requires one of the 
following:

Windows 2000 or XP or Linux computer: Intel or AMD 32 bit processor at 2 
GHz; 512MB memory; 1024x768 32 Bit color capable graphics card; TCP/IP 
compatible computer network.

Macintosh OS-X (10.2 or greater) computer: G4 32 bit processor at 1 GHz, 
G5 64 bit processor (any); 512MB memory; 1024x768 32 Bit color capable 
graphics card; TCP/IP compatible computer network.

Linux Kernel version 2.4 or later

This documentation reflects functionality of Adtec Digital’s adCode Server Firmware 
version 0.1 and adCode application version 1.1.22 released December 2005. Please 
refer to the Adtec website for updated documentation. www.adtecinc.com/support/
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Chapter 2  - Installation and Setup

This chapter covers the setup of the adCode Server and installation 
of the adCode Application as well as encode instructions. 

Setting up the adCode Server
The adCode server should be installed into a one-rack unit 19” rack 

slot. Power should be applied to the unit and configured with a valid IP 
address via the front panel. 

To set the IP address:
 - Press the “Mode” button
 - Enter the IP address of the Server using the “Select” and arrow buttons
 - Press “Enter”
 - Power down unit

With the power disconnected, connect the appropriate ports/cables 
for your setup. Refer to the diagrams on the previous pages for port 
information. Once your cables are connected, apply power to the unit.  
Confirm that the IP address is correct on your unit and that the Link LED 
on the front of the unit is lit before installing the adCode application.

Note: Multiple input sources may be connected at the same time.  For 
example, you can connect a VTR via the RS422 at the same time that 
you have a live feed source connected via FireWire.  

Application Installation

For Windows: The adCode software can be installed on Windows 
XP and 2000 machines. Refer to the system requirements in Chapter 1 
for additional information. Insert the installation CD into your CD player. 
The install program will automatically launch. If it does not, locate the 
CD drive via  “My Computer” and double-click the adCode Installer 
icon. The wizard will walk you through the installation process. After 
installation, the icon for the application can be found on the desktop and 
in the start menu in the adCode folder. 

For MAC: The adCode software can be installed on MAC OSX 
(10.2 or greater). Refer to the system requirements in Chapter 1 for 
additional information. Insert the installation CD into your CD player. 
When the CD appears on the Desktop, double-click on the icon and 
then on the adCode Installer icon. The wizard will take you through the 

installation process. After installation, the launch icon for the application 
can be found on the dock and in the Applications/Adtec/bin/ folder.

Getting Started
 Launch the adCode application. On the following page is an 

overview of the adCode application (Figure 2.1). Take a few minutes to 
review the layout as terms defined there will be used through out the 
manual.

The adCode Application
The adCode User Interface consists of one main screen. There are 

additional adCode tools that are independent of the main screen. These 
tools can be found and launched from the Tools menu of the GUI. These 
include; Video Controls and Audio Controls.



Figure 2.1

adCode Application Main Panel
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Chapter 3 - Configuring adCode 

Profiles
Profiles are used in this application to provide one-click access to 

varying settings. This is most useful when using multiple sources and 
encoding parameters. 

adCode comes with 5 profiles in place. These are standard 
encoding profiles and may meet your needs or you may have the need 
to create your own profile. 

Included Profiles
1 - SDI Tape Deck: RS422, VOD standard.
2 - Composite Tape Deck: RS422, VOD standard.
3 - SDI Input: no source control
4 - Composite Input: no source control (crash record)
5 - Firewire: firewire control, VOD standard.

Creating New Profiles
To create a new profile, browse to File > New Profile.  The 

following screen (Figure 3.1) will appear allowing you to enter a Profile 
Name and Description.  Note that new profiles are based off of the 
currently selected profile, so select the pre-installed profile closest to 
your needs before creating a new one. Those parameters are by default 
listed in the description input box. You may edit that description when 
you create the profile or at a later time. However, the description does 
not need to contain any parameters as it is not tied to those parameters 
and will not update as you make changes to your profile. 

 Figure 3.1

Once you have saved your new profile name and description, 
you will see that the application has disconnected the old profile and 
reconnected using the new one. 

 
Managing Profiles
You are able to edit and/or manage your profiles in two ways. You 

can either make configuration edits while connected to the server via 
the desired profile or select File> Edit Profile> (select your profile name) 
if you are not connected. Editing while connected immediately saves 
your profile setting to the server while editing off-line saves the profile 
to the server the next time you connect to it. 

To delete a profile, go to File> Delete Profile. (Figure 3.2)

  Figure 3.2

This will allow you to select a profile to delete from a drop down 
menu. Once the profile is selected, click on Delete. This will delete the 
profile and close the window. Deleting a profile deletes all of the setting 
attached to that profile. 
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Configuring adCode Server

Connection:
The method of connecting to a source is defined within a profile 

and you will need a completed and correctly configured profile to 
connect to the adCode server.  You can modify one of the default 
profiles provided or create a new one. Go to File > Edit Profile > (the 
name of the profile you wish to use). This allows you to make changes 
to the profile without being connected to the server. 

Now browse to Configuration > adCode Server and select the 
Connection tab.  (Figure 2.2) The Connections tab allows you to 
configure your server to application connection as well as additional 
encoder and decoder parameters. 

 (Figure 2.2)

Profile Name: This field displays the name of the profile you are editing. 
You are allowed to change the name of the Profile which will result in a 
new profile being created.  This makes it easy to create multiple profiles 
with very similar settings. The profile name should be kept to under 35 
characters. Spaces are allowed. 

Profile Description:  This description will help you distinguish this profile 
from others with a brief text description. The fill button next to the input 
box will automatically fill this box with critical values of the profile (ex. 
encode rate, etc).

Server Name: The name of the adCode Server.  As of this release, this 
input box is read-only. In future versions, you will be able to name the 
server. 

Encoder Name: The name of the encoder within the adCode Server. As of 
this release, this input box is read-only. In future versions, you will be able 
to name the encoder. 

Decoder Name: The name of the decoder within the adCode Sever. As of 
this release, this input box is read-only. In future versions, you will be able 
to name the decoder.

adCode Server IP Address: This is the IP address of your adCode Server.   

adCode Server Port:   This is the telnet port number for the adCode 
server.

Username: The telnet user name.

Password: The telnet password.

Once you have configured these fields, click on the OK button. 
This will save your settings and close the connection tab screen.  With 
correctly configured connection settings, you may now connect the 
adCode application and server. To do so, go to File > Connect > and 
select the profile name you configured or simply click on the profile  
name in the drop down list located within the top status bar of the user 
interface. Both actions will attempt to connect the application with the 
server. When you are connected, you will see the word CONNECTED 
appear in the adCode server status panel next to the header adCode 
Server. Next, you will need to configure a source to encode from. 
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Source:
Sources can be any Sony protocol tape deck or a live feed such as 

satellite or a newsroom source. 
To configure your source, got to Configuration > adCode Server. 

Select the Source tab.  (Figure 2.3)

 (Figure 2.3)

Control Interface: Select the type of source input you will be using. 

None should be selected if you are recording from a live feed (crash 
recording). 
VTR (RS422) should be selected when connecting a tape deck via RS422. 
VTR (FireWire) should be selected when your source is a VTR connected 
via FireWire.

Note: To have source control over the VTR via the adCode application, 
your VTR control switch must be set to Remote.  

PreRoll: Select the number of seconds to pass before encoding begins. This 
enables the tape to become stable prior to encoding. 

Decode Delay: The decode delay designates the amount of time between the  
completion of the encode and the playback of the decode. Selecting Off turns 
off the automatic playback. Selecting 0 results in the fastest playback. All 
other values are noted in seconds. 
 

Select your preferences and click on the OK button. Once you have 
a correctly connected source, you will see its status noted in the Source 
Tab of the application. Connect to the server and check the status 
information. Refer to the adCode Application Main Panel illustration in 
Chapter 1 for details on status.  Once you have correctly configured 
the Connection and Source, you will need to configure the File Transfer 
Settings. 
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File Transfer:
The File Transfer tab (Figure 3.5) allows you to choose one of three 

options for managing and saving encoded files. Go to Configuration > 
adCode Server. Select the File Transfer tab.  

Figure 3.5

On Accept: Select what you want done with the file once it has  been 
reviewed and accepted.

Leave on adCode: This option will save the file to the adCode server only. 
Copy from adCode: This option will save the file on the server and transfer 
a copy of the file to a location you can designate. 
Move from adCode: This option will transfer the file from adCode to the 
location you designate leaving no copy on the adCode server.

If you select to Copy or Move the encoded file, you will need to designate a 
transfer method and path.  

Transfer Method:  The current method of transfer is limited to FTP from 
adCode. Additional options will become available in future releases. 

Source IP Address: This is the IP address of the adCode Server.

Source Port: This is the port of the adCode server used for FTP.

Server Username:  The FTP username.

Sever Password: The FTP password.

Local Media Path: This field lists the local media path of the adCode Server

Server Media Path: This field denotes the path to which files should be 
saved on the adCode server.
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Encoding a File:
Once the connection and source have been configured correctly, 

you are ready to encode a file. There are three basic steps to encoding 
the file: Connect, Source, Encode and Review. Recording from a VTR 
and Crash Recording vary and are described separately.

VTR Source Encode

Connect  - Step 1  
To begin the encode process, go to File > Connect > and select the profile 
you wish to encode with. Confirm that your adCode Server reports back as 
CONNECTED. 

Source  - Step 2  
Prior to encoding a file, you will be using the main panel of the application 
to verify and control your source. At the top of the Source panel, confirm 
that the Interface, Mode, Cassette, Activity, Video, Audio Only and 2nd 
Video settings correctly reflect the type of encode you wish to make. 
The position of the VTR (LTC) will be displayed in the Current Position input 
box. Use the standard VTR and slide shuttle controls to locate your IN 
position. 
To mark this as the IN position, click on the Set IN Button. That will fill 
the In input box with the value from the current position input box. Then 
set your encode duration. You can enter it manually or use the quick 
duration buttons (15s, 30s, 60s or 120s). You can also customize these 
quick duration buttons to any length of time. See Chapter 3 on Configuring 
adCode Application > Duration Markers for more details. Selecting a 
duration will automatically fill the OUT input box. 

Encode  - Step 3  
In the encode tab verify the status information at the top of the tab. Then 
enter a name for the file you wish to encode in the Content ID input box. 
**Should we make a note about the length of this name when using with 
edje, etc?** There are no limits on the size or characters of the file name. 
Do not include the file extension as adCode automatically appends the file 
name with the proper extension. The Content ID is all that is required to 
encode a file. The other fields located within the Encode Tab are meta data 
fields used in conjunction with Adtec’s adManage content server. If your 
adCode Server is not configured to work with adManage then these fields 
will be grayed out or inaccessible.
To encode the file, click the ENCODE button. The status of the encode is 
shown in the top of the tab. The activity status, the length of the encode, 
the encoding parameters and the bits per second of the encode is shown. 
When the file has completed encoding, you may review it before accepting 
or rejecting it.

Review (confidence decode)  - Step 4
While the file is being encoded, you have the ability to abort the encode by 
clicking on the Reject button within the Review tab at any time. To view a 
confidence decode, you will need to have a monitor set up specifically for 
the decoded file to play through and it should be connected to the YC or C 
Out decoder port and the Audio 1 Out port if audio is present. Within the 
Review tab, you have standard VTR controls to manage the file. Unless 
you have the decode delay turned off, the decode will automatically begin 
playback. If the file is as you intended, you can accept the file by clicking 
on the Accept button. Accepting the file will save the file for you. The 
location of the saved file depends on the File Transfer setting previously 
configured. To edit those settings, refer to the previous section. If it is 
not as intended, then click the Reject button and start the process again 
beginning with Step 2.
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Live Feed Encode

Connect  - Step 1  
To begin the encode process, go to File > Connect > and select the profile 
you wish to encode with. Confirm that your adCode Server reports back as 
CONNECTED. 

Source  - Step 2  
Prior to encoding a file, you will be using the main panel of the application 
to verify your source. At the top of the Source panel, confirm that the 
Interface setting reads as NONE :Schedule encode mode.
The current time will be displayed in the Current Position input box. Enter 
the time you wish to start your encode into the In input box. Then set 
your encode duration. You can enter it manually or use the quick duration 
buttons (15s, 30s, 60s or 120s). You can also customize these quick 
duration buttons to any length of time. See Chapter 3 on Configuring 
adCode Application > Duration Markers for more details. Selecting a 
duration will automatically fill the OUT input box. 

Encode  - Step 3  
In the encode tab verify the status information at the top of the tab. Then 
enter a name for the file you wish to encode in the Content ID input box. 
**Should we make a note about the length of this name when using with 
edje, etc?** There are no limits on the size or characters of the file name. 
Do not include the file extension as adCode automatically appends the file 
name with the proper extension. The Content ID is all that is required to 
encode a file. The other fields located within the Encode Tab are meta data 
fields used in conjunction with Adtec’s adManage content server. If your 
adCode Server is not configured to work with adManage then these fields 
will be grayed out or inaccessible.
To encode the file, click the ENCODE button. This will schedule your encode 
to occur at the time designated. A popup box will appear letting you know 
that the encode has been scheduled. You can only schedule one encode at 
a time. Once the file begins encoding, the status of the encode is shown 
in the top of the tab. The activity status, the length of the encode, the 
encoding parameters and the bits per second of the encode is shown. 
When the file has completed encoding, you may review it before accepting 
or rejecting it.

Review (confidence decode)  - Step 4
While the file is being encoded, you have the ability to abort the encode 
by clicking on the Reject button within the Review tab at any time. To view 
a confidence decode, you will need to have a monitor set up specifically 
for the decoded file to play through and it should be connected to the YC 
or C Out decoder port and the Audio 1 Out port if audio is present. Within 
the Review tab, you have standard controls to manage the file. Unless 
you have the decode delay turned off, the decode will automatically begin 

playback. If the file is as you intended, you can accept the file by clicking 
on the Accept button. Accepting the file will save the file for you. The 
location of the saved file depends on the File Transfer setting previously 
configured. To edit those settings, refer to the previous section. Once a file 
has been accepted you can schedule a new encode from a live feed.
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Configuring adCode Application

Using adCode with adManage
Using adCode in conjunction with adManage will streamline your 

encode process for files to be distributed via adManage. When properly 
configured, adCode will query adManage and provide a prioritized list of 
files that are scheduled for ad insertion. When the file is encoded and 
accepted, the adManage database is updated with valuable metadata 
including actual duration, ingest time, operator and optional expiration 
data. 

To configure adCode to work with adManage you will need to 
modify your ODBC settings as well as your adCode application settings. 
Refer to Appendix D for help with setting up ODBC first. When that is 
complete, go to Configuration > Application > adManage tab. (Figure 
3.6)

Figure 3.6

In the adManage Data Source input box, you need to enter the 
name of your Data Source as outlined in the ODBC settings as the DSN 

Name. Checking the following checkboxes enables these items while 
unchecking them turns them off.  

Note: Enabling adManage prior to correctly configuring the ODBC 
settings will keep the application from launching correctly. 

Enable adManage: Allows adCode to talk to adManage

Enable adManage Security: Requires users of adCode to login using their 
adManage username and password before being able to access adCode. 

Enable adManage Updates: Enables adCode to make database updates in 
adManage for Meta Data ( Advertiser Name, Description, Duration, etc.) 

Enable adManage Encoding List: Turns on a query of adManage for files 
that need to be encoded and lists them in Encode List window of the adCode 
Main Panel. 

From the adCode application main panel, you will be able to view 
the following information for each file within the Encode List. Some of 
these fields can be changed and can be saved back into adManage. All 
of this information is pulled from the traffic schedules of the adManage 
content management server. 

Content ID: The name of the file to be encoded or the name of already 
encoded files. **Should we make a note about the length of this name when 
using with edje, etc?**

Advertiser/Program: The name of the advertiser or program. 

Description: A brief description of the encoded file or spot.

Expiration Date: Defines when this file can expire. This date is used by the 
adManage Content Expiration Service to help maximize the use of available 
disk space on each ad inserter. 

Never Expire: Check this box if you do not want this file to expire. 

Encoded Date/Time: The date and time stamp when the file is encoded.

Schedule Date/Time: This denotes when the file is scheduled for play. 

Scheduled Channel/Headend: This shows which channel and headend the 
file is scheduled for next. 

Operator: This is a meta data field to assist in keeping track of work flow.
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Duration Markers
The duration markers 

located in the Source tab of the 
adCode application main panel 
can be customized. To configure 
these settings, go to Configure > 
Application > Duration Tab. (Figure 
3.7)  For each button, modify the 
duration and title to reflect your 
needs. Click on the ok button to 
save and return to the adCode panel 
with the new settings. 

(Figure 3.7)

adCode Tools

Video & Audio Controls
adCode has Video and Audio control panels which can be launched 

by going to Tools > and choosing either Video Controls (Figure 3.8) or 
Audio Controls (Figure 3.9).  

Video Controls:
The Video Control panel allows 

you to adjust Brightness, Contrast, 
Saturation and Hue. You can modify 
these settings per encode without 
changing the profile parameters. 
Clicking on the Defaults button at the 
bottom of the panel will return the 
levels to those selected in the Encoder 
Video Defaults configuration screen. 

 
Figure 3.8

Audio Controls
The Audio Control panel allows you 

to adjust the Audio Levels for Channels 
1&2 and Channels 3&4. There is a mute 
checkbox for each set and like the Video 
Controls, you can modify these settings 
per encode without changing the profile 
parameters. Clicking on the Defaults 
button at the bottom of the panel will 
return the levels to those selected in the 
Encoder Audio Defaults configuration 
screen. You can customize these defaults. 

Figure 3.9

adCode IFP
adCode comes with a built in “In Field Program” to upgrade the 

firmware in the adCode server.  Upgrades are deployed via our FTP 
server. Once you have the upgrade file located on the same LAN as your 
adCode Server, go to Tools > IFP - Upgrade Server (Figure 3.10). Enter 
the location of the file or use the Browse function to locate it. Then click 
on the Program Application button. Once the server has been upgraded, 
you will need to restart both the server and the application. 

Figure 3.10
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A    -    Contacting  Customer Support

Technical Support and Customer Service includes troubleshooting 
product/system functional operations concerning Adtec equipment 
,embedded systems and single device issues; Service Order generation, 
processing and tracking; Warranty claim processing; and on-site 
system evaluation and maintenance.  Technical Support plans do not 
include customer training programs.  Programs incorporating customer 
training are defined in the Training Services Policy.  Customer Services 
technicians provide limited instruction during a support call/email/fax in 
order to facilitate checking for proper equipment operation. 

Telephone and Email Support

Telephone: 615.256.6619 
Email: support@adtecinc.com 
Internet: www.adtecinc.com/supportrequest/

Adtec Digital offers telephone, email and fax support, warranty 
and service related inquiries during normal business hours (9:00 AM 
to 5:00PM Central Standard Time CST, Monday thru Friday, except 
holidays. Support Requests can also be submitted on-line. 

All inquiries will be processed in the order in which they are 
received and by the criteria outlined in the Call Response Order.  
Inquiries and inquiry responses made after 5:00 PM (CST) weekdays, 
Saturday, Sunday or on an Adtec recognized holiday will be processed 
the next business day in the order received.  

Callers on hold and returned calls will be prioritized by the 
following criteria:

• Priority-24 Subscription Customers
• Standard-Priority Subscription Customers
• All customers that have purchased Installation & Training, within 90 days of 
the installation
• Adtec Certified Operators (ACO)
• Limited Level Support, Warranty & Service Requests
• Multi-device system installations that have purchased Installation & Training 
from Adtec
• Distributors
• System Integrators
• Multi-device systems 
• Single device users

Information needed for Support
To help expedite the troubleshooting process, please be prepared 

to provide the following information to the support representative. 

Product(s) affected: Please provide a list of the Adtec Products 
involved including the Revision Number for each affected product.  

Description of the Problem: Please include a detailed description 
of the problem.  Include the approximate time and day the problem 
occurred, the spot ID of the material being inserted and what the 
operator reported about the incident.  It is also helpful to note any 
recent changes to the system. More information is always better than 
too little information.   

Your Contact Data: Please include contact information so we 
can reach you to discuss how to fix the problem, additional 
troubleshooting steps that are required or to gather more complete 
information regarding the problem.  Please include your facility name 
(or call letters), your name, title, email address, telephone number, 
hours of work, and other contact persons if you are not available.

Advanced Support Plans
In addition to our basic Inquiry Response Policy, Adtec offers 

two advanced levels of priority inquiry support: Standard-Priority 
and Priority-24.  The Standard-Priority & Priority-24 plans provide 
guaranteed* response times with the Priority-24 plan offering after 
hours and holiday support. Standard-Priority support is included with 
the Adtec Certified Operator (ACO) training. Contact Adtec Sales to 
upgrade your current support plan.

SUPPORT PLAN PRIORITY –24 STANDARD-
PRIORITY

LIMITED

Hours 24 Hours/Day        
7 Days/Week

“9 AM – 5 PM 
(CST), Excluding 
Weekends & 
Holidays”

9 AM – 5 PM 
(CST) Excluding 
Weekends & 
Holidays

Call Response 
Time: Guaranty*

Same Day: 2 
Hours (1st in 
order of call list)

Same Day: 4 
Hours (2nd in 
order of call list)

48 Hours

Discounted Site 
Visits

25% 10% None

Discounted Training 25% 10% None

Repair Service: 
Guaranty*

1 Day Turnaround 3 Day Turnaround None

One month free service extension will be awarded if Adtec fails to 
meet its service guarantee.
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Standard-Priority Support Plan
Customers can improve upon our normal call processing times 

and can expedite inquiry support responses through our subscription 
Standard-Priority service plan.   Under this plan all telephone inquiries 
are guarantied** a telephone response of no more than 4 hours after 
they are received (within the designated hours of operation).  Telephone 
inquiries received by 4:00 PM (CST) on weekdays, excluding Adtec 
holidays are guarantied a same-day telephone response. However, 
inquiry responses may be made after hours until 8:00 pm (CST).  
Email and fax inquiries are limited in scope to normal business hours, 
excluding holidays.  Standard-Priority customers are entitled to a 10% 
discount on site visit and training charges after the initial system/
product installation and training.  Standard-Priority customers also 
receive a 3-day turnaround time guaranty* on warranty and non-
warranty repairs on Adtec manufactured equipment, excluding Studio 
Encoders.

Priority - 24 Support Plan (24 Hour)
In addition to our Standard-Support plan, after hours, weekend 

and holiday support is available with the Priority-24 support plan.  This 
plan is a subscription only service available for service inquiries 24 
hours a day, 7 days a week.  All telephone inquiries are guarantied* a 
telephone response of no more than 2 hours.  Email and fax inquiries 
are limited in scope to normal business hours, excluding holidays.  Calls 
after 5:00 PM will be forwarded to a Customer Services representative 
on call.  Priority-24 customers are entitled to a 25% discount on site 
visit and training charges after the initial system/product installation 
and training.  Priority-24 customers also receive a 1- day turnaround 
time guaranty* on warranty and non-warranty repairs on Adtec 
manufactured equipment, excluding Studio Encoders.
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B    -    adCode Technical Reference

Video Inputs
• Composite (BNC)

• S-Video (4 Pin Mini-Din YC) analog to digital conversion 9 bit 

with scaling Horizontal and Vertical 16 tap filters.

• SDI input video with embedded SMPTE 259M AES-EBU audio on 

BNC.

• FireWire: DV25 with PCM audio and control on Mini-Firewire 

connector.

Video Outputs
• Composite (BNC)

• S-Video (4 Pin Mini-Din YC) 

VBI Support
• Line 21-Closed Captioning DVS053 Rev 6

• V-Chip DVS157

• Teletext: NABTS-DVS053 Rev 6 and PAL

• Neilson Source Identification (SID) DVS053

• Automated Measurement of Lineups (AMOL) DVS053

Video Encoding and Decoding
• MPEG 2 SD 1 Profile: SIF ISO 11172-2 

• MPEG 2 SD 2 Profile: Adaptive Field Frame (AFF) ISO13818 

MP@ML

• MPEG 2 SD Profile: AFF ISO13818 422P@ML (encode only 

option)

• Encoder Filters: Temporal; Spatial Vertically and Horizontally 

Temporal and Horizontal Spatial can be concurrent

• Chroma filtering and full scaling

• Video bit rates: MPEG 2 SD 300K-15 Mbs

• Video bit rates: MPEG 1 SIF 300K-5 Mbs

• Multiplexing Formats: Program and Transport

• MPEG Program Specific Information (PSI) Table Compliance: 

PAT, PMT; All PIDs user definable

• DVB Program Information (PI) Table Compliance: SDT, NIT; All 

PIDs user definable

• SCTE 35 Splice Point injection

Video Resolutions
• Per Macro Block (16x16) Note: Non-standard Vertical 

resolutions may adversely effect STB decoders, PC decoders have 

more flexibility when scaling.

• Horizontal NTSC examples: 720x480 (Full D1 NTSC), 544x480, 

528x480, 512x480, 496x480, 480x480, 352x480 (Half D1 NTSC).

• Vertical NTSC example: 720x 464

• Horizontal and Vertical example: 528x464 etc.

• PAL resolutions examples: 720x576 (FullD1 PAL), 720x560, 

544x544 etc

Audio Specifications

Audio Inputs

• Analog Audio 1 Stereo Balanced  (5 Pin Removable Screw 

Terminal)

• Analog Audio 2 Stereo (SAP) Balanced (5 Pin Removable 

Screw Terminal)

• User level control on Analog inputs

• AES-1 digital audio (PCM or uncompressed) for Dolby AC-3 

channel 1,2 encoding (5 Pin RST - 110 Ohm).

• AES-2 digital audio (PCM or uncompressed) for Dolby AC-3 

channel 3,4 encoding (5 Pin RST - 110 Ohm).

• SDI embedded with video per SMPTE 272M A, B, C, (BNC)

• Digital PCM audio via FireWire 

• Audio inputs can be mixed, one Analog, one AES-EBU, or One 

AES-EBU and one SDI etc.

Audio Outputs

• Primary Stereo unbalanced (1/8” phono) selectable between 

audio tracks 1 and 2 decode.

• Fixed unity audio level output

Audio Encoding and Decoding

• Dolby Digital AC-3 encoding from analog, SDI embedded 

audio or AES input.

• MPEG 1 Layer 1 Profile: ISO11172-3

• MPEG 1 Layer 2 Profile: ISO13818-3

• Audio Delay: Adjustable PTS delay up to 700 milliseconds

• 24 Bit A-D Conversion

• Audio Sampling: 16, 22.05, 24, 32, 44.1 and 48 KHz

• MPEG 2 Audio Bit Rate: 64-384 Kbs 

• Dolby Digital AC-3 Bit Rate: 64-640 Kbs

adCode Server

• Embedded Linux real time operating system with 80GB internal 

storage.

• Power: 70-240 VAC 50-60Hz and 65 Watts (20 Watts typical) of 

power.

• Size: 1RU rack mount chassis. 19” width, 1.75” height, 16” 

depth - need cm

• Weight: 14 lbs - need KG

• Environmental: Active cooling (Fans), 0 to 90 Degrees 

Fahrenheit, Less than 70% RH, Non-Condensing

Communications

• Ethernet 10/100 (RJ-45) Half Duplex, Full Duplex, Auto 

Negotiate

• Ethernet Protocols: Telnet, FTP, Adtec command API.

• Serial Communications: 2-RS232 (38400-115,200K, 8, 1 N)

• Automatically copy files from adCode server to client PC using 

FTP.

Front Panel

• Keypad: Mode, Select, Enter, Escape, Up, Down, Left, Right 

• Blue Translucent LCD (20 character by 2 row)

• Host Status LEDs   Power, Alarm, Link, Busy, Storage. 

• Encode Status LEDs: Encode Active, Video Present, LTC 

Active, Audio 1 & 2, Control, Alarm.

• Decode Status LEDs: Decode Active, Video Present, LTC 

Active, Audio 1 & 2, Control, Alarm.

adCode Application

adCode configuration and control application requires one of the 

following:

• Windows 2000 or XP or Linux computer: Intel or AMD 32 bit 

processor at 2 GHz; 512MB memory; 1024x768 32 Bit color 

capable graphics card; TCP/IP compatible computer network.

• Macintosh OS-X (10.2 or greater) computer: G4 32 bit 

processor at 1 GHz, G5 64 bit processor (any); 512MB memory; 

1024x768 32 Bit color capable graphics card; TCP/IP compatible 

computer network.
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C    -    Ad Insertion Enterprise Solution

1 - adManage/TBGS
 At the core of the adVantage solution is the TBGS traffic and billing gateway 
server and the adManage software application. This is the gateway that invisibly 
coordinates the complex flow of media and data across the enterprise. adManage 
streamlines the process of getting the right ads, schedules and verifications 
to the right places at the right times, resulting in high customer satisfaction 
levels and increased revenues. The powerful server architecture and SQL 
database offers rapid access to current data via the browser interface supporting 
customizable alarms with notification via paging, email or text messaging.

2 - Traffic and Billing
adManage merges local and interconnect schedules to create a master insertion 
schedule for each channel at each headend. After commercials are played, 
adManage creates and sends separate verification files to local and interconnect 
traffic and billing systems facilitating seamless media and data management 
across your enterprise.

3 - eyeMonitor
The eyeMonitor interface graphically displays the status of all headends and 
channels in the enterprise on a single screen. It provides visibly better real time 
status and highlights exceptions so that corrections can be easily made.

4 -  autoDialer
The autoDialer application provides a back channel for schedule distribution 
and verification retrieval over a simple phone line. This feature is essential for 
disconnected remote headends and adds redundancy in networked headends, all 
for the price of a phone call.

5 - adCode
 New media is ingested and prepared by adCode and sent to adManage for 
storage and distribution to the headends. Sources can be tapes, DVDs or over 
FireWireTM from nonlinear editors. The architecture of adCode supports Cable 
Labs VOD and SCTE encoding standards, an important aspect that future proofs 
your investment. Use adCode to seamlessly bridge the transition from analog 
and SDI digital insertion to DPI. adCode prepares the highest quality DPI ready 
media in the industry. Compatibility with other ad insertion systems is standard 
innovation at Adtec.

Headends
In an ad insertion enterprise, there are likely to be several different types of 
headends with varying levels of connectivity available. From networked LAN/WAN 
to satellite to disconnected remote, adManage can work with them all. Flexibly 
better by design.

6 -  Networked Headend
A networked headend has an existing broadband LAN/WAN connection, such 
as a T1 line or cable modem. adManage uses this connection to send ads 
and schedules and receive verifications and status monitoring. Ad insertion is 
performed by Adtec’s scalable single-channel Duet or Duet-SDI. Since each Duet 
is a single-channel modular unit that is totally self-contained, the system is fault 
tolerant by design. Media distribution within the headend is invisibly performed 
via multicast techniques making it available to all inserters all the time.

7 - Disconnected Remote Headend
What can you do when a headend is so small or remote that it has no economical 
network connection and satellite is not an option? Media can be ingested by 
adCode and burned onto a CD or DVD and sent to the headend where the disk is 
simply placed into a Duet-DVD unit. The Duet-DVD automatically makes all the 
ads available to every unit at the headend. At the remote headend, adManage 
performs schedule distribution, status monitoring and verification retrieval over 
standard phone lines (PTSN) via dial-up modem through autoDialer.

8 - Optional Satellite Serviced Headend
In headends without a network connection, media and data distribution can 
easily be achieved via satellite. Here’s how it works. At the central office, 
adManage sends the media and schedules to Adtec’s FCMP server which prepares 
the data by adding forward error correction then multicasting it to the Adtec DTA-
3050 multiplexer for encapsulation and encrypting prior to the multicast uplink. 
At each satellite headend, an Adtec edje-1123 with built-in satellite data receiver 
unscrambles and distributes the media to the Duet, Duet-SDI or DPI-1200 
units. At the satellite headend, adManage performs schedule distribution, status 
monitoring and verification retrieval over a simple phone line with a dial-up 
modem through autoDialer.

9 - Digital Program Insertion Option
Adtec’s DPI-1200 digital-into-transport (DIT) ad server takes the place of up 
to twelve Duets. Designed for the all-digital headend, the DPI-1200 will deliver 
seamless splicing effortlessly in concert with Duets in your analog systems. 
The DPI-1200 can deliver up to twelve programs to the ad splicer. adManage 
transparently delivers media and schedules and retrieves verifications and status 
monitoring in the DPI environment just as in any other type of headend. The 
adGroomer provides automated transcoding of media from legacy encoders 
making the media compliant with Cable Labs VOD standard which has been 
chosen by major MSOs as the standard for DPI media ingest.
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D    -    Traffic and Billing Central



E    -    Media Ingest
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F    -    Configuring ODBC 

The ODBC settings for your computer must be set up to allow for 
adManage and adCode to communicate. 

ODBC installation and configuration for Windows 2000 or 
XP MySQL Driver:

1. Click on the Start button , and then click Control Panel. Double-
click Administrative Tools, and then double-click Data Sources (ODBC).  

2. On the User DSN tab, click the Add button. 
3. Scroll to and highlight MySQL.  See driver installation 

instructions below if the MySQL driver is not listed. Click the Finish 
button.

4.On the following screen, modify the following:

Windows DSN name:  gatewaysource
MySQL host (name or IP):  IP address of your TBGS server
MySQL database name:  gateway
User:    gatewaywebuser
Password:    adtec

Click OK to close that panel and Ok again to close the Data Source 
panel. You will need to restart your computer.  

Driver Installation:
 If the MySQL driver is not included in the driver list, you will 

need to install the driver. ODBC Drivers for Windows XP or 2000 can be 
found on the adCode Installation CD in the Drivers folder.

You will need to install the driver in the ODBC folder located in the 
C:\Program Files\Common Files\  folder on your computer. Restart your 
computer and begin again with Step 1. 

ODBC installation and configuration for MAC OSX 10.2 or 
greater MySQL Driver:

1. Open the Finder and locate the ODBC Adminstrator in the 
Unilities section of Applications. You will need to have administrator 
access to continue. 

2. On the User DSN tab, click the Add button.
3. Scroll to and highlight MySQL. If MySQL is not listed, you will 

need to install the driver first. See Driver Installation instructions below. 
Click the Finish button.

4.On the following screen, modify the following:

Driver Installation:
 If the MySQL driver is not included in the driver list, you will 

need to install the driver. ODBC Drivers for Windows XP or 2000 can be 
found on the adCode Installation CD in the Drivers folder.

You will need to install the driver in the ODBC folder located in the 
C:\Program Files\Common Files\  folder on your computer. Restart your 
computer and begin again with Step 1. 
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